source: projects/specs/trunk/a/anacron/anacron-vl.spec @ 8191

Revision 8191, 8.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary: A cron-like program that can run jobs lost during downtime.
2Name: anacron
3Version: 2.3
4Release: 32%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7Source: ftp://ftp.debian.org/debian/pool/main/a/anacron/%{name}_%{version}.orig.tar.gz
8Source1: anacrontab
9Source2: anacron.init
10Patch0: anacron-2.3-mk-incl.patch
11Patch1: anacron-2.3-mail-content-type-77108.patch
12Patch2: anacron-2.3-gregor.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
15Requires: /bin/sh
16Requires: crontabs
17Requires(post): chkconfig
18Requires(preun): chkconfig
19Requires(preun): initscripts
20Requires(postun): initscripts
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26Anacron (like `anac(h)ronistic') is a periodic command scheduler.  It
27executes commands at intervals specified in days.  Unlike cron, it
28does not assume that the system is running continuously.  It can
29therefore be used to control the execution of daily, weekly and
30monthly jobs (or anything with a period of n days), on systems that
31don't run 24 hours a day.  When installed and configured properly,
32Anacron will make sure that the commands are run at the specified
33intervals as closely as machine-uptime permits. 
34
35This package is pre-configured to execute the daily jobs of the Red
36Hat Linux system. You should install this program if your system isn't
37powered on 24 hours a day to make sure the maintenance jobs of other
38Red Hat Linux packages are executed each day.
39
40%prep
41%setup -q
42%patch0 -p1 -b .incl
43%patch1 -p1 -b .charset
44%patch2 -p1 -b .gregor
45
46%build
47make CFLAGS="$RPM_OPT_FLAGS"
48
49%install
50mkdir -p $RPM_BUILD_ROOT/{etc/,usr/sbin/,%{_mandir}/man5,%{_mandir}/man8/}
51mkdir -p $RPM_BUILD_ROOT/var/spool/anacron/
52
53#
54cp anacron $RPM_BUILD_ROOT/usr/sbin
55cp anacron.8 $RPM_BUILD_ROOT/%{_mandir}/man8/
56cp anacrontab.5 $RPM_BUILD_ROOT/%{_mandir}/man5/
57cp %SOURCE1 $RPM_BUILD_ROOT/etc
58
59for i in cron.daily cron.weekly cron.monthly;do
60mkdir -p $RPM_BUILD_ROOT/etc/$i/
61cat << EOF > $RPM_BUILD_ROOT/etc/$i/0anacron
62#!/bin/sh
63#
64# anacron's cron script
65#
66# This script updates anacron time stamps. It is called through run-parts
67# either by anacron itself or by cron.
68#
69# The script is called "0anacron" to assure that it will be executed
70# _before_ all other scripts.
71
72anacron -u $i
73
74EOF
75chmod +x $RPM_BUILD_ROOT/etc/$i/0anacron
76done
77
78#
79#for i in `find $RPM_BUILD_ROOT/ -type 'f' -perm '+a=x'`;do
80#       file $i|grep -q "not stripped" && strip $i
81#done
82
83mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d/
84install -c -m755 %SOURCE2 $RPM_BUILD_ROOT/etc/rc.d/init.d/anacron
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89
90%post
91/sbin/chkconfig --add anacron
92
93%preun
94if [ "$1" = "0" ]; then
95    service anacron stop >/dev/null 2>&1
96    /sbin/chkconfig --del anacron
97fi
98
99%postun
100if [ "$1" -ge "1" ]; then
101    service anacron condrestart >/dev/null 2>&1
102fi
103
104%files
105%defattr(-,root,root,0755)
106%doc COPYING README
107%config /etc/anacrontab
108%dir /var/spool/anacron/
109%config /etc/rc.d/init.d/*
110/%{_mandir}/man5/*
111/%{_mandir}/man8/*
112/usr/sbin/anacron
113%config /etc/cron.daily/0anacron
114%config /etc/cron.monthly/0anacron
115%config /etc/cron.weekly/0anacron
116
117%changelog
118* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3-32
119- rebuild with VineSeed environment
120
121* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-31
122- fix typo..
123
124* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-30
125- rebuild for Vine 6
126- use Requires({post,preun,postun}) instead of PreReq
127
128* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl5
129- applied new versioning policy
130
131* Sat Jul 08 2006 Shu KONNO <owa@bg.wakwak.com> 2.3-29vl2
132- added anacron-2.3-gregor.patch
133
134* Wed Jul 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-29vl1
135- rebuild for Vine Linux
136
137* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-29
138- don't require vixie-cron (#21176) [reported by Gerald Teschl]
139- in init script don't remove /var/lock/subsys/anacron when stopping (#58462)
140- exit init script with actual exit status (#44600) [reported by Enrico Scholz]
141
142* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-28
143- add a Content-Type header to mails giving the charset encoding (#77108)
144
145* Thu Jul 10 2003 Jens Petersen <petersen@redhat.com> - 2.3-27
146- in init script do not touch /var/lock/subsys/anacron when starting (#58462)
147- require crontabs (#21176)
148- update source url
149
150* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
151- rebuilt
152
153* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
154- rebuilt
155
156* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 2.3-24
157- rebuild on all arches
158
159* Fri Aug 23 2002 Jens Petersen <petersen@redhat.com> 2.3-23
160- delay the start of anacron by 60min to make startup more pleasant (#68304)
161- at startup run jobs serially and nice 19 to reduce load (#65870, #68304)
162- spec file now in utf-8
163- dont install non-existant NEWS file
164- silence make include warnings
165
166* Fri Jul 19 2002 Akira TAGOH <tagoh@redhat.com> 2.3-22
167- fix the stripped binary issue.
168
169* Mon Jul 08 2002 Bill Huang <bhuang@redhat.com>
170- Update "Copyright" to "License" in spec file
171
172* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
173- automated rebuild
174
175* Thu May 23 2002 Tim Powers <timp@redhat.com>
176- automated rebuild
177
178* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
179- automated rebuild
180
181* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
182- Bump release + rebuild.
183
184* Tue Apr  3 2001 Crutcher Dunnavant <crutcher@redhat.com>
185- add dependancy to vixie-cron (for /usr/bin/run-parts)
186
187* Tue Feb 13 2001 Tim Waugh <twaugh@redhat.com>
188- killproc is a shell function and can't be passed as a parameter
189  (bug #27150).
190
191* Mon Feb  5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
192- Fix i18n in initscript ("Stopping anacron" wasn't translated)
193  (#26076)
194
195* Fri Feb  2 2001 Trond Eivind Glomsrød <teg@redhat.com>
196- i18nize initscript
197
198* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
199- rebuild in rebuild cycle.
200
201* Mon Oct 30 2000 Matt Wilson <msw@redhat.com>
202- touch /var/lock/subsys/anacron to prevent excess startage during
203  init level change
204
205* Wed Aug 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
206- Shut down earlier to prevent NFS mounted /usr filesystems from causing
207  problems (Bug #16257)
208
209* Fri Aug  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
210- Start it later so services some cron scripts may depend on are running
211  (Bug #15335)
212
213* Thu Aug  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
214- Fix up initscript (Bug #15123 and an unreported bug)
215
216* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
217- move initscript back
218
219* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
220- automatic rebuild
221
222* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
223- Fix up initscripts (Bug #13625)
224
225* Tue Jul  4 2000 Matt Wilson <msw@redhat.com>
226- Prereq: /sbin/chkconfig
227
228* Mon Jun 26 2000 Preston Brown <pbrown@redhat.com>
229- move initscript to /etc/init.d, fix up post/preun/postun scripts.
230
231* Mon Jun 26 2000 Bernhard Rosenkraenzer <bero@redhat.com>
232- 2.3
233
234* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
235- use %%{_mandir}
236
237* Fri Mar 03 2000 Tim Powers <timp@redhat.com>
238- fixed startup script so that it doesn't put stuff in /var/lock/subsys.
239        Complains since anacronda turns itself off when it is run, and the file in
240        /var/lock/subsys isn't removed.
241       
242* Mon Feb 28 2000 Tim Powers <timp@redhat.com>
243- fixed startup script, now it actually stops, gives status and restarts.
244        Fixes bug #9835
245
246* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
247- handle compressed manpages
248
249* Fri Feb  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
250- rebuild to get compressed man pages
251- mark /etc/cron.daily/... as config files
252
253* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
254- fix annoying defines
255- rebuild to update description and group
256
257* Thu Jan  6 2000 Bernhard Rosenkränzer <bero@redhat.com>
258- initial Red Hat package
259
260* Wed Dec 29 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
261- Remove cron.hourly check (unusefull).
262
263* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
264- 2.1 from debian.
265- Fix typo in initscripts.
266
267* Thu Jul 22 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
268- Fix wrong entries in anacrontab.
269- Add a /etc/rc.sysinit/ script
270
271* Tue Apr 27 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
272- Fix bug with /var/spool/anacron/
273
274* Sat Apr 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
275- First version mainly inspired from the Debian package.
Note: See TracBrowser for help on using the repository browser.