source: projects/specs/trunk/a/amor/amor-vl.spec @ 10548

Revision 10548, 2.6 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name: amor
2Summary: Desktop mascot for KDE
3Version: 4.14.3
4Release: 2%{?_dist_release}
5
6Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
7
8License: GPLv2
9Group: Applications/Accessories
10URL: http://www.kde.org/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: desktop-file-utils
15BuildRequires: kdelibs-devel >= %{version}
16
17Requires(posttrans,postun): desktop-file-utils
18
19Vendor: Project Vine
20Distribution: Vine Linux
21Packager: Takemikaduchi
22
23
24%description
25Amor is an acronym which stands for Amusing Misuse of Resources.
26It is actually an animation which sits on top of your active window.
27In its default configuration, amor takes the form of a yellow spot
28which performs many tricks.  Amor also has many different themes
29which change the appearance and behavior of the animation.
30
31%prep
32%setup -q
33
34%build
35mkdir -p %{_target_platform}
36pushd %{_target_platform}
37%cmake \
38    -DCMAKE_BUILD_TYPE=release \
39    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
40    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
41    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
42    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
43    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
44    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
45    ..
46popd
47
48make %{?_smp_mflags} -C %{_target_platform}
49
50%install
51rm -rf $RPM_BUILD_ROOT
52make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%post
58touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
59
60%posttrans
61gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
62update-desktop-database -q &> /dev/null ||:
63
64%postun
65if [ $1 -eq 0 ] ; then
66  touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
67  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
68  update-desktop-database -q &> /dev/null ||:
69fi
70
71
72%files
73%defattr(-,root,root,-)
74%doc COPYING COPYING.DOC
75%{_bindir}/%{name}
76%{_datadir}/applications/kde4/%{name}.desktop
77%{_datadir}/dbus-1/interfaces/org.kde.%{name}.xml
78%{_datadir}/icons/hicolor/*/*/*
79%{_datadir}/kde4/apps/%{name}
80%{_docdir}/HTML/*/*/
81%{_mandir}/man6/%{name}.6*
82
83%changelog
84* Wed Jul 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
85- rebuild with gcc-5.4.0
86
87* Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
88- new upstream release
89
90* Tue May 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.5-1
91- new upstream release
92
93* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.12.2-1
94- new upstream release
95
96* Sun Dec 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.4-1
97- new upstream release
98
99* Sun Sep 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.11.1-1
100- initial build
101
Note: See TracBrowser for help on using the repository browser.