source: projects/specs/trunk/a/amarok/amarok-vl.spec @ 2091

Revision 2091, 6.5 KB checked in by inagaki, 14 years ago (diff)

update: amarok, phonon
NEW: qtscriptgenerator

Line 
1Name: amarok
2Summary: Amarok Media Player
3Summary(ja): Amarok メディアプレイヤー
4Version: 2.3.2
5Release: 1%{?_dist_release}
6
7Group: Applications/Multimedia
8License: GPLv2
9URL: http://amarok.kde.org
10
11Source0: http://download.kde.org/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
12## upstream patches
13Patch10: amarok-2.3.2_bpm_tags-in-flac_fix.patch
14Patch20: amarok-2.3.2_0001-Re-add-some-tests-for-unprintable-but-also-invalid-c.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: curl-devel
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: kdelibs4-devel
21#BuildRequires: libifp-devel
22#BuildRequires: liblastfm-devel
23#BuildRequires: libmp4v2-devel
24BuildRequires: libgcrypt-devel
25BuildRequires: libgpod-devel >= 0.7.0
26BuildRequires: libmtp-devel >= 1.0.0
27BuildRequires: libnjb-devel
28BuildRequires: libusb-devel
29BuildRequires: libxml2-devel
30BuildRequires: libvisual-devel
31BuildRequires: loudmouth-devel
32BuildRequires: MySQL-devel
33BuildRequires: MySQL-embedded-devel
34BuildRequires: phonon-devel
35BuildRequires: qca2-devel
36BuildRequires: qtscriptbindings
37BuildRequires: soprano-devel
38BuildRequires: taglib-devel >= 1.6
39BuildRequires: taglib-extras-devel >= 1.0.1
40BuildRequires: zlib-devel
41
42Requires: qtscriptbindings
43Requires: %{name}-libs = %{version}-%{release}
44Requires: %{name}-utils = %{version}-%{release}
45
46# for trash protocol support, phonon kcm, etc...
47# FIXME: should probably be handled lower in the stack
48Requires: kdebase-runtime >= 4.5
49
50# when we grew a -libs subpkg, multilib love
51Obsoletes: amarok-konqueror < 1.5
52Obsoletes: amarok-helix-engine < 1.5
53Obsoletes: amarok-void-engine < 1.5
54Obsoletes: amarok-xine-engine < 1.5
55Obsoletes: amarok-visualisation < 1.5
56
57Vendor: Project Vine
58Distribution: Vine Linux
59
60%description
61Amarok is a multimedia player with:
62 - fresh playlist concept, very fast to use, with drag and drop
63 - plays all formats supported by the various engines
64 - audio effects, like reverb and compressor
65 - compatible with the .m3u and .pls formats for playlists
66 - nice GUI, integrates into the KDE look, but with a unique touch
67
68%description -l ja
69Amarokは、直感的インターフェースを備えた、Linux および Unix 用の音楽プレーヤーです。
70Amarokはより好きな音楽を簡単に再生します。
71
72%package libs
73Summary: Runtime libraries for %{name}
74Summary(ja): %{name} のランタイムライブラリ
75Group:   System Environment/Libraries
76#Requires: %{name} = %{version}-%{release}
77Requires: qt4 >= 4.6
78
79%description libs
80%{summary}.
81
82%package utils
83Summary: Amarok standalone utilities
84Group: Applications/Multimedia
85Obsoletes: amarok-collectionscanner < 2.0.90-2
86Obsoletes: amarok-utilities < 2.0.96
87
88%description utils
89%{summary}, including amarokcollectionscanner.
90
91%prep
92%setup -q
93%patch10 -p0
94%patch20 -p1
95
96%build
97mkdir -p %{_target_platform}
98pushd %{_target_platform}
99%cmake \
100    -DCMAKE_BUILD_TYPE=release \
101    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
102    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
103    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
104    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
105    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
106    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
107    ..
108popd
109
110make %{?_smp_mflags} -C %{_target_platform}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
115
116%find_lang amarok
117%find_lang amarokcollectionscanner_qt
118%find_lang amarokpkg
119%find_lang amarok_scriptengine_qscript
120cat amarokpkg.lang >> amarok.lang
121cat amarok_scriptengine_qscript.lang >> amarok.lang
122
123# unpackaged files
124rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok{-sqlcollection,_taglib,core,lib,plasma,pud,ocsclient}.so
125
126%check
127desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok.desktop
128desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok_containers.desktop
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post
134touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
135
136%posttrans
137gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
138update-desktop-database -q &> /dev/null ||:
139
140%postun
141if [ $1 -eq 0 ] ; then
142    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
143    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
144    update-desktop-database -q &> /dev/null ||:
145fi
146
147%post libs -p /sbin/ldconfig
148
149%postun libs -p /sbin/ldconfig
150
151
152%files -f %{name}.lang
153%defattr(-,root,root)
154%doc AUTHORS COPYING ChangeLog README
155%doc %{_docdir}/HTML/*/amarok/*
156%{_bindir}/amarok
157%{_bindir}/amarokpkg
158%{_bindir}/amarok_afttagger
159%{_bindir}/amarokmp3tunesharmonydaemon
160%{_datadir}/kde4/apps/amarok/
161%{_datadir}/kde4/apps/desktoptheme/Amarok-Mockup/
162%{_datadir}/kde4/apps/desktoptheme/default/widgets/*
163%{_datadir}/kde4/apps/solid/actions/amarok-play-audiocd.desktop
164%{_datadir}/config/amarok.knsrc
165%{_datadir}/config//amarok_homerc
166%{_datadir}/config/amarokapplets.knsrc
167%{_datadir}/applications/kde4/amarok.desktop
168%{_datadir}/applications/kde4/amarok_containers.desktop
169%{_datadir}/config.kcfg/amarokconfig.kcfg
170%{_datadir}/dbus-1/interfaces/*.xml
171%{_datadir}/kde4/services/*.desktop
172%{_datadir}/kde4/services/*.protocol
173%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
174%{_datadir}/kde4/servicetypes/*.desktop
175%{_datadir}/icons/hicolor/*/*/*
176%{_libdir}/kde4/*.so
177%{_libdir}/strigi/*
178
179%files libs
180%defattr(-,root,root,-)
181%{_libdir}/libamarokcore.so.1*
182%{_libdir}/libamaroklib.so.1*
183%{_libdir}/libamarokocsclient.so.4*
184%{_libdir}/libamarokpud.so.1*
185%{_libdir}/libamarok-sqlcollection.so.1*
186
187%files utils -f amarokcollectionscanner_qt.lang
188%defattr(-,root,root,-)
189%{_bindir}/amarokcollectionscanner
190
191
192%changelog
193* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.2-1
194- new upstream release for KDE 4
195- updated BR
196
197* Mon Nov 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.10-5
198- drop helixplayer stuff to resolve unmet dependency
199- drop --with-mp4v2 configure option
200
201* Wed Jun 17 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-4vl5
202- add BuildRequires: libvisual-devel
203
204* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-3vl5
205- add Patch4 (from Ubuntu/Debian) to fix build against libmtp >= 0.3.0
206
207* Sat Mar 21 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-2vl5
208- Package Name Changes: self-build-libmad, self-build-faad2
209- add patch100 for fix CVE2009-0135, CVE-2009-0136
210- add PreReq & BuildPreReq: libart_lgpl, libart_lgpl-devel
211
212* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-1vl5
213- initial build for Vine Seed.
214- add Patch3
215- spec in utf-8, and applied vine versioning policy
216
Note: See TracBrowser for help on using the repository browser.