source: projects/specs/trunk/a/amarok/amarok-vl.spec @ 9328

Revision 9328, 8.3 KB checked in by inagaki, 9 years ago (diff)

2015-02-04 Ryoichi INAGAKI <ryo1@…>

  • MySQL-python, kio-upnp-ms, kio_mtp, python-oauth python-urlgrabber: new package
  • amarok: updated


Line 
1Name: amarok
2Summary: Amarok Media Player
3Summary(ja): Amarok メディアプレイヤー
4Version: 2.8.0
5Release: 1%{?_dist_release}
6
7# KDE e.V. may determine that future GPL versions are accepted
8License: GPLv2 or GPLv3
9Group: Applications/Multimedia
10URL: http://amarok.kde.org
11
12Source0: http://download.kde.org/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
13# http://quickgit.kde.org/?p=amarok.git&a=blob&&f=src%2Famarok.appdata.xml&o=plain
14Source1: amarok.appdata.xml
15
16# Invoke a browser on the online UserBase documentation instead of KHelpCenter
17# for the help contents if the amarok-doc subpackage is not installed.
18Patch0:  amarok-2.8.0-onlinedoc.patch
19
20## upstreamable patches
21
22## upstream patches
23
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: curl-devel
27BuildRequires: desktop-file-utils
28BuildRequires: gettext
29BuildRequires: kdelibs4-devel >= 4.9.0
30BuildRequires: libappstream-glib-devel
31BuildRequires: mariadb-devel mariadb-embedded
32BuildRequires: gdk-pixbuf2-devel
33BuildRequires: glib2-devel
34BuildRequires: libxml2-devel
35BuildRequires: phonon-devel
36BuildRequires: qca2-devel
37BuildRequires: qjson-devel
38BuildRequires: qt4-devel
39BuildRequires: taglib-devel >= 1.7
40BuildRequires: taglib-extras-devel >= 1.0.1
41#BuildRequires: libifp-devel
42#BuildRequires: liblastfm-devel
43#BuildRequires: libmp4v2-devel
44BuildRequires: libgcrypt-devel
45BuildRequires: libgpod-devel >= 0.7.0
46BuildRequires: libmtp-devel >= 1.0.0
47BuildRequires: loudmouth-devel
48BuildRequires: qtscriptbindings
49BuildRequires: soprano-devel
50BuildRequires: zlib-devel
51
52Requires: qtscriptbindings
53Requires: %{name}-libs = %{version}-%{release}
54Requires: %{name}-utils = %{version}-%{release}
55
56# for trash protocol support, phonon kcm, etc...
57# FIXME: should probably be handled lower in the stack
58Requires: kdebase-runtime
59Requires: kio_mtp
60Requires: kio-upnp-ms
61Requires: media-player-info
62Requires: mariadb-server
63
64Requires(post,postun): gtk2
65Requires(post,postun): desktop-file-utils
66Requires(post,postun): shared-mime-info
67
68# when we grew a -libs subpkg, multilib love
69Obsoletes: amarok-konqueror < 1.5
70Obsoletes: amarok-helix-engine < 1.5
71Obsoletes: amarok-void-engine < 1.5
72Obsoletes: amarok-xine-engine < 1.5
73Obsoletes: amarok-visualisation < 1.5
74
75Vendor: Project Vine
76Distribution: Vine Linux
77
78%description
79Amarok is a multimedia player with:
80 - fresh playlist concept, very fast to use, with drag and drop
81 - plays all formats supported by the various engines
82 - audio effects, like reverb and compressor
83 - compatible with the .m3u and .pls formats for playlists
84 - nice GUI, integrates into the KDE look, but with a unique touch
85
86%description -l ja
87Amarokは、直感的インターフェースを備えた、Linux および Unix 用の音楽プレーヤーです。
88Amarokはより好きな音楽を簡単に再生します。
89
90%package libs
91Summary: Runtime libraries for %{name}
92Summary(ja): %{name} のランタイムライブラリ
93Group: System Environment/Libraries
94%{?_qt4_version:Requires: qt4 >= %{_qt4_version}}
95
96%description libs
97%{summary}.
98
99%package utils
100Summary: Amarok standalone utilities
101Summary(ja): Amarok のスタンドアロンユーティリティ
102Group: Applications/Multimedia
103Obsoletes: amarok-collectionscanner < 2.0.90-2
104Obsoletes: amarok-utilities < 2.0.96
105
106%description utils
107%{summary}, including amarokcollectionscanner.
108
109%package doc
110Summary: Application handbook, documentation
111Summary(ja): Amarok のドキュメント
112Group: Applications/Documentation
113# for upgrade path
114Obsoletes: amarok < 2.6.0-1
115Requires:  %{name} = %{version}-%{release}
116BuildArch: noarch
117
118%description doc
119%{summary}.
120
121
122%prep
123%setup -q
124%patch0 -p1
125
126
127%build
128mkdir -p %{_target_platform}
129pushd %{_target_platform}
130%cmake \
131    -DCMAKE_BUILD_TYPE=release \
132    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
133    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
134    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
135    -DKDE4_BUILD_TESTS=off \
136    ..
137popd
138#    -DWITH_MYSQL_EMBEDDED=no \
139
140make %{?_smp_mflags} -C %{_target_platform}
141
142%install
143rm -rf $RPM_BUILD_ROOT
144make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
145
146# install appdata
147install -m644 -p -D %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/appdata/%{name}.appdata.xml
148
149%find_lang amarok
150%find_lang amarokcollectionscanner_qt
151%find_lang amarokpkg
152#find_lang amarok_scriptengine_qscript
153cat amarokpkg.lang >> amarok.lang
154#cat amarok_scriptengine_qscript.lang >> amarok.lang
155
156# unpackaged files
157rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok{-sqlcollection,-transcoding,_taglib,core,lib,plasma,pud,ocsclient,shared}.so
158
159%check
160desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok.desktop
161desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok_containers.desktop
162
163%clean
164rm -rf $RPM_BUILD_ROOT
165
166%post
167touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
168touch --no-create %{_datadir}/mime/packages &> /dev/null || :
169
170%posttrans
171gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
172update-desktop-database -q &> /dev/null ||:
173update-mime-database %{_datadir}/mime &> /dev/null || :
174
175%postun
176if [ $1 -eq 0 ] ; then
177    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
178    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
179    update-desktop-database -q &> /dev/null ||:
180    touch --no-create %{_datadir}/mime/packages &> /dev/null || :
181    update-mime-database %{_datadir}/mime &> /dev/null || :
182fi
183
184%post libs -p /sbin/ldconfig
185
186%postun libs -p /sbin/ldconfig
187
188
189%files -f %{name}.lang
190%defattr(-,root,root)
191%doc AUTHORS COPYING ChangeLog README
192%{_bindir}/amarok
193%{_bindir}/amarokpkg
194%{_bindir}/amarok_afttagger
195%{_bindir}/amarokmp3tunesharmonydaemon
196%{_bindir}/amzdownloader
197%{_datadir}/appdata/%{name}.appdata.xml
198%{_datadir}/applications/kde4/amarok.desktop
199%{_datadir}/applications/kde4/amarok_containers.desktop
200%{_datadir}/applications/kde4/amzdownloader.desktop
201%{_datadir}/config/amarok.knsrc
202%{_datadir}/config/amarok_homerc
203%{_datadir}/config/amarokapplets.knsrc
204%{_datadir}/config.kcfg/amarokconfig.kcfg
205%{_datadir}/dbus-1/interfaces/*.xml
206%{_datadir}/icons/hicolor/*/*/*
207%{_datadir}/kde4/apps/amarok/
208%{_datadir}/kde4/apps/desktoptheme/default/widgets/*
209%{_datadir}/kde4/apps/kconf_update/amarok*
210%{_datadir}/kde4/apps/solid/actions/amarok-play-audiocd.desktop
211%{_datadir}/kde4/services/*.desktop
212%{_datadir}/kde4/services/*.protocol
213%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
214%{_datadir}/kde4/servicetypes/*.desktop
215%{_datadir}/mime/packages/amzdownloader.xml
216%{_libdir}/kde4/*.so
217
218%files libs
219%defattr(-,root,root,-)
220%{_libdir}/libamarokcore.so.1*
221%{_libdir}/libamaroklib.so.1*
222%{_libdir}/libamarokocsclient.so.4*
223%{_libdir}/libamarokpud.so.1*
224%{_libdir}/libamarokshared.so.1*
225%{_libdir}/libamarok-sqlcollection.so.1*
226%{_libdir}/libamarok-transcoding.so.*
227%{_libdir}/libampache_account_login.so
228
229%files utils -f amarokcollectionscanner_qt.lang
230%defattr(-,root,root,-)
231%{_bindir}/amarokcollectionscanner
232
233%files doc
234%defattr(-,root,root,-)
235%doc %{_docdir}/HTML/*/amarok/*
236
237
238%changelog
239* Wed Feb  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.8.0-1
240- new upstream release
241- split documents into doc subpackage
242- built with libgrypt 1.6.0, libmtp 1.1.8 and mariadb-embedded 10.0.16
243
244* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
245- new upstream release
246- add BuildRequires: qjson-devel
247- remove BuildRequires: MySQL-embedded-devel
248
249* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
250- new upstream release
251
252* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.2-1
253- new upstream release for KDE 4
254- updated BR
255
256* Mon Nov 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.10-5
257- drop helixplayer stuff to resolve unmet dependency
258- drop --with-mp4v2 configure option
259
260* Wed Jun 17 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-4vl5
261- add BuildRequires: libvisual-devel
262
263* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-3vl5
264- add Patch4 (from Ubuntu/Debian) to fix build against libmtp >= 0.3.0
265
266* Sat Mar 21 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-2vl5
267- Package Name Changes: self-build-libmad, self-build-faad2
268- add patch100 for fix CVE2009-0135, CVE-2009-0136
269- add PreReq & BuildPreReq: libart_lgpl, libart_lgpl-devel
270
271* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-1vl5
272- initial build for Vine Seed.
273- add Patch3
274- spec in utf-8, and applied vine versioning policy
275
Note: See TracBrowser for help on using the repository browser.