source: projects/specs/trunk/a/amarok/amarok-vl.spec @ 6785

Revision 6785, 6.8 KB checked in by Takemikaduchi, 12 years ago (diff)

kdelibs, kdebase-runtime, kdenetwork, kdeplasma-addons: rebuild
others: new upstream release

RevLine 
[521]1Name: amarok
[2091]2Summary: Amarok Media Player
3Summary(ja): Amarok メディアプレイヤー
[6785]4Version: 2.6.0
[2091]5Release: 1%{?_dist_release}
6
[521]7Group: Applications/Multimedia
[2091]8License: GPLv2
[521]9URL: http://amarok.kde.org
10
[2091]11Source0: http://download.kde.org/stable/amarok/%{version}/src/amarok-%{version}.tar.bz2
12## upstream patches
13Patch10: amarok-2.3.2_bpm_tags-in-flac_fix.patch
14Patch20: amarok-2.3.2_0001-Re-add-some-tests-for-unprintable-but-also-invalid-c.patch
[521]15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
[2091]17BuildRequires: curl-devel
18BuildRequires: desktop-file-utils
19BuildRequires: gettext
20BuildRequires: kdelibs4-devel
21#BuildRequires: libifp-devel
22#BuildRequires: liblastfm-devel
23#BuildRequires: libmp4v2-devel
24BuildRequires: libgcrypt-devel
25BuildRequires: libgpod-devel >= 0.7.0
26BuildRequires: libmtp-devel >= 1.0.0
27BuildRequires: libnjb-devel
28BuildRequires: libusb-devel
29BuildRequires: libxml2-devel
30BuildRequires: libvisual-devel
31BuildRequires: loudmouth-devel
32BuildRequires: MySQL-devel
33BuildRequires: phonon-devel
34BuildRequires: qca2-devel
[6785]35BuildRequires: qjson-devel
[2091]36BuildRequires: qtscriptbindings
37BuildRequires: soprano-devel
[6785]38BuildRequires: taglib-devel >= 1.7
[2091]39BuildRequires: taglib-extras-devel >= 1.0.1
40BuildRequires: zlib-devel
41
42Requires: qtscriptbindings
43Requires: %{name}-libs = %{version}-%{release}
44Requires: %{name}-utils = %{version}-%{release}
45
46# for trash protocol support, phonon kcm, etc...
47# FIXME: should probably be handled lower in the stack
48Requires: kdebase-runtime >= 4.5
49
50# when we grew a -libs subpkg, multilib love
51Obsoletes: amarok-konqueror < 1.5
52Obsoletes: amarok-helix-engine < 1.5
53Obsoletes: amarok-void-engine < 1.5
54Obsoletes: amarok-xine-engine < 1.5
55Obsoletes: amarok-visualisation < 1.5
56
[521]57Vendor: Project Vine
58Distribution: Vine Linux
59
60%description
[2091]61Amarok is a multimedia player with:
62 - fresh playlist concept, very fast to use, with drag and drop
63 - plays all formats supported by the various engines
64 - audio effects, like reverb and compressor
65 - compatible with the .m3u and .pls formats for playlists
66 - nice GUI, integrates into the KDE look, but with a unique touch
67
[521]68%description -l ja
69Amarokは、直感的インターフェースを備えた、Linux および Unix 用の音楽プレーヤーです。
70Amarokはより好きな音楽を簡単に再生します。
71
[2091]72%package libs
73Summary: Runtime libraries for %{name}
74Summary(ja): %{name} のランタイムライブラリ
75Group:   System Environment/Libraries
76#Requires: %{name} = %{version}-%{release}
77Requires: qt4 >= 4.6
[521]78
[2091]79%description libs
80%{summary}.
[521]81
[2091]82%package utils
83Summary: Amarok standalone utilities
[521]84Group: Applications/Multimedia
[2091]85Obsoletes: amarok-collectionscanner < 2.0.90-2
86Obsoletes: amarok-utilities < 2.0.96
[521]87
[2091]88%description utils
89%{summary}, including amarokcollectionscanner.
[521]90
91%prep
92%setup -q
[4054]93#patch10 -p0
94#patch20 -p1
[521]95
96%build
[2091]97mkdir -p %{_target_platform}
98pushd %{_target_platform}
99%cmake \
100    -DCMAKE_BUILD_TYPE=release \
101    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
102    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
103    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
104    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
105    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
106    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
[6785]107    -DWITH_MYSQL_EMBEDDED=no \
[2091]108    ..
109popd
[521]110
[2091]111make %{?_smp_mflags} -C %{_target_platform}
[521]112
113%install
[2091]114rm -rf $RPM_BUILD_ROOT
115make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
[521]116
[2091]117%find_lang amarok
118%find_lang amarokcollectionscanner_qt
119%find_lang amarokpkg
120%find_lang amarok_scriptengine_qscript
121cat amarokpkg.lang >> amarok.lang
122cat amarok_scriptengine_qscript.lang >> amarok.lang
123
[521]124# unpackaged files
[4054]125rm -f $RPM_BUILD_ROOT%{_libdir}/libamarok{-sqlcollection,-transcoding,_taglib,core,lib,plasma,pud,ocsclient}.so
[521]126
[2091]127%check
128desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok.desktop
129desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/kde4/amarok_containers.desktop
[521]130
131%clean
[2091]132rm -rf $RPM_BUILD_ROOT
[521]133
134%post
[2091]135touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
[521]136
[2091]137%posttrans
138gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
139update-desktop-database -q &> /dev/null ||:
[521]140
141%postun
[2091]142if [ $1 -eq 0 ] ; then
143    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
144    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
145    update-desktop-database -q &> /dev/null ||:
146fi
[521]147
[2091]148%post libs -p /sbin/ldconfig
149
150%postun libs -p /sbin/ldconfig
151
152
[521]153%files -f %{name}.lang
154%defattr(-,root,root)
[2091]155%doc AUTHORS COPYING ChangeLog README
[521]156%doc %{_docdir}/HTML/*/amarok/*
157%{_bindir}/amarok
[2091]158%{_bindir}/amarokpkg
159%{_bindir}/amarok_afttagger
160%{_bindir}/amarokmp3tunesharmonydaemon
161%{_datadir}/kde4/apps/amarok/
162%{_datadir}/kde4/apps/desktoptheme/default/widgets/*
[4054]163%{_datadir}/kde4/apps/kconf_update/amarok*
[2091]164%{_datadir}/kde4/apps/solid/actions/amarok-play-audiocd.desktop
165%{_datadir}/config/amarok.knsrc
[4054]166%{_datadir}/config/amarok_homerc
[2091]167%{_datadir}/config/amarokapplets.knsrc
168%{_datadir}/applications/kde4/amarok.desktop
169%{_datadir}/applications/kde4/amarok_containers.desktop
170%{_datadir}/config.kcfg/amarokconfig.kcfg
171%{_datadir}/dbus-1/interfaces/*.xml
172%{_datadir}/kde4/services/*.desktop
173%{_datadir}/kde4/services/*.protocol
174%{_datadir}/kde4/services/ServiceMenus/amarok_append.desktop
175%{_datadir}/kde4/servicetypes/*.desktop
176%{_datadir}/icons/hicolor/*/*/*
177%{_libdir}/kde4/*.so
[4054]178#{_libdir}/strigi/*
[521]179
[2091]180%files libs
[521]181%defattr(-,root,root,-)
[2091]182%{_libdir}/libamarokcore.so.1*
183%{_libdir}/libamaroklib.so.1*
184%{_libdir}/libamarokocsclient.so.4*
185%{_libdir}/libamarokpud.so.1*
186%{_libdir}/libamarok-sqlcollection.so.1*
[4054]187%{_libdir}/libamarok-transcoding.so.*
188%{_libdir}/libampache_account_login.so
[521]189
[2091]190%files utils -f amarokcollectionscanner_qt.lang
[521]191%defattr(-,root,root,-)
[2091]192%{_bindir}/amarokcollectionscanner
[521]193
194
[2091]195%changelog
[6785]196* Mon Sep 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.0-1
197- new upstream release
198- add BuildRequires: qjson-devel
199- remove BuildRequires: MySQL-embedded-devel
200
[4054]201* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1
202- new upstream release
203
[2091]204* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.2-1
205- new upstream release for KDE 4
206- updated BR
[521]207
[2091]208* Mon Nov 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.10-5
209- drop helixplayer stuff to resolve unmet dependency
210- drop --with-mp4v2 configure option
[521]211
212* Wed Jun 17 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-4vl5
213- add BuildRequires: libvisual-devel
214
215* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.10-3vl5
216- add Patch4 (from Ubuntu/Debian) to fix build against libmtp >= 0.3.0
217
218* Sat Mar 21 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-2vl5
219- Package Name Changes: self-build-libmad, self-build-faad2
220- add patch100 for fix CVE2009-0135, CVE-2009-0136
221- add PreReq & BuildPreReq: libart_lgpl, libart_lgpl-devel
222
223* Wed Dec 31 2008 TOSHI <milk-tea1977@dune.ocn.ne.jp> 1.4.10-1vl5
224- initial build for Vine Seed.
225- add Patch3
226- spec in utf-8, and applied vine versioning policy
227
Note: See TracBrowser for help on using the repository browser.