source: projects/specs/trunk/a/alsaplayer/alsaplayer-vl.spec @ 521

Revision 521, 8.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define desktop_vendor vine
2
3Summary: Audio player for systems using the Advanced Linux Sound Architecture
4Name: alsaplayer
5Version: 0.99.79
6Release: 0vl3
7License: GPL
8Group: Applications/Multimedia
9URL: http://www.alsaplayer.org/
10Source0: http://www.alsaplayer.org/alsaplayer-%{version}.tar.bz2
11Source1: alsaplayer.png
12Source2: alsaplayer-small.png
13Source3: alsaplayer-large.png
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: alsa-lib, esound-devel, libvorbis-devel
16BuildRequires: flac-devel, libmad-devel, libid3tag-devel
17BuildRequires: libsndfile-devel, mikmod-devel
18BuildRequires: zlib-devel, gtk2-devel, gtk+-devel
19BuildRequires: gcc-c++, desktop-file-utils
20#BuildRequires:  doxygen
21BuildRequires: libxosd-devel
22Requires: mikmod, libsndfile, libxosd, libid3tag, libmad, libxosd
23
24%description
25AlsaPlayer is a new PCM player developed on the Linux Operating System. Since
26the first public beta release it support has been added for various other
27Operating Systems (mostly Unix variants). AlsaPlayer was written in the first
28place to excercise the new ALSA (Advanced Linux Sound Architecture) driver and
29library system.
30
31It has now developed into a versitile audio player with rich plugin system.
32The  Input Plugins plugins include: OGG, MPEG, MAD, CDDA, MikMod, and
33Audiofile. The Output Plugins include: ALSA, OSS and OSS/Lite, Esound,
34Sparc (tested on UltraSparc), SGI, and JACK. There are also a few scope
35plugins included.
36
37Install AlsaPlayer if you want a versatile audio player.
38
39
40%prep
41%setup -q
42
43%build
44%configure --enable-audiofile --enable-gtk2
45%{__make} %{?_smp_mflags}
46
47
48%install
49%{__rm} -rf %{buildroot}
50%{__make} install DESTDIR=%{buildroot}
51# Install icons
52%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
53%{__install} -m 644 %{SOURCE1} %{SOURCE2} %{SOURCE3} \
54    %{buildroot}%{_datadir}/pixmaps/
55
56# System menu entry
57%{__cat} << EOF > %{name}.desktop
58[Desktop Entry]
59Name=ALSA Player
60Comment=Audio player for the Advanced Linux Sound Architecture
61Icon=alsaplayer.png
62Exec=alsaplayer
63Terminal=false
64Type=Application
65Encoding=UTF-8
66EOF
67
68%{__rm} %{buildroot}%{_datadir}/applications/*.desktop
69
70%{__mkdir_p} %{buildroot}%{_datadir}/applications
71desktop-file-install --vendor %{desktop_vendor} \
72  --dir %{buildroot}%{_datadir}/applications    \
73  --add-category Application                    \
74  --add-category AudioVideo                     \
75  --delete-original                             \
76  %{name}.desktop
77
78# Clean up for the docs
79#%{__rm} -f examples/Makefile*
80%{__rm} -rf %{buildroot}%{_docdir}/%{name}
81
82
83%clean
84%{__rm} -rf %{buildroot}
85
86
87%files
88%defattr(-, root, root, 0755)
89%doc AUTHORS ChangeLog COPYING README TODO docs/reference/html
90%doc examples
91%{_bindir}/%{name}
92%{_includedir}/%{name}
93%{_libdir}/%{name}
94%{_libdir}/lib%{name}.*
95%{_libdir}/pkgconfig/%{name}.pc
96%{_mandir}/man1/%{name}.1*
97%{_datadir}/applications/*%{name}.desktop
98%{_datadir}/pixmaps/%{name}*
99
100
101%changelog
102* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.79-0vl3
103- rebuilt with flac-1.2.0
104
105* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.79-0vl2
106- deleted duplicated .desktop files
107
108* Tue May 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.79-0vl1
109- new upstream release
110- rebuilt with new toolchain
111
112* Sun Jul 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.76-0vl3
113- rebuilt for VineSeed (4.0)
114
115* Wed Apr  6 2005 Jun NISHII <jun@vinelinux.org>
116- build on Vine 3.1
117
118* Fri Jan 21 2005 Jun Nishii <jun@vinelinux.org> 0.99.76-0vl1
119- modify for Vine
120
121* Wed May 19 2004 Matthias Saou <http://freshrpms.net/> 0.99.76-2
122- Rebuild for Fedora Core 2.
123
124* Fri Nov  7 2003 Matthias Saou <http://freshrpms.net/> 0.99.76-1
125- Update to 0.99.76.
126- Rebuild for Fedora Core 1.
127- Added missing gcc-c++ build dependency.
128
129* Fri May  2 2003 Matthias Saou <http://freshrpms.net/>
130- Update to 0.99.75.
131
132* Mon Mar 31 2003 Matthias Saou <http://freshrpms.net/>
133- Rebuilt for Red Hat Linux 9.
134- Fix build order.
135
136* Sat Feb  8 2003 Matthias Saou <http://freshrpms.net/>
137- Update to 0.99.74.
138- Added xosd support.
139
140* Mon Jan 13 2003 Matthias Saou <http://freshrpms.net/>
141- Update to 0.99.73.
142
143* Fri Sep 27 2002 Matthias Saou <http://freshrpms.net/>
144- Rebuilt for Red Hat Linux 8.0.
145- New desktop entry.
146
147* Wed Sep 18 2002 Matthias Saou <http://freshrpms.net/>
148- Update to 0.99.72.
149- Further spec file changes and fixes.
150
151* Thu Sep  5 2002 Matthias Saou <http://freshrpms.net/>
152- Spec file cleanup to match freshrpms.net habits :-)
153
154* Sat Jul 6 2002 Angles <angles@aminvestments.com>
155- version 0.99.71
156
157* Thu May 30 2002 Angles <angles@aminvestments.com>
158- version 0.99.70
159- updated summary and description to highlight the apps increased versitility
160- minor spec file cleanup and desktop link update to latest usage
161
162* Sun May 5 2002 Angles <angles@aminvestments.com>
163- version 0.99.60
164- package now has include files
165- package has 4 files in libdir that actually belong there, not in a subdir
166- made patch so rpm installs docs, not the app make install
167
168* Sat Apr 6 2002 Angles <angles@phpgroupware.org>
169- version 0.99.58
170
171* Wed Mar 20 2002 Angles <angles@phpgroupware.org>
172- version 0.99.57
173
174* Sat Mar 02 2002 Angles <angles@phpgroupware.org>
175- version 0.99.54
176
177* Sat Feb 23 2002 Angles <angles@phpgroupware.org> 0.99.53-aap4
178- customize for RedHat 7.2
179
180* Sat Feb 16 2002 Yves Duret <yduret@mandrakesoft.com> 0.99.53-1mdk
181- version 0.99.53
182- %%makeinstall_std
183
184* Sat Jan 26 2002 Yves Duret <yduret@mandrakesoft.com> 0.99.52-1mdk
185- version 0.99.52
186- build against mad
187- png icons
188
189* Sat Dec 22 2001 Stefan van der Eijk <stefan@eijk.nu> 0.99.50-3mdk
190- fix BuildRequires
191
192* Fri Dec  7 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.50-2mdk
193- s|Copyright|License|;
194
195* Fri Sep 28 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.50-1mdk
196- 0.99.50.
197- Add --enable-alsa --enable-esd --disable-debug --enable-oggvorbis.
198
199* Fri Aug 24 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.36-1mdk
200- 0.99.36.
201
202* Sat Jun 16 2001 Stefan van der Eijk <stefan@eijk.nu> 0.99.33-0.2mdk
203- BuildRequires: gtk+-devel
204
205* Fri Jun 15 2001 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.33-0.1mdk
206- 0.99.33-pre3.
207
208* Fri Feb  9 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 0.99.32-13mdk
209- Do not exclude alpha from build.
210
211* Thu Dec  7 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.32-12mdk
212- Recompile with alsa-0.5.10.
213
214* Tue Nov 28 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.32-11mdk
215- Add icons.
216
217* Sat Nov 18 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.32-10mdk
218- fix gcc2.96 compilation.
219
220* Thu Oct 24 2000 David BAUDENS <baudens@mandrakesoft.com> 0.99.32-9mdk
221- EcludeArch: ppc
222
223* Thu Aug 24 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.99.32-8mdk
224- remove some debugging messages
225
226* Thu Aug 24 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.99.32-7mdk
227- build against latest alsa-lib
228- fix requires
229
230* Sun Aug 13 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.99.32-6mdk
231- disabled the use of makeinstall macro in order to have the libraries installed
232  in the correct place (reported by Anton Graham <darkimage@bigfoot.com>)
233- cleaner specfile
234- more menu dir macros
235
236* Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 0.99.32-5mdk
237- automatically added BuildRequires
238
239* Mon Jul 17 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.99.32-4mdk
240- fix macros
241
242* Tue Jun 27 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.32-3mdk
243- macroszifications.
244- build against latest alsa-lib
245- Use macros for update-menus.
246
247* Mon Jun 26 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.99.32-2mdk
248- build against latest alsa-lib
249- add url
250
251* Thu Jun 08 2000 Thierry Vignaud <tvignaud@mandrakesoft.com> 0.99.32-1mdk
252- new release
253
254* Fri May 19 2000 Francis Galiegue <fg@mandrakesoft.com> 0.99.31-2mdk
255
256- ExcludeArch: alpha sparc sparc64
257
258* Sun Apr 23 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 0.99.31-1mdk
259- Add menu entry.
260- Fix Requires.
261- Fix titi sucks.
262- Build again latest alsa-lib and libmikmod.
263
264* Thu Apr 20 2000 Guillaume Cottenceau <gc@mandrakesoft.com> 0.99.31-2mdk
265- fixed group
266
267* Thu Mar 09 2000 Thierry Vignaud <tvignaud@mandrakesoft.com>
268- update to 99.31
269- compiled against alsa-lib-0.5.5
270
271* Tue Aug 24 1999 Thierry Vignaud <tvignaud@mandrakesoft.com>
272- initial spec
Note: See TracBrowser for help on using the repository browser.