source: projects/specs/trunk/a/alsa-lib/alsa-lib-vl.spec @ 521

Revision 521, 11.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# --define nosrc:1 ... to make nosrc package
2Summary: Advanced Linux Sound Architecture (ALSA) Library
3Summary(ja): Advanced Linux Sound Architecture (ALSA) ライブラリ
4Name: alsa-lib
5Version: 1.0.22
6Release: 2%{?_dist_release}
7License: LGPLv2+
8Group: System Environment/Libraries
9Source: ftp://ftp.alsa-project.org/pub/lib/alsa-lib-%{version}.tar.bz2
10Patch2:  alsa-lib-1.0.14-glibc-open.patch
11Patch3:  alsa-lib-pulse-default.patch
12Patch4:  alsa-lib-1.0.16-no-dox-date.patch
13Patch10: alsa-lib-1.0.15-dmix-not-use-audio-group.patch
14
15%{?nosrc:NoSource:     0}
16URL: http://www.alsa-project.org/
17%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: doxygen
21#BuildRequires: python-devel
22%define make_doc %(which doxygen &> /dev/null && echo 1 || echo 0)
23
24#BuildRequires: alsa-driver >= 0.9
25#Requires: alsa-driver >= 0.9
26#Provides: libasound-%{version}.so
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Advanced Linux Sound Architecture (ALSA) - Library
33
34Features
35========
36* general
37  - modularized architecture with support for 2.0 and latest 2.1 kernels
38  - support for versioned and exported symbols
39  - full proc filesystem support - /proc/sound
40* ISA soundcards
41  - support for 128k ISA DMA buffer
42* mixer
43  - new enhanced API for applications
44  - support for unlimited number of channels
45  - volume can be set in three ways (percentual (0-100), exact and decibel)
46  - support for mute (and hardware mute if hardware supports it)
47  - support for mixer events
48    - this allows two or more applications to be synchronized
49* digital audio (PCM)
50  - new enhanced API for applications
51  - full real duplex support
52  - full duplex support for SoundBlaster 16/AWE soundcards
53  - digital audio data for playback and record should be read back using
54    proc filesystem
55* OSS/Lite compatibility
56  - full mixer compatibity
57  - full PCM (/dev/dsp) compatibility
58
59%description -l ja
60Advanced Linux Sound Architecture (ALSA) - ライブラリ
61
62仕様
63========
64* 総合
65  - 2.0以降のカーネル用にモジュール化された構造
66  - バージョンとシンボル群の出力をサポート
67  - procファイルシステムの完全なサポート - /proc/sound
68* ISAサウンドカード
69  - 128K ISA DMAバッファのサポート
70* ミキサー
71  - アプリケーション用に拡張された新しいAPI
72  - 無制限のチャンネル数をサポート
73  - 3通りの音量調整 (パーセント (0-100)、厳密 そして デシベル)
74  - 消音時のサポート (及び、ハードウェアが対応していればハードウェアによる消音のサポート)
75  - ミキサーによる制御をサポート
76    - this allows two or more applications to be synchronized
77* デジタルオーディオ (PCM)
78  - アプリケーション用に拡張された新しいAPI
79  - 完全な二重化通信をサポート
80  - SoundBlaster 16/AWE用の完全な二重化通信をサポート
81  - proc filesystemを用いたデジタル音声の再生と録音
82* OSS/Lite互換性
83  - ミキサーとの完全互換
84  - PCMとの完全互換 (/dev/dsp)
85
86
87%package -n compat32-%{name}
88Summary: Advanced Linux Sound Architecture (ALSA) Library
89Summary(ja): Advanced Linux Sound Architecture (ALSA) ライブラリ
90Group: System Environment/Libraries
91Requires: alsa-lib = %{version}
92
93%description -n compat32-%{name}
94Advanced Linux Sound Architecture (ALSA) - Library
95
96Features
97========
98* general
99  - modularized architecture with support for 2.0 and latest 2.1 kernels
100  - support for versioned and exported symbols
101  - full proc filesystem support - /proc/sound
102* ISA soundcards
103  - support for 128k ISA DMA buffer
104* mixer
105  - new enhanced API for applications
106  - support for unlimited number of channels
107  - volume can be set in three ways (percentual (0-100), exact and decibel)
108  - support for mute (and hardware mute if hardware supports it)
109  - support for mixer events
110    - this allows two or more applications to be synchronized
111* digital audio (PCM)
112  - new enhanced API for applications
113  - full real duplex support
114  - full duplex support for SoundBlaster 16/AWE soundcards
115  - digital audio data for playback and record should be read back using
116    proc filesystem
117* OSS/Lite compatibility
118  - full mixer compatibity
119  - full PCM (/dev/dsp) compatibility
120
121
122%description -n compat32-%{name} -l ja
123Advanced Linux Sound Architecture (ALSA) - ライブラリ
124
125仕様
126========
127* 総合
128  - 2.0以降のカーネル用にモジュール化された構造
129  - バージョンとシンボル群の出力をサポート
130  - procファイルシステムの完全なサポート - /proc/sound
131* ISAサウンドカード
132  - 128K ISA DMAバッファのサポート
133* ミキサー
134  - アプリケーション用に拡張された新しいAPI
135  - 無制限のチャンネル数をサポート
136  - 3通りの音量調整 (パーセント (0-100)、厳密 そして デシベル)
137  - 消音時のサポート (及び、ハードウェアが対応していればハードウェアによる消音のサポート)
138  - ミキサーによる制御をサポート
139    - this allows two or more applications to be synchronized
140* デジタルオーディオ (PCM)
141  - アプリケーション用に拡張された新しいAPI
142  - 完全な二重化通信をサポート
143  - SoundBlaster 16/AWE用の完全な二重化通信をサポート
144  - proc filesystemを用いたデジタル音声の再生と録音
145* OSS/Lite互換性
146  - ミキサーとの完全互換
147  - PCMとの完全互換 (/dev/dsp)
148
149
150%package devel
151Summary: Development files for alsa-lib
152Summary(ja): alsa-lib の開発用ファイル
153Group: Development/Libraries
154Requires: alsa-lib = %{version}
155
156%description devel
157alsa-lib-devel package includes thje static libraries and  header files.
158
159%description -l ja devel
160alsa-lib-develパッケージは静的ライブラリとヘッダファイルを含んでいます。
161
162
163%package -n compat32-%{name}-devel
164Summary: Development files for alsa-lib
165Summary(ja): alsa-lib の開発用ファイル
166Group: Development/Libraries
167Requires: %{name}-devel    = %{version}
168Requires: compat32-%{name} = %{version}
169
170%description -n compat32-%{name}-devel
171alsa-lib-devel package includes thje static libraries and  header files.
172
173%description -n compat32-%{name}-devel -l ja
174alsa-lib-develパッケージは静的ライブラリとヘッダファイルを含んでいます。
175
176
177%prep
178%setup -q
179%patch2 -p1 -b .glibc-open
180%patch3 -p1 -b .pulse-default
181%patch4 -p1 -b .no-dox-date
182#%patch5 -p1 -b .softvolmute
183#%patch6 -p1 -b .clamprrfw
184#%patch7 -p1 -b .fixtype
185#%patch8 -p1 -b .fixreturnrrfw
186%patch10 -p1
187
188%build
189%configure --disable-python
190make %{?_smp_mflags}
191
192%if %make_doc
193 make doc
194%endif
195
196%install
197rm -rf %{buildroot}
198make install DESTDIR=$RPM_BUILD_ROOT
199
200rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
201rm -f $RPM_BUILD_ROOT/%{_libdir}/alsa-lib/smixer/*.la
202
203%clean
204rm -rf %{buildroot}
205
206%post -p /sbin/ldconfig
207
208%postun -p /sbin/ldconfig
209
210%files
211%defattr(-, root, root)
212%doc [A-Z][^a]* doc/R* doc/*.txt
213%{_libdir}/lib*.so.*
214%dir %{_libdir}/alsa-lib
215%{_libdir}/alsa-lib/smixer/*.so
216%{_datadir}/alsa/*
217%{_bindir}/aserver
218
219%files devel
220%defattr(-, root, root)
221%if %make_doc
222  %doc doc/doxygen/html
223%endif
224%{_libdir}/lib*.so
225%{_includedir}/alsa
226%{_includedir}/sys/asoundlib.h
227%{_libdir}/pkgconfig/alsa.pc
228%{_datadir}/aclocal/alsa.m4
229
230%if %{build_compat32}
231%files -n compat32-%{name}
232%defattr(-, root, root)
233%{_libdir}/lib*.so.*
234%dir %{_libdir}/alsa-lib
235%{_libdir}/alsa-lib/smixer/*.so
236
237%files -n compat32-%{name}-devel
238%defattr(-, root, root)
239%{_libdir}/lib*.so
240%{_libdir}/pkgconfig/alsa.pc
241%endif
242
243
244%changelog
245* Tue Jan 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.22-2
246- added --disable-python
247- added %%post and %%postun section
248
249* Wed Dec 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.22-1
250- new upstream release
251- added BR: python-devel
252
253* Thu Oct  8 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.21a-1
254- new upstream release
255
256* Sun Jun 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.20-1
257- new upstream release
258
259* Wed Feb 18 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.19-1
260- new upstream release
261- drop Patch5/6/7/8 since they are already merged into upstream
262
263* Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.17-1
264- new upstream release
265- add patches from upstream to better support pulseaudio
266- add hook to /etc/alsa/default-pluse.conf
267- disable static libs
268
269* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.16-1vl5
270- new upstream release
271
272* Sun Oct 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.15-0vl1
273- new upstream release
274- updated Patch10
275
276* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-0vl2
277- add Patch10 (not to use audio group for dmix)
278
279* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-0vl1
280- new upstream release
281
282* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.10-0vl5
283- removed unnecessary branch statement
284
285* Tue Jun 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.10-0vl4
286- add BuildRequires: doxygen again
287
288* Mon Mar 13 2006 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.0.10-0vl3
289- added compat32-* packages for x86_64 architecture support
290
291* Sat Mar 11 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.10-0vl2
292- unused libtool at make
293- rebuilt for x86_64 architecture
294
295* Sat Dec 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.10-0vl1
296- new upstream release
297
298* Sat Jun 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl2
299- add Japanese summary and description (thanks to Masa Takahashi)
300
301* Fri Jun 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
302- new upstream release
303
304* Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-0vl1
305- new upstream version
306- remove Requires: alsa-driver
307- split development files to alsa-lib-devel
308
309* Wed Aug 04 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
310- New upstream version alsa-lib-1.0.5)
311
312* Sat May 29 2004 IWAI, Masaharu <iwai@alib.jp> 1.0.4-0vl2
313- rebuild for VineSeed
314- merged spec file from 1.0.4-0vl2.13
315
316* Mon Apr 26 2004 Masaki Shinomiya <shino@pos.to> 1.0.4-0vl1
317- new upstream release
318
319* Sat Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
320- rebuild for VineSeed
321
322* Thu Feb 12 2004 Masaki Shinomiya <shino@pos.to> 1.0.2-0vl1
323- new upstream release
324- not buildrequire alsa-driver
325- make doc if doxygen installed
326
327* Fri Feb 15 2002 Toru Sagami <sagami@vinelinux.org> 0.5.10b-0vl2
328- rebuilt on current environment
329
330* Tue Mar 27 2001 Satoshi MACHINO <machino@vinelinux.org> 0.5.10b-0vl1
331- updated 0.5.10b and build kernel-2.2.18-0vl13
332
333* Sun Jan 14 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
334- 0.5.10-0vl2
335- use better macros and makeinstall
336
337* Thu Dec 07 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
338- 0.5.10
339- removed Provides: libasound-0.5.5.so
340
341* Tue Jun 20 2000 Toru Sagami <czs14350@nifty.ne.jp>
342- import to Vine 0.5.8-0vl1 from 0.5.8-0k1
343- BuildRequires: alsa-driver >= 0.5.5
344
345* Tue Jun  5 2000 AYUHANA Tomonori <l@kondara.org>
346- Version up 0.5.7 -> 0.5.8
347- add -q at %setup
348- use %%configure
349
350* Thu Apr  9 2000 Toru Hoshina <t@kondara.org>
351- Version up 0.5.6 -> 0.5.7
352
353* Wed Mar 15 2000 Daiki Matsuda <dyky@kondara.org>
354- Version up 0.5.5 -> 0.5.6
355- Provides libasound-0.5.5.so for compatiblity
356
357* Thu Mar  2 2000 Toru Hoshina <t@kondara.org>
358- Version up 0.5.4 -> 0.5.5
359
360* Sun Feb 28 2000 Toru Hoshina <t@kondara.org>
361- Version up 0.4.1e -> 0.5.4
362
363* Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
364- be a NoSrc :-P
365
366* Mon May 28 1998 Helge Jensen <slog@slog.dk>
367
368- Made SPEC file
Note: See TracBrowser for help on using the repository browser.