source: projects/specs/trunk/a/alsa-firmware/alsa-firmware-vl.spec @ 521

Revision 521, 6.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Firmware for several ALSA-supported sound cards
2Summary(ja):    ALSA がサポートするサウンドカード用のファームウェア
3Name:           alsa-firmware
4Version:        1.0.20
5Release:        1%{?_dist_release}
6# See later in the spec for a breakdown of licensing
7License:        GPL+ and BSD and GPLv2+ and GPLv2 and LGPLv2+
8Group:          Applications/Multimedia
9URL:            http://www.alsa-project.org/
10# This source removes the emi_26_62 firmware which is under a questionable
11# license. See bug #217259.
12# To generate the "pruned" tarball, extract the original source, remove
13# the emi_26_62 directory and create a new tarball with a "-pruned" suffix.
14# Original source: ftp://ftp.alsa-project.org/pub/firmware/%{name}-%{version}.tar.bz2
15Source0:        %{name}-%{version}-pruned.tar.bz2
16Source1:        alsa-firmware.README
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18Requires:       alsa-tools-firmware >= %{version}
19Requires:       udev
20BuildRequires:  automake
21BuildRequires:  autoconf
22
23# noarch, since the package is firmware
24BuildArch:      noarch
25
26%description
27This package contains the firmware binaries for a number of sound cards.
28Some (but not all of these) require firmware loaders which are included in
29the alsa-tools-firmware package.
30
31%description -l ja
32このパッケージには、いろんな種類のサウンドカード用のファームウェアが
33収録されています。これらファームウェアの中には、alsa-tools-firmware
34パッケージに収録されているファームウェアローダを必要とするものがあります。
35
36
37%prep
38%setup -q
39
40
41%build
42# emi_26_62 is not in the pruned tarball
43sed -i s#'emi_26_62/Makefile \\'## configure.in
44sed -i s#emi_26_62## Makefile.am
45
46# Leaving this directory in place ends up with the following crazy, broken
47# symlinks in the output RPM, with no sign of the actual firmware (*.bin) files
48# themselves:
49#
50# /lib/firmware/turtlebeach:
51# msndinit.bin -> /etc/sound/msndinit.bin
52# msndperm.bin -> /etc/sound/msndperm.bin
53# pndsperm.bin -> /etc/sound/pndsperm.bin
54# pndspini.bin -> /etc/sound/pndspini.bin
55#
56# Probably an upstream package bug.
57sed -i s#'multisound/Makefile \\'## configure.in
58sed -i s#multisound## Makefile.am
59
60%__aclocal
61%__automake
62%__autoconf
63%configure --disable-loader
64make %{?_smp_mflags}
65
66# Rename README files from firmware subdirs that have them
67for i in hdsploader mixartloader pcxhrloader usx2yloader vxloader
68do
69  mv ${i}/README README.${i}
70done
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make install DESTDIR=%{buildroot}
76cp -p %{SOURCE1} README.00alsa-firmware
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81
82%files
83%defattr(-,root,root,-)
84%doc COPYING README*
85
86# License: KOS (BSD-alike)
87/lib/firmware/aica_firmware.bin
88
89# License: No explicit license; default package license is GPLv2+
90/lib/firmware/asihpi
91
92# License: GPL (undefined version)
93/lib/firmware/digiface_firmware*
94
95# The licenses for the Echo Audio firmware vary slightly so each is enumerated
96# separately, to be really sure.
97# LGPLv2.1+
98/lib/firmware/ea/3g_asic.fw
99# GPL (undefined version)
100/lib/firmware/ea/darla20_dsp.fw
101# LGPLv2.1+
102/lib/firmware/ea/darla24_dsp.fw
103# LGPLv2.1+
104/lib/firmware/ea/echo3g_dsp.fw
105# GPL (undefined version)
106/lib/firmware/ea/gina20_dsp.fw
107# GPL (undefined version)
108/lib/firmware/ea/gina24_301_asic.fw
109# GPL (undefined version)
110/lib/firmware/ea/gina24_301_dsp.fw
111# GPL (undefined version)
112/lib/firmware/ea/gina24_361_asic.fw
113# GPL (undefined version)
114/lib/firmware/ea/gina24_361_dsp.fw
115# LGPLv2.1+
116/lib/firmware/ea/indigo_dj_dsp.fw
117# LGPLv2.1+
118/lib/firmware/ea/indigo_dsp.fw
119# LGPLv2.1+
120/lib/firmware/ea/indigo_io_dsp.fw
121# LGPLv2.1+
122/lib/firmware/ea/indigo_djx_dsp.fw
123# LGPLv2.1+
124/lib/firmware/ea/indigo_iox_dsp.fw
125# GPL (undefined version)
126/lib/firmware/ea/layla20_asic.fw
127# GPL (undefined version)
128/lib/firmware/ea/layla20_dsp.fw
129# GPL (undefined version)
130/lib/firmware/ea/layla24_1_asic.fw
131# GPL (undefined version)
132/lib/firmware/ea/layla24_2A_asic.fw
133# GPL (undefined version)
134/lib/firmware/ea/layla24_2S_asic.fw
135# GPL (undefined version)
136/lib/firmware/ea/layla24_dsp.fw
137# GPL (undefined version)
138/lib/firmware/ea/loader_dsp.fw
139# LGPLv2.1+
140/lib/firmware/ea/mia_dsp.fw
141# GPL (undefined version)
142/lib/firmware/ea/mona_2_asic.fw
143# GPL (undefined version)
144/lib/firmware/ea/mona_301_1_asic_48.fw
145# GPL (undefined version)
146/lib/firmware/ea/mona_301_1_asic_96.fw
147# GPL (undefined version)
148/lib/firmware/ea/mona_301_dsp.fw
149# GPL (undefined version)
150/lib/firmware/ea/mona_361_1_asic_48.fw
151# GPL (undefined version)
152/lib/firmware/ea/mona_361_1_asic_96.fw
153# GPL (undefined version)
154/lib/firmware/ea/mona_361_dsp.fw
155
156# Licenses vary so are enumerated separately
157# GPLv2
158/lib/firmware/emu/audio_dock.fw
159# GPLv2
160/lib/firmware/emu/emu0404.fw
161# GPLv2
162/lib/firmware/emu/emu1010_notebook.fw
163# GPLv2
164/lib/firmware/emu/emu1010b.fw
165# GPLv2
166/lib/firmware/emu/hana.fw
167# GPLv2+
168/lib/firmware/emu/micro_dock.fw
169
170# License: GPL (undefined version)
171/lib/firmware/ess
172
173# License: No explicit license; default package license is GPLv2+
174/lib/firmware/korg
175
176# License: GPL (undefined version)
177/lib/firmware/mixart
178
179# License: GPL (undefined version)
180/lib/firmware/multiface_firmware*
181
182# License: GPL (undefined version)
183/lib/firmware/pcxhr
184
185# License: GPLv2+
186/lib/firmware/sb16
187
188# License: GPL (undefined version)
189/lib/firmware/vx
190
191# License: No explicit license; default package license is GPLv2+
192# See ALSA bug #3412
193/lib/firmware/yamaha
194
195# Even with --disable-loader, we still get usxxx firmware here; looking at the
196# alsa-tools-firmware package, it seems like these devices probably use an old-
197# style hotplug loading method
198# License: GPL (undefined version)
199%{_datadir}/alsa/firmware
200
201
202%changelog
203* Thu Jul  2 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.20-1
204- new upstream release
205
206* Thu Feb 19 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.19-1
207- initial build for Vine Linux
208
209* Tue Jan 20 2009 Tim Jackson <rpm@timj.co.uk> - 1.0.19-1
210- Update to 1.0.19
211
212* Mon Jul 21 2008 Jaroslav Kysela <jkysela@redhat.com> - 1.0.17-1
213- Updated to 1.0.17
214
215* Mon May 12 2008 Tim Jackson <rpm@timj.co.uk> - 1.0.16-1
216- Update to upstream 1.0.16
217- Clarify licensing conditions
218
219* Tue Aug 14 2007 Tim Jackson <rpm@timj.co.uk> - 1.0.14-1
220- Update to upstream 1.0.14, but skip turtlebeach firmware as it doesn't seem
221  to install properly
222- Remove files from old-style firmware loader locations
223- Spec file cosmetics, keep rpmlint quiet
224
225* Sat Nov 25 2006 Tim Jackson <rpm@timj.co.uk> - 1.0.12-1
226- Update to 1.0.12
227- Add udev dep
228
229* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
230- rebuilt
231
232* Sat Apr 03 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.4-0.fdr.1
233- Update to 1.0.4
234
235* Fri Jan 16 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.1-0.fdr.2
236- add missing rm in install section
237
238* Fri Jan 09 2004 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 1.0.1-0.fdr.1
239- Update to 1.0.1
240- Contains now the license -- is "Distributable under GPL"
241
242* Thu Dec 04 2003 Thorsten Leemhuis <fedora[AT]leemhuis.info> 1.0.0-0.fdr.0.1.rc1
243- Initial build.
Note: See TracBrowser for help on using the repository browser.