source: projects/specs/trunk/a/alacarte/alacarte-vl.spec @ 6323

Revision 6323, 7.7 KB checked in by Takemikaduchi, 12 years ago (diff)

cinnamon,muffin: New Package
others: new upstream release

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           alacarte
4Version:        0.13.4
5Release:        1%{?_dist_release}
6Summary:        Menu editor for the GNOME desktop
7Summary(ja):    GNOME デスクトップ用メニューエディタ
8
9Group:          Applications/System
10License:        LGPLv2+
11URL:            http://www.gnome.org
12Source0:        http://download.gnome.org/sources/alacarte/0.13/%{name}-%{version}.tar.xz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15
16BuildRequires:  gettext
17BuildRequires:  python-devel
18BuildRequires:  pygobject3-devel
19BuildRequires:  gnome-menus-devel >= 3.2.0.1
20BuildRequires:  intltool
21BuildRequires:  desktop-file-utils
22
23Requires:       gnome-menus >= 3.2.0.1
24
25%description
26Alacarte is a graphical menu editor that lets you edit, add, and delete
27menu entries. It follows the freedesktop.org menu specification and
28should work with any desktop environment that uses this specification.
29
30%prep
31%setup -q
32
33%build
34%configure
35make
36
37%install
38rm -rf $RPM_BUILD_ROOT
39make install DESTDIR=$RPM_BUILD_ROOT
40
41# desktop-file-install can't manipulate NotShowIn
42sed -i -e 's/NotShowIn=KDE;/OnlyShowIn=GNOME;/' \
43  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
44desktop-file-validate \
45  $RPM_BUILD_ROOT%{_datadir}/applications/alacarte.desktop
46
47
48%find_lang %{name}
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%post
54touch --no-create %{_datadir}/icons/hicolor
55if [ -x /usr/bin/gtk-update-icon-cache ]; then
56  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
57fi
58
59%postun
60touch --no-create %{_datadir}/icons/hicolor
61if [ -x /usr/bin/gtk-update-icon-cache ]; then
62  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
63fi
64
65%files -f %{name}.lang
66%defattr(-,root,root,-)
67%doc README AUTHORS COPYING
68%{python_sitelib}/Alacarte
69%{_bindir}/alacarte
70%{_datadir}/applications/alacarte.desktop
71%{_datadir}/alacarte
72%{_datadir}/icons/hicolor/16x16/apps/alacarte.png
73%{_datadir}/icons/hicolor/22x22/apps/alacarte.png
74%{_datadir}/icons/hicolor/24x24/apps/alacarte.png
75%{_datadir}/icons/hicolor/32x32/apps/alacarte.png
76%{_datadir}/icons/hicolor/48x48/apps/alacarte.png
77%{_datadir}/icons/hicolor/256x256/apps/alacarte.png
78
79%changelog
80* Sun Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.4-1
81- new upstream release
82- remove Patch0
83- remove BuildRequires: pygtk2-devel
84- add BuildRequires: pygobject3-devel
85- remove Requires: pygtk2, gnome-python
86
87* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.2-1
88- new upstream release
89
90* Sat Apr 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.13.1-1
91- new upstream release
92
93* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.12.4-2
94- initial build for Vine Linux
95
96* Mon Sep 21 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.4-1
97- Update to 0.12.4
98
99* Sat Sep 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-2
100- Bump the gnome-menus requires
101
102* Tue Sep  8 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.3-1
103- Update to 0.12.3
104
105* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12.1-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Sat May 16 2009 Matthias Clasen <mclasen@redhat.com> - 0.12.1-1
109- Update to 0.12.1
110
111* Tue Mar 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.10-1
112- Update to 0.11.10
113
114* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.9-3
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
116
117* Mon Feb 23 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-2
118- Only show in GNOME (#486887)
119
120* Tue Feb 17 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.9-1
121- Update to 0.11.9
122
123* Tue Feb  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.8-1
124- Update to 0.11.8
125
126* Tue Jan 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.11.7-1
127- Update to 0.11.7
128
129* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.11.6-6
130- Rebuild for Python 2.6
131
132* Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-5
133- Tweak %%summary and %%description
134
135* Fri Oct 17 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-4
136- Make undoing of deletion work
137
138* Mon Sep 22 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.6-3
139- Update to 0.11.6
140
141* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.5-1
142- Update to 0.11.5
143
144* Thu Feb 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.11.4-1
145- Update to 0.11.4
146
147* Sun Dec 02 2007 Todd Zullinger <tmz@pobox.com> - 0.11.3-5
148- put the python scripts in sitelib, not sitearch
149- remove autoconf, automake, and intltool BRs
150- don't run autoconf/automake in %%build
151- BR perl(XML::Parser)
152- remove smeg Obsoletes and Provides
153- minor rpmlint cleanups
154
155* Sat Aug 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-4
156- Fix the build with intltool 0.36
157- Update the license field
158
159* Fri Mar 23 2007 Ray Strode <rstrode@redhat.com> - 0.11.3-3
160- change url to gnome.org (bug 233237)
161
162* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.3-2
163- Update to 0.11.3
164
165* Mon Feb 12 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.2-1.svn20070212
166- Bring back editing of the System menu
167
168* Fri Jan 26 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-2
169- Fix the Provides: line
170
171* Thu Jan 11 2007 Matthias Clasen <mclasen@redhat.com> - 0.11.1.1-1
172- Update to 0.11.1.1
173
174* Wed Dec 20 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.2-2
175- Update to 0.10.2
176
177* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-4
178- try again
179
180* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.10.1-2
181- build against python 2.5
182
183* Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.1-1
184- Update to 0.10.1
185* Mon Sep  4 2006 Matthias Clasen <mclasen@redhat.com> - 0.10.0-1.fc6
186- Update to 0.10.0
187
188* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-7.fc6
189- Fix more build requires
190
191* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-3.fc6
192- Add BR for pkgconfig
193
194* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 0.9.90-1.fc6
195- Update to 0.9.90
196
197* Thu Aug 17 2006 Ray Strode <rstrode@redhat.com> - 0.8-8
198- initial build for Fedora Core
199
200* Wed Feb 15 2006 John Mahowald <jpmahowald@gmail.com> - 0.8-7
201- Rebuild for Fedora Extras 5
202
203* Fri Feb 3 2006  John Mahowald <jpmahowald@gmail.com> - 0.8-3
204- Fix stray reference to smeg
205- Use python sitearch macro from template
206
207* Sat Oct 29 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-2
208- Rebuild
209
210* Thu Oct 27 2005  John Mahowald <jpmahowald@gmail.com> - 0.8-1
211- rename to alacarte
212- Update to 0.8
213
214* Thu Oct 20 2005  John Mahowald <jpmahowald@gmail.com> - 0.7.5-4
215- remove requires gnome-menus
216
217* Tue Aug 30 2005 John Mahowald <jpmahowald@gmail.com> - 0.7.5-3
218- Move to /usr/share
219
220* Tue Jun 28 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-2
221- Desktop-file-utils for kde desktop entry as well as default one.
222
223* Wed Jun 08 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.5-1
224- Rebuilt for 0.7.5
225
226* Sun Jun 06 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.4-1
227- Rebuilt for 0.7.4
228
229* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7.1-1
230- Rebuilt for 0.7.1
231- Smeg now use the stock gnome menu icon, removed pixmaps from %%files
232
233* Wed Jun 01 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-2
234- Added missing dependency gnome-python2-gconf
235
236* Tue May 31 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.7-1
237- Rebuilt for 0.7
238
239* Mon May 30 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-2
240- Added desktop-file-utils to Buildrequires
241- Addded desktop-file-utils %%post and %%postun
242
243* Sat May 29 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.6.2-1
244- Rebuilt for 0.6.2
245
246* Mon May 23 2005 Sindre Pedersen Bjordal <foolish[AT]fedoraforum.org> - 0.5-1
247- Initial build
Note: See TracBrowser for help on using the repository browser.