source: projects/specs/trunk/a/agg/agg-vl.spec @ 10579

Revision 10579, 7.5 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Summary: Anti-Grain Geometry
2Name:    agg
3Version: 2.5
4Release: 3%{?_dist_release}
5Group:   System Environment/Libraries
6URL:     http://www.antigrain.com
7License: GPL
8#Source:  http://www.antigrain.com/%{name}-%{version}.tar.gz
9Source0: %{name}-free-%{version}.tar.gz
10# agg contains gpc.c, 'free for non-commercial use', we cannot ship.
11# We use this script to remove the non-free code before shipping it.
12# Download the upstream tarball and invoke this script while in the
13# tarball's directory:
14# sh agg-generate-tarball.sh 2.5
15Source1: agg-generate-tarball.sh
16
17Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires: automake, libtool, xorg-x11-devel, freetype2-devel, SDL-devel
19
20Patch0: agg-2.4-depends.patch
21Patch1: agg-2.5-pkgconfig.patch
22Patch2: agg-2.5-autotools.patch
23
24Patch101: 0001-Fix-non-terminating-loop-conditions-when-len-1.patch
25Patch102: 0002-Cure-recursion-by-aborting-if-the-co-ordinates-are-t.patch
26Patch103: 0003-Get-coordinates-from-previous-vertex-if-last-command.patch
27Patch104: 0004-Make-rasterizer_outline_aa-ignore-close_polygon-when.patch
28Patch105: 0005-Remove-VC-6-workaround.patch
29Patch106: 0006-Implement-grain-merge-blending-mode-GIMP.patch
30Patch107: 0007-Implement-grain-extract-blending-mode-GIMP.patch
31Patch108: 0008-Declare-multiplication-and-division-operators-as-con.patch
32Patch109: 0009-Add-a-static-identity-transformation.patch
33Patch110: 0010-Add-renderer_scanline_aa_alpha.patch
34Patch111: 0011-Avoid-division-by-zero-in-color-burn-mode.patch
35Patch112: 0012-Avoid-pixel-artifacts-when-compositing.patch
36Patch113: 0013-Modify-agg-conv-classes-to-allow-access-to-the-origi.patch
37Patch114: 0014-Avoid-potential-zero-division-resulting-in-nan-in-ag.patch
38Patch115: 0015-Ensure-first-value-in-the-gamma-table-is-always-zero.patch
39
40%description
41A High Quality Rendering Engine for C++
42
43%package devel
44Summary: Support files necessary to compile applications with agg
45Group: Development/Libraries
46Requires: agg = %{version}-%{release}
47
48%description devel
49Libraries, headers, and support files necessary to compile applications using agg
50
51%prep
52%setup -q
53%patch0 -p1 -b .depends
54%patch1 -p1 -b .pkgconfig
55%patch2 -p0 -b .autotools
56%patch101 -p1
57%patch102 -p1
58%patch103 -p1
59%patch104 -p1
60%patch105 -p1
61%patch106 -p1
62%patch107 -p1
63%patch108 -p1
64%patch109 -p1
65%patch110 -p1
66%patch111 -p1
67%patch112 -p1
68%patch113 -p1
69%patch114 -p1
70%patch115 -p1
71aclocal
72autoheader
73autoconf
74libtoolize --force
75automake --foreign --add-missing --ignore-deps
76
77%build
78%configure --disable-static --disable-gpc
79# parallel build fails in examples/ because the .la is in _LDFLAGS instead of
80# _LIBADD
81make
82
83%install
84make install DESTDIR=$RPM_BUILD_ROOT
85rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
86
87rm -rf __dist_examples __clean_examples
88cp -a examples __clean_examples
89make -C __clean_examples distclean
90rm -rf __clean_examples/Makefile.am __clean_examples/{win32*,macosx*,BeOS}
91mkdir __dist_examples
92mv __clean_examples __dist_examples/examples
93
94%post
95/sbin/ldconfig
96
97%postun
98/sbin/ldconfig
99
100%files
101%defattr(-,root,root)
102%doc authors copying readme
103%{_libdir}/lib*.so.*
104
105%files devel
106%{_libdir}/*.so
107%{_libdir}/pkgconfig/libagg.pc
108%{_includedir}/agg2
109%{_datadir}/aclocal/libagg.m4
110
111%clean
112rm -r $RPM_BUILD_ROOT
113
114%changelog
115* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-3
116- rebuild with gcc-5.4.0
117
118* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5-2
119- merge with fedora rawhide package
120  * Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-23
121  - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
122  * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.5-22
123  - Rebuilt for GCC 5 C++11 ABI change
124  * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-21
125  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
126  * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-20
127  - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
128  * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-19
129  - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
130  * Sat Jun 22 2013 Tom Hughes <tom@compton.nu> - 2.5-18
131  - Update mapnik patches
132  * Sun May 19 2013 Tom Hughes <tom@compton.nu> - 2.5-17
133  - Add patches from mapnik
134  * Fri Feb 22 2013 Jon Ciesla <limburgher@gmail.com> - 2.5-16
135  - Fix FTBFS, BZ 913873.
136  * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-15
137  - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
138  * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-14
139  - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
140  * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-13
141  - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
142  * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-12
143  - Rebuilt for glibc bug#747377
144  * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-11
145  - Rebuilt for glibc bug#747377
146  * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-10
147  - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
148  * Fri Jan 29 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 2.5-9
149  - also remove include/agg_conv_gpc.h as it also carries a copy of the non-Free
150    GPC license (upstream also recommends removing that file under
151    http://www.antigrain.com/license/index.html#toc0005) (#559611)
152  * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-8
153  - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
154  * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-7
155  - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156  * Tue Feb  5 2008 Patrice Dumas <pertusus@free.fr> - 2.5-6
157  - remove non free files
158  - minor cleanups
159  - parallel build fails
160  * Fri Aug 03 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-4
161  - clarify license
162  - source upstream silently changed even though version remained
163    unchanged
164  * Tue Jun 26 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-3
165  - Resolves: rhbz#245650 -devel Require: freetype-devel
166  * Mon Apr 23 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-2
167  - Resolves: rhbz#237493 misapplied patch
168
169* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.5-1vl5
170- applied new versioning policy
171- rebuilt with xorg-x11-devel
172
173* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
174- initial build for Vine Linux
175
176* Sat Jan 06 2007 Caolan McNamara <caolanm@redhat.com> - 2.5-1
177- bump to 2.5
178
179* Fri Nov 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-3
180- Resolves: rhbz#214970 rebuild with new 2.4 sources
181
182* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4-2.1
183- rebuild
184
185* Mon Jul 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-2
186- rh#198174# add extra links from libs to their runtime requirements
187
188* Wed May 10 2006 Caolan McNamara <caolanm@redhat.com> - 2.4-1
189- next version
190
191* Fri Feb 17 2006 Karsten Hopp <karsten@redhat.de> 2.3-4
192- add BuildRequires freetype-devel for ft2build.h
193
194* Mon Feb 13 2006 Caolan McNamara <caolanm@redhat.com> - 2.3-3
195- BuildRequires
196
197* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.3-2.1
198- bump again for double-long bug on ppc(64)
199
200* Wed Feb 08 2006 Caolan McNamara <caolanm@redhat.com> - 2.3-2
201- rh#180341# BuildRequires
202
203* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.3-1.1
204- rebuilt for new gcc4.1 snapshot and glibc changes
205
206* Wed Nov 23 2005 Caolan McNamara <caolanm@redhat.com> 2.3-1
207- initial import
Note: See TracBrowser for help on using the repository browser.