source: projects/specs/trunk/a/acpica-tools/acpica-tools-vl.spec @ 11501

Revision 11501, 13.4 KB checked in by tomop, 6 years ago (diff)

acpica-tools-20180105-1

Line 
1Name:           acpica-tools
2Version:        20180105
3Release:        1%{?_dist_release}
4Summary:        ACPICA tools for the development and debug of ACPI tables
5
6Group:          Development/Languages
7License:        GPLv2
8URL:            https://www.acpica.org/
9
10Source0:        https://acpica.org/sites/acpica/files/acpica-unix2-%{version}.tar.gz
11Source1:        https://acpica.org/sites/acpica/files/acpitests-unix-%{version}.tar.gz
12Source2:        README.Fedora
13Source3:        iasl.1
14Source4:        acpibin.1
15Source5:        acpidump.1
16Source6:        acpiexec.1
17Source7:        acpihelp.1
18Source8:        acpinames.1
19Source9:        acpisrc.1
20Source10:       acpixtract.1
21Source11:       badcode.asl.result
22Source12:       grammar.asl.result
23Source13:       run-misc-tests.sh
24Source14:       COPYING
25
26Patch0:         big-endian.patch
27Patch1:         unaligned.patch
28Patch2:         OPT_LDFLAGS.patch
29Patch3:         int-format.patch
30Patch4:         f23-harden.patch
31Patch5:         template.patch
32Patch6:         free.patch
33Patch7:         ppc64le.patch
34Patch8:         arm7hl.patch
35Patch9:         big-endian-v2.patch
36Patch10:        simple-64bit.patch
37Patch11:        be-tpm2.patch
38Patch12:        mips-be-fix.patch
39
40BuildRequires:  bison patchutils flex
41
42# The previous iasl package contained only a very small subset of these tools
43# and it produced only the iasl package listed below; further, the pmtools
44# package -- which provides acpidump -- also provides a /usr/sbin/acpixtract
45# that we don't really want to collide with
46Provides:       acpixtract >= 20120913-7
47Provides:       iasl = %{version}-%{release}
48Obsoletes:      iasl < 20120913-8
49
50# The pmtools package provides an obsolete and deprecated version of the
51# acpidump command from lesswatts.org which has now been taken off-line.
52# ACPICA, however, is providing a new version and we again do not want to
53# conflict with the command name.
54Provides:       acpidump >= 20100513-5
55Provides:       pmtools = %{version}-%{release}
56Obsoletes:      pmtools < 20100513-6
57
58%description
59The ACPI Component Architecture (ACPICA) project provides an OS-independent
60reference implementation of the Advanced Configuration and Power Interface
61Specification (ACPI).  ACPICA code contains those portions of ACPI meant to
62be directly integrated into the host OS as a kernel-resident subsystem, and
63a small set of tools to assist in developing and debugging ACPI tables.
64
65This package contains only the user-space tools needed for ACPI table
66development, not the kernel implementation of ACPI.  The following commands
67are installed:
68   -- iasl: compiles ASL (ACPI Source Language) into AML (ACPI Machine
69      Language), suitable for inclusion as a DSDT in system firmware.
70      It also can disassemble AML, for debugging purposes.
71   -- acpibin: performs basic operations on binary AML files (e.g.,
72      comparison, data extraction)
73   -- acpidump: write out the current contents of ACPI tables
74   -- acpiexec: simulate AML execution in order to debug method definitions
75   -- acpihelp: display help messages describing ASL keywords and op-codes
76   -- acpinames: display complete ACPI name space from input AML
77   -- acpisrc: manipulate the ACPICA source tree and format source files
78      for specific environments
79   -- acpixtract: extract binary ACPI tables from acpidump output (see
80      also the pmtools package)
81
82This version of the tools is being released under GPLv2 license.
83
84%prep
85%setup -q -n acpica-unix2-%{version}
86%setup -q -T -D -a 1 -n acpica-unix2-%{version}
87gzip -dc %{SOURCE1} | tar -x --strip-components=1 -f -
88
89%patch0 -p1 -b .big-endian
90%patch1 -p1 -b .unaligned
91%patch2 -p1 -b .OPT_LDFLAGS
92%patch3 -p1 -b .int-format
93%patch4 -p1 -b .f23-harden
94%patch5 -p1 -b .template
95%patch6 -p1 -b .free
96%patch7 -p1 -b .ppc64le
97%patch8 -p1 -b .arm7hl
98%patch9 -p1 -b .big-endian-v2
99%patch10 -p1 -b .simple-64bit
100%patch11 -p1 -b .be-tpm2
101%patch12 -p1 -b .mips-be-fix
102
103cp -p %{SOURCE2} README.Fedora
104cp -p %{SOURCE3} iasl.1
105cp -p %{SOURCE4} acpibin.1
106cp -p %{SOURCE5} acpidump.1
107cp -p %{SOURCE6} acpiexec.1
108cp -p %{SOURCE7} acpihelp.1
109cp -p %{SOURCE8} acpinames.1
110cp -p %{SOURCE9} acpisrc.1
111cp -p %{SOURCE10} acpixtract.1
112cp -p %{SOURCE11} badcode.asl.result
113cp -p %{SOURCE12} grammar.asl.result
114cp -p %{SOURCE13} tests/run-misc-tests.sh
115chmod a+x tests/run-misc-tests.sh
116cp -p %{SOURCE14} COPYING
117
118# spurious executable permissions on text files in upstream
119chmod a-x changes.txt
120chmod a-x source/compiler/new_table.txt
121
122
123%build
124make OPT_CFLAGS="%{optflags}"
125
126
127%install
128# Install the binaries
129mkdir -p %{buildroot}%{_bindir}
130install -pD generate/unix/bin*/* %{buildroot}%{_bindir}/
131mv %{buildroot}%{_bindir}/acpidump %{buildroot}%{_bindir}/acpidump-acpica
132mv %{buildroot}%{_bindir}/acpixtract %{buildroot}%{_bindir}/acpixtract-acpica
133
134# Install the man pages
135mkdir -p %{buildroot}%{_mandir}/man1
136install -pDm 0644 -p -D *.1 %{buildroot}%{_mandir}/man1/
137mv %{buildroot}%{_mandir}/man1/acpixtract.1 \
138   %{buildroot}%{_mandir}/man1/acpixtract-acpica.1
139mv %{buildroot}%{_mandir}/man1/acpidump.1 \
140   %{buildroot}%{_mandir}/man1/acpidump-acpica.1
141
142%check
143cd tests
144
145# ASL tests
146./aslts.sh                         # relies on non-zero exit
147[ $? -eq 0 ] || exit 1
148
149# misc tests
150./run-misc-tests.sh %{buildroot}%{_bindir} %{version}
151
152# Template tests
153cd templates
154make
155if [ -f diff.log ]
156then
157    if [ -s diff.log ]
158    then
159        exit 1                  # implies errors occurred
160    fi
161fi
162cd ..
163
164
165%post
166alternatives --install %{_bindir}/acpixtract acpixtract \
167                       %{_bindir}/acpixtract-acpica 120 \
168               --slave %{_mandir}/man1/acpixtract.1.gz acpixtract.1.gz \
169                       %{_mandir}/man1/acpixtract-acpica.1.gz
170
171alternatives --install %{_bindir}/acpidump acpidump \
172                       %{_bindir}/acpidump-acpica 120 \
173               --slave %{_mandir}/man1/acpidump.1.gz acpidump.1.gz \
174                       %{_mandir}/man1/acpidump-acpica.1.gz
175
176
177%postun
178if [ ! -e %{_bindir}/acpixtract-acpica ]
179then
180    alternatives --remove acpixtract %{_bindir}/acpixtract-acpica
181fi
182if [ ! -e %{_bindir}/acpidump-acpica ]
183then
184    alternatives --remove acpidump %{_bindir}/acpidump-acpica
185fi
186
187
188%files
189%doc changes.txt source/compiler/new_table.txt
190%doc README.Fedora COPYING
191%{_bindir}/*
192%{_mandir}/*/*
193
194
195%changelog
196* Tue Feb 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180105-1
197- new upstream release.
198- dropped Patch0-6.
199- imported Patch0-12 from rawhide.
200
201* Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140424-1
202- initial build for Vine Linux
203
204* Fri Jun 6 2014 Dan Horák <dan[at]danny.cz> - 20140424-3
205- refresh the big endian patch so it applies correctly, fixes build on big endians
206
207* Thu May 22 2014 Al Stone <ahs3@redhat.com> - 20140424-2
208- Add ppc64le as a 64-bit arch in run-misc-tests.sh.  Closes BZ#1098614.
209- Re-enable big-endian support in iasl.
210
211* Wed May 7 2014 Al Stone <ahs3@redhat.com> - 20140424-1
212- Update to latest upstream.  Closes BZ#1091189.
213
214* Fri Apr 4 2014 Al Stone <ahs3@redhat.com> - 20140325-1
215- Update to latest upstream.  Closes BZ#1080791.
216- Incorporated patch to fix broken symlinks.  Closes BZ#1074256.
217- Add patch to fix missing .o files in aapits tests.
218
219* Wed Feb 26 2014 Al Stone <ahs3@redhat.com> - 20140214-1
220- Update to latest upstream.  Closes BZ#1053396.
221- Remove temporary patch so that AAPITS will build and run.
222- Add patch to print asllookup.c warning properly on big endian;
223  Closes BZ#1069178.
224
225* Tue Jan 21 2014 Al Stone <ahs3@redhat.com> - 20140114-1
226- Update to latest upstream.  Closes BZ#1053396.
227- Remove temporary patch to add Makefile missing from upstream tarball.
228- Add temporary patch so that AAPITS will build and run.
229
230* Tue Jan 7 2014 Al Stone <ahs3@redhat.com> - 20131218-1
231- Update to latest upstream.  Closes BZ#1044951.
232- Add temporary patch to add Makefile missing from upstream tarball.
233
234* Mon Nov 25 2013 Al Stone <ahs3@redhat.com> - 20131115-1
235- Update to latest upstream.  Closes BZ#1031255.
236- Add a little code to workaround build problems that can occur (the tests
237  will fail) when a build starts before midnight, but ends after midnight
238- Remove patch to include Makefile.config that was missing from tarball.
239
240* Wed Oct 09 2013 Al Stone <ahs3@redhat.com> - 20130927-1
241- Update to latest upstream.  Closes BZ#1013090.
242- Add temporary patch to include Makefile.config being missing from tarball.
243
244* Fri Sep 13 2013 Michael Schwendt <mschwendt@fedoraproject.org> - 20130823-5
245- correct iasl obs_ver
246
247* Tue Sep 10 2013 Dean Nelson <dnelson@redhat.com> - 20130823-4
248- Fix run-misc-tests.sh script to properly set the number of BITS to 64
249  when run on a s390x system.
250
251* Tue Sep 10 2013 Michael Schwendt <mschwendt@fedoraproject.org> - 20130823-3
252- correct pmtools obs_ver
253
254* Tue Aug 27 2013 Al Stone <ahs3@redhat.com> - 20130823-2
255- Add in a copy of the GPLv2 text in order to comply with the requirement
256  to always redistribute the terms of the license.
257
258* Mon Aug 26 2013 Al Stone <ahs3@redhat.com> - 20130823-1
259- Update to latest upstream source.
260
261* Tue Aug 20 2013 Al Stone <ahs3@redhat.com> - 20130725-2
262- Fix several rpmlint items (listed below)
263- Add versions to explicit provides for acpixtract, acpidump
264- Not all setup steps used -q
265- Setup executable test script (run-misc-tests.sh) differently
266- Removed unneeded commented out line with macros in it
267- Removed mixed use of spaces and tabs (all spaces now)
268- Corrected source URLs (upstream moved)
269
270* Sun Aug 18 2013 Al Stone <ahs3@redhat.com> - 20130725-1
271- Update to latest upstream source.
272
273* Wed Jul 24 2013 Al Stone <ahs3@redhat.com> - 20130626-1
274- Update to latest upstream source.
275- Move acpidump to acpidump-acpica so it be an alternative properly
276- Add basic man page for acpidump
277- Enable use of AAPITS tests during the check step
278
279* Sun Jun 02 2013 Al Stone <ahs3@redhat.com> - 20130517-2
280- Correct an oversight: we provide an acpidump in conflict with the
281  version in pmtools (which appears to be dead upstream) but had not
282  made it an alternative before
283
284* Tue May 28 2013 Al Stone <ahs3@redhat.com> - 20130517-1
285- Update to latest upstream source.
286- Remove acpica-tools-config.patch -- now in upstream
287- Remove iasl-signed-char.patch -- now in upstream
288- Updated debian-big_endian.patch
289- Updated debian-unaligned.patch
290
291* Mon May 13 2013 Al Stone <ahs3@redhat.com> - 20130328-1
292- Update to latest upstream source.
293
294* Wed Mar 20 2013 Al Stone <ahs3@redhat.com> - 20130214-2
295- Incorporate use of optflags macro in the build.
296- Remove extraneous rm -rf of buildroot.
297- Remove extraneous use of defattr in the files section.
298- Incorporate use of parallel make.
299- Remove extraneous use of the clean section.
300- Use simpler globbing in the files section.
301- Use simpler globbing in the install section.
302- Remove obsolete git notes from README.Fedora.
303- Remove ExcludeArch restrictions.
304
305* Mon Feb 18 2013 Al Stone <ahs3@redhat.com> - 20130214-1
306- New upstream.
307- Remove most of the config file patch; still need to remove -m{32,64}.
308- Clarify the licensing; this source is dual-licensed and is being released
309  under the GPLv2 as allowed by the original Intel license.
310- Redo the misc tests so they compare results properly.
311
312* Wed Feb 06 2013 Al Stone <ahs3@redhat.com> - 20130117-6
313- Added a zero-fill to a date used in comparing testing results so that the
314  comparison would be correct on days numbered < 10.
315
316* Thu Jan 31 2013 Al Stone <ahs3@redhat.com> - 20130117-5
317- Simplify versioning scheme and revert to the original scheme in use by
318  iasl, which is use the latest official tarball date (2013017) as the
319  version and 1%{?dist} as the release, to be incremented for packaging
320  and bug fixes as needed.
321
322* Wed Jan 30 2013 Al Stone <ahs3@redhat.com> - 20130117-4
323- Do a little reset: go back to using just the original upstream tarball
324  instead of the latest git; the snapshot approach was more complicated
325  than needed.
326- Upstream tarballs split commands from test suites, so had to add the
327  test suite back in as another Source: file.
328- Change versioning scheme to include the APCI specification level (5.0),
329  the latest official tarball date (2013017) and a revision level  (the
330  .1 at the end) for packaging and bug fixes as needed.
331- Changed the License field to reflect the source tarball change; the release
332  tarball is dual-licensed, Intel ACPI or GPLv2.
333- Updated patches to apply cleanly as needed.
334- Corrected Obsoletes and Provides version numbers.
335
336* Mon Jan 28 2013 Al Stone <ahs3@redhat.com> - 20130117-3
337- Reconcile Fedora and Debian patches to be as alike as possible
338
339* Mon Jan 28 2013 Al Stone <ahs3@redhat.com> - 20130117-2
340- Verify ExcludeArch restrictions -- the architectures excluded can have
341  no use for these tools.  Hardware support for ACPI is simply not
342  implemented for them.
343- Corrected versioning to note this source came from a git pull.
344- Add License file as upstream has not yet provided one (and has not for
345  many years).
346- Insert properly versioned Provides and Obsoletes for iasl.
347- Corrected files to use man.1* (vs man.1.gz) to allow flexibility in the
348  compression being used.
349
350* Wed Jan 23 2013 Al Stone <ahs3@redhat.com> - 20130117-1
351- Clone from the current iasl package, with the intent of replacing it
352- Update source to latest upstream
353- NB: ACPICA documentation would normally be included in a source tarball.
354  But, since it is not clearly redistributable, it is not included in the
355  source RPM for this package.
356- Build all ACPICA tools, not just iasl (and hence the package replacement)
357- Add in brief man pages
358- Set up acpixtract from this package as an alternative to the same command
359  in the pmtools package
360- Run the check step once built
361
Note: See TracBrowser for help on using the repository browser.