source: projects/specs/trunk/a/acl/acl-vl.spec @ 521

Revision 521, 8.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Access control list utilities
2Name: acl
3Version: 2.2.47
4Release: 2%{?_dist_release}
5BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
6BuildRequires: libattr-devel >= 2.4.1
7BuildRequires: autoconf, libtool >= 1.5, gettext, gawk
8Source: ftp://oss.sgi.com/projects/xfs/cmd_tars/acl_%{version}-1.tar.gz
9Patch0: acl-2.2.3-multilib.patch
10Patch1: acl-2.2.39-build.patch
11Patch2: acl-2.2.39-path_max.patch
12Patch3: acl-2.2.39-params.patch
13Patch4: acl-2.2.45-exitcode.patch
14Patch5: acl-2.2.39-segfault.patch
15License: GPL
16Group: System Environment/Base
17URL: http://oss.sgi.com/projects/xfs/
18
19%description
20This package contains the getfacl and setfacl utilities needed for
21manipulating access control lists.
22
23%package -n libacl
24Summary: Dynamic library for access control list support
25License: LGPL
26Group: System Environment/Libraries
27Requires(post): /sbin/ldconfig
28Requires(postun): /sbin/ldconfig
29
30%description -n libacl
31This package contains the libacl.so dynamic library which contains
32the POSIX 1003.1e draft standard 17 functions for manipulating access
33control lists.
34
35%package -n libacl-devel
36Summary: Access control list static libraries and headers.
37License: LGPL
38Group: Development/Libraries
39Requires: libacl = %{version}-%{release}, libattr-devel
40#Requires: nfs-utils-lib, openldap
41
42%description -n libacl-devel
43This package contains static libraries and header files needed to develop
44programs which make use of the access control list programming interface
45defined in POSIX 1003.1e draft standard 17.
46
47%prep
48%setup -q
49%patch0 -p1 -b .multilib
50%patch1 -p1 -b .build
51%patch2 -p1 -b .path_max
52%patch3 -p1 -b .params
53%patch4 -p1 -b .exitcode
54%patch5 -p1 -b .segfault
55autoconf
56
57%build
58touch .census
59# acl abuses libexecdir
60%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
61make LIBTOOL="libtool --tag=CC"%{?_smp_mflags}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install DESTDIR=$RPM_BUILD_ROOT
66make install-dev DESTDIR=$RPM_BUILD_ROOT
67make install-lib DESTDIR=$RPM_BUILD_ROOT
68
69# get rid of libacl.la
70rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.la
71
72# fix links to shared libs and permissions
73rm -f $RPM_BUILD_ROOT/%{_libdir}/libacl.so
74ln -sf ../../%{_lib}/libacl.so $RPM_BUILD_ROOT/%{_libdir}/libacl.so
75chmod 0755 $RPM_BUILD_ROOT/%{_lib}/libacl.so.*.*.*
76
77%find_lang %{name}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -n libacl -p /sbin/ldconfig
83
84%postun -n libacl -p /sbin/ldconfig
85
86%files -f %{name}.lang
87%defattr(-,root,root)
88%{_bindir}/chacl
89%{_bindir}/getfacl
90%{_bindir}/setfacl
91%{_datadir}/doc/acl-%{version}
92%{_mandir}/man1/chacl.1*
93%{_mandir}/man1/getfacl.1*
94%{_mandir}/man1/setfacl.1*
95%{_mandir}/man5/acl.5*
96
97%files -n libacl-devel
98%defattr(-,root,root)
99/%{_lib}/libacl.so
100%{_includedir}/acl
101%{_includedir}/sys/acl.h
102%{_libdir}/libacl.*
103%{_mandir}/man3/acl_*
104
105%files -n libacl
106%defattr(-,root,root)
107/%{_lib}/libacl.so.*
108
109%changelog
110* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
111- initial build for Vine Linux
112
113* Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
114- new upstream version
115
116* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
117- Fixed segfault when using only "--" as parameter
118- Resolves: #430458
119
120* Wed Nov  7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
121- Fixed setfacl exitcodes
122- Resolves: #368451
123
124* Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
125- New version
126- dropped walk patch
127
128* Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
129- Rewriten path_max patch to support long UTF8 names
130- Resolves #287701, #183181
131
132* Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
133- Removed NFS4 ACL patch since it was rejected by upstream.
134
135* Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
136- disable nfs patch; linking libacl against libs in /usr will lead to breakage
137
138* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
139- Build Require gawk
140
141* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
142- Rebuild for selinux ppc32 issue.
143
144* Mon Aug 27 2007 Steve Dickson <steved@redhat.com>  2.2.39-5
145- Added NFS v4 ACL support
146
147* Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
148- Updated man page for getfacl
149
150* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
151- Added support fort short params to getfacl
152- Resolves: #204087
153
154* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
155- new improved walk patch with fixed getfacl exit code (rhbz#232884)
156
157* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
158- fix buildroot
159- remove trailing dot from summary
160- -devel requires same version of libacl
161- escape macro in changelog
162- make .so symlink relative
163
164* Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
165- Apply patch to make order consistent.
166
167* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
168- rebuild
169
170* Wed Jul  5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
171- new version 2.2.39
172- fixed usage of long UTF-8 filenames (#183181)
173  Thanks to Andrey for the initial patch.
174
175* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
176- rebuild for -devel deps
177
178* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
179- bump again for double-long bug on ppc(64)
180
181* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
182- rebuilt for new gcc4.1 snapshot and glibc changes
183
184* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
185- new version 2.2.34
186
187* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
188- rebuilt
189
190* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
191- fixed permissions of libacl
192
193* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
194- spec file cleanup
195- mark po files as lang specific
196
197* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
198- 2.2.32
199
200* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
201- update to 2.2.31
202
203* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
204- get rid of *.la files
205- remove duplicate doc files
206
207* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
208- Rebuild
209
210* Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
211- make the libs executable so that we find their dependencies (#132696)
212
213* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
214- libacl-devel Requires: libattr-devel for libattr.la
215
216* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
217- Requires libtool >= 1.5 for building
218
219* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
220- Make libacl.so.* executable.
221
222* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
223- Update to latest upstream version.
224
225* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
226- Close bug #125300 (Steve Grubb: build requires libtool,gettext)
227
228* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
229- rebuilt
230
231* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
232- Add missing %%defattr
233
234* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
235- Add /usr/include/acl to files manifest
236- Fix location of doc files, add main doc dir to files manifest
237
238* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
239- rebuilt
240
241* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
242- rebuilt
243
244* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
245- Fix libtool invocation
246
247* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
248- Update to acl-2.2.7
249
250* Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
251- include patch from Jay Berkenbilt to print better error messages
252
253* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
254- udpate/rebuild
255
256* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
257- set execute bits on library so that requires are generated.
258
259* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
260- Correct patch in previous fix so that shared libraries go in /lib*
261  instead of /usr/lib*
262
263* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
264- Fix multilibbing
265
266* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
267- Added fix to install libs in correct directory on 64bit machine
268
269* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
270- Made the package only own the one directory that is unique to it:
271  /usr/include/acl
272
273* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
274- Initial Red Hat package
275  Made as few changes as possible relative to upstream packaging to
276  make it easier to maintain long-term.  This means that some of
277  the techniques used here are definitely not standard Red Hat
278  techniques.  If you are looking for an example package to fit
279  into Red Hat Linux transparently, this would not be the one to
280  pick.
281- acl-devel -> libacl-devel
Note: See TracBrowser for help on using the repository browser.