source: projects/specs/trunk/a/acl/acl-vl.spec @ 12120

Revision 12120, 10.5 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: acl
4Summary: Access control list utilities
5Version: 2.2.53
6Release: 1%{?_dist_release}
7
8Group: System Environment/Base
9License: GPLv2+
10URL: http://oss.sgi.com/projects/xfs/
11
12Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gawk
19BuildRequires: gettext
20BuildRequires: libattr-devel >= 2.4.1
21BuildRequires: libtool
22Requires: libacl = %{version}-%{release}
23
24%description
25This package contains the getfacl and setfacl utilities needed for
26manipulating access control lists.
27
28%package -n libacl
29Summary: Dynamic library for access control list support
30License: LGPLv2+
31Group: System Environment/Libraries
32Requires(post): /sbin/ldconfig
33Requires(postun): /sbin/ldconfig
34
35%description -n libacl
36This package contains the libacl.so dynamic library which contains
37the POSIX 1003.1e draft standard 17 functions for manipulating access
38control lists.
39
40%package -n libacl-devel
41Summary: Access control list static libraries and headers.
42License: LGPLv2+
43Group: Development/Libraries
44Requires: libacl = %{version}-%{release}
45Requires: libattr-devel
46
47%description -n libacl-devel
48This package contains static libraries and header files needed to develop
49programs which make use of the access control list programming interface
50defined in POSIX 1003.1e draft standard 17.
51
52%if %build_compat32
53
54%package -n compat32-libacl
55Summary: Dynamic library for access control list support
56License: LGPLv2+
57Group: System Environment/Libraries
58Requires(post): /sbin/ldconfig
59Requires(postun): /sbin/ldconfig
60
61%description -n compat32-libacl
62This package contains the libacl.so dynamic library which contains
63the POSIX 1003.1e draft standard 17 functions for manipulating access
64control lists.
65
66%endif
67
68%prep
69%setup -q
70
71%build
72touch .census
73# acl abuses libexecdir
74%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
75make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
76
77%install
78rm -rf %{buildroot}
79make install DESTDIR=%{buildroot}
80#make install-dev DESTDIR=%{buildroot}
81#make install-lib DESTDIR=%{buildroot}
82
83mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
84
85# get rid of libacl.a and libacl.la
86rm -f %{buildroot}/%{_lib}/libacl.a
87rm -f %{buildroot}/%{_lib}/libacl.la
88rm -f %{buildroot}%{_libdir}/libacl.a
89rm -f %{buildroot}%{_libdir}/libacl.la
90
91# fix links to shared libs and permissions
92rm -f %{buildroot}%{_libdir}/libacl.so
93mkdir -p %{buildroot}%{_libdir}
94ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
95chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
96
97mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
98
99%find_lang %{name}
100
101%check
102if ./setfacl/setfacl -m u:`id -u`:rwx .; then
103    make tests || exit $?
104    if test 0 = `id -u`; then
105        make root-tests || exit $?
106    fi
107else
108    echo '*** ACLs are probably not supported by the file system,' \
109         'the test-suite will NOT run ***'
110fi
111
112%clean
113rm -rf %{buildroot}
114
115%post -n libacl
116/sbin/ldconfig
117
118%postun -n libacl
119/sbin/ldconfig
120
121%if %build_compat32
122
123%post -n compat32-libacl
124/sbin/ldconfig
125
126%postun -n compat32-libacl
127/sbin/ldconfig
128
129%endif
130
131%files -f %{name}.lang
132%defattr(-,root,root)
133%doc doc-nover/*
134%{_bindir}/chacl
135%{_bindir}/getfacl
136%{_bindir}/setfacl
137%{_mandir}/man1/chacl.1*
138%{_mandir}/man1/getfacl.1*
139%{_mandir}/man1/setfacl.1*
140%{_mandir}/man5/acl.5*
141
142%files -n libacl-devel
143%defattr(-,root,root)
144/%{_lib}/libacl.so
145%{_includedir}/acl
146%{_includedir}/sys/acl.h
147%{_libdir}/libacl.*
148%{_libdir}/pkgconfig/*.pc
149%{_mandir}/man3/acl_*
150
151%files -n libacl
152%defattr(-,root,root)
153/%{_lib}/libacl.so.*
154
155%if %build_compat32
156
157%files -n compat32-libacl
158%defattr(-,root,root,-)
159/%{_lib}/libacl.so.*
160
161%endif
162
163%changelog
164* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
165- new upstream release.
166- dropped all patches: fixed in upstream.
167
168* Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
169- added compat32 package.
170
171* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
172- new upstream release.
173- replaced patches to the newest rawhide's.
174
175* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
176- updated to 2.2.49
177- added Patch2-7 from Fedora
178  * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
179  - add function acl_extended_file_nofollow() (#692982)
180  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
181  - fix typos in setfacl(1) man page (#675451)
182  * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
183  - remove dependency of libacl-devel on nfs-utils-lib and openldap
184  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
185  - let acl depend on the same version of libacl (#595674)
186  * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
187  - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
188
189* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
190- initial build for Vine Linux
191
192* Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
193- new upstream version
194
195* Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
196- Fixed segfault when using only "--" as parameter
197- Resolves: #430458
198
199* Wed Nov  7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
200- Fixed setfacl exitcodes
201- Resolves: #368451
202
203* Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
204- New version
205- dropped walk patch
206
207* Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
208- Rewriten path_max patch to support long UTF8 names
209- Resolves #287701, #183181
210
211* Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
212- Removed NFS4 ACL patch since it was rejected by upstream.
213
214* Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
215- disable nfs patch; linking libacl against libs in /usr will lead to breakage
216
217* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
218- Build Require gawk
219
220* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
221- Rebuild for selinux ppc32 issue.
222
223* Mon Aug 27 2007 Steve Dickson <steved@redhat.com>  2.2.39-5
224- Added NFS v4 ACL support
225
226* Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
227- Updated man page for getfacl
228
229* Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
230- Added support fort short params to getfacl
231- Resolves: #204087
232
233* Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
234- new improved walk patch with fixed getfacl exit code (rhbz#232884)
235
236* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
237- fix buildroot
238- remove trailing dot from summary
239- -devel requires same version of libacl
240- escape macro in changelog
241- make .so symlink relative
242
243* Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
244- Apply patch to make order consistent.
245
246* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
247- rebuild
248
249* Wed Jul  5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
250- new version 2.2.39
251- fixed usage of long UTF-8 filenames (#183181)
252  Thanks to Andrey for the initial patch.
253
254* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
255- rebuild for -devel deps
256
257* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
258- bump again for double-long bug on ppc(64)
259
260* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
261- rebuilt for new gcc4.1 snapshot and glibc changes
262
263* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
264- new version 2.2.34
265
266* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
267- rebuilt
268
269* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
270- fixed permissions of libacl
271
272* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
273- spec file cleanup
274- mark po files as lang specific
275
276* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
277- 2.2.32
278
279* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
280- update to 2.2.31
281
282* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
283- get rid of *.la files
284- remove duplicate doc files
285
286* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
287- Rebuild
288
289* Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
290- make the libs executable so that we find their dependencies (#132696)
291
292* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
293- libacl-devel Requires: libattr-devel for libattr.la
294
295* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
296- Requires libtool >= 1.5 for building
297
298* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
299- Make libacl.so.* executable.
300
301* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
302- Update to latest upstream version.
303
304* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
305- Close bug #125300 (Steve Grubb: build requires libtool,gettext)
306
307* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
308- rebuilt
309
310* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
311- Add missing %%defattr
312
313* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
314- Add /usr/include/acl to files manifest
315- Fix location of doc files, add main doc dir to files manifest
316
317* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
318- rebuilt
319
320* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
321- rebuilt
322
323* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
324- Fix libtool invocation
325
326* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
327- Update to acl-2.2.7
328
329* Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
330- include patch from Jay Berkenbilt to print better error messages
331
332* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
333- udpate/rebuild
334
335* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
336- set execute bits on library so that requires are generated.
337
338* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
339- Correct patch in previous fix so that shared libraries go in /lib*
340  instead of /usr/lib*
341
342* Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
343- Fix multilibbing
344
345* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
346- Added fix to install libs in correct directory on 64bit machine
347
348* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
349- Made the package only own the one directory that is unique to it:
350  /usr/include/acl
351
352* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
353- Initial Red Hat package
354  Made as few changes as possible relative to upstream packaging to
355  make it easier to maintain long-term.  This means that some of
356  the techniques used here are definitely not standard Red Hat
357  techniques.  If you are looking for an example package to fit
358  into Red Hat Linux transparently, this would not be the one to
359  pick.
360- acl-devel -> libacl-devel
Note: See TracBrowser for help on using the repository browser.