source: projects/specs/trunk/a/accountsservice/accountsservice-vl.spec @ 12005

Revision 12005, 6.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define _unpackaged_files_terminate_build 1
2%global _vpath_srcdir .
3%global _vpath_builddir build
4%global __global_cflags %{optflags}
5%global __global_ldflags ""
6
7Name:           accountsservice
8Version:        0.6.54
9Release:        1%{?_dist_release}
10Summary:        D-Bus interfaces for querying and manipulating user account information
11Summary(ja):    ユーザーアカウント情報の問合せや処理を行うための D-Bus インターフェース
12
13Group:          System Environment/Daemons
14License:        GPLv3+
15URL:            http://www.fedoraproject.org/wiki/Features/UserAccountDialog
16#VCS: git:git://git.freedesktop.org/accountsservice
17Source0:        http://mclasen.fedorapeople.org/accounts/accountsservice-%{version}.tar.xz
18
19# upstream patch
20Patch1: accountsservice-minimum-uid.patch
21Patch2: accountsservice-expose-interface-directory.patch
22
23# for Vine Linux
24Patch1000:      accountsservice-0.6.54-vine-environment.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
27BuildRequires:  meson
28BuildRequires:  glib2-devel
29BuildRequires:  dbus-glib-devel
30BuildRequires:  polkit-devel
31BuildRequires:  intltool
32# BuildRequires:  systemd-units
33BuildRequires:  gobject-introspection-devel
34BuildRequires:  elogind-devel
35BuildRequires:  python3-setuptools
36
37Requires:       polkit
38Requires:       shadow-utils
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43
44%description
45The accountsservice project provides a set of D-Bus interfaces for
46querying and manipulating user account information and an implementation
47of these interfaces, based on the useradd, usermod and userdel commands.
48
49
50%package libs
51Summary: Client-side library to talk to accountsservice
52Summary(ja): accountsservice と対話するためのクライアント側ライブラリ
53Group: System Environment/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description libs
57The accountsservice-libs package contains a library that can
58be used by applications that want to interact with the accountsservice
59daemon.
60
61
62%package devel
63Summary: Development files for accountsservice-libs
64Summary(ja): accountsservice-libs の開発用ファイル
65Group: Development/Libraries
66Requires: %{name}-libs = %{version}-%{release}
67
68%description devel
69The accountsservice-devel package contains headers and other
70files needed to build applications that use accountsservice-libs.
71
72
73%package        doc
74Summary:        Documentation for %{name}
75Summary(ja):    %{name} 用のドキュメント
76Group:          Documentation
77Requires:       %{name} = %{version}-%{release}
78BuildArch:      noarch
79
80%description    doc
81This package contains documentation for %{name}.
82
83
84%prep
85%autosetup -p1
86
87%build
88%meson \
89  -Dsystemd=false \
90  -Dsystemdsystemunitdir=no \
91  -Delogind=true \
92  -Dadmin_group=wheel \
93  -Dminimum_uid=500 \
94  -Dgtk_doc=true
95
96%meson_build
97
98
99%install
100rm -rf $RPM_BUILD_ROOT
101%meson_install
102
103%find_lang accounts-service
104
105
106%post libs -p /sbin/ldconfig
107
108%postun libs -p /sbin/ldconfig
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113
114%files -f accounts-service.lang
115%defattr(-,root,root,-)
116%doc COPYING README AUTHORS
117%{_sysconfdir}/dbus-1/system.d/org.freedesktop.Accounts.conf
118%{_libexecdir}/accounts-daemon
119%{_datadir}/dbus-1/interfaces/org.freedesktop.Accounts.xml
120%{_datadir}/dbus-1/interfaces/org.freedesktop.Accounts.User.xml
121%{_datadir}/dbus-1/system-services/org.freedesktop.Accounts.service
122%{_datadir}/polkit-1/actions/org.freedesktop.accounts.policy
123%dir %{_localstatedir}/lib/AccountsService/
124%dir %{_localstatedir}/lib/AccountsService/users
125%dir %{_localstatedir}/lib/AccountsService/icons
126#/lib/systemd/system/accounts-daemon.service
127
128%files libs
129%defattr(-,root,root,-)
130%{_libdir}/libaccountsservice.so.*
131%{_libdir}/girepository-1.0/AccountsService-1.0.typelib
132
133%files devel
134%defattr(-,root,root,-)
135%{_includedir}/accountsservice-1.0
136%{_libdir}/libaccountsservice.so
137%{_libdir}/pkgconfig/accountsservice.pc
138%{_datadir}/gir-1.0/AccountsService-1.0.gir
139
140%files doc
141%defattr(-,root,root,-)
142%{_datadir}/gtk-doc/html/libaccountsservice/
143
144%changelog
145* Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.6.54-1
146- new upstream release.
147- added elogind support.
148- updated Patch1000.
149
150* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.40-1
151- new upstream release
152
153* Mon Nov 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.39-1
154- new upstream release
155
156* Sat Nov  1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.6.37-2
157- moved libs package to System Environment/Libraries
158- added %%post, %%postun and %%clean section
159- added Japanese summary
160
161* Sun Apr 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.37-1
162- new upstream release
163- add Patch1000 (accountsservice-0.6.37-vine-environment.patch)
164
165* Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.31-2
166- rebuild with VineSeed environment
167
168* Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.31-1
169- new upstream release
170
171* Sun Jan 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.30-1
172- new upstream release
173- create subpackage (%{name}-doc)
174
175* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.25-1
176- new upstream release
177
178* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.18-1
179- new upstream release
180
181* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-1
182- new upstream release
183
184* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.13-1
185- initial build for Vine Linux
186
187
188* Mon Jun 06 2011 Ray Strode <rstrode@redhat.com> 0.6.12-1
189- Update to latest release
190
191* Wed May 18 2011 Matthias Clasen <mclasen@redhat.com> 0.6.11-1
192- Update to 0.6.11
193
194* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-2
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
196
197* Wed Feb 02 2011 Ray Strode <rstrode@redhat.com> 0.6.3-1
198- Update to 0.6.3
199
200* Thu Jan 27 2011 Matthias Clasen <mclasen@redhat.com> 0.6.2-1
201- Update to 0.6.2
202
203* Wed Jul 21 2010 Matthias Clasen <mclasen@redhat.com> 0.6.1-1
204- Update to 0.6.1
205- Install systemd unit file
206
207* Mon Apr  5 2010 Matthias Clasen <mclasen@redhat.com> 0.6-2
208- Always emit changed signal on icon change
209
210* Tue Mar 30 2010 Matthias Clasen <mclasen@redhat.com> 0.6-1
211- Update to 0.6
212
213* Mon Mar 22 2010 Matthias Clasen <mclasen@redhat.com> 0.5-1
214- Update to 0.5
215
216* Mon Feb 22 2010 Bastien Nocera <bnocera@redhat.com> 0.4-3
217- Fix directory ownership
218
219* Mon Feb 22 2010 Bastien Nocera <bnocera@redhat.com> 0.4-2
220- Add missing directories to the filelist
221
222* Fri Jan 29 2010 Matthias Clasen <mclasen@redhat.com> 0.4-1
223- Initial packaging, based on work by Richard Hughes
Note: See TracBrowser for help on using the repository browser.