source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 521

Revision 521, 26.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define desktop_file_utils_version 0.9
2%define abiver 2.6
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 2.6.8
8Release: 2%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
14Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
15Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
16Source11: abiword.mime
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22#Packager:
23
24# for abiword
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.4.0
42#BuildRequires: ots-devel >= 0.4.2
43BuildRequires: libwpd-devel >= 0.8.0
44BuildRequires: librsvg2-devel
45#BuildRequires: aiksaurus-gtk-devel >= 1.2.1
46#BuildRequires: link-grammar-devel >= 4.2.1
47#BuildRequires: gtkmathview-devel >= 0.7.5
48BuildRequires: libgsf-devel >= 1.12.1
49BuildRequires: libboost-devel >= 1.33.1
50
51# gnome build deps
52BuildRequires: libbonobo-devel
53BuildRequires: libbonoboui-devel
54BuildRequires: libgnomeui-devel
55
56PreReq: desktop-file-utils >= %{desktop_file_utils_version}
57Obsoletes: abiword-fonts abiword-plugins
58
59URL: http://www.abisource.com/
60
61Patch0: abiword-2.6.0-windowshelppaths.patch
62Patch1: abiword-2.6.4-desktop.patch
63Patch2: abiword-2.6.0-boolean.patch
64Patch3: abiword-plugins-2.6.0-boolean.patch
65
66%description
67AbiWord is a cross-platform Open Source word processor. The goal is to make
68AbiWord full-featured, and remain lean.
69
70%description -l ja
71AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
72多機能で機敏に動くことを目標としています。
73
74%package -n libabiword
75Summary: Library for developing applications based on AbiWord's core
76Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
77Group: System Environment/Libraries
78
79%description -n libabiword
80Library for developing applications based on AbiWord's core.
81
82%description -n libabiword -l ja
83AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
84
85%package -n libabiword-devel
86Summary: Files for developing with libabiword
87Summary(ja): libabiword を用いた開発に必要なファイル群
88Group: Development/Libraries
89Requires: libabiword = %{epoch}:%{version}-%{release}
90
91%description -n libabiword-devel
92Includes and definitions for developing with libabiword.
93
94%description -n libabiword-devel -l ja
95libabiword で開発するためのインクルードファイル及び定義ファイルです。
96
97%prep
98%setup -q
99%patch1 -p1 -b .desktop
100%patch2 -p1 -b .boolean
101
102# setup abiword-plugins
103%setup -q -T -b 1 -n abiword-plugins-%{version}
104%patch3 -p1 -b .boolean
105
106# setup abiword extras
107%setup -q -T -b 2 -n abiword-extras-%{version}
108
109# setup abiword documentation
110%setup -q -T -b 3 -n abiword-docs-%{version}
111%patch0 -p1 -b .windowshelppaths
112
113%build
114# build libabiword and abiword
115cd $RPM_BUILD_DIR/abiword-%{version}
116%configure --enable-libabiword
117make %{?_smp_mflags}
118
119# build abiword-plugins
120cd $RPM_BUILD_DIR/abiword-plugins-%{version}
121export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
122CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
123# Remove libtool predep_objects and postdep_objects wonkiness so that
124# building without -nostdlib doesn't include them twice.  Because we
125# already link with g++, weird stuff happens if you don't let the
126# compiler handle this.
127sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
128sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
129sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
130make %{?_smp_mflags}
131
132# build abiword-extras
133cd $RPM_BUILD_DIR/abiword-extras-%{version}
134# abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
135# however, that file is not installed yet, so just point to it in the abiword source tree
136export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
137%configure
138make
139
140# build the documentation
141cd $RPM_BUILD_DIR/abiword-docs-%{version}
142ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
143
144%install
145rm -rf $RPM_BUILD_ROOT
146
147# install abiword
148cd $RPM_BUILD_DIR/abiword-%{version}
149make install DESTDIR=$RPM_BUILD_ROOT
150# overwrite the static binary with the dynamic one
151mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
152
153# Fix script permission
154#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
155
156# install abiword-plugins
157cd $RPM_BUILD_DIR/abiword-plugins-%{version}
158make install DESTDIR=$RPM_BUILD_ROOT
159
160# install the extras
161cd $RPM_BUILD_DIR/abiword-extras-%{version}
162make install DESTDIR=$RPM_BUILD_ROOT
163
164# install the documentation
165cd $RPM_BUILD_DIR/abiword-docs-%{version}
166mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
167cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
168# some of the help dirs have bad perms (#109261)
169find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
170
171# finish up
172mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
173cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
174
175cd $RPM_BUILD_DIR/abiword-%{version}
176mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
177desktop-file-install \
178  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
179  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
180  --add-category Applications --add-category Office \
181  ./abiword.desktop
182# remove the original one (which has X-Red-Hat-Base)  (#107023)
183#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
184
185mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
186install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
187
188# nuke .la files
189rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
190# nuke custom dictionary files
191rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
192
193%clean
194rm -rf $RPM_BUILD_ROOT
195
196%post
197update-desktop-database %{_datadir}/applications
198
199%postun
200update-desktop-database %{_datadir}/applications
201
202%files
203%defattr(-,root,root)
204%{_bindir}/abiword
205%{_datadir}/applications/*
206%{_datadir}/mime-info/*
207%{_datadir}/pixmaps/*png
208%{_datadir}/icons/*png
209
210%files -n libabiword
211%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
212%{_libdir}/abiword-%{abiver}
213%{_libdir}/libabiword-%{abiver}.so
214%{_datadir}/abiword-%{abiver}
215
216%files -n libabiword-devel
217%{_includedir}/abiword-%{abiver}
218%{_libdir}/pkgconfig/*.pc
219
220%changelog
221* Thu Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
222- add Japanese Summary and description
223- add BuildRequires: libSM-devel
224
225* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
226- new upstream release
227
228* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
229- new upstream release
230- built with enchant
231- split libabiword, libabiword-devel subpackage
232
233* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
234- built with gucharmap-2.24.0
235
236* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
237- applied new versioning policy, spec in utf-8
238
239* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
240- rebuilt with new toolchain
241
242* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
243- new upstream release
244- rebuilt with wv-1.2.4
245
246* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
247- fixed .desktop file
248
249* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
250- updated to 2.4.5
251
252* Tue Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
253- rebuilt for Vine and merged old spec files
254  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
255  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
256  - source update, plugins-1.0.3, many plugins enabled in -0vl2
257  - disabled perl
258  - abiword-mkhash.sh for spell check
259  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
260  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
261  - source update
262  - touch fonts.dir, abiword-wrapper.patch
263  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
264  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
265  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
266  - 0vl1 omits plugins because Vine 2.1.x fails to compile
267  - 0vl1 also disables gnome and perl support
268  - Japanese fonts are now usable on VineSeed/Vine 2.5
269  - by using mkjafontsdir.sh made by me
270  - source upstream to 1.0.1, plugins(merged in the main package)
271  - doc, mime-info
272  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
273  - new upstream version
274  - fix symbolic link ([VineSeed-Plus:00941])
275  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
276  - new upstream version
277  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
278  - new upstream version.
279  - disable plugin all and comment out plugin part in build/make section,
280    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
281  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
282  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
283  - fix files owner/group ([VineSeed-Plus:00819])
284  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
285  - 0.99.1-0vl0.1
286  - change release number for VinePlus 2.1
287  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
288  - 0.99.1-0vl1
289  - add japanese fonts.dir
290     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
291    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
292    but this release fail to input/display japanese.
293    please someone fix this problem.
294
295* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
296- Fix documentation generation
297- Fix charting support
298
299* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
300- New upstream version
301- Remove the macro patch and update the desktop patch
302
303* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
304- Rebuild
305
306* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
307- Disable the collaboration plugin; it is not working in 2.4.x
308
309* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
310- Rebuild for Fedora Extras 5
311
312* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
313- bug 171926
314
315* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
316- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
317  headers anymore
318
319* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
320- Remove redundant requires - bug 177305
321
322* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
323- Bump release, forgot to add desktop patch
324
325* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
326- Update to 2.4.2
327- Add BuildRequires readline-devel for the AbiCommand plugin
328- Add BuildRequires bzip2-devel and poppler-devel for plugins
329- Update desktop patch
330- Patch to fix plugin marcros
331
332* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
333- Fix bug 171928
334
335* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
336- Fix bug 161832: "Abiword is not loading certain modules"
337- Add libgsf dependecy, which was needed all along
338- Disable the collaboration plugin, it is not for general use at all
339
340* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
341- Use %%{?dist} in the release name
342
343* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
344- Update to 2.4.1
345
346* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
347- Require mathml-fonts
348- Don't rerun autogen.sh, no need anymore
349- Update gtkmathview dependency to 0.7.5
350- Update to 2.4.0
351
352* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
353- Fix gtkmathview BuildRequires
354
355* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
356- Update to 2.3.99
357
358* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
359- Update to 2.3.6
360- Drop the pango patch
361
362* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
363- Rebuild
364
365* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
366- Enable the abimathview plugin
367
368* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
369- Update to 2.3.5
370
371* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
372- Update the pango patch to disable more pango code
373
374* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
375- Fix the build after applying the pango disabling patch by
376  rerunning autogen.sh
377
378* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
379- Disable the experimental pango renderer
380
381* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
382- Update to 2.3.4
383- Add link-grammar dependency
384
385* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
386- Update to 2.2.9
387- Drop the mailmerge patch again
388
389* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
390- Fix build with mailmerge patch
391
392* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
393- Update to 2.2.8
394
395* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
396- rebuild on all arches
397
398* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
399- Because we love brown paper bag releases
400
401* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
402- Drop the gcc4, wvread, virtdestr and pt64 patches
403- Update the desktop patch
404
405* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
406- Fix 64bit build
407- Add virtual destructors to classes with virtual functions
408
409* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
410- Remove the --disable-magick plugin switch
411- disable GDA support until the plugin is ported to gnomedb 1.2.x
412- Change the download location from SF to http://www.abisource.com/
413- patch libole2
414- fix read as a macro in new glibc
415
416* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
417- bump to latest stable
418- drop integrated dashboard patch again
419- some gcc4 fixes
420
421* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
422- rh#149447# dashboard spam revisited
423
424* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
425- bump to latest stable version
426- drop integrated nautilus depend patch
427- drop integrated libwpd depend patch
428
429* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
430- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
431
432* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
433- rebuild
434
435* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
436- remove unneccessary nautilus dependency
437
438* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
439- bump to new version
440- drop integrated silenceabidash patch
441
442* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
443- RH#145085# annoying cluepacket message on stdout/stderr
444
445* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
446- Rebuilt for new readline.
447
448* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
449- RH#143368# use enchant as spellchecker
450
451* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
452- bump to new version
453
454* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
455- bump to new version
456- geometry patch upstreamed
457- security patch upstreamed
458- removeoledecod patch upstreamed
459- regenerate desktop patch
460
461* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
462- #abi7961# remove tempnam usages
463
464* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
465- bump to latest major stable version
466- #rh140321# sanity check geometry
467
468* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
469- bump to latest stable version
470
471* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
472- rebuild for python 2.4
473
474* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
475- Change to PreReq instead of Requires(post), up to 0.9
476
477* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
478- Better Requires desktop-file-utils
479
480* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
481- update to new abiword, + change norwegian wordprocessor translation
482
483* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
484- #132389# Add more abiword supported mime types to abiword.desktop
485
486* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
487- merge abiword.keys into abiword.desktop
488
489* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
490- 2.0.11
491
492* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
493- use libgnomedb
494
495* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
496- 2.0.10
497- use aiksaurus
498
499* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
500- rebuilt
501
502* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
503- #126012# some desktop translations
504
505* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
506- #128004# fix irritating windows looking filenames for generated pngs
507
508* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
509- 2.0.9, new version with security fix
510
511* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
512- rebuilt
513
514* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
515- 2.0.7, new version + gcc34 fixes
516
517* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
518- 2.0.6, 64bit changes made upstream
519
520* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
521- 2.0.5
522
523* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
524- rebuilt
525
526* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
527- rebuild for newer libots and libwpd
528- fix verify as non-root (#109261)
529- add wpd files to abiword.keys (#114907)
530
531* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
532- rebuilt
533
534* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
535- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
536
537* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
538- rebuild for new libwpd
539
540* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
541- and librsvg2-devel (#111222)
542
543* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
544- buildrequire libgnomeui-devel (#111164)
545
546* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
547- 2.0.1
548- really remove duplicate desktop file
549
550* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
551- make the docs with the just built abiword so that we don't have to
552  have abiword installed to build the docs (#107279)
553
554* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
555- fix linkage to glib 1.2 in hancom plugin (#106033)
556
557* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
558- add %%clean specfile target
559
560* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
561- remove duplicate desktop file (#107023)
562
563* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
564- include the help
565- show the clipart (#104577)
566
567* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
568- rebuild with newer libwpd and libots to get those plugins
569
570* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
571- 2.0.0
572
573* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
574- 1.99.6
575
576* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
577- 1.99.5
578
579* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
580- 1.99.3
581- put icon in the right place (#101646)
582- fix some 64bit casting issues
583- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
584- disable -pedantic -ansi so that it will build
585
586* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
587- ugly hack to deal with libtool silliness on x86_64
588
589* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
590- 1.99.2
591- add buildrequires to make sure the ots and wp plugins get built
592- no longer needs libgal2, remove buildrequires
593
594* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
595- 1.99.1
596
597* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
598- rebuilt
599
600* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
601- rebuild for new libgal2
602
603* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
604- tweak plugins build
605
606* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
607- 1.9.1
608- drop old patches, switch to using autoconf based build system instead
609  of diving makefiles
610- build with gnome support
611- build with plugins
612- add patch to build on AMD64
613
614* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
615- rebuild to fix broken libpspell dep
616
617* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
618- 1.0.5
619
620* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
621- fix for abiword starting off the screen (#82425)
622
623* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
624- 1.0.4
625
626* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
627- rebuilt
628
629* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
630- make it build on x86_64
631
632* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
633- 1.0.3 (#80560)
634- set umask before running mkfontdir in %%post
635- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
636
637* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
638- Fix doc lines
639- Fix multilib
640
641* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
642- rebuilt with gcc-3.2 (we hope)
643
644* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
645- fix help index symlink (#71219)
646
647* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
648- add abiword binary symlink for upstream compatibility (#70267)
649
650* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
651- rebuild using gcc-3.2-0.1
652
653* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
654- use included desktop file (#64447)
655- use desktop-file-install
656
657* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
658- 1.0.2
659- disable perl module build since we weren't including it anyway
660
661* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
662- 1.0.1
663
664* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
665- zh_CN and zh_TW fonts.dir were flipped
666- update to 0.99.5 as it fixes some major bugs
667- define ABI_BUILD_VERSION so the about screen gives us a version
668
669* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
670- 1st try at fixing up CJK (#61590)
671- #if 0'ify font warning dialog (#62909, #64556)
672
673* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
674- Update to 0.99.4, fixes #61153
675- Fix #61344
676- Nuke the warning about being unable to add anything to font path,
677  that's not how xfs works.
678
679* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
680- 0.99.2
681- remove blank lines in fonts.dir
682
683* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
684- 0.99.1
685
686* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
687- Added patch to use libpng10
688- Added patch to fix perl build problems.
689
690* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
691- 0.9.5
692
693* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
694- Update to 0.9.4.1 (RFE #54806)
695- Add URL (RFE #54590)
696
697* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
698- Fix uninstall (#49350)
699
700* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
701- rebuilt so that dirs aren't sgid root
702
703* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
704- Add build requirements (#45157)
705
706* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
707- Remove CVS admin files from documentation (#44916)
708
709* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
710- add s390x patch from <oliver.paukstadt@millenux.com>
711
712* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
713- add s390 patch from Helge Deller
714
715* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
716- Update to 0.7.14
717
718* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
719- Handle MIME type stuff (Bug #27530)
720- Add BuildPrereqs for some of the less common stuff AbiWord uses
721  (gal-devel, gnome-print-devel, libunicode-devel)
722
723* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
724- 0.7.13
725
726* Mon Jan 15 2001 Than Ngo <than@redhat.com>
727- fixed broken code for building
728
729* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
730- 0.7.12
731- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
732
733* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
734- Rebuild to get rid of 0777 dirs
735
736* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
737- 0.7.11
738
739* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
740- fix path to chkfontpath, it was wrong.
741
742* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
743- Up Epoch and release
744
745* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
746- Don't ship AbiWord_s if we have AbiWord_d
747- Register AbiWord's fontpath with xfs
748
749* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
750- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
751  change the ABI without increasing the soname!
752- fix tooltip (Bug #14711)
753- move binaries from /usr/share to /usr/lib
754
755* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
756- Fix build on ia64.
757
758* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
759- automatic rebuild
760
761* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
762- Rebuild with new gcc.
763
764* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
765- Fix build on ia64
766
767* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
768- 0.7.10
769- update download location
770
771* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
772- initial build for main CD
773- clean up specfile
774- fix build with gcc 2.96 and glibc 2.2
775- exclude ia64 for now
776
777* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
778- 0.7.9
779
780* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
781- 0.7.8
782- move the desktop file to /etc/X11/applnk so it can be used in both
783  GNOME and KDE
784- fix up handling of RPM_OPT_FLAGS
785
786* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
787- bzipped source to conserve space.
788
789* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
790- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
791- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
792
793* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
794- 0.7.7
795- handle RPM_OPT_FLAGS
796
797* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
798- first build for inclusion into Powertools.
799- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.