source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 5339

Revision 5339, 27.0 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild with libgsf-1.14.22

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 2.8
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 2.8.6
8Release: 4%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13## Source1: http://abisource.com/downloads/abiword/%{version}/source/abiword-plugins-%{version}.tar.gz
14## Source2: http://abisource.com/downloads/abiword/%{version}/source/abiword-extras-%{version}.tar.gz
15Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
16Source11: abiword.mime
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22#Packager:
23
24# for abiword
25BuildRequires: flex
26BuildRequires: bison
27BuildRequires: gcc-c++
28BuildRequires: gtk2-devel
29BuildRequires: libpng-devel
30BuildRequires: libxml2-devel
31BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
32BuildRequires: fribidi-devel
33BuildRequires: enchant-devel
34BuildRequires: libgnomeprint-devel
35BuildRequires: libgnomeprintui-devel
36BuildRequires: wv-devel
37BuildRequires: gucharmap-devel
38BuildRequires: libSM-devel
39
40# some plugin build deps
41BuildRequires: readline-devel
42BuildRequires: bzip2-devel
43BuildRequires: poppler-devel >= 0.14.2
44#BuildRequires: ots-devel >= 0.4.2
45BuildRequires: libwpd-devel >= 0.8.0
46BuildRequires: librsvg2-devel
47#BuildRequires: aiksaurus-gtk-devel >= 1.2.1
48#BuildRequires: link-grammar-devel >= 4.2.1
49#BuildRequires: gtkmathview-devel >= 0.7.5
50BuildRequires: libgsf-devel >= 1.12.1
51BuildRequires: libboost-devel >= 1.33.1
52
53# gnome build deps
54BuildRequires: libbonobo-devel
55BuildRequires: libbonoboui-devel
56BuildRequires: libgnomeui-devel
57
58Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
59Obsoletes: abiword-fonts abiword-plugins
60
61URL: http://www.abisource.com/
62
63Patch0: abiword-2.6.0-windowshelppaths.patch
64Patch1: abiword-2.6.4-desktop.patch
65Patch2: abiword-2.6.0-boolean.patch
66Patch3: abiword-2.8.6-no-undefined.patch
67
68
69%description
70AbiWord is a cross-platform Open Source word processor. The goal is to make
71AbiWord full-featured, and remain lean.
72
73%description -l ja
74AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
75多機能で機敏に動くことを目標としています。
76
77%package -n libabiword
78Summary: Library for developing applications based on AbiWord's core
79Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
80Group: System Environment/Libraries
81
82%description -n libabiword
83Library for developing applications based on AbiWord's core.
84
85%description -n libabiword -l ja
86AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
87
88%package -n libabiword-devel
89Summary: Files for developing with libabiword
90Summary(ja): libabiword を用いた開発に必要なファイル群
91Group: Development/Libraries
92Requires: libabiword = %{epoch}:%{version}-%{release}
93
94%description -n libabiword-devel
95Includes and definitions for developing with libabiword.
96
97%description -n libabiword-devel -l ja
98libabiword で開発するためのインクルードファイル及び定義ファイルです。
99
100%prep
101%setup -q
102## %patch1 -p1 -b .desktop
103%patch2 -p1 -b .boolean
104
105%patch3 -p1 -b .undefined
106
107# setup abiword extras
108## %setup -q -T -b 2 -n abiword-extras-%{version}
109
110# setup abiword documentation
111%setup -q -T -b 3 -n abiword-docs-%{version}
112%patch0 -p1 -b .windowshelppaths
113
114%build
115# build libabiword and abiword
116cd $RPM_BUILD_DIR/abiword-%{version}
117%configure --enable-libabiword -enable-static=no
118make %{?_smp_mflags}
119
120# build abiword-plugins
121## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
122## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
123## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
124## # Remove libtool predep_objects and postdep_objects wonkiness so that
125## # building without -nostdlib doesn't include them twice.  Because we
126## # already link with g++, weird stuff happens if you don't let the
127## # compiler handle this.
128## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
129## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
130## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
131## make %{?_smp_mflags}
132
133# build abiword-extras
134## cd $RPM_BUILD_DIR/abiword-extras-%{version}
135## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
136## # however, that file is not installed yet, so just point to it in the abiword source tree
137## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
138## %configure
139## make
140
141# build the documentation
142cd $RPM_BUILD_DIR/abiword-docs-%{version}
143ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
144
145%install
146rm -rf $RPM_BUILD_ROOT
147
148# install abiword
149cd $RPM_BUILD_DIR/abiword-%{version}
150make install DESTDIR=$RPM_BUILD_ROOT
151# overwrite the static binary with the dynamic one
152## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
153
154# Fix script permission
155#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
156
157# install abiword-plugins
158## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
159## make install DESTDIR=$RPM_BUILD_ROOT
160
161# install the extras
162## cd $RPM_BUILD_DIR/abiword-extras-%{version}
163## make install DESTDIR=$RPM_BUILD_ROOT
164
165# install the documentation
166cd $RPM_BUILD_DIR/abiword-docs-%{version}
167mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
168cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
169# some of the help dirs have bad perms (#109261)
170find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
171
172# finish up
173## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
174## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
175
176cd $RPM_BUILD_DIR/abiword-%{version}
177mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
178desktop-file-install \
179  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
180  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
181  --add-category Applications --add-category Office \
182  ./abiword.desktop
183# remove the original one (which has X-Red-Hat-Base)  (#107023)
184#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
185
186mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
187install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
188
189# nuke .la files
190rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
191rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
192# nuke .a files
193rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
194# nuke custom dictionary files
195rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
196
197
198%clean
199rm -rf $RPM_BUILD_ROOT
200
201%post
202update-desktop-database -q %{_datadir}/applications
203
204%postun
205update-desktop-database -q %{_datadir}/applications
206
207%files
208%defattr(-,root,root)
209%{_bindir}/abiword
210%{_datadir}/applications/*
211%{_datadir}/mime-info/*
212## %{_datadir}/pixmaps/*png
213%{_datadir}/icons/*png
214%{_mandir}/man1/abiword.1.gz
215
216%files -n libabiword
217%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
218%{_libdir}/abiword-%{abiver}
219%{_libdir}/libabiword-%{abiver}.so
220%{_datadir}/abiword-%{abiver}
221
222%files -n libabiword-devel
223%{_includedir}/abiword-%{abiver}
224%{_libdir}/pkgconfig/*.pc
225
226%changelog
227* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-4
228- add Patch3 (abiword-2.8.6-no-undefined.patch)
229- add BuildRequires: flex, bison
230
231* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-3
232- rebuild with poppler-0.14.2
233
234* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
235- rebuild with rpm-4.8.1 for pkg-config file
236
237* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
238- new upstream release
239- drop Source1, Source2
240- drop Patch1, Patch3
241- fix %setup, %build, %install and %files
242
243* Thu Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
244- add Japanese Summary and description
245- add BuildRequires: libSM-devel
246
247* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
248- new upstream release
249
250* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
251- new upstream release
252- built with enchant
253- split libabiword, libabiword-devel subpackage
254
255* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
256- built with gucharmap-2.24.0
257
258* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
259- applied new versioning policy, spec in utf-8
260
261* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
262- rebuilt with new toolchain
263
264* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
265- new upstream release
266- rebuilt with wv-1.2.4
267
268* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
269- fixed .desktop file
270
271* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
272- updated to 2.4.5
273
274* Tue Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
275- rebuilt for Vine and merged old spec files
276  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
277  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
278  - source update, plugins-1.0.3, many plugins enabled in -0vl2
279  - disabled perl
280  - abiword-mkhash.sh for spell check
281  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
282  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
283  - source update
284  - touch fonts.dir, abiword-wrapper.patch
285  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
286  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
287  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
288  - 0vl1 omits plugins because Vine 2.1.x fails to compile
289  - 0vl1 also disables gnome and perl support
290  - Japanese fonts are now usable on VineSeed/Vine 2.5
291  - by using mkjafontsdir.sh made by me
292  - source upstream to 1.0.1, plugins(merged in the main package)
293  - doc, mime-info
294  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
295  - new upstream version
296  - fix symbolic link ([VineSeed-Plus:00941])
297  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
298  - new upstream version
299  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
300  - new upstream version.
301  - disable plugin all and comment out plugin part in build/make section,
302    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
303  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
304  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
305  - fix files owner/group ([VineSeed-Plus:00819])
306  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
307  - 0.99.1-0vl0.1
308  - change release number for VinePlus 2.1
309  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
310  - 0.99.1-0vl1
311  - add japanese fonts.dir
312     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
313    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
314    but this release fail to input/display japanese.
315    please someone fix this problem.
316
317* Tue Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
318- Fix documentation generation
319- Fix charting support
320
321* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
322- New upstream version
323- Remove the macro patch and update the desktop patch
324
325* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
326- Rebuild
327
328* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
329- Disable the collaboration plugin; it is not working in 2.4.x
330
331* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
332- Rebuild for Fedora Extras 5
333
334* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
335- bug 171926
336
337* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
338- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
339  headers anymore
340
341* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
342- Remove redundant requires - bug 177305
343
344* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
345- Bump release, forgot to add desktop patch
346
347* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
348- Update to 2.4.2
349- Add BuildRequires readline-devel for the AbiCommand plugin
350- Add BuildRequires bzip2-devel and poppler-devel for plugins
351- Update desktop patch
352- Patch to fix plugin marcros
353
354* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
355- Fix bug 171928
356
357* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
358- Fix bug 161832: "Abiword is not loading certain modules"
359- Add libgsf dependecy, which was needed all along
360- Disable the collaboration plugin, it is not for general use at all
361
362* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
363- Use %%{?dist} in the release name
364
365* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
366- Update to 2.4.1
367
368* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
369- Require mathml-fonts
370- Don't rerun autogen.sh, no need anymore
371- Update gtkmathview dependency to 0.7.5
372- Update to 2.4.0
373
374* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
375- Fix gtkmathview BuildRequires
376
377* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
378- Update to 2.3.99
379
380* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
381- Update to 2.3.6
382- Drop the pango patch
383
384* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
385- Rebuild
386
387* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
388- Enable the abimathview plugin
389
390* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
391- Update to 2.3.5
392
393* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
394- Update the pango patch to disable more pango code
395
396* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
397- Fix the build after applying the pango disabling patch by
398  rerunning autogen.sh
399
400* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
401- Disable the experimental pango renderer
402
403* Thu Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
404- Update to 2.3.4
405- Add link-grammar dependency
406
407* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
408- Update to 2.2.9
409- Drop the mailmerge patch again
410
411* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
412- Fix build with mailmerge patch
413
414* Sun Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
415- Update to 2.2.8
416
417* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
418- rebuild on all arches
419
420* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
421- Because we love brown paper bag releases
422
423* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
424- Drop the gcc4, wvread, virtdestr and pt64 patches
425- Update the desktop patch
426
427* Fri Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
428- Fix 64bit build
429- Add virtual destructors to classes with virtual functions
430
431* Fri Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
432- Remove the --disable-magick plugin switch
433- disable GDA support until the plugin is ported to gnomedb 1.2.x
434- Change the download location from SF to http://www.abisource.com/
435- patch libole2
436- fix read as a macro in new glibc
437
438* Fri Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
439- bump to latest stable
440- drop integrated dashboard patch again
441- some gcc4 fixes
442
443* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
444- rh#149447# dashboard spam revisited
445
446* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
447- bump to latest stable version
448- drop integrated nautilus depend patch
449- drop integrated libwpd depend patch
450
451* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
452- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
453
454* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
455- rebuild
456
457* Mon Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
458- remove unneccessary nautilus dependency
459
460* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
461- bump to new version
462- drop integrated silenceabidash patch
463
464* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
465- RH#145085# annoying cluepacket message on stdout/stderr
466
467* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
468- Rebuilt for new readline.
469
470* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
471- RH#143368# use enchant as spellchecker
472
473* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
474- bump to new version
475
476* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
477- bump to new version
478- geometry patch upstreamed
479- security patch upstreamed
480- removeoledecod patch upstreamed
481- regenerate desktop patch
482
483* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
484- #abi7961# remove tempnam usages
485
486* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
487- bump to latest major stable version
488- #rh140321# sanity check geometry
489
490* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
491- bump to latest stable version
492
493* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
494- rebuild for python 2.4
495
496* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
497- Change to PreReq instead of Requires(post), up to 0.9
498
499* Thu Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
500- Better Requires desktop-file-utils
501
502* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
503- update to new abiword, + change norwegian wordprocessor translation
504
505* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
506- #132389# Add more abiword supported mime types to abiword.desktop
507
508* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
509- merge abiword.keys into abiword.desktop
510
511* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
512- 2.0.11
513
514* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
515- use libgnomedb
516
517* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
518- 2.0.10
519- use aiksaurus
520
521* Tue Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
522- rebuilt
523
524* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
525- #126012# some desktop translations
526
527* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
528- #128004# fix irritating windows looking filenames for generated pngs
529
530* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
531- 2.0.9, new version with security fix
532
533* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
534- rebuilt
535
536* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
537- 2.0.7, new version + gcc34 fixes
538
539* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
540- 2.0.6, 64bit changes made upstream
541
542* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
543- 2.0.5
544
545* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
546- rebuilt
547
548* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
549- rebuild for newer libots and libwpd
550- fix verify as non-root (#109261)
551- add wpd files to abiword.keys (#114907)
552
553* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
554- rebuilt
555
556* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
557- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
558
559* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
560- rebuild for new libwpd
561
562* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
563- and librsvg2-devel (#111222)
564
565* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
566- buildrequire libgnomeui-devel (#111164)
567
568* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
569- 2.0.1
570- really remove duplicate desktop file
571
572* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
573- make the docs with the just built abiword so that we don't have to
574  have abiword installed to build the docs (#107279)
575
576* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
577- fix linkage to glib 1.2 in hancom plugin (#106033)
578
579* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
580- add %%clean specfile target
581
582* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
583- remove duplicate desktop file (#107023)
584
585* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
586- include the help
587- show the clipart (#104577)
588
589* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
590- rebuild with newer libwpd and libots to get those plugins
591
592* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
593- 2.0.0
594
595* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
596- 1.99.6
597
598* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
599- 1.99.5
600
601* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
602- 1.99.3
603- put icon in the right place (#101646)
604- fix some 64bit casting issues
605- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
606- disable -pedantic -ansi so that it will build
607
608* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
609- ugly hack to deal with libtool silliness on x86_64
610
611* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
612- 1.99.2
613- add buildrequires to make sure the ots and wp plugins get built
614- no longer needs libgal2, remove buildrequires
615
616* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
617- 1.99.1
618
619* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
620- rebuilt
621
622* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
623- rebuild for new libgal2
624
625* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
626- tweak plugins build
627
628* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
629- 1.9.1
630- drop old patches, switch to using autoconf based build system instead
631  of diving makefiles
632- build with gnome support
633- build with plugins
634- add patch to build on AMD64
635
636* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
637- rebuild to fix broken libpspell dep
638
639* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
640- 1.0.5
641
642* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
643- fix for abiword starting off the screen (#82425)
644
645* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
646- 1.0.4
647
648* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
649- rebuilt
650
651* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
652- make it build on x86_64
653
654* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
655- 1.0.3 (#80560)
656- set umask before running mkfontdir in %%post
657- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
658
659* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
660- Fix doc lines
661- Fix multilib
662
663* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
664- rebuilt with gcc-3.2 (we hope)
665
666* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
667- fix help index symlink (#71219)
668
669* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
670- add abiword binary symlink for upstream compatibility (#70267)
671
672* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
673- rebuild using gcc-3.2-0.1
674
675* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
676- use included desktop file (#64447)
677- use desktop-file-install
678
679* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
680- 1.0.2
681- disable perl module build since we weren't including it anyway
682
683* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
684- 1.0.1
685
686* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
687- zh_CN and zh_TW fonts.dir were flipped
688- update to 0.99.5 as it fixes some major bugs
689- define ABI_BUILD_VERSION so the about screen gives us a version
690
691* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
692- 1st try at fixing up CJK (#61590)
693- #if 0'ify font warning dialog (#62909, #64556)
694
695* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
696- Update to 0.99.4, fixes #61153
697- Fix #61344
698- Nuke the warning about being unable to add anything to font path,
699  that's not how xfs works.
700
701* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
702- 0.99.2
703- remove blank lines in fonts.dir
704
705* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
706- 0.99.1
707
708* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
709- Added patch to use libpng10
710- Added patch to fix perl build problems.
711
712* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
713- 0.9.5
714
715* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
716- Update to 0.9.4.1 (RFE #54806)
717- Add URL (RFE #54590)
718
719* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
720- Fix uninstall (#49350)
721
722* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
723- rebuilt so that dirs aren't sgid root
724
725* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
726- Add build requirements (#45157)
727
728* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
729- Remove CVS admin files from documentation (#44916)
730
731* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
732- add s390x patch from <oliver.paukstadt@millenux.com>
733
734* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
735- add s390 patch from Helge Deller
736
737* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
738- Update to 0.7.14
739
740* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
741- Handle MIME type stuff (Bug #27530)
742- Add BuildPrereqs for some of the less common stuff AbiWord uses
743  (gal-devel, gnome-print-devel, libunicode-devel)
744
745* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
746- 0.7.13
747
748* Mon Jan 15 2001 Than Ngo <than@redhat.com>
749- fixed broken code for building
750
751* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
752- 0.7.12
753- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
754
755* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
756- Rebuild to get rid of 0777 dirs
757
758* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
759- 0.7.11
760
761* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
762- fix path to chkfontpath, it was wrong.
763
764* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
765- Up Epoch and release
766
767* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
768- Don't ship AbiWord_s if we have AbiWord_d
769- Register AbiWord's fontpath with xfs
770
771* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
772- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
773  change the ABI without increasing the soname!
774- fix tooltip (Bug #14711)
775- move binaries from /usr/share to /usr/lib
776
777* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
778- Fix build on ia64.
779
780* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
781- automatic rebuild
782
783* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
784- Rebuild with new gcc.
785
786* Sat Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
787- Fix build on ia64
788
789* Fri Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
790- 0.7.10
791- update download location
792
793* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
794- initial build for main CD
795- clean up specfile
796- fix build with gcc 2.96 and glibc 2.2
797- exclude ia64 for now
798
799* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
800- 0.7.9
801
802* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
803- 0.7.8
804- move the desktop file to /etc/X11/applnk so it can be used in both
805  GNOME and KDE
806- fix up handling of RPM_OPT_FLAGS
807
808* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
809- bzipped source to conserve space.
810
811* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
812- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
813- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
814
815* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
816- 0.7.7
817- handle RPM_OPT_FLAGS
818
819* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
820- first build for inclusion into Powertools.
821- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.