source: projects/specs/trunk/a/abiword/abiword-vl.spec @ 10489

Revision 10489, 27.0 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1%define desktop_file_utils_version 0.16
2%define abiver 3.0
3
4Summary: The AbiWord word processor
5Summary(ja): AbiWord ワードプロセッサ
6Name: abiword
7Version: 3.0.1
8Release: 3%{?_dist_release}
9Epoch: 1
10Group: Applications/Productivity
11License: GPLv2+
12Source0: http://abisource.com/downloads/abiword/%{version}/source/abiword-%{version}.tar.gz
13Source3: http://abisource.com/downloads/abiword/%{version}/source/abiword-docs-%{version}.tar.gz
14Source11: abiword.mime
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20#Packager:
21
22# for abiword
23BuildRequires: flex
24BuildRequires: bison
25BuildRequires: gcc-c++
26BuildRequires: gtk2-devel
27BuildRequires: libpng-devel
28BuildRequires: libxml2-devel
29BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
30BuildRequires: fribidi-devel
31BuildRequires: enchant-devel
32BuildRequires: libgnomeprint-devel
33BuildRequires: libgnomeprintui-devel
34BuildRequires: wv-devel
35BuildRequires: gucharmap-devel
36BuildRequires: libSM-devel
37
38# some plugin build deps
39BuildRequires: readline-devel
40BuildRequires: bzip2-devel
41BuildRequires: poppler-devel >= 0.14.2
42BuildRequires: libwpd-devel >= 0.8.0
43BuildRequires: librsvg2-devel
44BuildRequires: libgsf-devel >= 1.12.1
45BuildRequires: libboost-devel >= 1.33.1
46
47# gnome build deps
48BuildRequires: libbonobo-devel
49BuildRequires: libbonoboui-devel
50BuildRequires: libgnomeui-devel
51
52
53Requires(pre): desktop-file-utils >= %{desktop_file_utils_version}
54Obsoletes: abiword-fonts abiword-plugins
55
56URL: http://www.abisource.com/
57
58Patch0: abiword-2.6.0-windowshelppaths.patch
59Patch1: abiword-2.6.4-desktop.patch
60Patch2: abiword-2.6.0-boolean.patch
61Patch3: abiword-2.8.6-no-undefined.patch
62
63
64%description
65AbiWord is a cross-platform Open Source word processor. The goal is to make
66AbiWord full-featured, and remain lean.
67
68%description -l ja
69AbiWord はクロスプラットフォームのオープンソースなワードプロセッサーです。
70多機能で機敏に動くことを目標としています。
71
72%package -n libabiword
73Summary: Library for developing applications based on AbiWord's core
74Summary(ja): AbiWord コアで稼動するアプリケーションを開発するためのライブラリ
75Group: System Environment/Libraries
76
77%description -n libabiword
78Library for developing applications based on AbiWord's core.
79
80%description -n libabiword -l ja
81AbiWord コアで稼動するアプリケーションを開発するためのライブラリです。
82
83%package -n libabiword-devel
84Summary: Files for developing with libabiword
85Summary(ja): libabiword を用いた開発に必要なファイル群
86Group: Development/Libraries
87Requires: libabiword = %{epoch}:%{version}-%{release}
88
89%description -n libabiword-devel
90Includes and definitions for developing with libabiword.
91
92%description -n libabiword-devel -l ja
93libabiword で開発するためのインクルードファイル及び定義ファイルです。
94
95%prep
96%setup -q
97## %patch1 -p1 -b .desktop
98%patch2 -p1 -b .boolean
99
100# setup abiword extras
101## %setup -q -T -b 2 -n abiword-extras-%{version}
102
103# setup abiword documentation
104%setup -q -T -b 3 -n abiword-docs-%{version}
105%patch0 -p1 -b .windowshelppaths
106
107%build
108# build libabiword and abiword
109cd $RPM_BUILD_DIR/abiword-%{version}
110%configure  -enable-static=no
111make %{?_smp_mflags}
112
113# build abiword-plugins
114## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
115## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
116## CXXFLAGS="-L$RPM_BUILD_DIR/%{name}-%{version}/src/wp/main/unix/" %configure --disable-gda --enable-libabiword --with-abiword=$RPM_BUILD_DIR/%{name}-%{version}
117## # Remove libtool predep_objects and postdep_objects wonkiness so that
118## # building without -nostdlib doesn't include them twice.  Because we
119## # already link with g++, weird stuff happens if you don't let the
120## # compiler handle this.
121## sed 's/^predep_objects=.*/predep_objects=\"\"/' < libtool > libtool.foo
122## sed 's/^postdep_objects=.*/postdep_objects=\"\"/' < libtool.foo > libtool.foobar
123## sed 's/-shared -nostdlib/-shared/' < libtool.foobar > libtool
124## make %{?_smp_mflags}
125
126# build abiword-extras
127## cd $RPM_BUILD_DIR/abiword-extras-%{version}
128## # abiword-extras looks at the abiword-%{version}.pc pkg-config file to get its location info
129## # however, that file is not installed yet, so just point to it in the abiword source tree
130## export PKG_CONFIG_PATH="$RPM_BUILD_DIR/%{name}-%{version}"
131## %configure
132## make
133
134# build the documentation
135cd $RPM_BUILD_DIR/abiword-docs-%{version}
136ABI_DOC_PROG=$(pwd)/../%{name}-%{version}/src/wp/main/unix/abiword ./make-html.sh
137
138%install
139rm -rf $RPM_BUILD_ROOT
140
141# install abiword
142cd $RPM_BUILD_DIR/abiword-%{version}
143make install DESTDIR=$RPM_BUILD_ROOT
144# overwrite the static binary with the dynamic one
145## mv -f $RPM_BUILD_DIR/abiword-%{version}/src/wp/main/unix/abiword-dynamic $RPM_BUILD_ROOT%{_bindir}/abiword
146
147# Fix script permission
148#chmod +x $RPM_BUILD_ROOT%{_datadir}/%{name}-%{abiver}/scripts/abw2html.pl
149
150# install abiword-plugins
151## cd $RPM_BUILD_DIR/abiword-plugins-%{version}
152## make install DESTDIR=$RPM_BUILD_ROOT
153
154# install the extras
155## cd $RPM_BUILD_DIR/abiword-extras-%{version}
156## make install DESTDIR=$RPM_BUILD_ROOT
157
158# install the documentation
159cd $RPM_BUILD_DIR/abiword-docs-%{version}
160mkdir -p $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help
161cp -rp help/* $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/
162# some of the help dirs have bad perms (#109261)
163find $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/AbiWord/help/ -type d -exec chmod -c o+rx {} \;
164
165# finish up
166## mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
167## cp $RPM_BUILD_DIR/abiword-extras-%{version}/icons/abiword_48.png $RPM_BUILD_ROOT%{_datadir}/pixmaps/abiword_48.png
168
169cd $RPM_BUILD_DIR/abiword-%{version}
170mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
171desktop-file-install \
172  --dir $RPM_BUILD_ROOT%{_datadir}/applications \
173  --add-category X-Red-Hat-Extra --remove-category X-Red-Hat-Base \
174  --add-category Applications --add-category Office \
175  ./abiword.desktop
176# remove the original one (which has X-Red-Hat-Base)  (#107023)
177#rm -f $RPM_BUILD_ROOT/%{_datadir}/applications/abiword.desktop
178
179mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime-info
180install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/mime-info
181
182# nuke .la files
183rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}-%{abiver}/plugins/*.la
184rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
185# nuke .a files
186rm -f $RPM_BUILD_ROOT/%{_libdir}/*.a
187# nuke custom dictionary files
188rm -f $RPM_BUILD_ROOT/%{_datadir}/%{name}-%{abiver}/dictionary/ispell_dictionary_list.xml
189
190
191%clean
192rm -rf $RPM_BUILD_ROOT
193
194%post
195update-desktop-database -q %{_datadir}/applications
196
197%postun
198update-desktop-database -q %{_datadir}/applications
199
200%files
201%defattr(-,root,root)
202%{_bindir}/abiword
203%{_datadir}/applications/*
204%{_datadir}/mime-info/*
205%{_datadir}/icons/*/*/*/abiword.*
206%{_mandir}/man1/abiword.1.gz
207
208%files -n libabiword
209%doc $RPM_BUILD_DIR/%{name}-%{version}/docs $RPM_BUILD_DIR/%{name}-%{version}/COPYING $RPM_BUILD_DIR/%{name}-%{version}/COPYRIGHT.TXT $RPM_BUILD_DIR/%{name}-%{version}/README.TXT
210%{_libdir}/abiword-%{abiver}
211%{_libdir}/libabiword-%{abiver}.so
212%{_datadir}/abiword-%{abiver}
213
214%files -n libabiword-devel
215%{_includedir}/abiword-%{abiver}
216%{_libdir}/pkgconfig/*.pc
217
218%changelog
219* Sat Jul 02 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.1-3
220- rebuild with gcc-5.4.0
221
222* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.1-2
223- rebuild with poppler-0.37.0
224
225* Thu Dec 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.1-1
226- new upstream release
227
228* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:3.0.0-1
229- update to 3.0.0
230- remove Patch3 (abiword-2.8.6-no-undefined.patch)
231
232* Fri Dec 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-4
233- add Patch3 (abiword-2.8.6-no-undefined.patch)
234- add BuildRequires: flex, bison
235
236* Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-3
237- rebuild with poppler-0.14.2
238
239* Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-2
240- rebuild with rpm-4.8.1 for pkg-config file
241
242* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.8.6-1
243- new upstream release
244- drop Source1, Source2
245- drop Patch1, Patch3
246- fix %setup, %build, %install and %files
247
248* Wed Jul 29 2009 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1:2.6.8-2
249- add Japanese Summary and description
250- add BuildRequires: libSM-devel
251
252* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.8-1
253- new upstream release
254
255* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.6.4-1vl5
256- new upstream release
257- built with enchant
258- split libabiword, libabiword-devel subpackage
259
260* Mon Oct 13 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-2vl5
261- built with gucharmap-2.24.0
262
263* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1:2.4.6-1vl5
264- applied new versioning policy, spec in utf-8
265
266* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl2
267- rebuilt with new toolchain
268
269* Thu Dec 21 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.6-0vl1
270- new upstream release
271- rebuilt with wv-1.2.4
272
273* Thu Sep 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl2
274- fixed .desktop file
275
276* Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.5-2vl1
277- updated to 2.4.5
278
279* Thu Apr 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1:2.4.4-2vl1
280- rebuilt for Vine and merged old spec files
281  * Thu Sep 26 2002 Masaki Shinomiya <shino@pos.to>
282  - 1.0.3-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
283  - source update, plugins-1.0.3, many plugins enabled in -0vl2
284  - disabled perl
285  - abiword-mkhash.sh for spell check
286  * Mon Jun 24 2002 Masaki Shinomiya <shino@pos.to>
287  - 1.0.2-0vl1 for VinePlus/2.1 and (-0vl2) for 2.5 and VineSeedPlus
288  - source update
289  - touch fonts.dir, abiword-wrapper.patch
290  - no longer segmentation fault on Vine 2.5 (see [vine-users:051609]-)
291  * Wed May 22 2002 Masaki Shinomiya <shino@pos.to>
292  - 1.0.1-0vl1 for VinePlus/2.1 and (-0vl2) for VineSeedPlus
293  - 0vl1 omits plugins because Vine 2.1.x fails to compile
294  - 0vl1 also disables gnome and perl support
295  - Japanese fonts are now usable on VineSeed/Vine 2.5
296  - by using mkjafontsdir.sh made by me
297  - source upstream to 1.0.1, plugins(merged in the main package)
298  - doc, mime-info
299  * Sat Mar 30 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.4-0vl2
300  - new upstream version
301  - fix symbolic link ([VineSeed-Plus:00941])
302  * Sun Mar 18 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.3-0vl2
303  - new upstream version
304  * Sun Feb 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com> 0.99.2-0vl0
305  - new upstream version.
306  - disable plugin all and comment out plugin part in build/make section,
307    because 0.99.2's source tar boll doesn't have abiword-plugins directory.
308  * Fri Feb 15 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
309  - 0.99.1-0vl3 (0.99.1-0vl2 for VinePlus-2.1)
310  - fix files owner/group ([VineSeed-Plus:00819])
311  * Sat Jan 28 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
312  - 0.99.1-0vl0.1
313  - change release number for VinePlus 2.1
314  * Sat Jan 24 2002 Ryoichi TACHIBANA <t-ryoichi@mbi.nifty.com>
315  - 0.99.1-0vl1
316  - add japanese fonts.dir
317     (see http://www.gnome.gr.jp/ml/gnome-users/200101/msg00034.html)
318    0vl0.1 release for VinePlus-2.1 succeed to input/display japanese,
319    but this release fail to input/display japanese.
320    please someone fix this problem.
321
322* Thu Apr 13 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-2.fc6
323- Fix documentation generation
324- Fix charting support
325
326* Tue Apr 11 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.4-1.fc6
327- New upstream version
328- Remove the macro patch and update the desktop patch
329
330* Wed Mar 29 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-8.fc6
331- Rebuild
332
333* Wed Mar 08 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-7.fc5
334- Disable the collaboration plugin; it is not working in 2.4.x
335
336* Thu Feb 16 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-6.fc5
337- Rebuild for Fedora Extras 5
338
339* Sun Feb 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-5.fc5
340- bug 171926
341
342* Sat Jan 21 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-4.fc5
343- Disable the PDF plugin for now, as poppler doesn't ship the xpdf
344  headers anymore
345
346* Sat Jan 14 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-3.fc5
347- Remove redundant requires - bug 177305
348
349* Thu Jan 05 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-2.fc5
350- Bump release, forgot to add desktop patch
351
352* Mon Jan 02 2006 Marc Maurer <uwog@abisource.com> - 1:2.4.2-1.fc5
353- Update to 2.4.2
354- Add BuildRequires readline-devel for the AbiCommand plugin
355- Add BuildRequires bzip2-devel and poppler-devel for plugins
356- Update desktop patch
357- Patch to fix plugin marcros
358
359* Wed Nov 09 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-4.fc5
360- Fix bug 171928
361
362* Sun Oct 23 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-3.fc5
363- Fix bug 161832: "Abiword is not loading certain modules"
364- Add libgsf dependecy, which was needed all along
365- Disable the collaboration plugin, it is not for general use at all
366
367* Tue Oct 11 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-2
368- Use %%{?dist} in the release name
369
370* Sun Oct 9 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.1-1
371- Update to 2.4.1
372
373* Mon Oct 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.4.0-1
374- Require mathml-fonts
375- Don't rerun autogen.sh, no need anymore
376- Update gtkmathview dependency to 0.7.5
377- Update to 2.4.0
378
379* Mon Sep 26 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-2
380- Fix gtkmathview BuildRequires
381
382* Thu Sep 22 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.99-1
383- Update to 2.3.99
384
385* Sat Sep 10 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.6-1
386- Update to 2.3.6
387- Drop the pango patch
388
389* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-3
390- Rebuild
391
392* Sat Sep 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-2
393- Enable the abimathview plugin
394
395* Sun Aug 21 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.5-1
396- Update to 2.3.5
397
398* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-4
399- Update the pango patch to disable more pango code
400
401* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-3
402- Fix the build after applying the pango disabling patch by
403  rerunning autogen.sh
404
405* Fri Aug 19 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-2
406- Disable the experimental pango renderer
407
408* Wed Aug 17 2005 Marc Maurer <uwog@abisource.com> - 1:2.3.4-1
409- Update to 2.3.4
410- Add link-grammar dependency
411
412* Thu Jul 28 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.9-1
413- Update to 2.2.9
414- Drop the mailmerge patch again
415
416* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-2
417- Fix build with mailmerge patch
418
419* Mon Jun 6 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.8-1
420- Update to 2.2.8
421
422* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1:2.2.7-2
423- rebuild on all arches
424
425* Mon Apr 4 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.7-1
426- Because we love brown paper bag releases
427
428* Sun Apr 3 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.6-1
429- Drop the gcc4, wvread, virtdestr and pt64 patches
430- Update the desktop patch
431
432* Tue Mar 15 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-3
433- Fix 64bit build
434- Add virtual destructors to classes with virtual functions
435
436* Mon Mar 14 2005 Marc Maurer <uwog@abisource.com> - 1:2.2.5-2
437- Remove the --disable-magick plugin switch
438- disable GDA support until the plugin is ported to gnomedb 1.2.x
439- Change the download location from SF to http://www.abisource.com/
440- patch libole2
441- fix read as a macro in new glibc
442
443* Wed Mar  2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.5-1
444- bump to latest stable
445- drop integrated dashboard patch again
446- some gcc4 fixes
447
448* Wed Feb 23 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-2
449- rh#149447# dashboard spam revisited
450
451* Tue Feb 22 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.4-1
452- bump to latest stable version
453- drop integrated nautilus depend patch
454- drop integrated libwpd depend patch
455
456* Fri Feb 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-4
457- upgrade to libwpd-0.8 and incoroprate necessary changeover patches
458
459* Mon Feb 7 2005 Matthias Clasen <mclasen@redhat.com> - 1:2.2.3-3
460- rebuild
461
462* Wed Feb 2 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-2
463- remove unneccessary nautilus dependency
464
465* Mon Jan 17 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.3-1
466- bump to new version
467- drop integrated silenceabidash patch
468
469* Fri Jan 14 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-4
470- RH#145085# annoying cluepacket message on stdout/stderr
471
472* Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 1:2.2.2-3
473- Rebuilt for new readline.
474
475* Tue Jan 11 2005 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-2
476- RH#143368# use enchant as spellchecker
477
478* Mon Dec 13 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.2-1
479- bump to new version
480
481* Mon Dec 6 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.1-1
482- bump to new version
483- geometry patch upstreamed
484- security patch upstreamed
485- removeoledecod patch upstreamed
486- regenerate desktop patch
487
488* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-2
489- #abi7961# remove tempnam usages
490
491* Mon Nov 22 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.2.0-1
492- bump to latest major stable version
493- #rh140321# sanity check geometry
494
495* Tue Nov  9 2004 Caolan McNamara <caolanm@redhat.com> - 1:2.0.14-1
496- bump to latest stable version
497
498* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.12-4
499- rebuild for python 2.4
500
501* Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 1:2.0.12-3
502- Change to PreReq instead of Requires(post), up to 0.9
503
504* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-2
505- Better Requires desktop-file-utils
506
507* Wed Sep 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.12-1
508- update to new abiword, + change norwegian wordprocessor translation
509
510* Tue Sep 14 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-3
511- #132389# Add more abiword supported mime types to abiword.desktop
512
513* Mon Sep 6 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-2
514- merge abiword.keys into abiword.desktop
515
516* Fri Aug 27 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.11-1
517- 2.0.11
518
519* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-2
520- use libgnomedb
521
522* Tue Aug 10 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.10-1
523- 2.0.10
524- use aiksaurus
525
526* Mon Aug 2 2004 Matthias Clasen <mclasen@redhat.com> 1:2.0.9-4
527- rebuilt
528
529* Thu Jul 29 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-3
530- #126012# some desktop translations
531
532* Wed Jul 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-2
533- #128004# fix irritating windows looking filenames for generated pngs
534
535* Fri Jul 16 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.9-1
536- 2.0.9, new version with security fix
537
538* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
539- rebuilt
540
541* Thu May 20 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
542- 2.0.7, new version + gcc34 fixes
543
544* Wed Apr 28 2004 Caolan McNamara <caolanm@redhat.com> 1:2.0.6-1
545- 2.0.6, 64bit changes made upstream
546
547* Sat Mar 13 2004 Jeremy Katz <> 1:2.0.5-1
548- 2.0.5
549
550* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
551- rebuilt
552
553* Thu Feb 19 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-3
554- rebuild for newer libots and libwpd
555- fix verify as non-root (#109261)
556- add wpd files to abiword.keys (#114907)
557
558* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
559- rebuilt
560
561* Thu Jan 29 2004 Jeremy Katz <katzj@redhat.com> - 1:2.0.3-1
562- 2.0.3 (fixes build against gtk+ 2.3 and lets us rebuild to fix libcroco dep)
563
564* Wed Dec 17 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.2-2
565- rebuild for new libwpd
566
567* Sun Nov 30 2003 Jeremy Katz <katzj@redhat.com>
568- and librsvg2-devel (#111222)
569
570* Fri Nov 28 2003 Jeremy Katz <katzj@redhat.com>
571- buildrequire libgnomeui-devel (#111164)
572
573* Tue Oct 28 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.1-1
574- 2.0.1
575- really remove duplicate desktop file
576
577* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-6
578- make the docs with the just built abiword so that we don't have to
579  have abiword installed to build the docs (#107279)
580
581* Tue Oct 21 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-5
582- fix linkage to glib 1.2 in hancom plugin (#106033)
583
584* Sun Oct 19 2003 Florian La Roche <Florian.LaRoche@redhat.de>
585- add %%clean specfile target
586
587* Tue Oct 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-4
588- remove duplicate desktop file (#107023)
589
590* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-3
591- include the help
592- show the clipart (#104577)
593
594* Mon Sep 15 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-2
595- rebuild with newer libwpd and libots to get those plugins
596
597* Sun Sep 14 2003 Jeremy Katz <katzj@redhat.com> 1:2.0.0-1
598- 2.0.0
599
600* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.6-1
601- 1.99.6
602
603* Mon Aug 25 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.5-1
604- 1.99.5
605
606* Tue Aug  5 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.3-1
607- 1.99.3
608- put icon in the right place (#101646)
609- fix some 64bit casting issues
610- disable ots plugin for now, doesn't seem to build with ots 0.4.0 :/
611- disable -pedantic -ansi so that it will build
612
613* Mon Jul 14 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-2
614- ugly hack to deal with libtool silliness on x86_64
615
616* Fri Jul 11 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.2-1
617- 1.99.2
618- add buildrequires to make sure the ots and wp plugins get built
619- no longer needs libgal2, remove buildrequires
620
621* Mon Jun 16 2003 Jeremy Katz <katzj@redhat.com> 1:1.99.1-1
622- 1.99.1
623
624* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
625- rebuilt
626
627* Mon May 26 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-3
628- rebuild for new libgal2
629
630* Mon May 19 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-2
631- tweak plugins build
632
633* Mon May 12 2003 Jeremy Katz <katzj@redhat.com> 1:1.9.1-0.2
634- 1.9.1
635- drop old patches, switch to using autoconf based build system instead
636  of diving makefiles
637- build with gnome support
638- build with plugins
639- add patch to build on AMD64
640
641* Mon Apr 28 2003 Tim Powers <timp@redhat.com> 1:1.0.5-2
642- rebuild to fix broken libpspell dep
643
644* Mon Mar 24 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.5-1
645- 1.0.5
646
647* Mon Feb 10 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-2
648- fix for abiword starting off the screen (#82425)
649
650* Thu Jan 23 2003 Jeremy Katz <katzj@redhat.com> 1:1.0.4-1
651- 1.0.4
652
653* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
654- rebuilt
655
656* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-2
657- make it build on x86_64
658
659* Sun Dec 29 2002 Jeremy Katz <katzj@redhat.com> 1:1.0.3-1
660- 1.0.3 (#80560)
661- set umask before running mkfontdir in %%post
662- patch AbiWord script to convert utf8 locales into non-utf8 variants (#72633)
663
664* Mon Dec 02 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-7
665- Fix doc lines
666- Fix multilib
667
668* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 1.0.2-6
669- rebuilt with gcc-3.2 (we hope)
670
671* Sat Aug 10 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-5
672- fix help index symlink (#71219)
673
674* Thu Aug  1 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-4
675- add abiword binary symlink for upstream compatibility (#70267)
676
677* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.0.2-3
678- rebuild using gcc-3.2-0.1
679
680* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-2
681- use included desktop file (#64447)
682- use desktop-file-install
683
684* Wed Jun 26 2002 Jeremy Katz <katzj@redhat.com> 1.0.2-1
685- 1.0.2
686- disable perl module build since we weren't including it anyway
687
688* Wed May 29 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.1-1
689- 1.0.1
690
691* Sun Apr 14 2002 Jeremy Katz <katzj@redhat.com> 0.99.5-1
692- zh_CN and zh_TW fonts.dir were flipped
693- update to 0.99.5 as it fixes some major bugs
694- define ABI_BUILD_VERSION so the about screen gives us a version
695
696* Mon Apr  8 2002 Bennhard Rosenkraenzer <bero@redhat.com> 0.99.4-2
697- 1st try at fixing up CJK (#61590)
698- #if 0'ify font warning dialog (#62909, #64556)
699
700* Tue Apr  2 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.4-1
701- Update to 0.99.4, fixes #61153
702- Fix #61344
703- Nuke the warning about being unable to add anything to font path,
704  that's not how xfs works.
705
706* Thu Feb 28 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.2-1
707- 0.99.2
708- remove blank lines in fonts.dir
709
710* Thu Jan 31 2002 Bernhard Rosenkraenzer <bero@redhat.com> 0.99.1-1
711- 0.99.1
712
713* Wed Jan 30 2002 Alex Larsson <alexl@redhat.com> 0.9.5-3
714- Added patch to use libpng10
715- Added patch to fix perl build problems.
716
717* Fri Nov 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.5-1
718- 0.9.5
719
720* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.9.4.1-1
721- Update to 0.9.4.1 (RFE #54806)
722- Add URL (RFE #54590)
723
724* Thu Jul 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-7
725- Fix uninstall (#49350)
726
727* Sat Jul  7 2001 Tim Powers <timp@redhat.com>
728- rebuilt so that dirs aren't sgid root
729
730* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-5
731- Add build requirements (#45157)
732
733* Tue Jun 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-4
734- Remove CVS admin files from documentation (#44916)
735
736* Mon Jun 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
737- add s390x patch from <oliver.paukstadt@millenux.com>
738
739* Sat Jun 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
740- add s390 patch from Helge Deller
741
742* Tue May 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.7.14-1
743- Update to 0.7.14
744
745* Tue Feb 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
746- Handle MIME type stuff (Bug #27530)
747- Add BuildPrereqs for some of the less common stuff AbiWord uses
748  (gal-devel, gnome-print-devel, libunicode-devel)
749
750* Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
751- 0.7.13
752
753* Mon Jan 15 2001 Than Ngo <than@redhat.com>
754- fixed broken code for building
755
756* Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
757- 0.7.12
758- copy fonts.dir to fonts.scale so mkfontdir doesn't blow it away
759
760* Tue Dec 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
761- Rebuild to get rid of 0777 dirs
762
763* Fri Nov 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
764- 0.7.11
765
766* Sun Aug 20 2000 Preston Brown <pbrown@redhat.com>
767- fix path to chkfontpath, it was wrong.
768
769* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
770- Up Epoch and release
771
772* Mon Aug  7 2000 Jakub Jelinek <jakub@redhat.com>
773- Don't ship AbiWord_s if we have AbiWord_d
774- Register AbiWord's fontpath with xfs
775
776* Wed Aug  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
777- Rebuild with new libpng. This fixes Bug #13707 - gotta love it when they
778  change the ABI without increasing the soname!
779- fix tooltip (Bug #14711)
780- move binaries from /usr/share to /usr/lib
781
782* Wed Jul 12 2000 Jakub Jelinek <jakub@redhat.com>
783- Fix build on ia64.
784
785* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
786- automatic rebuild
787
788* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
789- Rebuild with new gcc.
790
791* Sun Jun 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
792- Fix build on ia64
793
794* Sat Jun 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
795- 0.7.10
796- update download location
797
798* Fri Jun  9 2000 Bernhard Rosenkraenzer <bero@redhat.com>
799- initial build for main CD
800- clean up specfile
801- fix build with gcc 2.96 and glibc 2.2
802- exclude ia64 for now
803
804* Wed May  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
805- 0.7.9
806
807* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
808- 0.7.8
809- move the desktop file to /etc/X11/applnk so it can be used in both
810  GNOME and KDE
811- fix up handling of RPM_OPT_FLAGS
812
813* Thu Jan 20 2000 Tim Powers <timp@redhat.com>
814- bzipped source to conserve space.
815
816* Sun Jan  9 2000 Matt Wilson <msw@redhat.com>
817- enable GNOME, remove perl hack to do RPM_OPT_FLAGS
818- added libpng requirement.  0.7.7 requires 1.0.5 libpng ABI
819
820* Tue Jan  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
821- 0.7.7
822- handle RPM_OPT_FLAGS
823
824* Mon Nov 15 1999 Tim Powers <timp@redhat.com>
825- first build for inclusion into Powertools.
826- some things in this spec file are from the abisuite-0.7.5-1mdk package
Note: See TracBrowser for help on using the repository browser.