source: projects/specs/trunk/a/aalib/aalib-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An ASCII art library.
2Summary(ja): ASCII アートライブラリ
3Name: aalib
4Version: 1.4
5Release: 0.rc5.4%{?_dist_release}
6Group: System Environment/Libraries
7License: LGPL
8URL: http://aa-project.sourceforge.net/aalib/
9Source: http://prdownloads.sourceforge.net/aa-project/%{name}-%{version}rc5.tar.gz
10Patch0: %{name}-aclocal.patch
11Patch1: %{name}-config-rpath.patch
12Patch2: aalib-1.4rc5-bug149361.patch
13Patch10: aalib-1.4.0-without-gpm.patch
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: slang-devel
17BuildRequires: libX11-devel
18BuildRequires: ncurses-devel
19
20%description
21AA-lib is a low level gfx library just as many other libraries are. The
22main difference is that AA-lib does not require graphics device. In
23fact, there is no graphical output possible. AA-lib replaces those
24old-fashioned output methods with a powerful ASCII art renderer. The API
25is designed to be similar to other graphics libraries.
26
27%description -l ja
28AA-lib は他のライブラリと同様な低レベルのグラフィックスライブラリです。
29AA-lib の一番の特徴はグラフィックデバイスを必要としない点です。実際の所、
30グラフィカルな出力先が無くても動作します。AA-lib はこれらの昔ながらの
31出力方法をパワフルな ACSCII アートレンダラで置き換えます。この API は
32その他のグラフィックライブラリと同じようにデザインされています。
33
34%package devel
35Summary: aalib development files
36Summary(ja): aalib 開発用のファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}
39Requires: libX11-devel
40Requires: slang-devel
41Requires: ncurses-devel
42Requires(post): /sbin/install-info
43Requires(preun): /sbin/install-info
44
45%description devel
46This package contains header files and other files needed to develop
47with aalib.
48
49%description devel -l ja
50このパッケージには aalib を使用して開発するために必要なヘッダファイルや
51その他のファイルが含まれています。
52
53
54%prep
55%setup -q -n %{name}-1.4.0
56
57%patch0 -p0
58%patch1 -p0
59%patch2 -p1 -b .bug149361
60%patch10 -p1 -b .without-gpm
61
62%build
63autoreconf -fi
64%configure --with-x \
65  --with-curses-driver=yes --with-ncurses \
66  --with-gpm-mouse=no
67make LIBTOOL=/usr/bin/libtool
68
69%install
70rm -rf $RPM_BUILD_ROOT
71%makeinstall LIBTOOL=/usr/bin/libtool
72rm -f $RPM_BUILD_ROOT/%{_infodir}/dir || :
73rm -f $RPM_BUILD_ROOT/%{_libdir}/libaa.{a,la} || :
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post -p /sbin/ldconfig
79
80%postun -p /sbin/ldconfig
81
82%post devel
83if [ -e %{_infodir}/libaa.info.gz ]; then
84        /sbin/install-info %{_infodir}/libaa.info.gz %{_infodir}/dir
85fi
86
87%preun devel
88if [ -e %{_infodir}/libaa.info.gz ]; then
89        /sbin/install-info --delete %{_infodir}/libaa.info.gz %{_infodir}/dir
90fi
91
92%files
93%defattr(-, root, root)
94%doc ANNOUNCE AUTHORS COPYING ChangeLog NEWS
95%{_bindir}/aafire
96%{_bindir}/aainfo
97%{_bindir}/aasavefont
98%{_bindir}/aatest
99%{_libdir}/*.so.*
100%{_mandir}/man1/*
101
102%files devel
103%defattr(-, root, root)
104%{_bindir}/aalib-config
105%{_libdir}/*.so
106%{_includedir}/*.h
107%{_datadir}/aclocal/*.m4
108%{_infodir}/aalib.info*
109%{_mandir}/man3/*
110
111%changelog
112* Wed May 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0.rc5.4
113- remove static library
114- build without gpm
115  - add BuildConflicts: gpm-libs
116
117* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0.rc5.3
118- spec in utf-8
119
120* Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4-0.rc5.2
121- rebuilt with slang 2.1.3, xorg-x11 7.3
122- updated dependancies
123
124* Sun Apr 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4-0.rc5.1
125- rebuild with new toolchain.
126- apply new versioning policy.
127
128* Mon Jun 18 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4-0.rc5vl3
129- rebuild with new toolchain.
130- add japanese summary and description.
131- delete libtool library (.la) files. <BTS:VineLinux:506>
132
133* Sat Sep 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4-0.rc5vl2
134- add BuildRequires: ncurses-devel
135- add Requires: ncurses-devel (devel package)
136
137* Thu Sep 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4-0.rc5vl1
138- new upstream release
139- added Patch0,1,2 from Fedora
140  * Fri Jul  1 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
141  - fix missing return value (#149361)
142  * Fri Jul 16 2004 Ville Skytt辰 <ville.skytta at iki.fi>
143  - Fix underquoted definition in aalib.m4 to appease aclocal >= 1.8.
144  - Avoid rpath in aalib-config.
145
146* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl0.rc4
147- initial build
148
Note: See TracBrowser for help on using the repository browser.