source: projects/specs/trunk/Z/Zope2/Zope2-vl.spec @ 5701

Revision 5701, 24.0 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1# if you want to checkout new modules, add "--define '_co 1'" to rpm option
2%define checkout_new_modules %{?_co:1}%{!?_co:0}
3%define zope2_version 2.12.3
4%define zope2_updates 20101124
5
6%define name Zope2
7%define zope2_libdir %{_libdir}/%{name}
8%define zope2_confdir %{_sysconfdir}/%{name}
9%define instance_home %{_var}/lib/%{name}
10%define sv_http_port 8280
11%define sv_ftp_port 8221
12%define sv_admin admin
13%define sv_password 123
14Summary: An application server and portal toolkit for building Web sites.
15Summary(ja): アプリケーションサーバおよびウェブサイト構築ツールキット
16Name: %{name}
17Version: %{zope2_version}
18Release: 2%{?_dist_release}
19License: ZPL (Zope Public License) 2.1
20URL: http://www.zope.org/
21Group: Development/Web Applications
22Source0: http://pypi.python.org/packages/source/Z/%{name}/%{name}-%{version}.tar.gz
23Source1: init.sh
24Source10: stable-req.txt
25Source11: Zope2-modules.%{zope2_updates}.tgz
26Buildrequires: python-devel >= 2.6.4
27Buildrequires: python-setuptools >= 0.6c11
28BuildRequires: python-virtualenv
29BuildRequires: chkconfig
30Requires: shadow-utils
31Requires: python >= 2.6.4
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33Packager: owa
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38The Z Object Programming Environment (Zope) is a free, Open Source[tm]
39Python-based application server for building high-performance, dynamic
40web sites, using a powerful and simple scripting object model and
41high-performance, integrated object database.
42
43For a fully functional installation of Zope, install this single huge
44package and then the Zope-zserver RPM
45
46%description -l ja
47Zオブジェクトプログラミング環境(Zope)はフリーです,オープンソースである
48Pythonをベースにした、高性能で動的なWebサイトを構築するためのアプリケー
49ションサーバです.強力でしかも単純なスクリプトからなるオブジェクトモデル
50と高性能な統合オブジェクトデータベースを使うことができます.
51
52
53%package zserver
54Summary: Initial Object Database/Standalone HTTP Server
55Summary(ja): %{name} インスタンス
56Group: Development/Web Applications
57Requires: %{name}
58Requires: /etc/rc.d/init.d
59
60%description zserver
61The %{name}-zserver package contains the files needed for setting up a
62Zope website, including an empty object database. Zope is an application
63server and portal toolkit.
64
65Also included is the ZServer, which is a small, standalone web server
66written in Python.  The ZServer uses the very fast Medusa technology
67and is multithreaded.  This package comes preconfigured to serve
68web pages on port %{sv_http_port} and ftp access on %{sv_ftp_port}.  The programmer's port
69interface comes disabled for security reasons but can be reenabled.
70
71%description -l ja zserver
72%{name}-zserver パッケージは Zope web サイトをセットアップするのに必要な
73ファイルを含んでいます,そこには空のオブジェクトデータベースも含みます.
74Zope はアプリケーションサーバであり,Webサイト構築のためのツール集です.
75
76また Python で書かれた小さなスタンドアロン Web サーバである ZServer も
77含まれています. ZServer は非常に高速な Medusa の技術を利用し,マルチス
78レッド化されています.このパッケージでは Web ページを %{sv_http_port} ポート, FTP
79アクセスを %{sv_ftp_port} でサービスするようにあらかじめ設定してあります.セキュ
80リティ上の理由のため,プログラマ用ポートインタフェースは使用できないよ
81うになっていますが,再び利用できるように戻すことが可能です.
82
83初期ユーザは "%{sv_admin}" パスワードは "%{sv_password}" に設定されています。
84初回の起動直後にこれらは変更すべきです。
85
86
87%prep
88%setup -T -c %{name}-%{version}
89(cd $RPM_BUILD_DIR; virtualenv --no-site-packages --unzip-setuptools %{name}-%{version})
90
91## for normal build: include stable-req.txt and Zope2-modules.%{zope2_updates}.tgz
92%if %{checkout_new_modules} == 0
93cp %{SOURCE10} .
94tar xvzf %{SOURCE11} > /dev/null
95tar xvzf %{SOURCE0} -C build > /dev/null
96mv build/%{name}-%{version} build/%{name}
97%endif
98
99
100%build
101source bin/activate
102export PIP_REQUIRE_VIRTUALENV=true
103
104## normal build: don't allow downloads
105%if %{checkout_new_modules} == 0
106bin/pip install --no-download --log=pip_install.log -r stable-req.txt
107
108## upgrade build: upgrade all packages to the newest available version
109%else
110cp %{SOURCE0} .
111bin/pip install %{name}-%{version}.tar.gz
112bin/easy_install %{name}-%{version}.tar.gz Zope2
113bin/pip freeze > stable-req.txt
114bin/pip install -I --no-install --log=pip_download.log -r stable-req.txt
115savedate=`date '+%Y%m%d'`
116tar cvzf Zope2-modules.$savedate.tgz build
117%endif
118
119
120%install
121rm -rf $RPM_BUILD_ROOT
122%{__install} -d $RPM_BUILD_ROOT%{zope2_libdir}
123%{__install} -d $RPM_BUILD_ROOT%{zope2_libdir}/bin
124%{__install} -m 755 bin/* $RPM_BUILD_ROOT%{zope2_libdir}/bin
125cp -a lib $RPM_BUILD_ROOT%{zope2_libdir}
126(cd $RPM_BUILD_ROOT%{zope2_libdir}; ln -s ./lib lib64)
127
128## make zope server instance
129bin/mkzopeinstance -d $RPM_BUILD_ROOT%{instance_home} -u %{sv_admin}:%{sv_password}
130## make zeo server instance (failed now: fix me!)
131#bin/mkzeoinstance $RPM_BUILD_ROOT%{instance_home}
132
133## put init script
134install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
135install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
136
137## put system config, logs
138install -d $RPM_BUILD_ROOT%{zope2_confdir}
139(cd $RPM_BUILD_ROOT%{zope2_confdir}; ln -sf %{instance_home}/etc/site.zcml)
140(cd $RPM_BUILD_ROOT%{zope2_confdir}; ln -sf %{instance_home}/etc/zope.conf)
141install -d $RPM_BUILD_ROOT%{_var}/log
142(cd $RPM_BUILD_ROOT%{_var}/log; ln -sf %{instance_home}/log %{name})
143
144## remove unused files
145find $RPM_BUILD_ROOT/ -name "*.pyc" | xargs rm
146
147## change python paths
148pushd $RPM_BUILD_ROOT%{zope2_libdir}/bin
149for s in `ls` ; do
150        if ! file -s -e elf $s | grep -s ELF ; then
151                sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" $s
152        fi
153done
154popd
155pushd $RPM_BUILD_ROOT%{zope2_libdir}/lib
156        find ./ -name "*.py" | xargs sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|"
157popd
158pushd $RPM_BUILD_ROOT%{instance_home}/bin
159        sed -i "s|$RPM_BUILD_ROOT||" runzope
160        sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" runzope
161        sed -i "s|$RPM_BUILD_ROOT||" zopectl
162        sed -i "s|$RPM_BUILD_DIR/%{name}-%{version}|%{zope2_libdir}|" zopectl
163popd
164
165## update zope.conf
166pushd $RPM_BUILD_ROOT%{instance_home}/etc
167cp -p zope.conf zope.conf.orig
168sed "s|$RPM_BUILD_ROOT||" zope.conf.orig \
169        | sed 's|^#.*effective-user chrism.*$|effective-user %{name}|' \
170        | sed 's|^#.*rest-input-encoding iso-8859-15.*$|rest-input-encoding utf-8|' \
171        | sed 's|^#.*rest-output-encoding iso-8859-15.*$|rest-output-encoding utf-8|' \
172        | sed 's|address 8080|address %{sv_http_port}|' \
173        | sed 's|address 8021|address %{sv_ftp_port}|' \
174        > zope.conf
175        rm -f zope.conf.orig
176popd
177
178
179%clean
180rm -rf $RPM_BUILD_ROOT
181
182
183%pre zserver
184if [ "$1" = 1 ] ; then
185        %{__grep} "%{name}:" /etc/group > /dev/null 2>&1
186        if [ $? == 0 ]; then
187                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} -g %{name} \
188                        %{name} > /dev/null 2>&1 || :
189        else
190                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} \
191                        %{name} > /dev/null 2>&1 || :
192        fi
193fi
194
195%post zserver
196if [ "$1" = 1 ] ; then
197        /sbin/chkconfig --add %{name}
198        /etc/rc.d/init.d/%{name} start
199else
200        mv %{instance_home}/inituser %{instance_home}/inituser.admin
201        /etc/rc.d/init.d/%{name} condrestart
202fi
203
204%preun zserver
205if [ "$1" = 0 ] ; then
206        /etc/rc.d/init.d/%{name} stop > /dev/null 2>&1
207        /sbin/chkconfig --del %{name}
208fi
209
210%postun zserver
211if [ "$1" = 0 ] ; then
212  /usr/sbin/userdel %{name} > /dev/null 2>&1 || :
213fi
214
215
216%files
217%defattr(-, root, root)
218%dir %{zope2_libdir}
219%{zope2_libdir}/bin
220%{zope2_libdir}/lib
221%{zope2_libdir}/lib64
222
223%files zserver
224%defattr(-, root, root)
225%config %{_sysconfdir}/rc.d/init.d/%{name}
226%config %{zope2_confdir}/site.zcml
227%config %{zope2_confdir}/zope.conf
228%{_var}/log/%{name}
229
230%defattr(700, %{name}, %{name})
231%dir %{instance_home}
232%dir %{instance_home}/Extensions
233%dir %{instance_home}/Products
234%dir %{instance_home}/bin
235%dir %{instance_home}/etc
236%dir %{instance_home}/import
237%dir %{instance_home}/lib
238%dir %{instance_home}/lib/python
239%dir %{instance_home}/log
240%defattr(1703, %{name}, %{name})
241%dir %{instance_home}/var
242
243%attr(600, %{name}, %{name})
244%{instance_home}/inituser
245
246%defattr(-, %{name}, %{name})
247%{instance_home}/Products/__init__.py
248%{instance_home}/bin/runzope
249%{instance_home}/bin/zopectl
250%{instance_home}/import/ZopeTutorialExamples.zexp
251%config %{instance_home}/etc/site.zcml
252%config %{instance_home}/etc/zope.conf
253#%{instance_home}/bin/runzeo
254#%{instance_home}/bin/zeoctl
255#%config %{instance_home}/etc/zeo.conf
256
257%exclude %{instance_home}/README.txt
258%exclude %{instance_home}/*/README.txt
259%exclude %{instance_home}/lib/python/README.txt
260%exclude %{instance_home}/bin/runzope.bat
261%exclude %{instance_home}/bin/zopectl.bat
262
263
264%changelog
265* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> Zope2-2.12.3-2
266- rebuild with python-2.7.2
267
268* Sun Dec 05 2010 Shu KONNO <owa@bg.wakwak.com> Zope2-2.12.3-1
269- updated zope to 2.12.3
270- changed package name to Zope2
271- use virtualenv and easy_install to build
272- added checkout_new_modules macro (0:no-download, 1:download new modules)
273- added stable-req.txt
274- added Zope2-modules.20101124.tgz
275
276* Thu Sep  02 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.7-1
277- updated zope to 2.11.7-final
278
279* Thu Jan 14 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.6-1
280- updated zope to 2.11.6-final
281
282* Thu Dec 24 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.5-1
283- updated zope to 2.11.5-final
284
285* Thu Aug 06 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.4-1
286- updated zope to 2.11.4-final
287
288* Sun May 03 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.3-1vl5
289- updated zope to 2.11.3-final
290
291* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.2-1vl5
292- updated zope to 2.11.2-final
293- dropt Hotfix_20080812.tar.gz
294
295* Wed Aug 13 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-3vl5
296- added Hotfix_20080812.tar.gz
297
298* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-2vl5
299- rebuilt with python-2.5.2
300
301* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-1vl5
302- updated zope to 2.11.1-final
303
304* Tue Jul 01 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.0-1vl5
305- updated zope to 2.11.0-final
306
307* Mon Jun 09 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.6-1vl5
308- applied new versioning policy and spec in utf-8
309- updated zope to 2.10.6-final
310
311* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl2
312- fixed prereq, buildrequires pkgs
313
314* Tue Oct 30 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl1
315- updated zope to 2.10.5-final
316- updated Requires python >= 2.4.4
317
318* Thu Aug 23 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.4-0vl1
319- updated zope to 2.10.4-final
320- updated %%install scripts
321- dropped Hotfix_20070320.tgz
322
323* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.2-0vl1
324- updated zope to 2.10.2
325- added Hotfix_20070320.tgz
326
327* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl3
328- added japanese summary
329
330* Fri Oct 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl2
331- updated zope to 2.9.5-final
332
333* Thu Jul 20 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.4-0vl1
334- updated zope to 2.9.4
335- dropped Hotfix_20060705.tar.gz
336
337* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl2
338- added Hotfix_20060705.tar.gz
339
340* Fri May 12 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl1
341- updated zope to 2.9.3
342
343* Tue Mar 28 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.2-0vl1
344- updated zope to 2.9.2
345
346* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.1-0vl1
347- updated zope to 2.9.1
348- x86_64 architecture support
349
350* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.0-0vl1
351- updated zope to 2.9.0
352
353* Thu Oct 27 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.4-0vl1
354- updated zope to 2.8.4-final
355
356* Wed Oct 19 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.3-0vl1
357- updated zope to 2.8.3-final
358
359* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.2-0vl1
360- updated zope to 2.8.2-final
361
362* Mon Oct 10 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl2
363- added Hotfix_2005-10-09.tar.gz (security)
364
365* Thu Aug 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl1
366- updated zope to 2.8.1-final
367
368* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.0-0vl1
369- updated zope to 2.8.0-final
370
371* Sun May 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl2
372- updated init.sh (added condrestart)
373- updated spec 'post zserver section'
374
375* Fri Apr 29 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl1
376- updated zope to 2.7.6-final
377
378* Wed Apr 06 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl4
379- added Hotfix_20050405.tar.gz
380
381* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl2
382- rebuilded with python 2.4.1
383
384* Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl1
385- updated zope to 2.7.5-final
386
387* Fri Mar 18 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl0.c1
388- updated zope to 2.7.5-rc1
389
390* Sat Jan 15 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl2
391- updated zope to 2.7.4-0
392
393* Sat Jan 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.c2
394- updated zope to 2.7.4-RC2
395
396* Thu Dec 16 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.b2
397- updated zope to 2.7.4-b2
398
399* Sun Oct 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl1
400- updated zope to 2.7.3
401
402* Mon Oct 11 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.2
403- updated zope to 2.7.3b2
404
405* Sun Sep 26 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.1
406- updated zope to 2.7.3b1
407- droped Hotfix-20040807.tar.gz
408
409* Tue Aug 10 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl2
410- added Hotfix-20040807.tar.gz
411
412* Wed Jul 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl1
413- updated zope to 2.7.2
414
415* Thu Jul 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl3
416- droped Hotfix_2004-07-13.tar.gz
417- added Hotfix_2004-07-14.tar.gz
418
419* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl2
420- added Hotfix_2004-07-13.tar.gz
421
422* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl1
423- updated zope to 2.7.1
424- added option with '--no-compile' to configure at the %build section
425- added to compile at the %post section
426
427* Sat Apr 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.0-0vl1
428- build with python-2.3.3-0vl1
429- added 'Obsoletes: Zope27'
430
431* Tue Mar 02 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl3
432- changed init.sh to use zopectl
433
434* Tue Feb 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl1
435- updated zope to 2.7.0
436- rewrited spec file
437
438* Sun Feb 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.4-0vl1
439- updated zope to 2.6.4
440
441* Fri Jan  9 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.3-0vl1
442- updated zope to 2.6.3
443
444* Wed Sep 10 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2-0vl1
445- updated zope to 2.6.2
446
447* Fri Aug 29 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b6-0vl1
448- updated zope to 2.6.2b6
449
450* Thu Jul 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl2
451- rebuild with python-2.2.3
452
453* Wed Jul 30 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl1
454- updated zope to 2.6.2b5
455
456* Sat Jul 19 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b4-0vl1
457- updated zope to 2.6.2b4
458
459* Sat Jul 12 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b3-0vl1
460- updated zope to 2.6.2b3
461
462* Sat May 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b2-0vl1
463- updated zope to 2.6.2b2
464- fixed many important bugs
465
466* Sun Apr 13 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1-0vl1
467- updated zope to 2.6.1
468- changed 'Requires: python >= 2.2.2'
469- japanese patch below has been included in zope 2.6.1
470
471* Thu Jan 16 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1b1-0vp1
472- updated zope to 2.6.1b1
473- added Zope261b.patch (by fukamachi, nakagami, tahara)
474- changed option parameter with -Z in startup script
475- added command 'umask 077' in startup script
476- added option -D in startup script that logout debug infomation
477- added 'chown root', 'chmod o+t' script in %%post section
478- this is a experimental release!!
479
480* Fri Oct 4 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl3
481  Security fix for XML-RPC handling (by tahara)
482
483* Fri Jun 21 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl2
484  added Hotfix_2002-06-14.tgz
485
486* Sat Jun 15 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl1
487  modified for Vine
488
489* Sat May 18 2002 Adam Manock <abmanock@earthlink.net>
490  Completely reworked the spec for Zope 2.5.1
491  PCGI is no longer built by default.
492  Build now simply wraps up the default "wo_pcgi" build, creating 2 packages.
493  (This will make it trivial to upgrade the spec for new Zope versions.)
494  Logging via syslog is now turned off by default. See the RPM-README
495
496* Wed Nov 14 2001 Jeff Rush <jrush@taupro.com>
497  bumped to zope 2.4.3.
498
499* Sat Nov 10 2001 Jeff Rush <jrush@taupro.com>
500  changed args to useradd, to work with Red Hat 7.2.
501
502* Sun Oct 21 2001 Jeff Rush <jrush@taupro.com>
503  bumped to zope 2.4.2, removed Hotfix 2001-09-28.
504
505* Thu Oct 18 2001 Jeff Rush <jrush@taupro.com>
506  Fixed broken syslogging facility and added Hotfix 2001-09-28.
507
508* Mon Sep 04 2001 Jeff Rush <jrush@taupro.com>
509  bumped to zope 2.4.1, removed Hotfix 2001-08-04.
510
511* Mon Aug 15 2001 Jeff Rush <jrush@taupro.com>
512  bumped to zope 2.4.0, changed to use python2.1, added Hotfix 2001-08-04.
513
514  Merged in Jun 29 2001 patch from Durval Menezes re support for ZPatterns:
515  "No longer removes cPersistence.h from lib/python/ZODB before installing
516  (this is needed to compile DynPersist, as part of the ZPatterns
517  installation.  Installs ExtensionClass.h into /usr/include/python2.1
518  (it too is needed to compile DynPersist, as part of the ZPatterns install)"
519
520  Merged in Jun 12 2001 additions from Jared Kelsey <jared@dolphinsearch.com>
521  to make more compatible with future releases of python.
522
523* Mon Aug 14 2001 Jeff Rush <jrush@taupro.com>
524  bumped to zope 2.3.3, added Hotfix 2001-08-04.
525
526* Mon May 07 2001 Jeff Rush <jrush@taupro.com>
527  bumped to zope 2.3.2, added Hotfix 2001-05-01, revised access
528  file permissions (600->640) and ownership (root.root->root.zope)
529  to fix the "can't log in" bug under ZServer subpackage.
530
531* Sat Mar 31 2001 Jeff Rush <jrush@taupro.com>
532  bumped to zope 2.3.1
533
534* Mon Jan 29 2001 Jeff Rush <jrush@taupro.com>
535  bumped to zope 2.3.0; removed obsolete Hotfixes.
536
537* Fri Dec 08 2000 Jeff Rush <jrush@taupro.com>
538  bumped to zope 2.2.4; removed obsolete Hotfixes.
539
540* Fri Nov 03 2000 Jeff Rush <jrush@taupro.com>
541  fixed misplaced SiteAccess, where dirs in tar moved btw v1 and v2.
542
543* Sun Oct 16 2000 Jeff Rush <jrush@taupro.com>
544  bumped to zope 2.2.2; added Hotfixes  2000-10-02 and 2000-10-11.
545
546* Sun Aug 27 2000 Jeff Rush <jrush@taupro.com>
547  bumped to zope 2.2.1; removed no-longer-needed Hotfix_2000-08-17
548
549* Tue Aug 22 2000 Jeff Rush <jrush@taupro.com>
550- added Hotfix_2000-08-17
551- temporarily removed /etc/init.d (RH7.0) until I figure out how
552  to support both RH6.x *and* RH7.0 in the same RPM. <sigh>
553- removed troublesome/obsolete ComputedAttribute.py
554
555* Sun Jul 16 2000 Jeff Rush <jrush@taupro.com>
556- bumped to zope 2.2.0; removed no-longer-needed Hotfix-06_16_2000
557
558* Thu Jul 06 2000 Tim Powers <timp@redhat.com>
559- fixed PreReq to PreReq /etc/init.d
560- added Hotfix-06_16_2000
561 
562* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
563- moved init script, added condrestart directive
564- auto stop/restart service on upgrades
565
566* Thu Jun 1 2000 Tim Powers <timp@redhat.com>
567- fixed so that it's no longer putting files into /home, instead they are
568  going into /var/www (FHS compliant).
569
570* Mon May 22 2000 Tim Powers <timp@redhat.com>
571- built for 7.0, thanks Jeff!
572
573* Fri Apr 28 2000 Jeff Rush <jrush@taupro.com>
574- bumped to zope 2.1.6
575
576* Sun Mar 12 2000 Jeff Rush <jrush@taupro.com>
577- added zpasswd.py back in, since my rename to just zpasswd confused some.
578  both are now present in the RPM, for all audiences.
579- modified the README.RPM re the section about Apache rewrite rules; I
580  discussed and removed the trailing slash, the presence of which causes
581  Zope to reject attempts to delete objects in the root folder.
582
583* Thu Feb 26 2000 Jeff Rush <jrush@taupro.com>
584- 2.1.4-1 Release on Zope.org site
585- bumped to zope 2.1.4
586- changed Zope-core to provide 'Zope', to satisfy zserver and pcgi subpkgs.
587
588* Fri Jan 14 2000 Tim Powers <timp@redhat.com>
589- added Provides lines to Zope-pcgi and Zope-zserver so that addon packages
590        such as Squishdot have something useful to require.
591
592* Thu Jan 13 2000 Tim Powers <timp@redhat.com>
593- built for Powertools 6.2
594
595* Thu Jan 11 2000 Jeff Rush <jrush@taupro.com>
596- bumped to zope 2.1.2
597- folded in Jonathan Marsden <jonathan@xc.org> Changes (many below)
598- used zpasswd.py to generate initial pw in encrypted form.
599- fixed syslog logging in various ways, and re-enabled it, for both
600-    ZServer AND pcgi-wrapper.
601- fixed /etc/rc.d/init.d/zope to be consistent about pid file.
602- fixed /etc/rc.d/init.d/zope to use RH killproc function.
603- added 'noreplace' so that Zope database and access file are retained
604-    on an RPM upgrade.
605- patched PCGI to support syslog logging, and then default to it.
606- patched ZServer/Medusa to properly support syslog logging.
607- added a user 'zope' and made many zope files/dirs owned by it.
608- cleaned up pcgi-wrapper's msg about can't find ZServer, since it is
609-    one of the most common errors.  It now explains what it is doing.
610- moved all *.{pid,soc} files into /var/run, to cleanly separate ownership
611-    issues in /var/zope hierarchy for user 'zope' and user 'nobody'.
612
613* Mon Jan 03 2000 Jeff Rush <jrush@taupro.com>
614- bumped to zope 2.1.1
615- added to /etc/rc.d/init.d/zope code to correctly kill the process specified
616-    in /var/zope/pcgi.pid
617- changed permissions on /var/zope/access such that only root can read/write
618-    it, to protect the Zope superuser password.
619
620* Sat Nov 29 1999 Jeff Rush <jrush@taupro.com>
621- changed ownership on /var/zope/access from nobody.nobody to root.root.
622
623* Sat Nov 20 1999 Jeff Rush <jrush@taupro.com>
624- updated to zope 2.1.0beta2
625- fixed permissions/ownership on /var/zope/access to be more secure (600).
626- removed pypath.patch, as those changes got into the zope distribution.
627
628* Tue Nov 2 1999 Jeff Rush <jrush@taupro.com>
629- added accidentally omitted /usr/bin/zpasswd to the RPM output.
630- clarified wording re use of zpasswd in README.RPM file.
631- added "-u nobody" to both zserver_*.sh files, for clarity of intent;
632-    it already ran as nobody by default, but some people worried.
633
634* Wed Oct 27 1999 Jeff Rush <jrush@taupro.com>
635- fixed /etc/rc.d/init.d/zope file to *NOT* delete /var/zope/zserver.pid
636- fixed /var/zope/Zope.cgi to use PCGI_PUBLISHER=/var/zope/pcgi_nullpublisher.py,
637-    so that when the PCGI wrapper can't find ZServer, it won't try to start one
638-    and generate bogus error messages, because PCGI doesn't do it right.
639- fixed /var/zope/zserver.sh to NOT specify syslog-style logging, since under
640-    Red Hat 6.1, the syslog daemon no longer listens to the port we expected.
641
642* Sat Sep 25 1999 Jeff Rush <jrush@taupro.com>
643- updated documents ZCMG, ZSQL and ZDTML to Sep 24th 1999 versions
644- added empty directories /var/zope/{import,Extensions}
645- relocated zope from /usr/lib/python1.5/site-packages/ZopeWorld/
646-    to /usr/share/zope/
647- added user zope, for better security control
648
649* Fri Sep 17 1999 Jeff Rush <jrush@taupro.com>
650- updated sources to minor (security fix) release 2.0.1
651
652* Fri Sep 10 1999 Jeff Rush <jrush@taupro.com>
653- heavily reworked spec file for 2.0.0
654
655* Thu Sep 9 1999 Tim Powers <timp@redhat.com>
656- updated sources to 2.0.0
657- _major_ spec file cleanups
658- merged patch from src.rpm authored by Andreas Kostyrka <andreas@mtg.co.at>
659- borrowed some things from Andreas Kostyrka's spec file
660
661* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
662- changed groups
663
664* Tue Aug 17 1999 Tim Powers <timp@redhat.com>
665- chown permissions on some files in /var/local for the pcgi package
666
667* Mon Aug 2 1999 Tim Powers <timp@redhat.com>
668- changed buildroot to be in /var/tmp instead of /tmp
669- rebuilt for 6.1
670
671* Mon Jul 21 1999 Jeff Rush <jrush@taupro.com>
672- Added in accidently omitted SearchIndex/{Query,Splitter}.so
673
674* Tue Jul 6 1999 Tim Powers <timp@redhat.com>
675- started changelog
676- cleaned up spec file
677- built for powertools
678
679* Mon Jun 24 1999 Jeff Rush <jrush@taupro.com>
680- Updated to 1.10.3
681
682* Mon Jun 23 1999 Jeff Rush <jrush@taupro.com>
683- Added /etc/rc.d/init.d/zope and reworked scripts
684
685* Tue Mar 1 1999 Jeff Rush <jrush@taupro.com>
686- Updated to 1.10.2
687
688* Wed Jan 29 1999 Jeff Rush <jrush@taupro.com>
689- Updated to 1.9.0 Final Release
690
691* Wed Dec 9 1998 Jeff Rush <jrush@taupro.com>
692- Original 1.9beta1 Release
Note: See TracBrowser for help on using the repository browser.