source: projects/specs/trunk/Z/Zope/Zope-vl.spec @ 521

Revision 521, 23.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#%define _pyver %(python -c 'import sys;print(sys.version[0:3])')
2#%define _python %{_bindir}/python
3%define _pyver 2.4
4%define _python %{_bindir}/python%{_pyver}
5
6%define zope_user zope
7%define zope_home %{_libdir}/%{zope_user}
8%define zope_conf %{_sysconfdir}/%{zope_user}
9%define software_home %{zope_home}/lib/python
10%define instance_home %{_var}/lib/%{zope_user}
11
12%define _http_port 8080
13%define _ftp_port 8021
14%define _admin admin
15%define _password 123
16#%define _hotfix Hotfix_20080812
17%define _hotfix 0
18
19Summary:  An application server and portal toolkit for building Web sites.
20Summary(ja):  アプリケーションサーバおよびウェブサイト構築ツールキット
21Name: Zope
22Version: 2.11.6
23Release: 1%{?_dist_release}
24License: ZPL (Zope Public License) 2.1
25URL: http://www.zope.org/
26Group: Development/Web Applications
27
28Source0: http://www.zope.org/Products/Zope/%{version}/Zope-%{version}-final.tgz
29Source1: init.sh
30%if %{_hotfix}
31Source2: %{_hotfix}.tar.gz
32%endif
33Prereq: /sbin/chkconfig /usr/sbin/useradd
34#Buildrequires: python-devel
35#Requires: python >= 2.4.4
36Buildrequires: python24-devel
37Requires: python24
38
39Vendor: Project Vine
40Distribution: Vine Linux
41#Packager: Shu KONNO <owa@bg.wakwak.com>
42Packager: <owa>
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44
45%description
46The Z Object Programming Environment (Zope) is a free, Open Source[tm]
47Python-based application server for building high-performance, dynamic
48web sites, using a powerful and simple scripting object model and
49high-performance, integrated object database.
50
51For a fully functional installation of Zope, install this single huge
52package and then the Zope-zserver RPM
53
54%description -l ja
55Zオブジェクトプログラミング環境(Zope)はフリーです,オープンソースである
56Pythonをベースにした、高性能で動的なWebサイトを構築するためのアプリケー
57ションサーバです.強力でしかも単純なスクリプトからなるオブジェクトモデル
58と高性能な統合オブジェクトデータベースを使うことができます.
59
60Zope の全機能をインストールするには,この一個の大きなパッケージをインスト
61ールし, 次に Zope-zserver RPM をインストールします.
62
63##
64## Zope-zserver
65##
66%package zserver
67Summary: Initial Object Database/Standalone HTTP Server
68Summary(ja): Zope インスタンス
69Group: Development/Web Applications
70Requires: Zope
71Prereq: /etc/rc.d/init.d
72
73%description zserver
74The Zope-zserver package contains the files needed for setting up a
75Zope website, including an empty object database. Zope is an application
76server and portal toolkit.
77
78Also included is the ZServer, which is a small, standalone web server
79written in Python.  The ZServer uses the very fast Medusa technology
80and is multithreaded.  This package comes preconfigured to serve
81web pages on port %{_http_port} and ftp access on %{_ftp_port}.  The programmer's port
82interface comes disabled for security reasons but can be reenabled.
83
84%description -l ja zserver
85Zope-zserver パッケージは Zope web サイトをセットアップするのに必要な
86ファイルを含んでいます,そこには空のオブジェクトデータベースも含みます.
87Zope はアプリケーションサーバであり,Webサイト構築のためのツール集です.
88
89また Python で書かれた小さなスタンドアロン Web サーバである ZServer も
90含まれています. ZServer は非常に高速な Medusa の技術を利用し,マルチス
91レッド化されています.このパッケージでは Web ページを %{_http_port} ポート, FTP
92アクセスを %{_ftp_port} でサービスするようにあらかじめ設定してあります.セキュ
93リティ上の理由のため,プログラマ用ポートインタフェースは使用できないよ
94うになっていますが,再び利用できるように戻すことが可能です.
95
96初期ユーザは "%{_admin}" パスワードは "%{_password}" に設定されています。
97初回の起動直後にこれらは変更すべきです。
98
99
100%prep
101%setup -q -n Zope-%{version}-final
102
103%if %{_hotfix}
104%{__tar} -xzf %{SOURCE2}
105%endif
106
107
108%build
109rm -rf $RPM_BUILD_ROOT
110./configure \
111        --with-python=%{_python} \
112        --prefix="$RPM_BUILD_ROOT%{zope_home}"
113
114make %{?_smp_mflags}
115
116
117%install
118rm -rf $RPM_BUILD_ROOT
119make install
120
121
122$RPM_BUILD_ROOT%{zope_home}/bin/mkzopeinstance.py \
123        --dir $RPM_BUILD_ROOT%{instance_home} \
124        --user %{_admin}:%{_password}
125
126install -d $RPM_BUILD_ROOT%{zope_conf}
127( cd $RPM_BUILD_ROOT%{instance_home}%{_sysconfdir}
128        sed "s|$RPM_BUILD_ROOT||" zope.conf \
129        | sed 's|^#.*effective-user chrism$|effective-user %{zope_user}|' \
130        | sed 's|\$INSTANCE/log|/var/log/%{zope_user}|' \
131        > $RPM_BUILD_ROOT%{zope_conf}/%{zope_user}.conf
132        install -m 644 site.zcml $RPM_BUILD_ROOT%{zope_conf}/
133)
134install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
135install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{zope_user}
136install -d $RPM_BUILD_ROOT/var/log/%{zope_user}
137
138( cd $RPM_BUILD_ROOT%{instance_home}/bin
139        mv runzope runzope.old
140        sed "s|$RPM_BUILD_ROOT||" runzope.old | \
141        sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > runzope
142        rm -f runzope.old
143)
144( cd $RPM_BUILD_ROOT%{instance_home}/bin
145        mv zopectl zopectl.old
146        sed "s|$RPM_BUILD_ROOT||" zopectl.old | \
147        sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > zopectl
148        rm -f zopectl.old
149)
150
151%if %{_hotfix}
152install -d $RPM_BUILD_ROOT%{instance_home}/Products/%{_hotfix}
153#install -m644 %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
154cp -a %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
155%endif
156
157## remove unused files
158rm -f $RPM_BUILD_ROOT%{instance_home}/bin/zopectl.bat
159
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164
165%post
166# byte-compile installed Python files
167pushd "%{zope_home}" > /dev/null 2>&1
168%{_python} "%{zope_home}/bin/compilezpy.py" > /dev/null 2>&1 || :
169popd > /dev/null 2>&1
170
171%pre zserver
172if [ "$1" = 1 ] ; then
173        %{__grep} "%{zope_user}:" /etc/group > /dev/null 2>&1
174        if [ $? == 0 ]; then
175                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} -g %{zope_user} \
176                        %{zope_user} > /dev/null 2>&1 || :
177        else
178                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} \
179                        %{zope_user} > /dev/null 2>&1 || :
180        fi
181fi
182
183%post zserver
184if [ "$1" = 1 ] ; then
185        /sbin/chkconfig --add %{zope_user}
186        ln -sf /var/log/%{zope_user} %{instance_home}/log
187        /etc/rc.d/init.d/%{zope_user} start
188else
189        mv %{instance_home}/inituser %{instance_home}/inituser.admin
190        /etc/rc.d/init.d/%{zope_user} condrestart
191fi
192
193%preun zserver
194if [ "$1" = 0 ] ; then
195        /etc/rc.d/init.d/%{zope_user} stop > /dev/null 2>&1
196        /sbin/chkconfig --del %{zope_user}
197        if [ /var/log/%{zope_user} -ef %{instance_home}/log ]; then
198                rm -rf %{instance_home}/log
199        fi
200fi
201
202%postun zserver
203if [ "$1" = 0 ] ; then
204  /usr/sbin/userdel %{zope_user} > /dev/null 2>&1 || :
205fi
206
207
208%files
209%defattr(-, root, root)
210%doc %{zope_home}/doc
211%{zope_home}/bin
212%{zope_home}/lib/python
213%{zope_home}/skel
214
215%files zserver
216%defattr(-, root, root)
217%config %{_sysconfdir}/rc.d/init.d/%{zope_user}
218%config(noreplace) %{zope_conf}/%{zope_user}.conf
219%{zope_conf}/site.zcml
220
221%defattr(700, %{zope_user}, %{zope_user})
222%dir /var/log/%{zope_user}
223
224%defattr(700, %{zope_user}, %{zope_user})
225%dir %{instance_home}/
226%dir %{instance_home}/bin/
227%dir %{instance_home}/Extensions/
228%dir %{instance_home}/Products/
229%dir %{instance_home}/import/
230%config %{instance_home}/bin/runzope
231%config %{instance_home}/bin/zopectl
232%config %{instance_home}/bin/zopeservice.py
233
234%attr(600, %{zope_user}, %{zope_user})
235%{instance_home}/inituser
236
237%defattr(1703, %{zope_user}, %{zope_user})
238%dir %{instance_home}/var/
239
240%defattr(-, %{zope_user}, %{zope_user})
241%{instance_home}/Products/__init__.py
242%{instance_home}/import/Examples.zexp
243%{instance_home}/import/ZopeTutorialExamples.zexp
244
245%exclude %{instance_home}/Extensions/README.txt
246%exclude %{instance_home}/Products/README.txt
247%exclude %{instance_home}/README.txt
248%exclude %{instance_home}/bin/runzope.bat
249%exclude %{instance_home}/etc/zope.conf
250%exclude %{instance_home}/etc/site.zcml
251%exclude %{instance_home}/import/README.txt
252%exclude %{instance_home}/lib/python/README.txt
253%exclude %{instance_home}/log/README.txt
254%exclude %{instance_home}/var/README.txt
255
256%if %{_hotfix}
257%defattr(-, %{zope_user}, %{zope_user})
258%{instance_home}/Products/%{_hotfix}
259%endif
260
261%changelog
262* Thu Jan 14 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.6-1
263- updated zope to 2.11.6-final
264
265* Thu Dec 24 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.5-1
266- updated zope to 2.11.5-final
267
268* Thu Aug 06 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.4-1
269- updated zope to 2.11.4-final
270
271* Sun May 03 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.3-1vl5
272- updated zope to 2.11.3-final
273
274* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.2-1vl5
275- updated zope to 2.11.2-final
276- dropt Hotfix_20080812.tar.gz
277
278* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-4vl5
279- rebuilt with python24
280- added BuildRequires: python24
281- added Requires: python24
282
283* Wed Aug 13 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-3vl5
284- added Hotfix_20080812.tar.gz
285
286* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-2vl5
287- rebuilt with python-2.5.2
288
289* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-1vl5
290- updated zope to 2.11.1-final
291
292* Tue Jul 01 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.0-1vl5
293- updated zope to 2.11.0-final
294
295* Mon Jun 09 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.6-1vl5
296- applied new versioning policy and spec in utf-8
297- updated zope to 2.10.6-final
298
299* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl2
300- fixed prereq, buildrequires pkgs
301
302* Tue Oct 30 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl1
303- updated zope to 2.10.5-final
304- updated Requires python >= 2.4.4
305
306* Thu Aug 23 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.4-0vl1
307- updated zope to 2.10.4-final
308- updated %%install scripts
309- dropped Hotfix_20070320.tgz
310
311* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.2-0vl1
312- updated zope to 2.10.2
313- added Hotfix_20070320.tgz
314
315* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl3
316- added japanese summary
317
318* Fri Oct 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl2
319- updated zope to 2.9.5-final
320
321* Thu Jul 20 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.4-0vl1
322- updated zope to 2.9.4
323- dropped Hotfix_20060705.tar.gz
324
325* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl2
326- added Hotfix_20060705.tar.gz
327
328* Fri May 12 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl1
329- updated zope to 2.9.3
330
331* Tue Mar 28 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.2-0vl1
332- updated zope to 2.9.2
333
334* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.1-0vl1
335- updated zope to 2.9.1
336- x86_64 architecture support
337
338* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.0-0vl1
339- updated zope to 2.9.0
340
341* Thu Oct 27 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.4-0vl1
342- updated zope to 2.8.4-final
343
344* Wed Oct 19 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.3-0vl1
345- updated zope to 2.8.3-final
346
347* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.2-0vl1
348- updated zope to 2.8.2-final
349
350* Mon Oct 10 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl2
351- added Hotfix_2005-10-09.tar.gz (security)
352
353* Thu Aug 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl1
354- updated zope to 2.8.1-final
355
356* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.0-0vl1
357- updated zope to 2.8.0-final
358
359* Sun May 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl2
360- updated init.sh (added condrestart)
361- updated spec 'post zserver section'
362
363* Fri Apr 29 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl1
364- updated zope to 2.7.6-final
365
366* Wed Apr 06 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl4
367- added Hotfix_20050405.tar.gz
368
369* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl2
370- rebuilded with python 2.4.1
371
372* Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl1
373- updated zope to 2.7.5-final
374
375* Fri Mar 18 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl0.c1
376- updated zope to 2.7.5-rc1
377
378* Sat Jan 15 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl2
379- updated zope to 2.7.4-0
380
381* Sat Jan 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.c2
382- updated zope to 2.7.4-RC2
383
384* Thu Dec 16 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.b2
385- updated zope to 2.7.4-b2
386
387* Sun Oct 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl1
388- updated zope to 2.7.3
389
390* Mon Oct 11 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.2
391- updated zope to 2.7.3b2
392
393* Sun Sep 26 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.1
394- updated zope to 2.7.3b1
395- droped Hotfix-20040807.tar.gz
396
397* Tue Aug 10 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl2
398- added Hotfix-20040807.tar.gz
399
400* Wed Jul 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl1
401- updated zope to 2.7.2
402
403* Thu Jul 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl3
404- droped Hotfix_2004-07-13.tar.gz
405- added Hotfix_2004-07-14.tar.gz
406
407* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl2
408- added Hotfix_2004-07-13.tar.gz
409
410* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl1
411- updated zope to 2.7.1
412- added option with '--no-compile' to configure at the %build section
413- added to compile at the %post section
414
415* Sat Apr 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.0-0vl1
416- build with python-2.3.3-0vl1
417- added 'Obsoletes: Zope27'
418
419* Tue Mar 02 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl3
420- changed init.sh to use zopectl
421
422* Tue Feb 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl1
423- updated zope to 2.7.0
424- rewrited spec file
425
426* Sun Feb 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.4-0vl1
427- updated zope to 2.6.4
428
429* Fri Jan  9 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.3-0vl1
430- updated zope to 2.6.3
431
432* Wed Sep 10 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2-0vl1
433- updated zope to 2.6.2
434
435* Fri Aug 29 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b6-0vl1
436- updated zope to 2.6.2b6
437
438* Thu Jul 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl2
439- rebuild with python-2.2.3
440
441* Wed Jul 30 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl1
442- updated zope to 2.6.2b5
443
444* Sat Jul 19 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b4-0vl1
445- updated zope to 2.6.2b4
446
447* Sat Jul 12 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b3-0vl1
448- updated zope to 2.6.2b3
449
450* Sat May 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b2-0vl1
451- updated zope to 2.6.2b2
452- fixed many important bugs
453
454* Sun Apr 13 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1-0vl1
455- updated zope to 2.6.1
456- changed 'Requires: python >= 2.2.2'
457- japanese patch below has been included in zope 2.6.1
458
459* Thu Jan 16 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1b1-0vp1
460- updated zope to 2.6.1b1
461- added Zope261b.patch (by fukamachi, nakagami, tahara)
462- changed option parameter with -Z in startup script
463- added command 'umask 077' in startup script
464- added option -D in startup script that logout debug infomation
465- added 'chown root', 'chmod o+t' script in %%post section
466- this is a experimental release!!
467
468* Fri Oct 4 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl3
469  Security fix for XML-RPC handling (by tahara)
470
471* Fri Jun 21 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl2
472  added Hotfix_2002-06-14.tgz
473
474* Sat Jun 15 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl1
475  modified for Vine
476
477* Sat May 18 2002 Adam Manock <abmanock@earthlink.net>
478  Completely reworked the spec for Zope 2.5.1
479  PCGI is no longer built by default.
480  Build now simply wraps up the default "wo_pcgi" build, creating 2 packages.
481  (This will make it trivial to upgrade the spec for new Zope versions.)
482  Logging via syslog is now turned off by default. See the RPM-README
483
484* Wed Nov 14 2001 Jeff Rush <jrush@taupro.com>
485  bumped to zope 2.4.3.
486
487* Sat Nov 10 2001 Jeff Rush <jrush@taupro.com>
488  changed args to useradd, to work with Red Hat 7.2.
489
490* Sun Oct 21 2001 Jeff Rush <jrush@taupro.com>
491  bumped to zope 2.4.2, removed Hotfix 2001-09-28.
492
493* Thu Oct 18 2001 Jeff Rush <jrush@taupro.com>
494  Fixed broken syslogging facility and added Hotfix 2001-09-28.
495
496* Mon Sep 04 2001 Jeff Rush <jrush@taupro.com>
497  bumped to zope 2.4.1, removed Hotfix 2001-08-04.
498
499* Mon Aug 15 2001 Jeff Rush <jrush@taupro.com>
500  bumped to zope 2.4.0, changed to use python2.1, added Hotfix 2001-08-04.
501
502  Merged in Jun 29 2001 patch from Durval Menezes re support for ZPatterns:
503  "No longer removes cPersistence.h from lib/python/ZODB before installing
504  (this is needed to compile DynPersist, as part of the ZPatterns
505  installation.  Installs ExtensionClass.h into /usr/include/python2.1
506  (it too is needed to compile DynPersist, as part of the ZPatterns install)"
507
508  Merged in Jun 12 2001 additions from Jared Kelsey <jared@dolphinsearch.com>
509  to make more compatible with future releases of python.
510
511* Mon Aug 14 2001 Jeff Rush <jrush@taupro.com>
512  bumped to zope 2.3.3, added Hotfix 2001-08-04.
513
514* Mon May 07 2001 Jeff Rush <jrush@taupro.com>
515  bumped to zope 2.3.2, added Hotfix 2001-05-01, revised access
516  file permissions (600->640) and ownership (root.root->root.zope)
517  to fix the "can't log in" bug under ZServer subpackage.
518
519* Sat Mar 31 2001 Jeff Rush <jrush@taupro.com>
520  bumped to zope 2.3.1
521
522* Mon Jan 29 2001 Jeff Rush <jrush@taupro.com>
523  bumped to zope 2.3.0; removed obsolete Hotfixes.
524
525* Fri Dec 08 2000 Jeff Rush <jrush@taupro.com>
526  bumped to zope 2.2.4; removed obsolete Hotfixes.
527
528* Fri Nov 03 2000 Jeff Rush <jrush@taupro.com>
529  fixed misplaced SiteAccess, where dirs in tar moved btw v1 and v2.
530
531* Sun Oct 16 2000 Jeff Rush <jrush@taupro.com>
532  bumped to zope 2.2.2; added Hotfixes  2000-10-02 and 2000-10-11.
533
534* Sun Aug 27 2000 Jeff Rush <jrush@taupro.com>
535  bumped to zope 2.2.1; removed no-longer-needed Hotfix_2000-08-17
536
537* Tue Aug 22 2000 Jeff Rush <jrush@taupro.com>
538- added Hotfix_2000-08-17
539- temporarily removed /etc/init.d (RH7.0) until I figure out how
540  to support both RH6.x *and* RH7.0 in the same RPM. <sigh>
541- removed troublesome/obsolete ComputedAttribute.py
542
543* Sun Jul 16 2000 Jeff Rush <jrush@taupro.com>
544- bumped to zope 2.2.0; removed no-longer-needed Hotfix-06_16_2000
545
546* Thu Jul 06 2000 Tim Powers <timp@redhat.com>
547- fixed PreReq to PreReq /etc/init.d
548- added Hotfix-06_16_2000
549 
550* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
551- moved init script, added condrestart directive
552- auto stop/restart service on upgrades
553
554* Thu Jun 1 2000 Tim Powers <timp@redhat.com>
555- fixed so that it's no longer putting files into /home, instead they are
556  going into /var/www (FHS compliant).
557
558* Mon May 22 2000 Tim Powers <timp@redhat.com>
559- built for 7.0, thanks Jeff!
560
561* Fri Apr 28 2000 Jeff Rush <jrush@taupro.com>
562- bumped to zope 2.1.6
563
564* Sun Mar 12 2000 Jeff Rush <jrush@taupro.com>
565- added zpasswd.py back in, since my rename to just zpasswd confused some.
566  both are now present in the RPM, for all audiences.
567- modified the README.RPM re the section about Apache rewrite rules; I
568  discussed and removed the trailing slash, the presence of which causes
569  Zope to reject attempts to delete objects in the root folder.
570
571* Thu Feb 26 2000 Jeff Rush <jrush@taupro.com>
572- 2.1.4-1 Release on Zope.org site
573- bumped to zope 2.1.4
574- changed Zope-core to provide 'Zope', to satisfy zserver and pcgi subpkgs.
575
576* Fri Jan 14 2000 Tim Powers <timp@redhat.com>
577- added Provides lines to Zope-pcgi and Zope-zserver so that addon packages
578        such as Squishdot have something useful to require.
579
580* Thu Jan 13 2000 Tim Powers <timp@redhat.com>
581- built for Powertools 6.2
582
583* Thu Jan 11 2000 Jeff Rush <jrush@taupro.com>
584- bumped to zope 2.1.2
585- folded in Jonathan Marsden <jonathan@xc.org> Changes (many below)
586- used zpasswd.py to generate initial pw in encrypted form.
587- fixed syslog logging in various ways, and re-enabled it, for both
588-    ZServer AND pcgi-wrapper.
589- fixed /etc/rc.d/init.d/zope to be consistent about pid file.
590- fixed /etc/rc.d/init.d/zope to use RH killproc function.
591- added 'noreplace' so that Zope database and access file are retained
592-    on an RPM upgrade.
593- patched PCGI to support syslog logging, and then default to it.
594- patched ZServer/Medusa to properly support syslog logging.
595- added a user 'zope' and made many zope files/dirs owned by it.
596- cleaned up pcgi-wrapper's msg about can't find ZServer, since it is
597-    one of the most common errors.  It now explains what it is doing.
598- moved all *.{pid,soc} files into /var/run, to cleanly separate ownership
599-    issues in /var/zope hierarchy for user 'zope' and user 'nobody'.
600
601* Mon Jan 03 2000 Jeff Rush <jrush@taupro.com>
602- bumped to zope 2.1.1
603- added to /etc/rc.d/init.d/zope code to correctly kill the process specified
604-    in /var/zope/pcgi.pid
605- changed permissions on /var/zope/access such that only root can read/write
606-    it, to protect the Zope superuser password.
607
608* Sat Nov 29 1999 Jeff Rush <jrush@taupro.com>
609- changed ownership on /var/zope/access from nobody.nobody to root.root.
610
611* Sat Nov 20 1999 Jeff Rush <jrush@taupro.com>
612- updated to zope 2.1.0beta2
613- fixed permissions/ownership on /var/zope/access to be more secure (600).
614- removed pypath.patch, as those changes got into the zope distribution.
615
616* Tue Nov 2 1999 Jeff Rush <jrush@taupro.com>
617- added accidentally omitted /usr/bin/zpasswd to the RPM output.
618- clarified wording re use of zpasswd in README.RPM file.
619- added "-u nobody" to both zserver_*.sh files, for clarity of intent;
620-    it already ran as nobody by default, but some people worried.
621
622* Wed Oct 27 1999 Jeff Rush <jrush@taupro.com>
623- fixed /etc/rc.d/init.d/zope file to *NOT* delete /var/zope/zserver.pid
624- fixed /var/zope/Zope.cgi to use PCGI_PUBLISHER=/var/zope/pcgi_nullpublisher.py,
625-    so that when the PCGI wrapper can't find ZServer, it won't try to start one
626-    and generate bogus error messages, because PCGI doesn't do it right.
627- fixed /var/zope/zserver.sh to NOT specify syslog-style logging, since under
628-    Red Hat 6.1, the syslog daemon no longer listens to the port we expected.
629
630* Sat Sep 25 1999 Jeff Rush <jrush@taupro.com>
631- updated documents ZCMG, ZSQL and ZDTML to Sep 24th 1999 versions
632- added empty directories /var/zope/{import,Extensions}
633- relocated zope from /usr/lib/python1.5/site-packages/ZopeWorld/
634-    to /usr/share/zope/
635- added user zope, for better security control
636
637* Fri Sep 17 1999 Jeff Rush <jrush@taupro.com>
638- updated sources to minor (security fix) release 2.0.1
639
640* Fri Sep 10 1999 Jeff Rush <jrush@taupro.com>
641- heavily reworked spec file for 2.0.0
642
643* Thu Sep 9 1999 Tim Powers <timp@redhat.com>
644- updated sources to 2.0.0
645- _major_ spec file cleanups
646- merged patch from src.rpm authored by Andreas Kostyrka <andreas@mtg.co.at>
647- borrowed some things from Andreas Kostyrka's spec file
648
649* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
650- changed groups
651
652* Tue Aug 17 1999 Tim Powers <timp@redhat.com>
653- chown permissions on some files in /var/local for the pcgi package
654
655* Mon Aug 2 1999 Tim Powers <timp@redhat.com>
656- changed buildroot to be in /var/tmp instead of /tmp
657- rebuilt for 6.1
658
659* Mon Jul 21 1999 Jeff Rush <jrush@taupro.com>
660- Added in accidently omitted SearchIndex/{Query,Splitter}.so
661
662* Tue Jul 6 1999 Tim Powers <timp@redhat.com>
663- started changelog
664- cleaned up spec file
665- built for powertools
666
667* Mon Jun 24 1999 Jeff Rush <jrush@taupro.com>
668- Updated to 1.10.3
669
670* Mon Jun 23 1999 Jeff Rush <jrush@taupro.com>
671- Added /etc/rc.d/init.d/zope and reworked scripts
672
673* Tue Mar 1 1999 Jeff Rush <jrush@taupro.com>
674- Updated to 1.10.2
675
676* Wed Jan 29 1999 Jeff Rush <jrush@taupro.com>
677- Updated to 1.9.0 Final Release
678
679* Wed Dec 9 1998 Jeff Rush <jrush@taupro.com>
680- Original 1.9beta1 Release
Note: See TracBrowser for help on using the repository browser.