source: projects/specs/trunk/Z/Zope/Zope-vl.spec @ 1743

Revision 1743, 23.2 KB checked in by owa, 14 years ago (diff)

new upstreams

Line 
1#%define _pyver %(python -c 'import sys;print(sys.version[0:3])')
2#%define _python %{_bindir}/python
3%define _pyver 2.4
4%define _python %{_bindir}/python%{_pyver}
5
6%define zope_user zope
7%define zope_home %{_libdir}/%{zope_user}
8%define zope_conf %{_sysconfdir}/%{zope_user}
9%define software_home %{zope_home}/lib/python
10%define instance_home %{_var}/lib/%{zope_user}
11
12%define _http_port 8080
13%define _ftp_port 8021
14%define _admin admin
15%define _password 123
16#%define _hotfix Hotfix_20080812
17%define _hotfix 0
18
19Summary:  An application server and portal toolkit for building Web sites.
20Summary(ja):  アプリケーションサーバおよびウェブサイト構築ツールキット
21Name: Zope
22Version: 2.11.7
23Release: 1%{?_dist_release}
24License: ZPL (Zope Public License) 2.1
25URL: http://www.zope.org/
26Group: Development/Web Applications
27
28Source0: http://www.zope.org/Products/Zope/%{version}/Zope-%{version}-final.tgz
29Source1: init.sh
30%if %{_hotfix}
31Source2: %{_hotfix}.tar.gz
32%endif
33Prereq: /sbin/chkconfig /usr/sbin/useradd
34Buildrequires: chkconfig
35Buildrequires: shadow-utils
36Buildrequires: python24
37Buildrequires: python24-devel
38Requires: python24
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: owa
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44
45%description
46The Z Object Programming Environment (Zope) is a free, Open Source[tm]
47Python-based application server for building high-performance, dynamic
48web sites, using a powerful and simple scripting object model and
49high-performance, integrated object database.
50
51For a fully functional installation of Zope, install this single huge
52package and then the Zope-zserver RPM
53
54%description -l ja
55Zオブジェクトプログラミング環境(Zope)はフリーです,オープンソースである
56Pythonをベースにした、高性能で動的なWebサイトを構築するためのアプリケー
57ションサーバです.強力でしかも単純なスクリプトからなるオブジェクトモデル
58と高性能な統合オブジェクトデータベースを使うことができます.
59
60Zope の全機能をインストールするには,この一個の大きなパッケージをインスト
61ールし, 次に Zope-zserver RPM をインストールします.
62
63##
64## Zope-zserver
65##
66%package zserver
67Summary: Initial Object Database/Standalone HTTP Server
68Summary(ja): Zope インスタンス
69Group: Development/Web Applications
70Requires: Zope
71Prereq: /etc/rc.d/init.d
72
73%description zserver
74The Zope-zserver package contains the files needed for setting up a
75Zope website, including an empty object database. Zope is an application
76server and portal toolkit.
77
78Also included is the ZServer, which is a small, standalone web server
79written in Python.  The ZServer uses the very fast Medusa technology
80and is multithreaded.  This package comes preconfigured to serve
81web pages on port %{_http_port} and ftp access on %{_ftp_port}.  The programmer's port
82interface comes disabled for security reasons but can be reenabled.
83
84%description -l ja zserver
85Zope-zserver パッケージは Zope web サイトをセットアップするのに必要な
86ファイルを含んでいます,そこには空のオブジェクトデータベースも含みます.
87Zope はアプリケーションサーバであり,Webサイト構築のためのツール集です.
88
89また Python で書かれた小さなスタンドアロン Web サーバである ZServer も
90含まれています. ZServer は非常に高速な Medusa の技術を利用し,マルチス
91レッド化されています.このパッケージでは Web ページを %{_http_port} ポート, FTP
92アクセスを %{_ftp_port} でサービスするようにあらかじめ設定してあります.セキュ
93リティ上の理由のため,プログラマ用ポートインタフェースは使用できないよ
94うになっていますが,再び利用できるように戻すことが可能です.
95
96初期ユーザは "%{_admin}" パスワードは "%{_password}" に設定されています。
97初回の起動直後にこれらは変更すべきです。
98
99
100%prep
101%setup -q -n Zope-%{version}-final
102
103%if %{_hotfix}
104%{__tar} -xzf %{SOURCE2}
105%endif
106
107
108%build
109rm -rf $RPM_BUILD_ROOT
110./configure \
111        --with-python=%{_python} \
112        --prefix="$RPM_BUILD_ROOT%{zope_home}"
113
114make %{?_smp_mflags}
115
116
117%install
118rm -rf $RPM_BUILD_ROOT
119make install
120
121
122$RPM_BUILD_ROOT%{zope_home}/bin/mkzopeinstance.py \
123        --dir $RPM_BUILD_ROOT%{instance_home} \
124        --user %{_admin}:%{_password}
125
126install -d $RPM_BUILD_ROOT%{zope_conf}
127( cd $RPM_BUILD_ROOT%{instance_home}%{_sysconfdir}
128        sed "s|$RPM_BUILD_ROOT||" zope.conf \
129        | sed 's|^#.*effective-user chrism$|effective-user %{zope_user}|' \
130        | sed 's|\$INSTANCE/log|/var/log/%{zope_user}|' \
131        > $RPM_BUILD_ROOT%{zope_conf}/%{zope_user}.conf
132        install -m 644 site.zcml $RPM_BUILD_ROOT%{zope_conf}/
133)
134install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
135install -m 755 %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{zope_user}
136install -d $RPM_BUILD_ROOT/var/log/%{zope_user}
137
138( cd $RPM_BUILD_ROOT%{instance_home}/bin
139        mv runzope runzope.old
140        sed "s|$RPM_BUILD_ROOT||" runzope.old | \
141        sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > runzope
142        rm -f runzope.old
143)
144( cd $RPM_BUILD_ROOT%{instance_home}/bin
145        mv zopectl zopectl.old
146        sed "s|$RPM_BUILD_ROOT||" zopectl.old | \
147        sed 's|^CONFIG_FILE.*$|CONFIG_FILE="%{zope_conf}/%{zope_user}.conf"|' > zopectl
148        rm -f zopectl.old
149)
150
151%if %{_hotfix}
152install -d $RPM_BUILD_ROOT%{instance_home}/Products/%{_hotfix}
153#install -m644 %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
154cp -a %{_hotfix}/* $RPM_BUILD_ROOT/%{instance_home}/Products/%{_hotfix}/
155%endif
156
157## remove unused files
158rm -f $RPM_BUILD_ROOT%{instance_home}/bin/zopectl.bat
159
160
161%clean
162rm -rf $RPM_BUILD_ROOT
163
164
165%post
166# byte-compile installed Python files
167pushd "%{zope_home}" > /dev/null 2>&1
168%{_python} "%{zope_home}/bin/compilezpy.py" > /dev/null 2>&1 || :
169popd > /dev/null 2>&1
170
171%pre zserver
172if [ "$1" = 1 ] ; then
173        %{__grep} "%{zope_user}:" /etc/group > /dev/null 2>&1
174        if [ $? == 0 ]; then
175                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} -g %{zope_user} \
176                        %{zope_user} > /dev/null 2>&1 || :
177        else
178                /usr/sbin/useradd -M -r -s /bin/bash -d %{instance_home} \
179                        %{zope_user} > /dev/null 2>&1 || :
180        fi
181fi
182
183%post zserver
184if [ "$1" = 1 ] ; then
185        /sbin/chkconfig --add %{zope_user}
186        ln -sf /var/log/%{zope_user} %{instance_home}/log
187        /etc/rc.d/init.d/%{zope_user} start
188else
189        mv %{instance_home}/inituser %{instance_home}/inituser.admin
190        /etc/rc.d/init.d/%{zope_user} condrestart
191fi
192
193%preun zserver
194if [ "$1" = 0 ] ; then
195        /etc/rc.d/init.d/%{zope_user} stop > /dev/null 2>&1
196        /sbin/chkconfig --del %{zope_user}
197        if [ /var/log/%{zope_user} -ef %{instance_home}/log ]; then
198                rm -rf %{instance_home}/log
199        fi
200fi
201
202%postun zserver
203if [ "$1" = 0 ] ; then
204  /usr/sbin/userdel %{zope_user} > /dev/null 2>&1 || :
205fi
206
207
208%files
209%defattr(-, root, root)
210%doc %{zope_home}/doc
211%{zope_home}/bin
212%{zope_home}/lib/python
213%{zope_home}/skel
214
215%files zserver
216%defattr(-, root, root)
217%config %{_sysconfdir}/rc.d/init.d/%{zope_user}
218%config(noreplace) %{zope_conf}/%{zope_user}.conf
219%{zope_conf}/site.zcml
220
221%defattr(700, %{zope_user}, %{zope_user})
222%dir /var/log/%{zope_user}
223
224%defattr(700, %{zope_user}, %{zope_user})
225%dir %{instance_home}/
226%dir %{instance_home}/bin/
227%dir %{instance_home}/Extensions/
228%dir %{instance_home}/Products/
229%dir %{instance_home}/import/
230%config %{instance_home}/bin/runzope
231%config %{instance_home}/bin/zopectl
232%config %{instance_home}/bin/zopeservice.py
233
234%attr(600, %{zope_user}, %{zope_user})
235%{instance_home}/inituser
236
237%defattr(1703, %{zope_user}, %{zope_user})
238%dir %{instance_home}/var/
239
240%defattr(-, %{zope_user}, %{zope_user})
241%{instance_home}/Products/__init__.py
242%{instance_home}/import/Examples.zexp
243%{instance_home}/import/ZopeTutorialExamples.zexp
244
245%exclude %{instance_home}/Extensions/README.txt
246%exclude %{instance_home}/Products/README.txt
247%exclude %{instance_home}/README.txt
248%exclude %{instance_home}/bin/runzope.bat
249%exclude %{instance_home}/etc/zope.conf
250%exclude %{instance_home}/etc/site.zcml
251%exclude %{instance_home}/import/README.txt
252%exclude %{instance_home}/lib/python/README.txt
253%exclude %{instance_home}/log/README.txt
254%exclude %{instance_home}/var/README.txt
255
256%if %{_hotfix}
257%defattr(-, %{zope_user}, %{zope_user})
258%{instance_home}/Products/%{_hotfix}
259%endif
260
261%changelog
262* Thu Sep  02 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.7-1
263- updated zope to 2.11.7-final
264
265* Thu Jan 14 2010 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.6-1
266- updated zope to 2.11.6-final
267
268* Thu Dec 24 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.5-1
269- updated zope to 2.11.5-final
270
271* Thu Aug 06 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.4-1
272- updated zope to 2.11.4-final
273
274* Sun May 03 2009 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.3-1vl5
275- updated zope to 2.11.3-final
276
277* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.2-1vl5
278- updated zope to 2.11.2-final
279- dropt Hotfix_20080812.tar.gz
280
281* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-4vl5
282- rebuilt with python24
283- added BuildRequires: python24
284- added Requires: python24
285
286* Wed Aug 13 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-3vl5
287- added Hotfix_20080812.tar.gz
288
289* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-2vl5
290- rebuilt with python-2.5.2
291
292* Thu Jul 17 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.1-1vl5
293- updated zope to 2.11.1-final
294
295* Tue Jul 01 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.11.0-1vl5
296- updated zope to 2.11.0-final
297
298* Mon Jun 09 2008 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.6-1vl5
299- applied new versioning policy and spec in utf-8
300- updated zope to 2.10.6-final
301
302* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl2
303- fixed prereq, buildrequires pkgs
304
305* Tue Oct 30 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.5-0vl1
306- updated zope to 2.10.5-final
307- updated Requires python >= 2.4.4
308
309* Thu Aug 23 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.4-0vl1
310- updated zope to 2.10.4-final
311- updated %%install scripts
312- dropped Hotfix_20070320.tgz
313
314* Wed Mar 21 2007 Shu KONNO <owa@bg.wakwak.com> Zope-2.10.2-0vl1
315- updated zope to 2.10.2
316- added Hotfix_20070320.tgz
317
318* Sat Oct 14 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl3
319- added japanese summary
320
321* Fri Oct 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.5-0vl2
322- updated zope to 2.9.5-final
323
324* Thu Jul 20 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.4-0vl1
325- updated zope to 2.9.4
326- dropped Hotfix_20060705.tar.gz
327
328* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl2
329- added Hotfix_20060705.tar.gz
330
331* Fri May 12 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.3-0vl1
332- updated zope to 2.9.3
333
334* Tue Mar 28 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.2-0vl1
335- updated zope to 2.9.2
336
337* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.1-0vl1
338- updated zope to 2.9.1
339- x86_64 architecture support
340
341* Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> Zope-2.9.0-0vl1
342- updated zope to 2.9.0
343
344* Thu Oct 27 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.4-0vl1
345- updated zope to 2.8.4-final
346
347* Wed Oct 19 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.3-0vl1
348- updated zope to 2.8.3-final
349
350* Thu Oct 13 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.2-0vl1
351- updated zope to 2.8.2-final
352
353* Mon Oct 10 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl2
354- added Hotfix_2005-10-09.tar.gz (security)
355
356* Thu Aug 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.1-0vl1
357- updated zope to 2.8.1-final
358
359* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.8.0-0vl1
360- updated zope to 2.8.0-final
361
362* Sun May 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl2
363- updated init.sh (added condrestart)
364- updated spec 'post zserver section'
365
366* Fri Apr 29 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.6-0vl1
367- updated zope to 2.7.6-final
368
369* Wed Apr 06 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl4
370- added Hotfix_20050405.tar.gz
371
372* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl2
373- rebuilded with python 2.4.1
374
375* Sun Mar 20 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl1
376- updated zope to 2.7.5-final
377
378* Fri Mar 18 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.5-0vl0.c1
379- updated zope to 2.7.5-rc1
380
381* Sat Jan 15 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl2
382- updated zope to 2.7.4-0
383
384* Sat Jan 08 2005 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.c2
385- updated zope to 2.7.4-RC2
386
387* Thu Dec 16 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.4-0vl0.b2
388- updated zope to 2.7.4-b2
389
390* Sun Oct 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl1
391- updated zope to 2.7.3
392
393* Mon Oct 11 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.2
394- updated zope to 2.7.3b2
395
396* Sun Sep 26 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.3-0vl0.1
397- updated zope to 2.7.3b1
398- droped Hotfix-20040807.tar.gz
399
400* Tue Aug 10 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl2
401- added Hotfix-20040807.tar.gz
402
403* Wed Jul 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.2-0vl1
404- updated zope to 2.7.2
405
406* Thu Jul 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl3
407- droped Hotfix_2004-07-13.tar.gz
408- added Hotfix_2004-07-14.tar.gz
409
410* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl2
411- added Hotfix_2004-07-13.tar.gz
412
413* Mon Jun 21 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.1-0vl1
414- updated zope to 2.7.1
415- added option with '--no-compile' to configure at the %build section
416- added to compile at the %post section
417
418* Sat Apr 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.7.0-0vl1
419- build with python-2.3.3-0vl1
420- added 'Obsoletes: Zope27'
421
422* Tue Mar 02 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl3
423- changed init.sh to use zopectl
424
425* Tue Feb 24 2004 Shu KONNO <owa@bg.wakwak.com> Zope27-2.7.0-uvl1
426- updated zope to 2.7.0
427- rewrited spec file
428
429* Sun Feb 15 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.4-0vl1
430- updated zope to 2.6.4
431
432* Fri Jan  9 2004 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.3-0vl1
433- updated zope to 2.6.3
434
435* Wed Sep 10 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2-0vl1
436- updated zope to 2.6.2
437
438* Fri Aug 29 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b6-0vl1
439- updated zope to 2.6.2b6
440
441* Thu Jul 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl2
442- rebuild with python-2.2.3
443
444* Wed Jul 30 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b5-0vl1
445- updated zope to 2.6.2b5
446
447* Sat Jul 19 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b4-0vl1
448- updated zope to 2.6.2b4
449
450* Sat Jul 12 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b3-0vl1
451- updated zope to 2.6.2b3
452
453* Sat May 31 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.2b2-0vl1
454- updated zope to 2.6.2b2
455- fixed many important bugs
456
457* Sun Apr 13 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1-0vl1
458- updated zope to 2.6.1
459- changed 'Requires: python >= 2.2.2'
460- japanese patch below has been included in zope 2.6.1
461
462* Thu Jan 16 2003 Shu KONNO <owa@bg.wakwak.com> Zope-2.6.1b1-0vp1
463- updated zope to 2.6.1b1
464- added Zope261b.patch (by fukamachi, nakagami, tahara)
465- changed option parameter with -Z in startup script
466- added command 'umask 077' in startup script
467- added option -D in startup script that logout debug infomation
468- added 'chown root', 'chmod o+t' script in %%post section
469- this is a experimental release!!
470
471* Fri Oct 4 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl3
472  Security fix for XML-RPC handling (by tahara)
473
474* Fri Jun 21 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl2
475  added Hotfix_2002-06-14.tgz
476
477* Sat Jun 15 2002 Shu KONNO <owa@bg.wakwak.com> Zope-2.5.1-0vl1
478  modified for Vine
479
480* Sat May 18 2002 Adam Manock <abmanock@earthlink.net>
481  Completely reworked the spec for Zope 2.5.1
482  PCGI is no longer built by default.
483  Build now simply wraps up the default "wo_pcgi" build, creating 2 packages.
484  (This will make it trivial to upgrade the spec for new Zope versions.)
485  Logging via syslog is now turned off by default. See the RPM-README
486
487* Wed Nov 14 2001 Jeff Rush <jrush@taupro.com>
488  bumped to zope 2.4.3.
489
490* Sat Nov 10 2001 Jeff Rush <jrush@taupro.com>
491  changed args to useradd, to work with Red Hat 7.2.
492
493* Sun Oct 21 2001 Jeff Rush <jrush@taupro.com>
494  bumped to zope 2.4.2, removed Hotfix 2001-09-28.
495
496* Thu Oct 18 2001 Jeff Rush <jrush@taupro.com>
497  Fixed broken syslogging facility and added Hotfix 2001-09-28.
498
499* Mon Sep 04 2001 Jeff Rush <jrush@taupro.com>
500  bumped to zope 2.4.1, removed Hotfix 2001-08-04.
501
502* Mon Aug 15 2001 Jeff Rush <jrush@taupro.com>
503  bumped to zope 2.4.0, changed to use python2.1, added Hotfix 2001-08-04.
504
505  Merged in Jun 29 2001 patch from Durval Menezes re support for ZPatterns:
506  "No longer removes cPersistence.h from lib/python/ZODB before installing
507  (this is needed to compile DynPersist, as part of the ZPatterns
508  installation.  Installs ExtensionClass.h into /usr/include/python2.1
509  (it too is needed to compile DynPersist, as part of the ZPatterns install)"
510
511  Merged in Jun 12 2001 additions from Jared Kelsey <jared@dolphinsearch.com>
512  to make more compatible with future releases of python.
513
514* Mon Aug 14 2001 Jeff Rush <jrush@taupro.com>
515  bumped to zope 2.3.3, added Hotfix 2001-08-04.
516
517* Mon May 07 2001 Jeff Rush <jrush@taupro.com>
518  bumped to zope 2.3.2, added Hotfix 2001-05-01, revised access
519  file permissions (600->640) and ownership (root.root->root.zope)
520  to fix the "can't log in" bug under ZServer subpackage.
521
522* Sat Mar 31 2001 Jeff Rush <jrush@taupro.com>
523  bumped to zope 2.3.1
524
525* Mon Jan 29 2001 Jeff Rush <jrush@taupro.com>
526  bumped to zope 2.3.0; removed obsolete Hotfixes.
527
528* Fri Dec 08 2000 Jeff Rush <jrush@taupro.com>
529  bumped to zope 2.2.4; removed obsolete Hotfixes.
530
531* Fri Nov 03 2000 Jeff Rush <jrush@taupro.com>
532  fixed misplaced SiteAccess, where dirs in tar moved btw v1 and v2.
533
534* Sun Oct 16 2000 Jeff Rush <jrush@taupro.com>
535  bumped to zope 2.2.2; added Hotfixes  2000-10-02 and 2000-10-11.
536
537* Sun Aug 27 2000 Jeff Rush <jrush@taupro.com>
538  bumped to zope 2.2.1; removed no-longer-needed Hotfix_2000-08-17
539
540* Tue Aug 22 2000 Jeff Rush <jrush@taupro.com>
541- added Hotfix_2000-08-17
542- temporarily removed /etc/init.d (RH7.0) until I figure out how
543  to support both RH6.x *and* RH7.0 in the same RPM. <sigh>
544- removed troublesome/obsolete ComputedAttribute.py
545
546* Sun Jul 16 2000 Jeff Rush <jrush@taupro.com>
547- bumped to zope 2.2.0; removed no-longer-needed Hotfix-06_16_2000
548
549* Thu Jul 06 2000 Tim Powers <timp@redhat.com>
550- fixed PreReq to PreReq /etc/init.d
551- added Hotfix-06_16_2000
552 
553* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
554- moved init script, added condrestart directive
555- auto stop/restart service on upgrades
556
557* Thu Jun 1 2000 Tim Powers <timp@redhat.com>
558- fixed so that it's no longer putting files into /home, instead they are
559  going into /var/www (FHS compliant).
560
561* Mon May 22 2000 Tim Powers <timp@redhat.com>
562- built for 7.0, thanks Jeff!
563
564* Fri Apr 28 2000 Jeff Rush <jrush@taupro.com>
565- bumped to zope 2.1.6
566
567* Sun Mar 12 2000 Jeff Rush <jrush@taupro.com>
568- added zpasswd.py back in, since my rename to just zpasswd confused some.
569  both are now present in the RPM, for all audiences.
570- modified the README.RPM re the section about Apache rewrite rules; I
571  discussed and removed the trailing slash, the presence of which causes
572  Zope to reject attempts to delete objects in the root folder.
573
574* Thu Feb 26 2000 Jeff Rush <jrush@taupro.com>
575- 2.1.4-1 Release on Zope.org site
576- bumped to zope 2.1.4
577- changed Zope-core to provide 'Zope', to satisfy zserver and pcgi subpkgs.
578
579* Fri Jan 14 2000 Tim Powers <timp@redhat.com>
580- added Provides lines to Zope-pcgi and Zope-zserver so that addon packages
581        such as Squishdot have something useful to require.
582
583* Thu Jan 13 2000 Tim Powers <timp@redhat.com>
584- built for Powertools 6.2
585
586* Thu Jan 11 2000 Jeff Rush <jrush@taupro.com>
587- bumped to zope 2.1.2
588- folded in Jonathan Marsden <jonathan@xc.org> Changes (many below)
589- used zpasswd.py to generate initial pw in encrypted form.
590- fixed syslog logging in various ways, and re-enabled it, for both
591-    ZServer AND pcgi-wrapper.
592- fixed /etc/rc.d/init.d/zope to be consistent about pid file.
593- fixed /etc/rc.d/init.d/zope to use RH killproc function.
594- added 'noreplace' so that Zope database and access file are retained
595-    on an RPM upgrade.
596- patched PCGI to support syslog logging, and then default to it.
597- patched ZServer/Medusa to properly support syslog logging.
598- added a user 'zope' and made many zope files/dirs owned by it.
599- cleaned up pcgi-wrapper's msg about can't find ZServer, since it is
600-    one of the most common errors.  It now explains what it is doing.
601- moved all *.{pid,soc} files into /var/run, to cleanly separate ownership
602-    issues in /var/zope hierarchy for user 'zope' and user 'nobody'.
603
604* Mon Jan 03 2000 Jeff Rush <jrush@taupro.com>
605- bumped to zope 2.1.1
606- added to /etc/rc.d/init.d/zope code to correctly kill the process specified
607-    in /var/zope/pcgi.pid
608- changed permissions on /var/zope/access such that only root can read/write
609-    it, to protect the Zope superuser password.
610
611* Sat Nov 29 1999 Jeff Rush <jrush@taupro.com>
612- changed ownership on /var/zope/access from nobody.nobody to root.root.
613
614* Sat Nov 20 1999 Jeff Rush <jrush@taupro.com>
615- updated to zope 2.1.0beta2
616- fixed permissions/ownership on /var/zope/access to be more secure (600).
617- removed pypath.patch, as those changes got into the zope distribution.
618
619* Tue Nov 2 1999 Jeff Rush <jrush@taupro.com>
620- added accidentally omitted /usr/bin/zpasswd to the RPM output.
621- clarified wording re use of zpasswd in README.RPM file.
622- added "-u nobody" to both zserver_*.sh files, for clarity of intent;
623-    it already ran as nobody by default, but some people worried.
624
625* Wed Oct 27 1999 Jeff Rush <jrush@taupro.com>
626- fixed /etc/rc.d/init.d/zope file to *NOT* delete /var/zope/zserver.pid
627- fixed /var/zope/Zope.cgi to use PCGI_PUBLISHER=/var/zope/pcgi_nullpublisher.py,
628-    so that when the PCGI wrapper can't find ZServer, it won't try to start one
629-    and generate bogus error messages, because PCGI doesn't do it right.
630- fixed /var/zope/zserver.sh to NOT specify syslog-style logging, since under
631-    Red Hat 6.1, the syslog daemon no longer listens to the port we expected.
632
633* Sat Sep 25 1999 Jeff Rush <jrush@taupro.com>
634- updated documents ZCMG, ZSQL and ZDTML to Sep 24th 1999 versions
635- added empty directories /var/zope/{import,Extensions}
636- relocated zope from /usr/lib/python1.5/site-packages/ZopeWorld/
637-    to /usr/share/zope/
638- added user zope, for better security control
639
640* Fri Sep 17 1999 Jeff Rush <jrush@taupro.com>
641- updated sources to minor (security fix) release 2.0.1
642
643* Fri Sep 10 1999 Jeff Rush <jrush@taupro.com>
644- heavily reworked spec file for 2.0.0
645
646* Thu Sep 9 1999 Tim Powers <timp@redhat.com>
647- updated sources to 2.0.0
648- _major_ spec file cleanups
649- merged patch from src.rpm authored by Andreas Kostyrka <andreas@mtg.co.at>
650- borrowed some things from Andreas Kostyrka's spec file
651
652* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
653- changed groups
654
655* Tue Aug 17 1999 Tim Powers <timp@redhat.com>
656- chown permissions on some files in /var/local for the pcgi package
657
658* Mon Aug 2 1999 Tim Powers <timp@redhat.com>
659- changed buildroot to be in /var/tmp instead of /tmp
660- rebuilt for 6.1
661
662* Mon Jul 21 1999 Jeff Rush <jrush@taupro.com>
663- Added in accidently omitted SearchIndex/{Query,Splitter}.so
664
665* Tue Jul 6 1999 Tim Powers <timp@redhat.com>
666- started changelog
667- cleaned up spec file
668- built for powertools
669
670* Mon Jun 24 1999 Jeff Rush <jrush@taupro.com>
671- Updated to 1.10.3
672
673* Mon Jun 23 1999 Jeff Rush <jrush@taupro.com>
674- Added /etc/rc.d/init.d/zope and reworked scripts
675
676* Tue Mar 1 1999 Jeff Rush <jrush@taupro.com>
677- Updated to 1.10.2
678
679* Wed Jan 29 1999 Jeff Rush <jrush@taupro.com>
680- Updated to 1.9.0 Final Release
681
682* Wed Dec 9 1998 Jeff Rush <jrush@taupro.com>
683- Original 1.9beta1 Release
Note: See TracBrowser for help on using the repository browser.