source: projects/specs/trunk/X/Xaw3d/Xaw3d-vl.spec @ 521

Revision 521, 10.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define compatlib 0
2
3Summary:        A version of the MIT Athena widget set for X.
4Summary(ja):    X 用 MIT Athena widget の 3D 風バージョン
5Name:           Xaw3d
6Version:        1.5E
7Release:        6%{?_dist_release}
8Group:          System Environment/Libraries
9Source:         ftp://ftp.visi.com/users/hawkeyd/X/Xaw3d-%{version}.tar.gz
10Source1:        ftp://ftp.x.org/contrib/widgets/Xaw3d/R6/Xaw3d-1.3.tar.gz
11Source2:        Imakefile
12URL:            ftp://ftp.visi.com/users/hawkeyd/X/
13
14# patch for compat libraries
15Patch0:         Xaw3d-1.1-shlib.patch
16Patch1:         Xaw3d-1.3-glibc.patch
17Patch2:         Xaw3d-1.3-X11R6.3.patch
18Patch3:         xaw3d.patch
19Patch4:         Xaw3d-1.3-static.patch
20Patch5:         Xaw3d-ia64.patch
21Patch6:         Xaw3d-1.5-i18n.patch
22Patch7:         Xaw3d-1.5-color.patch
23Patch8:         Xaw3d-1.5-troughColor.patch
24Patch9:         Xaw3d-1.3-misc.patch
25Patch10:        Xaw3d-1.5-scrollbar2.patch
26
27# patch for current libraries
28Patch50:        Xaw3d-1.5E-xorg-imake.patch
29
30License:        MIT
31Prereq:         fileutils
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33BuildRequires: libXmu-devel
34BuildRequires: libXt-devel
35BuildRequires: libSM-devel
36BuildRequires: libXext-devel
37BuildRequires: libX11-devel
38BuildRequires: libXpm-devel
39BuildRequires: imake
40BuildRequires: bison
41BuildRequires: flex
42BuildRequires: ed
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46
47%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
48
49%description
50Xaw3d is an enhanced version of the MIT Athena Widget set for
51the X Window System.  Xaw3d adds a three-dimensional look to applications
52with minimal or no source code changes.
53
54You should install Xaw3d if you are using applications which incorporate
55the MIT Athena widget set and you'd like to incorporate a 3D look into
56those applications.
57
58%description -l ja
59Xaw3d は X ウィンドウシステム用 MIT Athena ウィジェットセットの
60拡張バージョンです.Xaw3d はソースコードに殆ど,あるいは全く変更を
61加えることなく,アプリケーションに 3D ルックを追加することが出来ます.
62
63MIT Athena ウィジェットセットを使ったアプリケーションを利用していて,
64これらで 3D ルックを使いたい場合は,Xaw3d をインストールして下さい.
65
66%package -n compat32-%{name}
67Summary:        A version of the MIT Athena widget set for X.
68Summary(ja):    X 用 MIT Athena widget の 3D 風バージョン
69Group:          System Environment/Libraries
70Requires:       %{name} = %{version}-%{release}
71
72%description -n compat32-%{name}
73Xaw3d is an enhanced version of the MIT Athena Widget set for
74the X Window System.  Xaw3d adds a three-dimensional look to applications
75with minimal or no source code changes.
76
77You should install Xaw3d if you are using applications which incorporate
78the MIT Athena widget set and you'd like to incorporate a 3D look into
79those applications.
80
81%description -n compat32-%{name} -l ja
82Xaw3d は X ウィンドウシステム用 MIT Athena ウィジェットセットの
83拡張バージョンです.Xaw3d はソースコードに殆ど,あるいは全く変更を
84加えることなく,アプリケーションに 3D ルックを追加することが出来ます.
85
86MIT Athena ウィジェットセットを使ったアプリケーションを利用していて,
87これらで 3D ルックを使いたい場合は,Xaw3d をインストールして下さい.
88
89%package devel
90Summary:        Header files and static libraries for development using Xaw3d.
91Group:          Development/Libraries
92Requires:       %{name} = %{version}-%{release}
93Requires: libXmu-devel
94Requires: libXt-devel
95Requires: libSM-devel
96Requires: libXext-devel
97Requires: libX11-devel
98Requires: libXpm-devel
99
100%description devel
101Xaw3d is an enhanced version of the MIT Athena widget set for
102the X Window System.  Xaw3d adds a three-dimensional look to those
103applications with minimal or no source code changes. Xaw3d-devel includes
104the header files and static libraries for developing programs that take
105full advantage of Xaw3d's features.
106
107You should install Xaw3d-devel if you are going to develop applications
108using the Xaw3d widget set.  You'll also need to install the Xaw3d
109package.
110
111%description devel -l ja
112Xaw3d は X ウィンドウシステム用 MIT Athena ウィジェットセットの
113拡張バージョンです.Xaw3d はソースコードに殆ど,あるいは全く変更を
114加えることなく,アプリケーションに 3D ルックを追加することが出来ます.
115Xaw3d-devel パッケージには,Xaw3d の機能を最大限に利用するプログラムの
116開発に必要なヘッダファイルとスタティックライブラリが収められています.
117
118Xaw3d ウィジェットセットを使ったアプリケーション開発を行う場合は
119Xaw3d-devel パッケージをインストールして下さい.
120同時に Xaw3d もインストールしておく必要があります.
121
122%prep
123%setup -q -c
124
125# Xaw3d7
126pushd xc/lib/Xaw3d
127ln -s .. X11
128%patch50 -p0 -b .config
129popd
130
131# Xaw3d6 (compat libs)
132%if %{compatlib}
133%ifnarch ia64
134mkdir old
135pushd old
136tar xzf %{SOURCE1}
137popd
138mv old/xc/lib/Xaw3d xc/lib/Xaw3d6
139rm -rf old
140pushd xc/lib/Xaw3d6
141%patch0 -p0
142ln -s .. X11
143%patch1 -p4
144%patch2 -p3
145%patch3 -p4
146%patch4 -p0
147%patch6 -p4
148%patch7 -p3
149#%patch8 -p3
150%patch9 -p3
151#%patch10 -p4
152popd
153%endif
154%endif
155
156%build
157
158# Xaw3d7
159pushd xc/lib/Xaw3d
160#export PATH=/usr/X11R6/bin:$PATH
161xmkmf
162make CDEBUGFLAGS="${RPM_OPT_FLAGS} -DARROW_SCROLLBAR -DUSEGRAY"
163popd
164
165# Xaw3d6 (compat libs)
166%if %{compatlib}
167%ifnarch ia64
168cp %{SOURCE2} xc/lib/Xaw3d6
169pushd xc/lib/Xaw3d6
170xmkmf
171make CFLAGS="${RPM_OPT_FLAGS} -DARROW_SCROLLBAR -DUSEGRAY"
172popd
173%endif
174%endif
175
176%install
177rm -rf $RPM_BUILD_ROOT
178
179# Xaw3d7
180pushd xc/lib/Xaw3d
181make install DESTDIR=$RPM_BUILD_ROOT
182popd
183
184# Xaw3d6
185%if %{compatlib}
186%ifnarch ia64
187%__mkdir_p $RPM_BUILD_ROOT/usr/%{_lib}
188cp -aR xc/lib/Xaw3d6/libXaw*so.* $RPM_BUILD_ROOT/usr/%{_lib}/
189%endif
190%endif
191
192%clean
193rm -rf $RPM_BUILD_ROOT
194
195%post -p /sbin/ldconfig
196
197%postun -p /sbin/ldconfig
198
199%post -n compat32-%{name} -p /sbin/ldconfig
200
201%postun -n compat32-%{name} -p /sbin/ldconfig
202
203%files
204%defattr(-,root,root)
205/usr/%{_lib}/*.so.*
206
207%if %{build_compat32}
208%files -n compat32-%{name}
209%defattr(-,root,root)
210/usr/%{_lib}/*.so.*
211%endif
212
213%files devel
214%defattr(-,root,root)
215#/usr/X11R6/%{_lib}/*.a
216/usr/%{_lib}/*.so
217%{_includedir}/X11/Xaw3d
218#ghost /usr/X11R6/include/Xaw3d
219
220%changelog
221* Sun Jul 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5E-6
222- update Requires of -devel
223
224* Sat Jun  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5E-5
225- rebuilt with xorg-x11-7.3
226- updated BuildRequires
227- spec in UTF-8
228
229* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5E-4vl1
230- update to 1.5E
231- sync with fedora core's 1.5E-4
232  - import patches:
233    - misc.patch (patch9)
234    - scrollbar2.patch (patch10)
235    - xorg-imake.patch (patch50)
236
237  * Thu Jan 20 2005 Than Ngo <than@redhat.com> 1.5E-2
238  - enable ARROW_SCROLLBARS, MULTIPLANE_PIXMAPS
239
240  * Tue Nov 30 2004 Than Ngo <than@redhat.com> 1.5E-1
241  - update to 1.5E, #130310
242  - fix compiler warning #110766
243
244  * Tue Nov 23 2004 Than Ngo <than@redhat.com> 1.5-24
245  - add patch to fix build problem with xorg-x11, #140475
246
247  * Wed Nov 26 2003 Than Ngo <than@redhat.com> 1.5-20
248  - added missing Buildprereq: XFree86-devel (bug #110601, #109692, #110735)
249  - fixed arguments in scrollbar (bug #110766)
250
251- fix description devel -l ja
252- update URLs
253- add Vendor/Distribution tag
254
255* Sat Sep 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5-17vl4
256- add BuildRequires: XOrg-devel, bison, flex
257- add Requires: XOrg-devel (Xaw3d-devel)
258- mkdir $RPM_BUILD_ROOT/usr/X11R6/%%{_lib} before copy libraries
259
260* Sun May 21 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.5-17vl3
261- added compat32-Xaw3d package for x86_64 architecture support
262
263* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.5-17vl2
264- rebuild
265
266* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-17vl1
267- add patch7 to use grayscale color.
268- merged with rawhide release
269    * Thu Nov  7 2002 han Ngo <than@redhat.com> 1.5-17
270    - fix some building problems
271    * Thu Sep  5 2002 Preston Brown <pbrown@redhat.com> 1.5-16
272    - -DARROW_SCROLLBAR for rms
273    * Thu Aug  8 2002 Than Ngo <than@redhat.com> 1.5-15
274    - Added patch file to fix i18n issue, ynakai@redhat.com
275
276* Fri Jul 13 2001 <sagami@vinelinux.org>
277- 1.5-9vl3: use %%{ix86} for _arch instead of i386 :-)
278
279* Wed May 23 2001 Tomoya TAKA <tomoya@olive.plala.or.jp>
280- 1.5-9vl2
281- add i386 and alpha to libXaw*so.*'s link in %%install
282
283* Wed May 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
284- 1.5-9vl1
285- rebuilt for Vine Linux
286- added Japanese summary and description
287- added sparc, sparc64 to libXaw*so.*'s link in %%install
288  (this is taken from 1.5-8vl1 from VineSeed/TestPkg by Machino-san)
289
290* Wed Feb 28 2001 Than Ngo <than@redhat.com>
291- add requires Xaw3d = %%{version}
292- add prereq /sbin/ldconfig
293
294* Tue Oct 10 2000 Than Ngo <than@redhat.com>
295- fix link which causes faulty update (Bug #17895)
296
297* Mon Jul 24 2000 Bill Nottingham <notting@redhat.com>
298- ia64 tweaks
299
300* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
301- automatic rebuild
302
303* Mon Jul 10 2000 Bernhard Rosenkraenzer <bero@redhat.de>
304- Restore Xaw3d 1.5 - the addition of the backward compatibility library
305  killed the current one.
306- get rid of the CDEBUGFLAGS="" hack, the current gcc fixes it
307
308* Mon Jul 03 2000 Than Ngo <than@redhat.de>
309- fix Imakefile to static Xawd3d
310
311* Sat Jun 17 2000 Than Ngo <than@redhat.de>
312- add backward compatibility libXaw3d.so.6 (Bug# 12261)
313
314* Mon May 15 2000 Bill Nottingham <notting@redhat.com>
315- fix unaligned traps on ia64
316
317* Mon May  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
318- 1.5
319
320* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
321- auto rebuild in the new build environment (release 21)
322
323* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
324- Injected new description and group.
325
326* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
327- bumped spec number for initial rh 6.0 build
328
329* Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
330- added security/update patch from debian (the X11R6.3 patch). Thanks guys. :)
331
332* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
333- handle the symlink with triggers instead of getting rid of it
334
335* Mon Oct  5 1998 Jeff Johnson <jbj@redhat.com>
336- remove backward compatible symlink.
337
338* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
339- fixed the bad symlink
340- BuildRoot
341
342* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
343- translations modified for de, fr, tr
344
345* Tue Nov 04 1997 Erik Troan <ewt@redhat.com>
346- don't lave an improper return code from %pre
347
348* Mon Nov 03 1997 Cristian Gafton <gafton@redhat.com>
349- take care of the old location of the Xaw3d includes in case that one exist
350- updated Prereq: field
351
352* Mon Oct 26 1997 Cristian Gafton <gafton@redhat.com
353- fixed the -devel package for the right include files path
354
355* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
356- minor spec file cleanups
357
358* Wed Oct 01 1997 Erik Troan <ewt@redhat.com>
359- i18n widec.h patch needs to be applied on all systems
360
361* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
362- changed axp check to alpha
363
364* Mon Jun 16 1997 Erik Troan <ewt@redhat.com>
365- built against glibc
Note: See TracBrowser for help on using the repository browser.