source: projects/specs/trunk/X/Xautoconfig/Xautoconfig-vl.spec @ 521

Revision 521, 5.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define      version 0.23
2
3Summary:     xorg.conf file generator for the X Window System.
4Summary(ja): X Window System ÍÑ xorg.conf ¥Õ¥¡¥¤¥ëÀ¸À®¥Ä¡¼¥ë
5
6Name:        Xautoconfig
7Version:     %{version}
8Release:     1vl12
9License:     distributable
10Group:       User Interface/X Hardware Support
11Source:      ftp://www.penguinppc.org/projects/xautocfg/%{name}-%{version}.tar.gz
12Patch0:      Xautoconfig.c.patch
13Patch1:      Xautoconfig.pci.c.patch
14Patch2:      Xautoconfig-mods.patch
15Patch3:      Xautoconfig-0.23-modeline.patch
16Patch4:      Xautoconfig-0.23-pm112.patch
17
18Patch100:    %{name}-%{version}-vine12.patch
19
20BuildRoot:   %{_tmppath}/%{name}-%{version}-root
21
22#Requires:    XOrg >= 6.9
23Obsoletes:   Xautoconfig4
24Conflicts:   cairo < 1.2.2-0vl3
25
26
27%description
28Xautoconfig generates a valid xorg.conf file under any hardware
29setup that is using the Linux framebuffer.
30
31%description -l ja
32Xautoconfig ¤Ï¡¢¥Õ¥ì¡¼¥à¥Ð¥Ã¥Õ¥¡¤ò»È¤Ã¤Æµ¯Æ°¤µ¤ì¤¿¥·¥¹¥Æ¥à¤Ç
33xorg.conf ÀßÄê¥Õ¥¡¥¤¥ë¤òÀ¸À®¤¹¤ë¥Ä¡¼¥ë¤Ç¤¹¡£
34
35
36%prep
37%setup -q
38
39%patch0 -p0
40%patch1 -p1
41%patch2 -p1
42%patch3 -p1
43%patch4 -p1
44
45%patch100 -p1
46
47
48%build
49export CFLAGS="$RPM_OPT_FLAGS"
50make
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55mkdir -p $RPM_BUILD_ROOT/usr/X11R6/bin
56install -m755 Xautoconfig $RPM_BUILD_ROOT/usr/X11R6/bin/Xautoconfig
57pushd $RPM_BUILD_ROOT/usr/X11R6/bin
58ln -s Xautoconfig Xautoconfig4
59popd
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%files
67%defattr(-,root,root)
68%doc COPYING
69/usr/X11R6/bin/Xautoconfig
70/usr/X11R6/bin/Xautoconfig4
71
72
73%changelog
74* Wed Oct 18 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl12
75- modify Patch100 (disable fbdev driver for ati rage cards)
76
77* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl11
78- modify Patch100
79  cairo-1.2.2-0vl3 now can handle 15bpp,
80  so depth is set to 15 when anaconda == 1
81
82* Sun Sep 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl10
83- modify Patch100 (handle PCI_CLASS_DISPLAY_OTHER)
84
85* Sun Sep 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl9
86- minor fix (interactive mode is now obsolete)
87
88* Sat Sep 09 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl8
89- modified Patch100 (don't use UseMode)
90- do not actually require XOrg (although it doesn't mean a thing)
91
92* Mon Sep 04 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl6
93- modified Patch100 (revert the change on 0.23-1vl4)
94
95* Mon Sep 04 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl5
96- modified Patch100 (revert depth from 15 to 16 when anaconda == 1)
97
98* Mon Sep 04 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl4
99- modified Patch100 (fbdev = 0 even when anaconda==1)
100
101* Mon Sep 04 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl3
102- modified Patch100 (more safe XConfig.test when anaconda==1)
103
104* Sun Sep 03 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl2
105- modified Patch100 (depth is always 15 when anaconda==1)
106
107* Sun Sep 03 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.23-1vl1
108- added Patch100 for Vine Linux
109
110* Fri Oct 7 2005 Owen Stampflee <ostampflee@terrasoftsolutions.com>
111- dont write modes, X works better without 'em
112
113* Wed Sep 14 2005 Dan Burcaw <dan@ydl.net>
114- no longer try to load glx & record modules
115- updated spec summary & description for xorg
116
117* Thu Sep  8 2005 Owen Stampflee <ostampflee@terrasoftsolutions.com>
118- re-add the old patch to write xorg.conf
119
120* Wed Aug 10 2005 Tim Renner <trenner@terrasoftsolutions.com>
121- Fix byte/word problem in pci.c w/ pci.c.patch
122
123* Mon Sep 27 2004 Owen Stampflee <ostampflee@terrasoftsolutions.com>
124- fix breakage
125
126* Sun Sep 26 2004 Dan Burcaw <dan@ydl.net>
127- 0.23
128
129* Fri Aug 29 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
130- 0.22
131
132* Sun Mar 16 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
133- 0.21
134
135* Wed Mar 12 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
136- 0.20
137
138* Mon Mar 10 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
139- a few more anaconda cleanups
140
141* Sat Mar 08 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
142- a few more anaconda cleanups
143
144* Fri Mar 07 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
145- write config /tmp/XF86Config.test in anaconda mode
146
147* Mon Mar 03 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
148- 0.19 release
149
150* Sun Mar 02 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
151- 0.18 release
152
153* Sat Feb 22 2003  Dan Burcaw <dburcaw@terrasoftsolutions.com>
154- fixed requires mouseconfig/kbdconfig -> r-c-mouse/keyboard
155
156* Mon Jan 27 2003 Dan Burcaw <dburcaw@terrasoftsolutions.com>
157- minor cosmetic fix
158
159* Sat Oct 26 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
160- 0.17 release
161
162* Thu Oct 17 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
163- don't provide Xconfigurator; conflicts with redhat-config-xfree86
164
165* Sat Oct 12 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
166- provide anaconda subpackage for YDL
167
168* Fri Oct 11 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
169- update to 0.16 release
170- don't ship rc script or perl script.
171- various changes, see ChangeLog
172
173* Sun Feb 24 2002 Dan Burcaw <dburcaw@terrasoftsolutions.com>
174- update to 0.15 release
175
176* Thu Oct 11 2001 Dan Burcaw <dburcaw@terrasoftsolutions.com>
177- 0.14: last merge from Rini before maintainer change.
178
179* Wed Dec 20 2000 Tom Rini <trini@kernel.crashing.org>
180- Add Xautoconfig.initd
181
182* Sun Dec 10 2000 Tom Rini <trini@kernel.crashing.org>
183- Add Xautoconfig_wrapper.pl
184
185* Fri Nov 24 2000 Tom Rini <trini@kernel.crashing.org>
186- Updates for Xautoconfig{3,4}
187
188* Wed Aug 04 1999 Tom Rini <trini@kernel.crashing.org>
189- created
Note: See TracBrowser for help on using the repository browser.