source: projects/specs/trunk/W/WindowMaker/WindowMaker-vl.spec @ 8949

Revision 8949, 23.3 KB checked in by Takemikaduchi, 10 years ago (diff)

cmemo,compiz: rebuild
others: new upstream release

Line 
1%define version 0.95.6
2%define vsource WindowMaker-%{version}-vine
3%define libdockapp libdockapp-0.4.0
4%define asclock asclock-2.0.12
5%define wmconfig wmconfig-vine-1.1
6%define wmmail 0.63a
7%define x11confdir %{_sysconfdir}/X11
8%define gnustepdir %{_prefix}/lib/GNUstep
9
10Summary: Window Maker - a window manager for X11
11Summary(ja): X11 用ウィンドウ・マネージャ
12Name: WindowMaker
13Version: %{version}
14Release: 1%{?_dist_release}
15License: GPLv2/OPL
16Group: User Interface/Desktops
17URL: http://windowmaker.info/
18Source0: %{name}-%{version}.tar.gz
19Source1: http://www.longstreet.ch/asclock/%{asclock}.tar.gz
20Source2: %{libdockapp}.tar.bz2
21Source6: %{vsource}.tar.gz
22
23# http://www.eecg.utoronto.ca/cgi-bin/cgiwrap/chanb/www/wmmail
24Source10: WMMail.app-%{wmmail}.tar.gz
25Source11: WMMail.defaults.vine
26
27Source20: %{wmconfig}.tar.bz2
28Source21: dockit
29Source22: WindowMaker.desktop
30Source23: RunWM
31
32#Patch1: WindowMaker-0.62.0-wmclock.patch
33Patch7: WindowMaker-0.95.6-wheel.diff.gz
34Patch10: WindowMaker-0.95.6-GSDIR.patch
35Patch20: WMMail.app-%{wmmail}-fix.patch
36Patch21: WMMail-%{wmmail}.mbox.patch
37Patch22: WMMail-%{wmmail}.appsdir.patch
38
39######################
40##### for 0.92.0 #####
41
42## for x86_64 architecture support
43Patch31: libdockapp-0.4.0-config.sub.patch
44
45## for gcc-4
46Patch41: WMMail.app-0.63a.config.patch
47Patch42: asclock-2.0.12.patch
48
49# libPropList is not necessary for Window Maker >= 0.70, but
50# for items around WindowMaker.
51BuildRequires: libPropList
52BuildRequires: automake automake14
53BuildRequires: autoconf >= 2.59
54BuildRequires: libtool
55
56BuildRequires: imake
57BuildRequires: libX11-devel
58BuildRequires: libXmu-devel
59BuildRequires: libXft-devel
60BuildRequires: libXinerama-devel
61BuildRequires: libXrandr-devel
62BuildRequires: libICE-devel
63BuildRequires: libXpm-devel
64
65BuildRequires: libjpeg-turbo-devel
66BuildRequires: libtiff-devel
67BuildRequires: libwebp-devel
68BuildRequires: ImageMagick-devel
69
70Requires: WindowMaker-libs = %{version}
71#Requires: libPropList >= 0.10.0
72Requires: WindowMaker-Icons, vine-backgrounds, cpp
73Requires: vine-logos, vutils, sed
74Requires: xterm
75Requires: xorg-x11-jpfonts
76
77Provides: libwraster.so.2
78Buildroot: %{_tmppath}/%{name}-%{version}-root
79
80%description
81WindowMaker is a window manager designed to emulate the look
82and feel of part of the NEXTSTEP(tm) GUI. It is supposed to be fast,
83relatively small, feature rich and easy to configure, with
84a simple and elegant appearance borrowed from NEXTSTEP(tm).
85
86%description -l ja
87NEXTSTEP(tm)のようなルック&フィールのウィンドウマネージャです。
88動作が軽く、また強力なカスタマイズ・ツールを装備しています。
89
90WindowMakerをインストール後、各クライアントで /usr/bin/wmaker.inst を
91実行してください。既に ~/GNUStep が存在する場合には、それを置き換えるか聞い
92て来ます。最後に .xinitrc を作るか聞いてきます。既に startx できる環境が作ら
93れている場合には、[Cntl]+C でキャンセルした方が良いかもしれません。
94
95%package libs
96Summary: Libraries bundled with WindowMaker
97Summary(ja): WindowMaker に必要なライブラリ集
98Group: System Environment/Libraries
99
100%description libs
101These libraries come bundled with WindowMaker, but are also used
102in other packages like AfterStep-APPS and wmakerconf
103
104%description libs -l ja
105このライブラリ集はWindowMakerに含まれているものです。
106wmakerconf や wdm 等にも必要です。
107
108%package devel
109Summary: Development files using WindowMaker related libraries
110Group: Development/Libraries
111Requires: WindowMaker-libs = %{version}
112
113%description devel
114This package contains the WindowMaker related library and header files
115used for developers.
116
117%description devel -l ja
118このパッケージは,WindowMaker のライブラリを利用したアプリケーション開発
119に必要なライブラリやヘッダファイルを含んでいます.
120
121
122%prep
123%setup -q -a 1 -a 2 -a 6 -a 10 -a 20 -n WindowMaker-%{version}
124%patch7 -p1 -b .wheel
125%patch10 -p1 -b .gsdir
126%patch20 -p0
127
128cd WMMail.app-%{wmmail}
129patch -p0 -s < %PATCH21
130patch -p1 -s < %PATCH22
131cd ..
132
133# for x86_64 architecture support
134%ifarch x86_64
135%patch31 -p0 -b .libdockapp
136%endif
137
138## for gcc-4
139%patch41 -p0 -b .config
140%patch42 -p0 -b .asclock
141
142%build
143aclocal
144autoheader
145autoconf
146libtoolize --force --automake
147automake -a --gnu --include-deps
148
149export LINGUAS; LINGUAS="de es fr it ja"
150export NLSDIR; NLSDIR=%{_localedir}
151export GNUSTEP_LOCAL_ROOT; GNUSTEP_LOCAL_ROOT='%{gnustepdir}'
152export CPP_PATH; CPP_PATH=/lib/cpp
153export CFLAGS; CFLAGS="$RPM_OPT_FLAGS"
154%configure --sysconfdir=%{x11confdir} --x-libraries=%{_libdir}
155make %{?_smp_mflags}
156
157## make libdockapp
158cd %{libdockapp}
159        aclocal
160        autoconf 
161        libtoolize --force --automake
162        automake -a --gnu --include-deps
163        %configure
164        make
165cd ..
166
167## make asclock
168cd %{asclock}
169        mkdir ./default_theme
170        cd ./default_theme
171        ln -sf ../themes/shaped/beats.xpm beats.xpm
172        ln -sf ../themes/shaped/clock.xpm clock.xpm
173        ln -sf ../themes/shaped/config config
174        ln -sf ../themes/shaped/date.xpm date.xpm
175        ln -sf ../themes/shaped/hour.xpm hour.xpm
176        ln -sf ../themes/shaped/led.xpm led.xpm
177        ln -sf ../themes/shaped/minute.xpm minute.xpm
178        ln -sf ../themes/shaped/second.xpm second.xpm
179        ln -sf ../languages/japanese/month.xpm month.xpm
180        ln -sf ../languages/japanese/weekday.xpm weekday.xpm
181        cd ..
182        ln -sf asclock.man wmclock.man
183        xmkmf
184        make clean
185        make
186cd ..
187
188## make wmmail
189cd WMMail.app-%{wmmail}
190        aclocal-1.4
191        automake-1.4 -a -c --gnu --include-deps
192        autoconf
193        %configure
194        make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-L%{_libdir}"
195cd ..
196
197
198%install
199rm -rf %{buildroot}
200%define SYSDEFDIR %{x11confdir}/WindowMaker/
201mkdir -p %{buildroot}%{SYSDEFDIR}
202
203%makeinstall nlsdir=%{buildroot}%{_localedir}
204
205for i in $(ls */README) ; do
206    echo $i | sed -e "s|\(.*\)/\(.*\)|\2\.\1|" | xargs cp $i
207done
208make install DESTDIR=%{buildroot} -C %{asclock}
209
210# install config files for Vine
211make DESTDIR=%{buildroot} SYSDEFDIR=%{SYSDEFDIR} install -C %{vsource}
212ln -s %{_libdir}/firefox-3.0/icons/default48.png \
213        %{buildroot}%{_datadir}/WindowMaker/Icons/firefox48.png
214
215# set default menubutton for PPC
216%ifarch ppc
217pushd %{buildroot}%{SYSDEFDIR}
218sed -e "s/MouseLeftButtonAction\ =\ SelectWindows/MouseLeftButtonAction\ =\ OpenApplicationsMenu/" \
219    -e "s/MouseRightButtonAction\ =\ OpenApplicationsMenu/MouseRightButtonAction\ =\ SelectWindows/" \
220    WindowMaker > WindowMaker.ppc
221    mv -f WindowMaker.ppc WindowMaker
222popd
223%endif
224
225# install wmconfig items
226make DESTDIR=%{buildroot} install -C %{wmconfig}
227
228# install libdockapp
229make DESTDIR=%{buildroot} install -C %{libdockapp}
230
231# install WMMail.app
232(
233        cd WMMail.app-%{wmmail}
234        %makeinstall
235        #install sound file and pixmaps of WMMail.app
236        WMMailDIR=%{buildroot}/%{gnustepdir}/Applications/WMMail.app/
237        mkdir -p ${WMMailDIR}/Sounds/
238        mkdir -p ${WMMailDIR}/Anims/{NeXT,asmail,e,monitor-e}
239        cp Sounds/*.au ${WMMailDIR}/Sounds/
240        for dir in NeXT asmail e monitor-e; do
241            cp Anims/${dir}/*.xpm ${WMMailDIR}/Anims/${dir}
242        done
243        #install config file of WMMail.app for Vine Linux
244        cp %{SOURCE11} %{buildroot}/%{SYSDEFDIR}/WMMail
245        #install dockit
246        install -m 755 %{SOURCE21} %{buildroot}%{_bindir}
247        # prepare docs
248        pwd
249        mkdir ../WMMail.app
250        cp -p AUTHORS COPYING ChangeLog INSTALL NEWS README Defaults/WMMail ../WMMail.app
251)
252
253# provide libwraster.so.2 tentatively
254ln -sf libwraster.so.3 %{buildroot}%{_libdir}/libwraster.so.2
255
256# added for 0.9.2
257pushd %{buildroot}/%{_includedir}
258        mkdir -p WINGs
259        mv WINGs.h WINGsP.h WUtil.h WINGs/
260popd
261
262# install WindowMaker.desktop
263install -d %{buildroot}%{_datadir}/xsessions
264install -m 644 %{SOURCE22} %{buildroot}%{_datadir}/xsessions/
265install -m 755 %{SOURCE23} %{buildroot}%{_bindir}
266
267# remove unpackaged files
268rm -rf %{buildroot}%{_sysconfdir}/WindowMaker
269rm -rf %{buildroot}%{_libdir}/*.la
270rm -rf %{buildroot}%{_libdir}/*.a
271
272
273%clean
274rm -rf %{buildroot}
275
276%pre libs
277# Script to support upgrade from old directory tree
278# This will be removed in near future...
279SYSDEFDIR=%{x11confdir}/WindowMaker
280if [ -L ${SYSDEFDIR} ]; then
281 rm -f ${SYSDEFDIR}
282fi
283
284# The below seems to be necessary to suppress warning in updates....
285OLDDEFDIR=%{_datadir}/WindowMaker/Defaults
286if [ -d ${OLDDEFDIR} ]; then
287 rm -f ${OLDDEFDIR}/*
288fi
289
290%triggerin -- ppxp
291SYSDEFDIR=%{x11confdir}/WindowMaker
292cd ${SYSDEFDIR}
293rm WMState
294ln -sf WMState.ppxp WMState
295
296%triggerun -- ppxp
297[ $2 = 0 ] || exit 0
298SYSDEFDIR=%{x11confdir}/WindowMaker
299cd ${SYSDEFDIR}
300rm WMState
301
302
303%post libs -p /sbin/ldconfig
304%postun libs -p /sbin/ldconfig
305
306%files
307%defattr(-,root,root)
308%doc AUTHORS BUGFORM BUGS COPYING* ChangeLog FAQ FAQ.I18N INSTALL
309%doc NEWS README* TODO
310%config %{_datadir}/xsessions/WindowMaker.desktop
311%{x11confdir}/WindowMaker/*
312%{_bindir}/*.sh
313%{_bindir}/RunWM
314%{_bindir}/wmclock
315%{_bindir}/convertfonts
316%{_bindir}/geticonset
317%{_bindir}/getstyle
318%{_bindir}/seticons
319%{_bindir}/setstyle
320%{_bindir}/wkdemenu.pl
321%{_bindir}/wm-oldmenu2new
322%{_bindir}/wmagnify
323%{_bindir}/wmaker
324%{_bindir}/wmaker.inst
325%{_bindir}/wmgenmenu
326%{_bindir}/wmiv
327%{_bindir}/wmmenugen
328%{_bindir}/wmsetbg
329%{_bindir}/wxcopy
330%{_bindir}/wxpaste
331%{_datadir}/WINGs/
332%{_datadir}/WindowMaker/
333%{_mandir}/*/*
334%{_localedir}/*/*/*
335%{gnustepdir}/Applications/WPrefs.app/
336%{_libdir}/pkgconfig/
337
338%{gnustepdir}/Applications/WMMail.app/
339%doc WMMail.app/
340%{_bindir}/dockit
341
342%files libs
343%defattr(-,root,root)
344%{_bindir}/get-wings-flags
345%{_bindir}/get-wraster-flags
346%{_bindir}/get-wutil-flags
347%{_bindir}/wdread
348%{_bindir}/wdwrite
349%{_libdir}/lib*.so.*
350
351%files devel
352%defattr(-,root,root)
353%{_includedir}/WINGs
354%{_includedir}/WMaker.h
355%{_includedir}/dockapp.h
356%{_includedir}/wraster.h
357%{_libdir}/lib*.so
358
359
360%changelog
361* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.95.6-1
362- update to 0.95.6
363- update Patch7 (WindowMaker-0.95.6-wheel.diff.gz)
364- update Patch10 (WindowMaker-0.95.6-GSDIR.patch)
365- remove Patch4 (WindowMaker-cvs-nomisc.patch)
366- remove Patch30 (WindowMaker-0.92.0-configure.noasm.patch)
367- remove Patch40 (WindowMaker-0.92.0-x86_specific.patch)
368- drop static library
369- add BuildRequires: libjpeg-turbo-devel, libtiff-devel, libwebp-devel, ImageMagick-devel
370
371* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 0.92.0-8
372- rebuilt
373
374* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92.0-7
375- rebuild with rpm-4.8.1 for pkg-config file
376
377* Mon Feb 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-6
378- putback static libraries
379
380* Sun Feb 21 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-5
381- rebuilt with new toolchain
382
383* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.92.0-4vl5
384- added libdockapp-0.4.0-config.sub.patch
385- dropt static library
386
387* Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.92.0-3vl5
388- changed libs Group to System Environment/Libraries
389- updated SOURCE23 (for AfterStep)
390
391* Sat Jun 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-2vl5
392- added WMMail.app-0.63a.config.patch
393- fixed WMMail.defaults.vine
394- fixed wmconfig-vine-1.1.tar.bz2
395- added symbolic link to %%{_libdir}/firefox-3.0/icons/default48.png
396- updated WindowMaker-0.92.0-vine to WindowMaker-0.92.0-vine.5a1
397        - fixed Defaults/WMWindowAttributes
398        - fixed Defaults/WMState*
399        - fixed BINDIR path in Makefile
400        - added bin/tknamazu.sh
401- updated asclock to 2.0.12
402        - dropt WindowMaker-0.62.0-wmclock.patch
403        - dropt asclock-jp.patch
404        - added asclock-2.0.12.patch
405
406* Mon Jun 02 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-1vl5
407- applied new versioning policy and utf-8
408- added BuildRequires: xorg-x11-devel imake
409- added Source23: RunWM (import from xinitrc-3.46-0vl1)
410- dropt Requires: xinitrc
411- fixed Source6: %{vsource}.tar.gz
412- fixed Source20: wmconfig-vine-1.1.tar.bz2
413- fixed Source22: WindowMaker.desktop
414
415* Mon Aug 20 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl10
416- added Patch40: WindowMaker-0.92.0-x86_specific.patch (from FC7 cvs20060123.patch)
417
418* Sun Aug 19 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl9
419- changed URL to http://windowmaker.info
420- added BuildPreReq: libtool, automake14
421- dropt patch40: %{vsource}.font.patch
422- updated Source6: %{vsource}.tar.gz
423        - added xterm item to menu
424        - changed mozilla to firefox in menu
425        - fixed fontset scripts
426
427* Tue Oct 17 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl7
428- dropt Requires: wmconfig
429
430* Sun Oct 15 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl6
431- added patch40: WindowMaker-0.92.0-vine.font.patch
432- fixed WMMail.app path in WMMail.defaults.vine
433
434* Fri Mar 10 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl5
435- fixed building error of WMMail.app for x86_64
436- fixed GNUstep/Applications directory for x86_64
437
438* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl4
439- rebuild for VineSeed
440- added x86_64 architecture support
441- added WindowMaker-0.92.0-configure.noasm.patch for x86_64
442
443* Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl3
444- new upstream release WindowMaker-0.92.0
445- added WindowMaker.desktop for gdm session
446- added WindowMaker-0.92.0-vine.tar.gz (replaced WindowMaker-0.91.0-vine31.tar.bz2)
447- added BuildPreReq: automake17
448- dropt WindowMaker-0.51.0-areas.patch -- no source
449- dropt WindowMaker-0.62.0-wmclock.patch -- fixed
450- dropt WindowMaker-0.64.0-wsetfont.patch -- changed source
451- dropt wmaker-xim-xft.patch -- fixed
452- dropt wmaker-xim-cvs20040509.patch -- fixed
453- changed WINGs headers to originals (next 2 patches are not needed)
454- dropt WindowMaker-0.64.0-WUtilPath.patch
455- dropt WindowMaker-cvs-src.build.patch
456
457* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl3
458- change menu messages code from EUC to UTF-8
459
460* Tue Nov 09 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl2
461- modified vsource
462
463* Wed Nov 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl1
464- source update
465- provides libwraster.so.2 tentatively.
466  until rebuild wdm, wmakerconf and WMSoundSet
467
468* Thu May 13 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.80.2-0vl2.1
469- TEST update source cvs-20040509
470
471* Sun Jul 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.80.2-0vl2
472- fixed spec file to build with automake-1.5 and current autoconf
473
474* Tue Nov 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.2-0vl1
475- new upstream release
476  - An exploitable buffer overrun bug has been found in Window Maker
477    recently. This release fixes the problem.
478
479* Sun Sep 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl10
480- vsource updated (linuxconf -> Webmin, vedit -> gedit)
481
482* Wed Jul 17 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl9
483- fix include path in WINGs related include files
484
485* Thu Jul 11 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl8
486- apply xim patch, wmaker-xim-0.80.0.patch.txt
487
488* Thu Mar 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.0-0vl7
489- update WindowMaker-0.80.0-vine25
490  - remove netscape and vedit, add mozilla and gedit
491  - add background image
492  - change some window color
493
494* Thu Mar 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl6
495- yet another typo fix. Doh...
496
497* Wed Mar 13 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl5
498- modified %install section (%ifarch ppc line contained typo)
499
500* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl4
501- enable CirculateRaise
502- ver.up ja.po
503
504* Sun Feb 10 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl3
505- back to WMMail-0.63a and merge some diffs from 0.64
506
507* Fri Feb  8 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl2
508- ja.po 更新 (WindowMaker-0.80.0ja2)
509- change option name around MouseButton in Defaults/WindowMaker to new one.
510
511* Thu Feb  7 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl1
512- ver.up
513- build with XFree-4.2
514
515* Sun Aug 05 2001 <sagami@vinelinux.org>
516- 0.65.1-0vl2:
517- don't apply guessfont.patch, which is no longer neeeded
518- split correctly WINGs stuff (wdm) into libs subpackage
519- consequently, move pre script to libs (shouldn't be removed in near future?)
520- PreReq: WindowMaker-libs = %%{version} for main package (Wow!!!)
521
522* Thu Jul 26 2001 <sagami@vinelinux.org>
523- 0.65.1-0vl1: update to 0.65.1 and regenerate patches
524
525* Sat Jun 23 2001 Jun Nishii <jun@vinelinux.org> 0.65.0-0vl3
526- update ja.po
527
528* Thu Jun 07 2001 <sagami@vinelinux.org>
529- 0.65.0-0vl2: handle non existent GNUSTEP_USER_ROOT directory
530
531* Mon May 21 2001 Jun Nishii <jun@vinelinux.org>
532- 0.65.0-0vl1
533- update WMMail.app to ver. 0.64
534- separate devel subpackage
535
536* Mon May 14 2001 Shoji Matsumoto <shom@vinelinux.org>
537- 0.64.0-0vl3
538- modify WindowMaker-0.62.1-vine6 to vine7 (add MozillaImStatus config)
539
540* Mon Apr 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
541- 0.64.0-0vl2
542- fixed WUtil.h path in WINGS.h
543
544* Mon Feb 26 2001 Jun Nishii <jun@vinelinux.org>
545- 0.64.0-0vl1
546
547* Thu Feb 08 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
548- added defattr to separated lib subpackage
549
550* Thu Feb  8 2001 Jun Nishii <jun@vinelinux.org>
551- 0.63.1-0vl4
552- separate libs subpackage
553
554* Wed Jan 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
555- 0.63.1-0vl3
556- change ${SYSDEFDIR} -> %{SYSDEFDIR} in %ifarch ppc lines
557
5581 Jun Nishii <jun@vinelinux.org>
559- 0.63.1-0vl2
560- more macros in spec
561- update WINGs patch
562
563* Sat Jan 13 2001 Jun Nishii <jun@vinelinux.org>
564- 0.63.1-0vl1
565- version up
566
567* Tue Oct 10 2000 Jun Nishii <jun@vinelinux.org>
568- 0.62.1-0vl8
569- bug fix in plmenu.ja
570
571* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
572- 0.62.1-0vl7
573- change icon of sylpheed
574
575* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
576- 0.62.1-0vl6
577- set font as alias-fixed
578
579* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
580- 0.62.1-0vl5
581- obsletes vmail and use sylpheed
582
583* Thu Aug 31 2000 Jun Nishii <jun@vinelinux.org>
584- 0.62.1-0vl4
585- change backbground path (use vine-backgrounds)
586
587* Sun Aug 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
588- 0.62.1-0vl3
589- swap default mousebutton if ppc
590  (PowerMac's default mouse has only one button...)
591
592* Wed Aug 16 2000 Jun Nishii <jun@vinelinux.org>
593- rename mozilla.sh as netscape.sh
594- use brp
595- added dockit
596
597* Mon Apr  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
598- updated to 0.62.1
599
600* Sun Apr  2 2000 Jun Nishii <jun@vinelinux.org>
601- added libdockapp instead of docklib
602
603* Fri Mar 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
604- updated to 0.62.0
605- added docklib src from 0.61.1
606- modified ja.po for WindowMaker and WMPrefs
607
608* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
609- bug fix of WINGs_im patch by Mr. Furukawa
610
611* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
612- bug fix of installation process of Makefile in WindowMaker-0.61.1vine7
613
614* Thu Dec 30 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine)
615- rel.9
616- added WINGs_im patch to support XIM in WINGs tool kits.
617
618* Fri Dec  3 1999 Jun Nishii <jun@flatout.org>
619- use rm --force in %post
620- Do not use birthwindow.patch which may cause incorrect window placement.
621
622* Fri Nov 26 1999 Jun NISHII <jun@flatout.org>
623- fix autostart.sh to check wsoundserver and wmsound
624- ver up wmconfig-vine
625- some other minor changes...
626
627* Fri Nov 12 1999 Jun Nishii <jun@flatout.org>
628- rel.6
629- added wheel patch
630- bug fix in mozilla.sh
631
632* Thu Nov 11 1999 Jun Nishii <jun@flatout.org>
633- rel.5
634- requires vutils instead of vsetup
635
636* Wed Nov 10 1999 Jun Nishii <jun@flatout.org>
637- rel.4
638- change menu
639- requires vsetup
640
641* Tue Nov  9 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine, JP-3)
642- use font guess patch instead of Japanese font patch
643- remove japanese fontset from default font-set
644
645* Thu Oct 14 1999 Jun Nishii <jun@flatout.org>
646- added dockapp.h
647
648* Sat Oct 9 1999 Jun Nishii <jun@flatout.org>
649- 0.61.1
650
651* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
652- added mozilla.sh
653
654* Sun Sep 26 1999 Jun Nishii <jun@flatout.org>
655- change default font-sets
656
657* Tue Sep 21 1999 Jun Nishii <jun@flatout.org>
658- use Default.style_kai instead of Default.style
659- install libdockapp
660
661* Wed Jul 21 1999 Jun Nishii <jun@flatout.org>
662- move to new directory structure (defaults in /etc/X11/WindowMaker)
663
664* Tue Jul 20 1999 Jun Nishii <jun@flatout.org>
665- build for Vine-1.9
666
667* Sun Jun 6 1999 Jun Nishii <jun@flatout.org>
668- merged patch for wsetfont to support MultiByteText
669- modify default font setting
670- launch netscape from autostart.sh
671
672* Fri Jun 4 1999 Jun Nishii <jun@flatout.org>
673- updated to 0.60.0
674
675* Fri Apr 23 1999 Jun Nishii <jun@flatout.org>
676- updated to 0.53.0
677
678* Thu Mar 25 1999 Jun Nishii <jun@flatout.org>
679- patch to fix focus
680
681* Sun Mar 14 1999 Jun Nishii <jun@flatout.org>
682- updated to 0.51.2
683
684* Fri Mar 12 1999 Jun Nishii <jun@flatout.org>
685- rel.11
686- bug fix of the wrapper of wmconfig
687
688* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
689- rel.10
690- added wrapper of wmconfig to support dummy NLS
691
692* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
693- rel.9
694- asclock-jp.patch and WindowMaker-birthwindow.patch by Yasuyuki Furukawa
695- remove xfig from menu
696
697* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
698- rel.8
699- bug fix in menu items which require root privilege (use su -)
700
701* Sun Feb 28 1999 Jun Nishii <jun@flatout.org>
702- rel.7
703- use plmenu.ja as a default menu
704
705* Thu Feb 25 1999 Jun Nishii <jun@flatout.org>
706- rel.6
707- stop autoraise
708
709* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
710- rel.5
711- added patch for WMMail not to down when no /var/spool/mail/$USER
712
713* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
714- rel.4
715- merge WMMail.app
716- dock WMMail if no xppxpm
717- fix bug that kterm doesn't start from dock after restart WM.
718- added plmenu.ja
719
720* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
721- rel.3
722- set BuggyApplication for xppxp in Dock which enables no warning when
723  xppxp is not installed
724- move Themes for Vine to WindowMaker-Icons
725
726* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
727- rel.2
728- modify menu, Dock, and etc for Vine 1.0
729
730* Fri Jan 29 1999 Jun Nishii <jun@flatout.org>
731- updated to 0.51.0
732
733* Wed Jan 27 1999 Jun Nishii <jun@flatout.org>
734- rel.4
735- customize some key bindings
736- remove xterm from menu.ja
737- make default iconsize 56x56
738
739* Thu Jan 14 1999 Jun Nishii <jun@flatout.org>
740- rel.3
741- use /lib/cpp which is a wrapper to choose one by gcc or egcs
742- typo fix in WPrefs.ja.po
743
744* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
745- rel.2
746- use gcc -E instead of /lib/cpp
747
748* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
749- updated to 0.50.2
750
751* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
752- updated to 0.50.1
753
754* Fri Jan 8 1999 Jun Nishii <jun@flatout.org>
755- updated to 0.50.0
756
757* Sun Dec 27 1998 Jun Nishii <jun@flatout.org>
758- added patch, new_nifty_pixmap-gradient.patch
759
760* Sun Dec 20 1998 Jun Nishii <jun@flatout.org>
761- modify menu and other default settings
762- added new themes
763
764* Fri Dec 11 1998 Jun Nishii <jun@flatout.org>
765- modified ja.po for WindowMaker and WPrefs
766- added config files for Vine Linux
767
768* Sat Dec 5 1998 Jun Nishii <jun@flatout.org>
769- updated to 0.20.3
770- added and modified ja.po for WindowMaker and WPrefs
771- make and merge patch to support nls for more messages
772
773* Mon Nov 30 1998 Jun Nishii <jun@flatout.org>
774- Moved Japanese catalog from ja_JP.ujis to ja
775
776* Tue Nov 24 1998 Jun Nishii <jun@flatout.org>
777- updated to 0.20.2
778
779* Mon Nov 23 1998 Jun Nishii <jun@flatout.org>
780- enable kanji for Vine Linux
781
782* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
783- fixed swicthing to other window managers problem
784- updated to 0.20.1
785- include all the .mo files, not just WindowMaker...
786- added an older version of asclock as wmclock
787- include libPropList.a in the %files
788
789* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
790- version 0.91.3
791
792* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
793- version 0.19.2
794- don't require asclock as a separate package
795
796* Wed Aug 12 1998 Cristian Gafton <gafton@redhat.com>
797- upgraded to 0.17.5
798
799* Tue Jul 21 1998 Cristian Gafton <gafton@redhat.com>
800- updated to 0.17.2
801
802* Thu Jul 09 1998 Cristian Gafton <gafton@redhat.com>
803- updated to 0.16.1
804- removed asclock (conflicts with AfterStep)
805
806* Fri Feb 27 1998 Cristian Gafton <gafton@redhat.com>
807- updated to 0.14.0
808
809* Fri Jan 30 1998 Cristian Gafton <gafton@redhat.com>
810- upgraded to 0.13.0
811- added the include files and the development libraries
812
813* Thu Nov 20 1997 Cristian Gafton <gafton@redhat.com>
814- first build against glibc
Note: See TracBrowser for help on using the repository browser.