source: projects/specs/trunk/W/WindowMaker/WindowMaker-vl.spec @ 1901

Revision 1901, 23.0 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define version 0.92.0
2%define vsource WindowMaker-%{version}-vine
3%define libdockapp libdockapp-0.4.0
4%define asclock asclock-2.0.12
5%define wmconfig wmconfig-vine-1.1
6%define wmmail 0.63a
7%define x11confdir %{_sysconfdir}/X11
8%define gnustepdir %{_prefix}/lib/GNUstep
9
10Summary: Window Maker - a window manager for X11
11Summary(ja): X11 用ウィンドウ・マネージャ
12Name: WindowMaker
13Version: %{version}
14Release: 7%{?_dist_release}
15License: GPLv2/OPL
16Group: User Interface/Desktops
17URL: http://windowmaker.info/
18Source0: %{name}-%{version}.tar.gz
19Source1: http://www.longstreet.ch/asclock/%{asclock}.tar.gz
20Source2: %{libdockapp}.tar.bz2
21Source6: %{vsource}.5a1.tar.gz
22
23# http://www.eecg.utoronto.ca/cgi-bin/cgiwrap/chanb/www/wmmail
24Source10: WMMail.app-%{wmmail}.tar.gz
25Source11: WMMail.defaults.vine
26
27Source20: %{wmconfig}.tar.bz2
28Source21: dockit
29Source22: WindowMaker.desktop
30Source23: RunWM
31
32#Patch1: WindowMaker-0.62.0-wmclock.patch
33Patch4: WindowMaker-cvs-nomisc.patch
34Patch7: WindowMaker-0.53.0-wheel.diff.gz
35Patch10: WindowMaker-0.65.0-GSDIR.patch
36Patch20: WMMail.app-%{wmmail}-fix.patch
37Patch21: WMMail-%{wmmail}.mbox.patch
38Patch22: WMMail-%{wmmail}.appsdir.patch
39
40######################
41##### for 0.92.0 #####
42
43## for x86_64 architecture support
44Patch30: WindowMaker-0.92.0-configure.noasm.patch
45Patch31: libdockapp-0.4.0-config.sub.patch
46
47## for gcc-4
48Patch40: WindowMaker-0.92.0-x86_specific.patch
49Patch41: WMMail.app-0.63a.config.patch
50Patch42: asclock-2.0.12.patch
51
52# libPropList is not necessary for Window Maker >= 0.70, but
53# for items around WindowMaker.
54BuildRequires: libPropList
55BuildRequires: automake automake14
56BuildRequires: autoconf >= 2.59
57BuildRequires: libtool
58
59BuildRequires: imake
60BuildRequires: xorg-x11-devel
61BuildRequires: xorg-x11-proto-devel
62
63Requires: WindowMaker-libs = %{version}
64#Requires: libPropList >= 0.10.0
65Requires: WindowMaker-Icons, vine-backgrounds, cpp
66Requires: vine-logos, vutils, sed
67Requires: xterm
68
69Provides: libwraster.so.2
70Buildroot: %{_tmppath}/%{name}-%{version}-root
71
72%description
73WindowMaker is a window manager designed to emulate the look
74and feel of part of the NEXTSTEP(tm) GUI. It is supposed to be fast,
75relatively small, feature rich and easy to configure, with
76a simple and elegant appearance borrowed from NEXTSTEP(tm).
77
78%description -l ja
79NEXTSTEP(tm)のようなルック&フィールのウィンドウマネージャです。
80動作が軽く、また強力なカスタマイズ・ツールを装備しています。
81
82WindowMakerをインストール後、各クライアントで /usr/bin/wmaker.inst を
83実行してください。既に ~/GNUStep が存在する場合には、それを置き換えるか聞い
84て来ます。最後に .xinitrc を作るか聞いてきます。既に startx できる環境が作ら
85れている場合には、[Cntl]+C でキャンセルした方が良いかもしれません。
86
87%package libs
88Summary: Libraries bundled with WindowMaker
89Summary(ja): WindowMaker に必要なライブラリ集
90Group: System Environment/Libraries
91
92%description libs
93These libraries come bundled with WindowMaker, but are also used
94in other packages like AfterStep-APPS and wmakerconf
95
96%description libs -l ja
97このライブラリ集はWindowMakerに含まれているものです。
98wmakerconf や wdm 等にも必要です。
99
100%package devel
101Summary: Development files using WindowMaker related libraries
102Group: Development/Libraries
103Requires: WindowMaker-libs = %{version}
104
105%description devel
106This package contains the WindowMaker related library and header files
107used for developers.
108
109%description devel -l ja
110このパッケージは,WindowMaker のライブラリを利用したアプリケーション開発
111に必要なライブラリやヘッダファイルを含んでいます.
112
113
114%prep
115%setup -q -a 1 -a 2 -a 6 -a 10 -a 20 -n WindowMaker-%{version}
116%patch4 -p1 -b .noexamble
117%patch7 -p1 -b .wheel
118%patch10 -p1 -b .gsdir
119%patch20 -p0
120
121cd WMMail.app-%{wmmail}
122patch -p0 -s < %PATCH21
123patch -p1 -s < %PATCH22
124cd ..
125
126# for x86_64 architecture support
127%ifarch x86_64
128%patch30 -p1 -b .noasm
129%patch31 -p0 -b .libdockapp
130%endif
131
132## for gcc-4
133%patch40 -p1 -b .x86_specific
134%patch41 -p0 -b .config
135%patch42 -p0 -b .asclock
136
137%build
138aclocal
139autoheader
140autoconf
141libtoolize --force --automake
142automake -a --gnu --include-deps
143
144export LINGUAS; LINGUAS="de es fr it ja"
145export NLSDIR; NLSDIR=%{_localedir}
146export GNUSTEP_LOCAL_ROOT; GNUSTEP_LOCAL_ROOT='%{gnustepdir}'
147export CPP_PATH; CPP_PATH=/lib/cpp
148export CFLAGS; CFLAGS="$RPM_OPT_FLAGS"
149%configure --sysconfdir=%{x11confdir} --x-libraries=%{_libdir}
150make %{?_smp_mflags}
151
152## make libdockapp
153cd %{libdockapp}
154        aclocal
155        autoconf 
156        libtoolize --force --automake
157        automake -a --gnu --include-deps
158        %configure
159        make
160cd ..
161
162## make asclock
163cd %{asclock}
164        mkdir ./default_theme
165        cd ./default_theme
166        ln -sf ../themes/shaped/beats.xpm beats.xpm
167        ln -sf ../themes/shaped/clock.xpm clock.xpm
168        ln -sf ../themes/shaped/config config
169        ln -sf ../themes/shaped/date.xpm date.xpm
170        ln -sf ../themes/shaped/hour.xpm hour.xpm
171        ln -sf ../themes/shaped/led.xpm led.xpm
172        ln -sf ../themes/shaped/minute.xpm minute.xpm
173        ln -sf ../themes/shaped/second.xpm second.xpm
174        ln -sf ../languages/japanese/month.xpm month.xpm
175        ln -sf ../languages/japanese/weekday.xpm weekday.xpm
176        cd ..
177        ln -sf asclock.man wmclock.man
178        xmkmf
179        make clean
180        make
181cd ..
182
183## make wmmail
184cd WMMail.app-%{wmmail}
185        aclocal-1.4
186        automake-1.4 -a -c --gnu --include-deps
187        autoconf
188        %configure
189        make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-L%{_libdir}"
190cd ..
191
192
193%install
194rm -rf %{buildroot}
195%define SYSDEFDIR %{x11confdir}/WindowMaker/
196mkdir -p %{buildroot}%{SYSDEFDIR}
197
198%makeinstall nlsdir=%{buildroot}%{_localedir}
199
200for i in $(ls */README) ; do
201    echo $i | sed -e "s|\(.*\)/\(.*\)|\2\.\1|" | xargs cp $i
202done
203make install DESTDIR=%{buildroot} -C %{asclock}
204
205# install config files for Vine
206make DESTDIR=%{buildroot} SYSDEFDIR=%{SYSDEFDIR} install -C %{vsource}
207ln -s %{_libdir}/firefox-3.0/icons/default48.png \
208        %{buildroot}%{_datadir}/WindowMaker/Icons/firefox48.png
209
210# set default menubutton for PPC
211%ifarch ppc
212pushd %{buildroot}%{SYSDEFDIR}
213sed -e "s/MouseLeftButtonAction\ =\ SelectWindows/MouseLeftButtonAction\ =\ OpenApplicationsMenu/" \
214    -e "s/MouseRightButtonAction\ =\ OpenApplicationsMenu/MouseRightButtonAction\ =\ SelectWindows/" \
215    WindowMaker > WindowMaker.ppc
216    mv -f WindowMaker.ppc WindowMaker
217popd
218%endif
219
220# install wmconfig items
221make DESTDIR=%{buildroot} install -C %{wmconfig}
222
223# install libdockapp
224make DESTDIR=%{buildroot} install -C %{libdockapp}
225
226# install WMMail.app
227(
228        cd WMMail.app-%{wmmail}
229        %makeinstall
230        #install sound file and pixmaps of WMMail.app
231        WMMailDIR=%{buildroot}/%{gnustepdir}/Applications/WMMail.app/
232        mkdir -p ${WMMailDIR}/Sounds/
233        mkdir -p ${WMMailDIR}/Anims/{NeXT,asmail,e,monitor-e}
234        cp Sounds/*.au ${WMMailDIR}/Sounds/
235        for dir in NeXT asmail e monitor-e; do
236            cp Anims/${dir}/*.xpm ${WMMailDIR}/Anims/${dir}
237        done
238        #install config file of WMMail.app for Vine Linux
239        cp %{SOURCE11} %{buildroot}/%{SYSDEFDIR}/WMMail
240        #install dockit
241        install -m 755 %{SOURCE21} %{buildroot}%{_bindir}
242        # prepare docs
243        pwd
244        mkdir ../WMMail.app
245        cp -p AUTHORS COPYING ChangeLog INSTALL NEWS README Defaults/WMMail ../WMMail.app
246)
247
248# provide libwraster.so.2 tentatively
249ln -sf libwraster.so.3 %{buildroot}%{_libdir}/libwraster.so.2
250
251# added for 0.9.2
252pushd %{buildroot}/%{_includedir}
253        mkdir -p WINGs
254        mv WINGs.h WINGsP.h WUtil.h proplist-compat.h WINGs/
255popd
256
257# install WindowMaker.desktop
258install -d %{buildroot}%{x11confdir}/dm/Sessions
259install -m 755 %{SOURCE22} %{buildroot}%{x11confdir}/dm/Sessions
260install -m 755 %{SOURCE23} %{buildroot}%{_bindir}
261
262# remove unpackaged files
263rm -rf %{buildroot}%{_sysconfdir}/WindowMaker
264rm -rf %{buildroot}%{_libdir}/*.la
265#rm -rf %{buildroot}%{_libdir}/*.a
266
267
268%clean
269rm -rf %{buildroot}
270
271%pre libs
272# Script to support upgrade from old directory tree
273# This will be removed in near future...
274SYSDEFDIR=%{x11confdir}/WindowMaker
275if [ -L ${SYSDEFDIR} ]; then
276 rm -f ${SYSDEFDIR}
277fi
278
279# The below seems to be necessary to suppress warning in updates....
280OLDDEFDIR=%{_datadir}/WindowMaker/Defaults
281if [ -d ${OLDDEFDIR} ]; then
282 rm -f ${OLDDEFDIR}/*
283fi
284
285%triggerin -- ppxp
286SYSDEFDIR=%{x11confdir}/WindowMaker
287cd ${SYSDEFDIR}
288rm WMState
289ln -sf WMState.ppxp WMState
290
291%triggerun -- ppxp
292[ $2 = 0 ] || exit 0
293SYSDEFDIR=%{x11confdir}/WindowMaker
294cd ${SYSDEFDIR}
295rm WMState
296
297
298%post libs -p /sbin/ldconfig
299%postun libs -p /sbin/ldconfig
300
301%files
302%defattr(-,root,root)
303%doc AUTHORS BUGFORM BUGS COPYING* ChangeLog FAQ FAQ.I18N INSTALL
304%doc MIRRORS NEWS README* TODO
305%config %{x11confdir}/dm/Sessions/WindowMaker.desktop
306%{x11confdir}/WindowMaker/*
307%{_bindir}/*.sh
308%{_bindir}/RunWM
309%{_bindir}/wmclock
310%{_bindir}/convertfonts
311%{_bindir}/geticonset
312%{_bindir}/getstyle
313%{_bindir}/seticons
314%{_bindir}/setstyle
315%{_bindir}/wkdemenu.pl
316%{_bindir}/wm-oldmenu2new
317%{_bindir}/wmagnify
318%{_bindir}/wmaker
319%{_bindir}/wmaker.inst
320%{_bindir}/wmsetbg
321%{_bindir}/wmsetup
322%{_bindir}/wxcopy
323%{_bindir}/wxpaste
324%{_datadir}/WINGs/
325%{_datadir}/WindowMaker/
326%{_mandir}/*/*
327%{_localedir}/*/*/*
328%{gnustepdir}/Applications/WPrefs.app/
329%{_libdir}/pkgconfig/
330
331%{gnustepdir}/Applications/WMMail.app/
332%doc WMMail.app/
333%{_bindir}/dockit
334
335%files libs
336%defattr(-,root,root)
337%{_bindir}/get-wings-flags
338%{_bindir}/get-wraster-flags
339%{_bindir}/get-wutil-flags
340%{_bindir}/wdread
341%{_bindir}/wdwrite
342%{_libdir}/lib*.so.*
343
344%files devel
345%defattr(-,root,root)
346%{_includedir}/WINGs
347%{_includedir}/WMaker.h
348%{_includedir}/dockapp.h
349%{_includedir}/wraster.h
350%{_libdir}/libdockapp.so
351%{_libdir}/libdockapp.so.1
352%{_libdir}/libdockapp.so.1.0.0
353%{_libdir}/libwraster.so
354%{_libdir}/libwraster.so.2
355%{_libdir}/libwraster.so.3
356%{_libdir}/libwraster.so.3.1.0
357%{_libdir}/libWINGs.a
358%{_libdir}/libWMaker.a
359%{_libdir}/libWUtil.a
360%{_libdir}/libdockapp.a
361%{_libdir}/libwraster.a
362
363
364%changelog
365* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92.0-7
366- rebuild with rpm-4.8.1 for pkg-config file
367
368* Mon Feb 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-6
369- putback static libraries
370
371* Sun Feb 21 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-5
372- rebuilt with new toolchain
373
374* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.92.0-4vl5
375- added libdockapp-0.4.0-config.sub.patch
376- dropt static library
377
378* Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.92.0-3vl5
379- changed libs Group to System Environment/Libraries
380- updated SOURCE23 (for AfterStep)
381
382* Sat Jun 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-2vl5
383- added WMMail.app-0.63a.config.patch
384- fixed WMMail.defaults.vine
385- fixed wmconfig-vine-1.1.tar.bz2
386- added symbolic link to %%{_libdir}/firefox-3.0/icons/default48.png
387- updated WindowMaker-0.92.0-vine to WindowMaker-0.92.0-vine.5a1
388        - fixed Defaults/WMWindowAttributes
389        - fixed Defaults/WMState*
390        - fixed BINDIR path in Makefile
391        - added bin/tknamazu.sh
392- updated asclock to 2.0.12
393        - dropt WindowMaker-0.62.0-wmclock.patch
394        - dropt asclock-jp.patch
395        - added asclock-2.0.12.patch
396
397* Mon Jun 02 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-1vl5
398- applied new versioning policy and utf-8
399- added BuildRequires: xorg-x11-devel imake
400- added Source23: RunWM (import from xinitrc-3.46-0vl1)
401- dropt Requires: xinitrc
402- fixed Source6: %{vsource}.tar.gz
403- fixed Source20: wmconfig-vine-1.1.tar.bz2
404- fixed Source22: WindowMaker.desktop
405
406* Mon Aug 20 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl10
407- added Patch40: WindowMaker-0.92.0-x86_specific.patch (from FC7 cvs20060123.patch)
408
409* Sun Aug 19 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl9
410- changed URL to http://windowmaker.info
411- added BuildPreReq: libtool, automake14
412- dropt patch40: %{vsource}.font.patch
413- updated Source6: %{vsource}.tar.gz
414        - added xterm item to menu
415        - changed mozilla to firefox in menu
416        - fixed fontset scripts
417
418* Tue Oct 17 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl7
419- dropt Requires: wmconfig
420
421* Sun Oct 15 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl6
422- added patch40: WindowMaker-0.92.0-vine.font.patch
423- fixed WMMail.app path in WMMail.defaults.vine
424
425* Fri Mar 10 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl5
426- fixed building error of WMMail.app for x86_64
427- fixed GNUstep/Applications directory for x86_64
428
429* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl4
430- rebuild for VineSeed
431- added x86_64 architecture support
432- added WindowMaker-0.92.0-configure.noasm.patch for x86_64
433
434* Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl3
435- new upstream release WindowMaker-0.92.0
436- added WindowMaker.desktop for gdm session
437- added WindowMaker-0.92.0-vine.tar.gz (replaced WindowMaker-0.91.0-vine31.tar.bz2)
438- added BuildPreReq: automake17
439- dropt WindowMaker-0.51.0-areas.patch -- no source
440- dropt WindowMaker-0.62.0-wmclock.patch -- fixed
441- dropt WindowMaker-0.64.0-wsetfont.patch -- changed source
442- dropt wmaker-xim-xft.patch -- fixed
443- dropt wmaker-xim-cvs20040509.patch -- fixed
444- changed WINGs headers to originals (next 2 patches are not needed)
445- dropt WindowMaker-0.64.0-WUtilPath.patch
446- dropt WindowMaker-cvs-src.build.patch
447
448* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl3
449- change menu messages code from EUC to UTF-8
450
451* Tue Nov 09 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl2
452- modified vsource
453
454* Wed Nov 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl1
455- source update
456- provides libwraster.so.2 tentatively.
457  until rebuild wdm, wmakerconf and WMSoundSet
458
459* Thu May 13 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.80.2-0vl2.1
460- TEST update source cvs-20040509
461
462* Sun Jul 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.80.2-0vl2
463- fixed spec file to build with automake-1.5 and current autoconf
464
465* Tue Nov 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.2-0vl1
466- new upstream release
467  - An exploitable buffer overrun bug has been found in Window Maker
468    recently. This release fixes the problem.
469
470* Sun Sep 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl10
471- vsource updated (linuxconf -> Webmin, vedit -> gedit)
472
473* Wed Jul 17 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl9
474- fix include path in WINGs related include files
475
476* Thu Jul 11 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl8
477- apply xim patch, wmaker-xim-0.80.0.patch.txt
478
479* Thu Mar 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.0-0vl7
480- update WindowMaker-0.80.0-vine25
481  - remove netscape and vedit, add mozilla and gedit
482  - add background image
483  - change some window color
484
485* Thu Mar 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl6
486- yet another typo fix. Doh...
487
488* Wed Mar 13 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl5
489- modified %install section (%ifarch ppc line contained typo)
490
491* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl4
492- enable CirculateRaise
493- ver.up ja.po
494
495* Sun Feb 10 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl3
496- back to WMMail-0.63a and merge some diffs from 0.64
497
498* Fri Feb  8 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl2
499- ja.po 更新 (WindowMaker-0.80.0ja2)
500- change option name around MouseButton in Defaults/WindowMaker to new one.
501
502* Thu Feb  7 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl1
503- ver.up
504- build with XFree-4.2
505
506* Sun Aug 05 2001 <sagami@vinelinux.org>
507- 0.65.1-0vl2:
508- don't apply guessfont.patch, which is no longer neeeded
509- split correctly WINGs stuff (wdm) into libs subpackage
510- consequently, move pre script to libs (shouldn't be removed in near future?)
511- PreReq: WindowMaker-libs = %%{version} for main package (Wow!!!)
512
513* Thu Jul 26 2001 <sagami@vinelinux.org>
514- 0.65.1-0vl1: update to 0.65.1 and regenerate patches
515
516* Sat Jun 23 2001 Jun Nishii <jun@vinelinux.org> 0.65.0-0vl3
517- update ja.po
518
519* Thu Jun 07 2001 <sagami@vinelinux.org>
520- 0.65.0-0vl2: handle non existent GNUSTEP_USER_ROOT directory
521
522* Mon May 21 2001 Jun Nishii <jun@vinelinux.org>
523- 0.65.0-0vl1
524- update WMMail.app to ver. 0.64
525- separate devel subpackage
526
527* Mon May 14 2001 Shoji Matsumoto <shom@vinelinux.org>
528- 0.64.0-0vl3
529- modify WindowMaker-0.62.1-vine6 to vine7 (add MozillaImStatus config)
530
531* Mon Apr 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
532- 0.64.0-0vl2
533- fixed WUtil.h path in WINGS.h
534
535* Mon Feb 26 2001 Jun Nishii <jun@vinelinux.org>
536- 0.64.0-0vl1
537
538* Thu Feb 08 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
539- added defattr to separated lib subpackage
540
541* Thu Feb  8 2001 Jun Nishii <jun@vinelinux.org>
542- 0.63.1-0vl4
543- separate libs subpackage
544
545* Wed Jan 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
546- 0.63.1-0vl3
547- change ${SYSDEFDIR} -> %{SYSDEFDIR} in %ifarch ppc lines
548
5491 Jun Nishii <jun@vinelinux.org>
550- 0.63.1-0vl2
551- more macros in spec
552- update WINGs patch
553
554* Sat Jan 13 2001 Jun Nishii <jun@vinelinux.org>
555- 0.63.1-0vl1
556- version up
557
558* Tue Oct 10 2000 Jun Nishii <jun@vinelinux.org>
559- 0.62.1-0vl8
560- bug fix in plmenu.ja
561
562* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
563- 0.62.1-0vl7
564- change icon of sylpheed
565
566* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
567- 0.62.1-0vl6
568- set font as alias-fixed
569
570* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
571- 0.62.1-0vl5
572- obsletes vmail and use sylpheed
573
574* Thu Aug 31 2000 Jun Nishii <jun@vinelinux.org>
575- 0.62.1-0vl4
576- change backbground path (use vine-backgrounds)
577
578* Sun Aug 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
579- 0.62.1-0vl3
580- swap default mousebutton if ppc
581  (PowerMac's default mouse has only one button...)
582
583* Wed Aug 16 2000 Jun Nishii <jun@vinelinux.org>
584- rename mozilla.sh as netscape.sh
585- use brp
586- added dockit
587
588* Sun Apr  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
589- updated to 0.62.1
590
591* Sun Apr  2 2000 Jun Nishii <jun@vinelinux.org>
592- added libdockapp instead of docklib
593
594* Fri Mar 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
595- updated to 0.62.0
596- added docklib src from 0.61.1
597- modified ja.po for WindowMaker and WMPrefs
598
599* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
600- bug fix of WINGs_im patch by Mr. Furukawa
601
602* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
603- bug fix of installation process of Makefile in WindowMaker-0.61.1vine7
604
605* Thu Dec 30 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine)
606- rel.9
607- added WINGs_im patch to support XIM in WINGs tool kits.
608
609* Fri Dec  3 1999 Jun Nishii <jun@flatout.org>
610- use rm --force in %post
611- Do not use birthwindow.patch which may cause incorrect window placement.
612
613* Fri Nov 26 1999 Jun NISHII <jun@flatout.org>
614- fix autostart.sh to check wsoundserver and wmsound
615- ver up wmconfig-vine
616- some other minor changes...
617
618* Fri Nov 12 1999 Jun Nishii <jun@flatout.org>
619- rel.6
620- added wheel patch
621- bug fix in mozilla.sh
622
623* Thu Nov 11 1999 Jun Nishii <jun@flatout.org>
624- rel.5
625- requires vutils instead of vsetup
626
627* Wed Nov 10 1999 Jun Nishii <jun@flatout.org>
628- rel.4
629- change menu
630- requires vsetup
631
632* Tue Nov  9 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine, JP-3)
633- use font guess patch instead of Japanese font patch
634- remove japanese fontset from default font-set
635
636* Thu Oct 14 1999 Jun Nishii <jun@flatout.org>
637- added dockapp.h
638
639* Sat Oct 9 1999 Jun Nishii <jun@flatout.org>
640- 0.61.1
641
642* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
643- added mozilla.sh
644
645* Sun Sep 26 1999 Jun Nishii <jun@flatout.org>
646- change default font-sets
647
648* Tue Sep 21 1999 Jun Nishii <jun@flatout.org>
649- use Default.style_kai instead of Default.style
650- install libdockapp
651
652* Wed Jul 21 1999 Jun Nishii <jun@flatout.org>
653- move to new directory structure (defaults in /etc/X11/WindowMaker)
654
655* Tue Jul 20 1999 Jun Nishii <jun@flatout.org>
656- build for Vine-1.9
657
658* Sun Jun 6 1999 Jun Nishii <jun@flatout.org>
659- merged patch for wsetfont to support MultiByteText
660- modify default font setting
661- launch netscape from autostart.sh
662
663* Fri Jun 4 1999 Jun Nishii <jun@flatout.org>
664- updated to 0.60.0
665
666* Fri Apr 23 1999 Jun Nishii <jun@flatout.org>
667- updated to 0.53.0
668
669* Thu Mar 25 1999 Jun Nishii <jun@flatout.org>
670- patch to fix focus
671
672* Sun Mar 14 1999 Jun Nishii <jun@flatout.org>
673- updated to 0.51.2
674
675* Fri Mar 12 1999 Jun Nishii <jun@flatout.org>
676- rel.11
677- bug fix of the wrapper of wmconfig
678
679* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
680- rel.10
681- added wrapper of wmconfig to support dummy NLS
682
683* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
684- rel.9
685- asclock-jp.patch and WindowMaker-birthwindow.patch by Yasuyuki Furukawa
686- remove xfig from menu
687
688* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
689- rel.8
690- bug fix in menu items which require root privilege (use su -)
691
692* Sun Feb 28 1999 Jun Nishii <jun@flatout.org>
693- rel.7
694- use plmenu.ja as a default menu
695
696* Thu Feb 25 1999 Jun Nishii <jun@flatout.org>
697- rel.6
698- stop autoraise
699
700* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
701- rel.5
702- added patch for WMMail not to down when no /var/spool/mail/$USER
703
704* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
705- rel.4
706- merge WMMail.app
707- dock WMMail if no xppxpm
708- fix bug that kterm doesn't start from dock after restart WM.
709- added plmenu.ja
710
711* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
712- rel.3
713- set BuggyApplication for xppxp in Dock which enables no warning when
714  xppxp is not installed
715- move Themes for Vine to WindowMaker-Icons
716
717* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
718- rel.2
719- modify menu, Dock, and etc for Vine 1.0
720
721* Fri Jan 29 1999 Jun Nishii <jun@flatout.org>
722- updated to 0.51.0
723
724* Wed Jan 27 1999 Jun Nishii <jun@flatout.org>
725- rel.4
726- customize some key bindings
727- remove xterm from menu.ja
728- make default iconsize 56x56
729
730* Thu Jan 14 1999 Jun Nishii <jun@flatout.org>
731- rel.3
732- use /lib/cpp which is a wrapper to choose one by gcc or egcs
733- typo fix in WPrefs.ja.po
734
735* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
736- rel.2
737- use gcc -E instead of /lib/cpp
738
739* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
740- updated to 0.50.2
741
742* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
743- updated to 0.50.1
744
745* Fri Jan 8 1999 Jun Nishii <jun@flatout.org>
746- updated to 0.50.0
747
748* Sun Dec 27 1998 Jun Nishii <jun@flatout.org>
749- added patch, new_nifty_pixmap-gradient.patch
750
751* Sun Dec 20 1998 Jun Nishii <jun@flatout.org>
752- modify menu and other default settings
753- added new themes
754
755* Fri Dec 11 1998 Jun Nishii <jun@flatout.org>
756- modified ja.po for WindowMaker and WPrefs
757- added config files for Vine Linux
758
759* Sat Dec 5 1998 Jun Nishii <jun@flatout.org>
760- updated to 0.20.3
761- added and modified ja.po for WindowMaker and WPrefs
762- make and merge patch to support nls for more messages
763
764* Mon Nov 30 1998 Jun Nishii <jun@flatout.org>
765- Moved Japanese catalog from ja_JP.ujis to ja
766
767* Mon Nov 24 1998 Jun Nishii <jun@flatout.org>
768- updated to 0.20.2
769
770* Mon Nov 23 1998 Jun Nishii <jun@flatout.org>
771- enable kanji for Vine Linux
772
773* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
774- fixed swicthing to other window managers problem
775- updated to 0.20.1
776- include all the .mo files, not just WindowMaker...
777- added an older version of asclock as wmclock
778- include libPropList.a in the %files
779
780* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
781- version 0.91.3
782
783* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
784- version 0.19.2
785- don't require asclock as a separate package
786
787* Wed Aug 12 1998 Cristian Gafton <gafton@redhat.com>
788- upgraded to 0.17.5
789
790* Tue Jul 21 1998 Cristian Gafton <gafton@redhat.com>
791- updated to 0.17.2
792
793* Thu Jul 09 1998 Cristian Gafton <gafton@redhat.com>
794- updated to 0.16.1
795- removed asclock (conflicts with AfterStep)
796
797* Fri Feb 27 1998 Cristian Gafton <gafton@redhat.com>
798- updated to 0.14.0
799
800* Fri Jan 30 1998 Cristian Gafton <gafton@redhat.com>
801- upgraded to 0.13.0
802- added the include files and the development libraries
803
804* Thu Nov 20 1997 Cristian Gafton <gafton@redhat.com>
805- first build against glibc
Note: See TracBrowser for help on using the repository browser.