source: projects/specs/trunk/W/WindowMaker/WindowMaker-vl.spec @ 9350

Revision 9350, 24.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-11 Ryoichi INAGAKI <ryo1@…>

  • WindowMaker?, wmakerconf: fixed spec
  • libPropList: split devel files to devel subpackage


Line 
1%define version 0.95.6
2%define vsource WindowMaker-%{version}-vine
3%define libdockapp libdockapp-0.4.0
4%define asclock asclock-2.0.12
5%define wmconfig wmconfig-vine-1.1
6%define wmmail 0.63a
7%define x11confdir %{_sysconfdir}/X11
8%define gnustepdir %{_prefix}/lib/GNUstep
9
10Summary: Window Maker - a window manager for X11
11Summary(ja): X11 用ウィンドウ・マネージャ
12Name: WindowMaker
13Version: %{version}
14Release: 2%{?_dist_release}
15License: GPLv2/OPL
16Group: User Interface/Desktops
17URL: http://windowmaker.info/
18Source0: %{name}-%{version}.tar.gz
19Source1: http://www.longstreet.ch/asclock/%{asclock}.tar.gz
20Source2: %{libdockapp}.tar.bz2
21Source6: %{vsource}.tar.gz
22
23# http://www.eecg.utoronto.ca/cgi-bin/cgiwrap/chanb/www/wmmail
24Source10: WMMail.app-%{wmmail}.tar.gz
25Source11: WMMail.defaults.vine
26
27Source20: %{wmconfig}.tar.bz2
28Source21: dockit
29Source22: WindowMaker.desktop
30Source23: RunWM
31
32#Patch1: WindowMaker-0.62.0-wmclock.patch
33Patch7: WindowMaker-0.95.6-wheel.diff.gz
34Patch10: WindowMaker-0.95.6-GSDIR.patch
35Patch20: WMMail.app-%{wmmail}-fix.patch
36Patch21: WMMail-%{wmmail}.mbox.patch
37Patch22: WMMail-%{wmmail}.appsdir.patch
38
39######################
40##### for 0.92.0 #####
41
42## for x86_64 architecture support
43Patch31: libdockapp-0.4.0-config.sub.patch
44
45## for gcc-4
46Patch41: WMMail.app-0.63a.config.patch
47Patch42: asclock-2.0.12.patch
48
49Buildroot: %{_tmppath}/%{name}-%{version}-root
50# libPropList is not necessary for Window Maker >= 0.70, but
51# for items around WindowMaker.
52BuildRequires: libPropList-devel
53BuildRequires: automake automake14
54BuildRequires: autoconf >= 2.59
55BuildRequires: libtool
56
57BuildRequires: imake
58BuildRequires: libX11-devel
59BuildRequires: libXmu-devel
60BuildRequires: libXft-devel
61BuildRequires: libXinerama-devel
62BuildRequires: libXrandr-devel
63BuildRequires: libICE-devel
64BuildRequires: libXpm-devel
65
66BuildRequires: giflib-devel
67BuildRequires: libexif-devel
68BuildRequires: libjpeg-turbo-devel
69BuildRequires: libtiff-devel
70BuildRequires: libwebp-devel
71BuildRequires: ImageMagick-devel
72
73Requires: WindowMaker-libs = %{version}
74Requires: WindowMaker-Icons, vine-backgrounds, cpp
75Requires: vine-logos, vutils, sed
76Requires: xterm
77Requires: xorg-x11-jpfonts
78
79# for WMMail
80Requires: libSM libXau libXdmcp libxcb
81# for WPrefs
82Requires: libXrender libexpat libtool-ltdl lcms2 xz-libs 
83
84Provides: libwraster.so.2
85
86%description
87WindowMaker is a window manager designed to emulate the look
88and feel of part of the NEXTSTEP(tm) GUI. It is supposed to be fast,
89relatively small, feature rich and easy to configure, with
90a simple and elegant appearance borrowed from NEXTSTEP(tm).
91
92%description -l ja
93NEXTSTEP(tm)のようなルック&フィールのウィンドウマネージャです。
94動作が軽く、また強力なカスタマイズ・ツールを装備しています。
95
96WindowMakerをインストール後、各クライアントで /usr/bin/wmaker.inst を
97実行してください。既に ~/GNUStep が存在する場合には、それを置き換えるか聞い
98て来ます。最後に .xinitrc を作るか聞いてきます。既に startx できる環境が作ら
99れている場合には、[Cntl]+C でキャンセルした方が良いかもしれません。
100
101%package libs
102Summary: Libraries bundled with WindowMaker
103Summary(ja): WindowMaker に必要なライブラリ集
104Group: System Environment/Libraries
105
106%description libs
107These libraries come bundled with WindowMaker, but are also used
108in other packages like AfterStep-APPS and wmakerconf
109
110%description libs -l ja
111このライブラリ集はWindowMakerに含まれているものです。
112wmakerconf や wdm 等にも必要です。
113
114%package devel
115Summary: Development files using WindowMaker related libraries
116Summary(ja): WindowMaker 関連ライブラリの開発用ファイル
117Group: Development/Libraries
118Requires: WindowMaker-libs = %{version}-%{release}
119Requires: libX11-devel
120Requires: libXext-devel
121Requires: xorg-x11-proto-devel
122# get-wraster-flags uses the following libraries
123Requires: giflib-devel
124Requires: libXpm-devel
125Requires: libjpeg-devel
126Requires: libpng-devel
127Requires: libtiff-devel
128Requires: libwebp-devel
129
130%description devel
131This package contains the WindowMaker related library and header files
132used for developers.
133
134%description devel -l ja
135このパッケージは,WindowMaker のライブラリを利用したアプリケーション開発
136に必要なライブラリやヘッダファイルを含んでいます.
137
138
139%prep
140%setup -q -a 1 -a 2 -a 6 -a 10 -a 20 -n WindowMaker-%{version}
141%patch7 -p1 -b .wheel
142%patch10 -p1 -b .gsdir
143%patch20 -p0
144
145cd WMMail.app-%{wmmail}
146patch -p0 -s < %PATCH21
147patch -p1 -s < %PATCH22
148cd ..
149
150# for x86_64 architecture support
151%ifarch x86_64
152%patch31 -p0 -b .libdockapp
153%endif
154
155## for gcc-4
156%patch41 -p0 -b .config
157%patch42 -p0 -b .asclock
158
159%build
160aclocal
161autoheader
162autoconf
163libtoolize --force --automake
164automake -a --gnu --include-deps
165
166export LINGUAS; LINGUAS="de es fr it ja"
167export NLSDIR; NLSDIR=%{_localedir}
168export GNUSTEP_LOCAL_ROOT; GNUSTEP_LOCAL_ROOT='%{gnustepdir}'
169export CPP_PATH; CPP_PATH=/lib/cpp
170export CFLAGS; CFLAGS="$RPM_OPT_FLAGS"
171%configure --sysconfdir=%{x11confdir} --x-libraries=%{_libdir}
172make %{?_smp_mflags}
173
174## make libdockapp
175cd %{libdockapp}
176        aclocal
177        autoconf 
178        libtoolize --force --automake
179        automake -a --gnu --include-deps
180        %configure
181        make
182cd ..
183
184## make asclock
185cd %{asclock}
186        mkdir ./default_theme
187        cd ./default_theme
188        ln -sf ../themes/shaped/beats.xpm beats.xpm
189        ln -sf ../themes/shaped/clock.xpm clock.xpm
190        ln -sf ../themes/shaped/config config
191        ln -sf ../themes/shaped/date.xpm date.xpm
192        ln -sf ../themes/shaped/hour.xpm hour.xpm
193        ln -sf ../themes/shaped/led.xpm led.xpm
194        ln -sf ../themes/shaped/minute.xpm minute.xpm
195        ln -sf ../themes/shaped/second.xpm second.xpm
196        ln -sf ../languages/japanese/month.xpm month.xpm
197        ln -sf ../languages/japanese/weekday.xpm weekday.xpm
198        cd ..
199        ln -sf asclock.man wmclock.man
200        xmkmf
201        make clean
202        make
203cd ..
204
205## make wmmail
206cd WMMail.app-%{wmmail}
207        aclocal-1.4
208        automake-1.4 -a -c --gnu --include-deps
209        autoconf
210        %configure
211        make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-L%{_libdir}"
212cd ..
213
214
215%install
216rm -rf %{buildroot}
217%define SYSDEFDIR %{x11confdir}/WindowMaker/
218mkdir -p %{buildroot}%{SYSDEFDIR}
219
220%makeinstall nlsdir=%{buildroot}%{_localedir}
221
222for i in $(ls */README) ; do
223    echo $i | sed -e "s|\(.*\)/\(.*\)|\2\.\1|" | xargs cp $i
224done
225make install DESTDIR=%{buildroot} -C %{asclock}
226
227# install config files for Vine
228make DESTDIR=%{buildroot} SYSDEFDIR=%{SYSDEFDIR} install -C %{vsource}
229ln -s %{_libdir}/firefox-3.0/icons/default48.png \
230        %{buildroot}%{_datadir}/WindowMaker/Icons/firefox48.png
231
232# set default menubutton for PPC
233%ifarch ppc
234pushd %{buildroot}%{SYSDEFDIR}
235sed -e "s/MouseLeftButtonAction\ =\ SelectWindows/MouseLeftButtonAction\ =\ OpenApplicationsMenu/" \
236    -e "s/MouseRightButtonAction\ =\ OpenApplicationsMenu/MouseRightButtonAction\ =\ SelectWindows/" \
237    WindowMaker > WindowMaker.ppc
238    mv -f WindowMaker.ppc WindowMaker
239popd
240%endif
241
242# install wmconfig items
243make DESTDIR=%{buildroot} install -C %{wmconfig}
244
245# install libdockapp
246make DESTDIR=%{buildroot} install -C %{libdockapp}
247
248# install WMMail.app
249(
250        cd WMMail.app-%{wmmail}
251        %makeinstall
252        #install sound file and pixmaps of WMMail.app
253        WMMailDIR=%{buildroot}/%{gnustepdir}/Applications/WMMail.app/
254        mkdir -p ${WMMailDIR}/Sounds/
255        mkdir -p ${WMMailDIR}/Anims/{NeXT,asmail,e,monitor-e}
256        cp Sounds/*.au ${WMMailDIR}/Sounds/
257        for dir in NeXT asmail e monitor-e; do
258            cp Anims/${dir}/*.xpm ${WMMailDIR}/Anims/${dir}
259        done
260        #install config file of WMMail.app for Vine Linux
261        cp %{SOURCE11} %{buildroot}/%{SYSDEFDIR}/WMMail
262        #install dockit
263        install -m 755 %{SOURCE21} %{buildroot}%{_bindir}
264        # prepare docs
265        pwd
266        mkdir -p ../WMMail.app
267        cp -p AUTHORS COPYING ChangeLog INSTALL NEWS README Defaults/WMMail ../WMMail.app
268)
269
270# provide libwraster.so.2 tentatively
271ln -sf libwraster.so.3 %{buildroot}%{_libdir}/libwraster.so.2
272
273# added for 0.9.2
274pushd %{buildroot}/%{_includedir}
275        mkdir -p WINGs
276        mv WINGs.h WINGsP.h WUtil.h WINGs/
277popd
278
279# install WindowMaker.desktop
280install -d %{buildroot}%{_datadir}/xsessions
281install -m 644 %{SOURCE22} %{buildroot}%{_datadir}/xsessions/
282install -m 755 %{SOURCE23} %{buildroot}%{_bindir}
283
284# remove unpackaged files
285rm -rf %{buildroot}%{_sysconfdir}/WindowMaker
286rm -rf %{buildroot}%{_libdir}/*.la
287rm -rf %{buildroot}%{_libdir}/*.a
288
289
290%clean
291rm -rf %{buildroot}
292
293%pre libs
294# Script to support upgrade from old directory tree
295# This will be removed in near future...
296SYSDEFDIR=%{x11confdir}/WindowMaker
297if [ -L ${SYSDEFDIR} ]; then
298 rm -f ${SYSDEFDIR}
299fi
300
301# The below seems to be necessary to suppress warning in updates....
302OLDDEFDIR=%{_datadir}/WindowMaker/Defaults
303if [ -d ${OLDDEFDIR} ]; then
304 rm -f ${OLDDEFDIR}/*
305fi
306
307%triggerin -- ppxp
308SYSDEFDIR=%{x11confdir}/WindowMaker
309cd ${SYSDEFDIR}
310rm WMState
311ln -sf WMState.ppxp WMState
312
313%triggerun -- ppxp
314[ $2 = 0 ] || exit 0
315SYSDEFDIR=%{x11confdir}/WindowMaker
316cd ${SYSDEFDIR}
317rm WMState
318
319
320%post libs -p /sbin/ldconfig
321%postun libs -p /sbin/ldconfig
322
323%files
324%defattr(-,root,root)
325%doc AUTHORS BUGFORM BUGS COPYING* ChangeLog FAQ FAQ.I18N INSTALL
326%doc NEWS README* TODO
327%config %{_datadir}/xsessions/WindowMaker.desktop
328%{x11confdir}/WindowMaker/*
329%{_bindir}/*.sh
330%{_bindir}/RunWM
331%{_bindir}/wmclock
332%{_bindir}/convertfonts
333%{_bindir}/geticonset
334%{_bindir}/getstyle
335%{_bindir}/seticons
336%{_bindir}/setstyle
337%{_bindir}/wdread
338%{_bindir}/wdwrite
339%{_bindir}/wkdemenu.pl
340%{_bindir}/wm-oldmenu2new
341%{_bindir}/wmagnify
342%{_bindir}/wmaker
343%{_bindir}/wmaker.inst
344%{_bindir}/wmgenmenu
345%{_bindir}/wmiv
346%{_bindir}/wmmenugen
347%{_bindir}/wmsetbg
348%{_bindir}/wxcopy
349%{_bindir}/wxpaste
350%{_datadir}/WINGs/
351%{_datadir}/WindowMaker/
352%{_mandir}/*/*
353%{_localedir}/*/*/*
354%{gnustepdir}/Applications/WPrefs.app
355
356%{gnustepdir}/Applications/WMMail.app
357%doc WMMail.app/
358%{_bindir}/dockit
359
360%files libs
361%defattr(-,root,root)
362%{_libdir}/lib*.so.*
363
364%files devel
365%defattr(-,root,root)
366%{_bindir}/get-wings-flags
367%{_bindir}/get-wraster-flags
368%{_bindir}/get-wutil-flags
369%{_includedir}/WINGs
370%{_includedir}/WMaker.h
371%{_includedir}/dockapp.h
372%{_includedir}/wraster.h
373%{_libdir}/lib*.so
374%{_libdir}/pkgconfig/*.pc
375
376
377%changelog
378* Tue Feb 10 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.95.6-2
379- moved %%{_bindir}/*-flags and %%{_libdir}/pkgconfig/+.pc to devel subpackage
380- added BuildRequires: giflib-devel and libexif-devel
381- added Requires for WMMail and WPrefs to main package
382- added Requires for get-wraster-flags to devel subpackage
383
384* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.95.6-1
385- update to 0.95.6
386- update Patch7 (WindowMaker-0.95.6-wheel.diff.gz)
387- update Patch10 (WindowMaker-0.95.6-GSDIR.patch)
388- remove Patch4 (WindowMaker-cvs-nomisc.patch)
389- remove Patch30 (WindowMaker-0.92.0-configure.noasm.patch)
390- remove Patch40 (WindowMaker-0.92.0-x86_specific.patch)
391- drop static library
392- add BuildRequires: libjpeg-turbo-devel, libtiff-devel, libwebp-devel, ImageMagick-devel
393
394* Sat Apr 23 2011 Shu KONNO <owa@bg.wakwak.com> 0.92.0-8
395- rebuilt
396
397* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.92.0-7
398- rebuild with rpm-4.8.1 for pkg-config file
399
400* Mon Feb 22 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-6
401- putback static libraries
402
403* Sun Feb 21 2010 Shu KONNO <owa@bg.wakwak.com> 0.92.0-5
404- rebuilt with new toolchain
405
406* Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.92.0-4vl5
407- added libdockapp-0.4.0-config.sub.patch
408- dropt static library
409
410* Wed Apr 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.92.0-3vl5
411- changed libs Group to System Environment/Libraries
412- updated SOURCE23 (for AfterStep)
413
414* Sat Jun 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-2vl5
415- added WMMail.app-0.63a.config.patch
416- fixed WMMail.defaults.vine
417- fixed wmconfig-vine-1.1.tar.bz2
418- added symbolic link to %%{_libdir}/firefox-3.0/icons/default48.png
419- updated WindowMaker-0.92.0-vine to WindowMaker-0.92.0-vine.5a1
420        - fixed Defaults/WMWindowAttributes
421        - fixed Defaults/WMState*
422        - fixed BINDIR path in Makefile
423        - added bin/tknamazu.sh
424- updated asclock to 2.0.12
425        - dropt WindowMaker-0.62.0-wmclock.patch
426        - dropt asclock-jp.patch
427        - added asclock-2.0.12.patch
428
429* Mon Jun 02 2008 Shu KONNO <owa@bg.wakwak.com> 0.92.0-1vl5
430- applied new versioning policy and utf-8
431- added BuildRequires: xorg-x11-devel imake
432- added Source23: RunWM (import from xinitrc-3.46-0vl1)
433- dropt Requires: xinitrc
434- fixed Source6: %{vsource}.tar.gz
435- fixed Source20: wmconfig-vine-1.1.tar.bz2
436- fixed Source22: WindowMaker.desktop
437
438* Mon Aug 20 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl10
439- added Patch40: WindowMaker-0.92.0-x86_specific.patch (from FC7 cvs20060123.patch)
440
441* Sun Aug 19 2007 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl9
442- changed URL to http://windowmaker.info
443- added BuildPreReq: libtool, automake14
444- dropt patch40: %{vsource}.font.patch
445- updated Source6: %{vsource}.tar.gz
446        - added xterm item to menu
447        - changed mozilla to firefox in menu
448        - fixed fontset scripts
449
450* Tue Oct 17 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl7
451- dropt Requires: wmconfig
452
453* Sun Oct 15 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl6
454- added patch40: WindowMaker-0.92.0-vine.font.patch
455- fixed WMMail.app path in WMMail.defaults.vine
456
457* Fri Mar 10 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl5
458- fixed building error of WMMail.app for x86_64
459- fixed GNUstep/Applications directory for x86_64
460
461* Sat Feb 25 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl4
462- rebuild for VineSeed
463- added x86_64 architecture support
464- added WindowMaker-0.92.0-configure.noasm.patch for x86_64
465
466* Mon Feb 13 2006 Shu KONNO <owa@bg.wakwak.com> 0.92.0-0vl3
467- new upstream release WindowMaker-0.92.0
468- added WindowMaker.desktop for gdm session
469- added WindowMaker-0.92.0-vine.tar.gz (replaced WindowMaker-0.91.0-vine31.tar.bz2)
470- added BuildPreReq: automake17
471- dropt WindowMaker-0.51.0-areas.patch -- no source
472- dropt WindowMaker-0.62.0-wmclock.patch -- fixed
473- dropt WindowMaker-0.64.0-wsetfont.patch -- changed source
474- dropt wmaker-xim-xft.patch -- fixed
475- dropt wmaker-xim-cvs20040509.patch -- fixed
476- changed WINGs headers to originals (next 2 patches are not needed)
477- dropt WindowMaker-0.64.0-WUtilPath.patch
478- dropt WindowMaker-cvs-src.build.patch
479
480* Tue Dec 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl3
481- change menu messages code from EUC to UTF-8
482
483* Tue Nov 09 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl2
484- modified vsource
485
486* Wed Nov 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.91.0-0vl1
487- source update
488- provides libwraster.so.2 tentatively.
489  until rebuild wdm, wmakerconf and WMSoundSet
490
491* Thu May 13 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.80.2-0vl2.1
492- TEST update source cvs-20040509
493
494* Sun Jul 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.80.2-0vl2
495- fixed spec file to build with automake-1.5 and current autoconf
496
497* Tue Nov 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.2-0vl1
498- new upstream release
499  - An exploitable buffer overrun bug has been found in Window Maker
500    recently. This release fixes the problem.
501
502* Sun Sep 22 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl10
503- vsource updated (linuxconf -> Webmin, vedit -> gedit)
504
505* Wed Jul 17 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl9
506- fix include path in WINGs related include files
507
508* Thu Jul 11 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl8
509- apply xim patch, wmaker-xim-0.80.0.patch.txt
510
511* Thu Mar 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80.0-0vl7
512- update WindowMaker-0.80.0-vine25
513  - remove netscape and vedit, add mozilla and gedit
514  - add background image
515  - change some window color
516
517* Thu Mar 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl6
518- yet another typo fix. Doh...
519
520* Wed Mar 13 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.80.0-0vl5
521- modified %install section (%ifarch ppc line contained typo)
522
523* Wed Mar  6 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl4
524- enable CirculateRaise
525- ver.up ja.po
526
527* Sun Feb 10 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl3
528- back to WMMail-0.63a and merge some diffs from 0.64
529
530* Fri Feb  8 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl2
531- ja.po 更新 (WindowMaker-0.80.0ja2)
532- change option name around MouseButton in Defaults/WindowMaker to new one.
533
534* Thu Feb  7 2002 Jun Nishii <jun@vinelinux.org> 0.80.0-0vl1
535- ver.up
536- build with XFree-4.2
537
538* Sun Aug 05 2001 <sagami@vinelinux.org>
539- 0.65.1-0vl2:
540- don't apply guessfont.patch, which is no longer neeeded
541- split correctly WINGs stuff (wdm) into libs subpackage
542- consequently, move pre script to libs (shouldn't be removed in near future?)
543- PreReq: WindowMaker-libs = %%{version} for main package (Wow!!!)
544
545* Thu Jul 26 2001 <sagami@vinelinux.org>
546- 0.65.1-0vl1: update to 0.65.1 and regenerate patches
547
548* Sat Jun 23 2001 Jun Nishii <jun@vinelinux.org> 0.65.0-0vl3
549- update ja.po
550
551* Thu Jun 07 2001 <sagami@vinelinux.org>
552- 0.65.0-0vl2: handle non existent GNUSTEP_USER_ROOT directory
553
554* Mon May 21 2001 Jun Nishii <jun@vinelinux.org>
555- 0.65.0-0vl1
556- update WMMail.app to ver. 0.64
557- separate devel subpackage
558
559* Mon May 14 2001 Shoji Matsumoto <shom@vinelinux.org>
560- 0.64.0-0vl3
561- modify WindowMaker-0.62.1-vine6 to vine7 (add MozillaImStatus config)
562
563* Mon Apr 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
564- 0.64.0-0vl2
565- fixed WUtil.h path in WINGS.h
566
567* Mon Feb 26 2001 Jun Nishii <jun@vinelinux.org>
568- 0.64.0-0vl1
569
570* Thu Feb 08 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
571- added defattr to separated lib subpackage
572
573* Thu Feb  8 2001 Jun Nishii <jun@vinelinux.org>
574- 0.63.1-0vl4
575- separate libs subpackage
576
577* Wed Jan 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
578- 0.63.1-0vl3
579- change ${SYSDEFDIR} -> %{SYSDEFDIR} in %ifarch ppc lines
580
5811 Jun Nishii <jun@vinelinux.org>
582- 0.63.1-0vl2
583- more macros in spec
584- update WINGs patch
585
586* Sat Jan 13 2001 Jun Nishii <jun@vinelinux.org>
587- 0.63.1-0vl1
588- version up
589
590* Tue Oct 10 2000 Jun Nishii <jun@vinelinux.org>
591- 0.62.1-0vl8
592- bug fix in plmenu.ja
593
594* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
595- 0.62.1-0vl7
596- change icon of sylpheed
597
598* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
599- 0.62.1-0vl6
600- set font as alias-fixed
601
602* Sat Sep 30 2000 Jun Nishii <jun@vinelinux.org>
603- 0.62.1-0vl5
604- obsletes vmail and use sylpheed
605
606* Thu Aug 31 2000 Jun Nishii <jun@vinelinux.org>
607- 0.62.1-0vl4
608- change backbground path (use vine-backgrounds)
609
610* Sun Aug 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
611- 0.62.1-0vl3
612- swap default mousebutton if ppc
613  (PowerMac's default mouse has only one button...)
614
615* Wed Aug 16 2000 Jun Nishii <jun@vinelinux.org>
616- rename mozilla.sh as netscape.sh
617- use brp
618- added dockit
619
620* Mon Apr  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
621- updated to 0.62.1
622
623* Sun Apr  2 2000 Jun Nishii <jun@vinelinux.org>
624- added libdockapp instead of docklib
625
626* Fri Mar 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
627- updated to 0.62.0
628- added docklib src from 0.61.1
629- modified ja.po for WindowMaker and WMPrefs
630
631* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
632- bug fix of WINGs_im patch by Mr. Furukawa
633
634* Sat Jan 22 2000 Jun Nishii <jun@vinelinux.org>
635- bug fix of installation process of Makefile in WindowMaker-0.61.1vine7
636
637* Thu Dec 30 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine)
638- rel.9
639- added WINGs_im patch to support XIM in WINGs tool kits.
640
641* Fri Dec  3 1999 Jun Nishii <jun@flatout.org>
642- use rm --force in %post
643- Do not use birthwindow.patch which may cause incorrect window placement.
644
645* Fri Nov 26 1999 Jun NISHII <jun@flatout.org>
646- fix autostart.sh to check wsoundserver and wmsound
647- ver up wmconfig-vine
648- some other minor changes...
649
650* Fri Nov 12 1999 Jun Nishii <jun@flatout.org>
651- rel.6
652- added wheel patch
653- bug fix in mozilla.sh
654
655* Thu Nov 11 1999 Jun Nishii <jun@flatout.org>
656- rel.5
657- requires vutils instead of vsetup
658
659* Wed Nov 10 1999 Jun Nishii <jun@flatout.org>
660- rel.4
661- change menu
662- requires vsetup
663
664* Tue Nov  9 1999 Yasuyuki Furukawa <yasu@on.cs.keio.ac.jp> (Vine, JP-3)
665- use font guess patch instead of Japanese font patch
666- remove japanese fontset from default font-set
667
668* Thu Oct 14 1999 Jun Nishii <jun@flatout.org>
669- added dockapp.h
670
671* Sat Oct 9 1999 Jun Nishii <jun@flatout.org>
672- 0.61.1
673
674* Mon Sep 27 1999 Jun Nishii <jun@flatout.org>
675- added mozilla.sh
676
677* Sun Sep 26 1999 Jun Nishii <jun@flatout.org>
678- change default font-sets
679
680* Tue Sep 21 1999 Jun Nishii <jun@flatout.org>
681- use Default.style_kai instead of Default.style
682- install libdockapp
683
684* Wed Jul 21 1999 Jun Nishii <jun@flatout.org>
685- move to new directory structure (defaults in /etc/X11/WindowMaker)
686
687* Tue Jul 20 1999 Jun Nishii <jun@flatout.org>
688- build for Vine-1.9
689
690* Sun Jun 6 1999 Jun Nishii <jun@flatout.org>
691- merged patch for wsetfont to support MultiByteText
692- modify default font setting
693- launch netscape from autostart.sh
694
695* Fri Jun 4 1999 Jun Nishii <jun@flatout.org>
696- updated to 0.60.0
697
698* Fri Apr 23 1999 Jun Nishii <jun@flatout.org>
699- updated to 0.53.0
700
701* Thu Mar 25 1999 Jun Nishii <jun@flatout.org>
702- patch to fix focus
703
704* Sun Mar 14 1999 Jun Nishii <jun@flatout.org>
705- updated to 0.51.2
706
707* Fri Mar 12 1999 Jun Nishii <jun@flatout.org>
708- rel.11
709- bug fix of the wrapper of wmconfig
710
711* Mon Mar 8 1999 Jun Nishii <jun@flatout.org>
712- rel.10
713- added wrapper of wmconfig to support dummy NLS
714
715* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
716- rel.9
717- asclock-jp.patch and WindowMaker-birthwindow.patch by Yasuyuki Furukawa
718- remove xfig from menu
719
720* Thu Mar 4 1999 Jun Nishii <jun@flatout.org>
721- rel.8
722- bug fix in menu items which require root privilege (use su -)
723
724* Sun Feb 28 1999 Jun Nishii <jun@flatout.org>
725- rel.7
726- use plmenu.ja as a default menu
727
728* Thu Feb 25 1999 Jun Nishii <jun@flatout.org>
729- rel.6
730- stop autoraise
731
732* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
733- rel.5
734- added patch for WMMail not to down when no /var/spool/mail/$USER
735
736* Sun Feb 21 1999 Jun Nishii <jun@flatout.org>
737- rel.4
738- merge WMMail.app
739- dock WMMail if no xppxpm
740- fix bug that kterm doesn't start from dock after restart WM.
741- added plmenu.ja
742
743* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
744- rel.3
745- set BuggyApplication for xppxp in Dock which enables no warning when
746  xppxp is not installed
747- move Themes for Vine to WindowMaker-Icons
748
749* Tue Feb 16 1999 Jun Nishii <jun@flatout.org>
750- rel.2
751- modify menu, Dock, and etc for Vine 1.0
752
753* Fri Jan 29 1999 Jun Nishii <jun@flatout.org>
754- updated to 0.51.0
755
756* Wed Jan 27 1999 Jun Nishii <jun@flatout.org>
757- rel.4
758- customize some key bindings
759- remove xterm from menu.ja
760- make default iconsize 56x56
761
762* Thu Jan 14 1999 Jun Nishii <jun@flatout.org>
763- rel.3
764- use /lib/cpp which is a wrapper to choose one by gcc or egcs
765- typo fix in WPrefs.ja.po
766
767* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
768- rel.2
769- use gcc -E instead of /lib/cpp
770
771* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
772- updated to 0.50.2
773
774* Sun Jan 10 1999 Jun Nishii <jun@flatout.org>
775- updated to 0.50.1
776
777* Fri Jan 8 1999 Jun Nishii <jun@flatout.org>
778- updated to 0.50.0
779
780* Sun Dec 27 1998 Jun Nishii <jun@flatout.org>
781- added patch, new_nifty_pixmap-gradient.patch
782
783* Sun Dec 20 1998 Jun Nishii <jun@flatout.org>
784- modify menu and other default settings
785- added new themes
786
787* Fri Dec 11 1998 Jun Nishii <jun@flatout.org>
788- modified ja.po for WindowMaker and WPrefs
789- added config files for Vine Linux
790
791* Sat Dec 5 1998 Jun Nishii <jun@flatout.org>
792- updated to 0.20.3
793- added and modified ja.po for WindowMaker and WPrefs
794- make and merge patch to support nls for more messages
795
796* Mon Nov 30 1998 Jun Nishii <jun@flatout.org>
797- Moved Japanese catalog from ja_JP.ujis to ja
798
799* Tue Nov 24 1998 Jun Nishii <jun@flatout.org>
800- updated to 0.20.2
801
802* Mon Nov 23 1998 Jun Nishii <jun@flatout.org>
803- enable kanji for Vine Linux
804
805* Mon Oct 05 1998 Cristian Gafton <gafton@redhat.com>
806- fixed swicthing to other window managers problem
807- updated to 0.20.1
808- include all the .mo files, not just WindowMaker...
809- added an older version of asclock as wmclock
810- include libPropList.a in the %files
811
812* Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
813- version 0.91.3
814
815* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
816- version 0.19.2
817- don't require asclock as a separate package
818
819* Wed Aug 12 1998 Cristian Gafton <gafton@redhat.com>
820- upgraded to 0.17.5
821
822* Tue Jul 21 1998 Cristian Gafton <gafton@redhat.com>
823- updated to 0.17.2
824
825* Thu Jul 09 1998 Cristian Gafton <gafton@redhat.com>
826- updated to 0.16.1
827- removed asclock (conflicts with AfterStep)
828
829* Fri Feb 27 1998 Cristian Gafton <gafton@redhat.com>
830- updated to 0.14.0
831
832* Fri Jan 30 1998 Cristian Gafton <gafton@redhat.com>
833- upgraded to 0.13.0
834- added the include files and the development libraries
835
836* Thu Nov 20 1997 Cristian Gafton <gafton@redhat.com>
837- first build against glibc
Note: See TracBrowser for help on using the repository browser.