source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 8771

Revision 8771, 7.7 KB checked in by Takemikaduchi, 10 years ago (diff)

poppler-0.26.2

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        2.4.4
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk3-devel
40BuildRequires:  at-spi2-core-devel
41BuildRequires:  gtk2-devel
42BuildRequires:  harfbuzz-icu-devel
43BuildRequires:  libjpeg-turbo-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gcr-devel
51BuildRequires:  gstreamer1-devel
52BuildRequires:  gstreamer1-plugins-base-devel
53BuildRequires:  enchant-devel
54BuildRequires:  libwebp-devel
55BuildRequires:  libsecret-devel
56BuildRequires:  gobject-introspection-devel
57BuildRequires:  gsettings-desktop-schemas
58BuildRequires:  gtk-doc
59
60%if %{with pango}
61BuildRequires:  pango-devel
62%else
63BuildRequires:  cairo-devel
64BuildRequires:  fontconfig-devel
65BuildRequires:  freetype2-devel
66%endif
67
68BuildRequires:  libsoup-devel >= 2.28.2
69
70
71%description
72WebKit is an open source web browser engine.
73
74%package        gtk
75Summary:        GTK+ port of WebKit
76Summary(ja):    WebKit の GTK+ ポート
77Group:          Development/Libraries
78
79%description    gtk
80%{name} is an open-source Web content engine library. This package contains
81the shared libraries for the WebKit GTK+ port as well as the sample
82GtkLauncher tool.
83
84
85%package        gtk-devel
86Summary:        Development package for %{name}
87Summary(ja):    %{name} の開発パッケージ
88Group:          Development/Libraries
89Requires:       %{name}-gtk = %{version}-%{release}
90Requires:       pkgconfig
91Requires:       gtk3-devel
92Requires:       libsoup-devel >= 2.28.2
93
94%description    gtk-devel
95The %{name}-gtk-devel package contains libraries, build data, and header
96files for developing applications that use %{name}-gtk.
97Please note that the WebKit/GTK+ API is not yet stable. This should
98only be used as a "preview" rather than a stable platform library.
99
100
101%package        docs
102Summary:        Documentation for %{name}
103Summary(ja):    %{name} のドキュメント
104Group:          Documentation
105BuildArch:      noarch
106Provides:       %{name}-doc = %{version}-%{release}
107
108%description    docs
109%{name} is an open-source Web content engine library. This package contains
110the documentation for %{name}, including various LICENSE, README, and
111AUTHORS files.
112
113
114%prep
115%setup -q -n webkitgtk-%{version}
116
117%build
118%configure \
119--with-gtk=3.0 \
120--with-gstreamer=1.0 \
121--enable-icon-database \
122--enable-geolocation \
123--enable-introspection=yes \
124--enable-dependency-tracking \
125%{?with_coverage:       --enable-coverage               }       \
126%{?with_pango:          --with-font-backend=pango       }       \
127%{?with_wml:            --enable-wml                    }
128
129make %{?_smp_mflags}
130#make V=1
131
132# workaround for bug 488112
133# Compile libJavaScriptCore.a with -fno-strict-aliasing
134##touch JavaScriptCore/AllInOneFile.cpp
135##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
136
137
138%install
139rm -rf %{buildroot}
140
141make install DESTDIR=%{buildroot}
142install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
143install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
144
145find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
146
147# conflict with WebKit-doc
148rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
149
150# Finally, copy over and rename the various files for %%doc inclusion.
151%add_to_doc_files Source/WebKit/LICENSE
152%add_to_doc_files Source/WebKit/gtk/NEWS
153%add_to_doc_files Source/WebCore/icu/LICENSE
154%add_to_doc_files Source/WebCore/LICENSE-APPLE
155%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
156%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
157%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
158%add_to_doc_files Source/JavaScriptCore/THANKS
159%add_to_doc_files Source/JavaScriptCore/AUTHORS
160%add_to_doc_files Source/JavaScriptCore/icu/README
161
162%find_lang WebKitGTK-3.0
163
164%clean
165rm -rf %{buildroot}
166
167
168%post   gtk -p /sbin/ldconfig
169
170%posttrans gtk
171glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172
173%postun gtk
174/sbin/ldconfig
175if [ $1 -eq 0 ] ; then
176    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
177fi
178
179
180# %files -f webkit.lang gtk
181%files gtk -f WebKitGTK-3.0.lang
182%defattr(-,root,root,-)
183%{_bindir}/jsc-3
184%{_libdir}/*.so.*
185%{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
186%{_libdir}/girepository-1.0/*.typelib
187%{_libexecdir}/WebKit3/
188%{_libexecdir}/WebKitNetworkProcess
189%{_libexecdir}/WebKitPluginProcess
190%{_libexecdir}/WebKitWebProcess
191%{_datadir}/webkitgtk-3.0/*
192
193%files  gtk-devel
194%defattr(-,root,root,-)
195%exclude %{_libdir}/*.la
196%{_includedir}/webkitgtk-3.0
197%{_libdir}/*.so
198%{_libdir}/pkgconfig/*.pc
199%{_datadir}/gir-1.0/*.gir
200
201%files  docs -f docfiles.list
202%defattr(-,root,root,-)
203
204
205%changelog
206* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
207- new upstream release
208
209* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
210- new upstream release
211
212* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
213- new upstream release
214
215* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
216- new upstream release
217
218* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
219- new upstream release
220
221* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
222- new upstream release
223
224* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
225- rebuild with icu-52.1
226
227* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
228- new upstream release
229
230* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
231- new upstream release
232
233* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
234- new upstream release
235- add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
236- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
237
238* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
239- new upstream release
240
241* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
242- new upstream release
243
244* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
245- new upstream release
246- add BuildRequires: ruby, gtk2-devel
247- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
248- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
249
250* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
251- new upstream release
252
253* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
254- new upstream release
255
256* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
257- new upstream release
258- change BuildRequires: gcr-devel instead of gnome-keyring-devel
259- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
260
261* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
262- new upstream release
263
264* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
265- new upstream release
266
267* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
268- new upstream release
269
270* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
271- initial build for Vine Linux
272
Note: See TracBrowser for help on using the repository browser.