source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 7294

Revision 7294, 6.5 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        1.10.2
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk3-devel
40BuildRequires:  gtk2-devel
41BuildRequires:  libicu-devel
42BuildRequires:  libjpeg-turbo-devel
43BuildRequires:  libtool
44BuildRequires:  libxslt-devel
45BuildRequires:  libXt-devel
46BuildRequires:  pcre-devel
47BuildRequires:  sqlite3-devel
48BuildRequires:  geoclue-devel
49BuildRequires:  gcr-devel
50BuildRequires:  gstreamer1-devel
51BuildRequires:  gstreamer1-plugins-base-devel
52BuildRequires:  enchant-devel
53BuildRequires:  gobject-introspection-devel
54BuildRequires:  gsettings-desktop-schemas
55BuildRequires:  gtk-doc
56
57%if %{with pango}
58BuildRequires:  pango-devel
59%else
60BuildRequires:  cairo-devel
61BuildRequires:  fontconfig-devel
62BuildRequires:  freetype2-devel
63%endif
64
65BuildRequires:  libsoup-devel >= 2.28.2
66
67
68%description
69WebKit is an open source web browser engine.
70
71%package        gtk
72Summary:        GTK+ port of WebKit
73Summary(ja):    WebKit の GTK+ ポート
74Group:          Development/Libraries
75
76%description    gtk
77%{name} is an open-source Web content engine library. This package contains
78the shared libraries for the WebKit GTK+ port as well as the sample
79GtkLauncher tool.
80
81
82%package        gtk-devel
83Summary:        Development package for %{name}
84Summary(ja):    %{name} の開発パッケージ
85Group:          Development/Libraries
86Requires:       %{name}-gtk = %{version}-%{release}
87Requires:       pkgconfig
88Requires:       gtk3-devel
89Requires:       libsoup-devel >= 2.28.2
90
91%description    gtk-devel
92The %{name}-gtk-devel package contains libraries, build data, and header
93files for developing applications that use %{name}-gtk.
94Please note that the WebKit/GTK+ API is not yet stable. This should
95only be used as a "preview" rather than a stable platform library.
96
97
98%package        doc
99Summary:        Documentation for %{name}
100Summary(ja):    %{name} のドキュメント
101Group:          Documentation
102
103%description    doc
104%{name} is an open-source Web content engine library. This package contains
105the documentation for %{name}, including various LICENSE, README, and
106AUTHORS files.
107
108
109%prep
110%setup -q -n webkitgtk-%{version}
111
112%build
113%configure \
114--with-gtk=3.0 \
115--with-gstreamer=1.0 \
116--enable-icon-database \
117--enable-geolocation \
118--enable-introspection=yes \
119--enable-dependency-tracking \
120%{?with_coverage:       --enable-coverage               }       \
121%{?with_pango:          --with-font-backend=pango       }       \
122%{?with_wml:            --enable-wml                    }
123
124make V=1 %{?_smp_mflags}
125
126# workaround for bug 488112
127# Compile libJavaScriptCore.a with -fno-strict-aliasing
128##touch JavaScriptCore/AllInOneFile.cpp
129##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
130
131
132%install
133rm -rf %{buildroot}
134
135make install DESTDIR=%{buildroot}
136install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
137install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
138
139# conflict with WebKit-doc
140rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
141
142# Finally, copy over and rename the various files for %%doc inclusion.
143%add_to_doc_files Source/WebKit/LICENSE
144%add_to_doc_files Source/WebKit/gtk/po/README
145%add_to_doc_files Source/WebKit/gtk/NEWS
146%add_to_doc_files Source/WebCore/icu/LICENSE
147%add_to_doc_files Source/WebCore/LICENSE-APPLE
148%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
149%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
150%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
151%add_to_doc_files Source/JavaScriptCore/THANKS
152%add_to_doc_files Source/JavaScriptCore/AUTHORS
153%add_to_doc_files Source/JavaScriptCore/icu/README
154%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
155
156%find_lang webkitgtk-3.0
157
158%clean
159rm -rf %{buildroot}
160
161
162%post   gtk -p /sbin/ldconfig
163
164%posttrans gtk
165glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
166
167%postun gtk
168/sbin/ldconfig
169if [ $1 -eq 0 ] ; then
170    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
171fi
172
173
174# %files -f webkit.lang gtk
175%files gtk -f webkitgtk-3.0.lang
176%defattr(-,root,root,-)
177%doc
178%{_libdir}/*.so.*
179%{_libexecdir}/WebKit3/
180%{_libexecdir}/WebKitPluginProcess
181%{_libexecdir}/WebKitWebProcess
182%{_bindir}/jsc-3
183%{_libdir}/girepository-1.0/*.typelib
184%{_datadir}/webkitgtk-3.0/*
185
186%files  gtk-devel
187%defattr(-,root,root,-)
188%exclude %{_libdir}/*.la
189%{_includedir}/webkitgtk-3.0
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_datadir}/gir-1.0/*.gir
193
194%files  doc -f docfiles.list
195%defattr(-,root,root,-)
196
197
198%changelog
199* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
200- new upstream release
201
202* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
203- new upstream release
204
205* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
206- new upstream release
207- add BuildRequires: ruby, gtk2-devel
208- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
209- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
210
211* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
212- new upstream release
213
214* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
215- new upstream release
216
217* Sun Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
218- new upstream release
219- change BuildRequires: gcr-devel instead of gnome-keyring-devel
220- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
221
222* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
223- new upstream release
224
225* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
226- new upstream release
227
228* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
229- new upstream release
230
231* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
232- initial build for Vine Linux
233
Note: See TracBrowser for help on using the repository browser.