source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 6078

Revision 6078, 5.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        1.8.1
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  gtk3-devel
39BuildRequires:  libicu-devel
40BuildRequires:  libjpeg-turbo-devel
41BuildRequires:  libtool
42BuildRequires:  libxslt-devel
43BuildRequires:  libXt-devel
44BuildRequires:  pcre-devel
45BuildRequires:  sqlite3-devel
46BuildRequires:  geoclue-devel
47BuildRequires:  gcr-devel
48BuildRequires:  gstreamer-devel
49BuildRequires:  gstreamer-plugins-base-devel
50BuildRequires:  enchant-devel
51BuildRequires:  gobject-introspection-devel
52BuildRequires:  gsettings-desktop-schemas
53BuildRequires:  gtk-doc
54
55%if %{with pango}
56BuildRequires:  pango-devel
57%else
58BuildRequires:  cairo-devel
59BuildRequires:  fontconfig-devel
60BuildRequires:  freetype2-devel
61%endif
62
63BuildRequires:  libsoup-devel >= 2.28.2
64
65
66%description
67WebKit is an open source web browser engine.
68
69%package        gtk
70Summary:        GTK+ port of WebKit
71Summary(ja):    WebKit の GTK+ ポート
72Group:          Development/Libraries
73
74%description    gtk
75%{name} is an open-source Web content engine library. This package contains
76the shared libraries for the WebKit GTK+ port as well as the sample
77GtkLauncher tool.
78
79
80%package        gtk-devel
81Summary:        Development package for %{name}
82Summary(ja):    %{name} の開発パッケージ
83Group:          Development/Libraries
84Requires:       %{name}-gtk = %{version}-%{release}
85Requires:       pkgconfig
86Requires:       gtk3-devel
87Requires:       libsoup-devel >= 2.28.2
88
89%description    gtk-devel
90The %{name}-gtk-devel package contains libraries, build data, and header
91files for developing applications that use %{name}-gtk.
92Please note that the WebKit/GTK+ API is not yet stable. This should
93only be used as a "preview" rather than a stable platform library.
94
95
96%package        doc
97Summary:        Documentation for %{name}
98Summary(ja):    %{name} のドキュメント
99Group:          Documentation
100
101%description    doc
102%{name} is an open-source Web content engine library. This package contains
103the documentation for %{name}, including various LICENSE, README, and
104AUTHORS files.
105
106
107%prep
108%setup -q -n webkit-%{version}
109
110%build
111%configure \
112--with-gtk=3.0 \
113--enable-icon-database \
114--enable-geolocation \
115--enable-introspection=yes \
116%{?with_coverage:       --enable-coverage               }       \
117%{?with_pango:          --with-font-backend=pango       }       \
118%{?with_wml:            --enable-wml                    }
119make V=1 %{?_smp_mflags}
120
121# workaround for bug 488112
122# Compile libJavaScriptCore.a with -fno-strict-aliasing
123##touch JavaScriptCore/AllInOneFile.cpp
124##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
125
126
127%install
128rm -rf %{buildroot}
129
130make install DESTDIR=%{buildroot}
131install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
132install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
133
134# conflict with WebKit-doc
135rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
136
137# Finally, copy over and rename the various files for %%doc inclusion.
138%add_to_doc_files Source/WebKit/LICENSE
139%add_to_doc_files Source/WebKit/gtk/po/README
140%add_to_doc_files Source/WebKit/gtk/NEWS
141%add_to_doc_files Source/WebCore/icu/LICENSE
142%add_to_doc_files Source/WebCore/LICENSE-APPLE
143%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
144%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
145%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
146%add_to_doc_files Source/JavaScriptCore/THANKS
147%add_to_doc_files Source/JavaScriptCore/AUTHORS
148%add_to_doc_files Source/JavaScriptCore/icu/README
149%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
150
151%find_lang webkit-3.0
152
153%clean
154rm -rf %{buildroot}
155
156
157%post   gtk -p /sbin/ldconfig
158
159%posttrans gtk
160glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
161
162%postun gtk
163/sbin/ldconfig
164if [ $1 -eq 0 ] ; then
165    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
166fi
167
168
169# %files -f webkit.lang gtk
170%files gtk -f webkit-3.0.lang
171%defattr(-,root,root,-)
172%doc
173%{_libdir}/*.so.*
174%{_libexecdir}/WebKit3/
175%{_bindir}/jsc-3
176%{_libdir}/girepository-1.0/*.typelib
177%{_datadir}/webkitgtk-3.0/*
178
179%files  gtk-devel
180%defattr(-,root,root,-)
181%exclude %{_libdir}/*.la
182%{_includedir}/webkitgtk-3.0
183%{_libdir}/*.so
184%{_libdir}/pkgconfig/*.pc
185%{_datadir}/gir-1.0/*.gir
186
187%files  doc -f docfiles.list
188%defattr(-,root,root,-)
189
190
191%changelog
192* Sun Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
193- new upstream release
194- change BuildRequires: gcr-devel instead of gnome-keyring-devel
195- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
196
197* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
198- new upstream release
199
200* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
201- new upstream release
202
203* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
204- new upstream release
205
206* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
207- initial build for Vine Linux
208
Note: See TracBrowser for help on using the repository browser.