source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 4850

Revision 4850, 5.5 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.2.0

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        1.6.1
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
32
33# upstream patch
34Patch100:       WebKit-icu44-36381.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37
38BuildRequires:  bison
39BuildRequires:  flex
40BuildRequires:  gperf
41BuildRequires:  gtk3-devel
42BuildRequires:  libicu-devel
43BuildRequires:  libjpeg-turbo-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gnome-keyring-devel
51BuildRequires:  gstreamer-devel
52BuildRequires:  gstreamer-plugins-base-devel
53BuildRequires:  enchant-devel
54BuildRequires:  gobject-introspection-devel
55
56%if %{with pango}
57BuildRequires:  pango-devel
58%else
59BuildRequires:  cairo-devel
60BuildRequires:  fontconfig-devel
61BuildRequires:  freetype2-devel
62%endif
63
64BuildRequires:  libsoup-devel >= 2.28.2
65
66
67%description
68WebKit is an open source web browser engine.
69
70%package        gtk
71Summary:        GTK+ port of WebKit
72Summary(ja):    WebKit の GTK+ ポート
73Group:          Development/Libraries
74
75%description    gtk
76%{name} is an open-source Web content engine library. This package contains
77the shared libraries for the WebKit GTK+ port as well as the sample
78GtkLauncher tool.
79
80
81%package        gtk-devel
82Summary:        Development package for %{name}
83Summary(ja):    %{name} の開発パッケージ
84Group:          Development/Libraries
85Requires:       %{name}-gtk = %{version}-%{release}
86Requires:       pkgconfig
87Requires:       gtk3-devel
88Requires:       libsoup-devel >= 2.28.2
89
90%description    gtk-devel
91The %{name}-gtk-devel package contains libraries, build data, and header
92files for developing applications that use %{name}-gtk.
93Please note that the WebKit/GTK+ API is not yet stable. This should
94only be used as a "preview" rather than a stable platform library.
95
96
97%package        doc
98Summary:        Documentation for %{name}
99Summary(ja):    %{name} のドキュメント
100Group:          Documentation
101
102%description    doc
103%{name} is an open-source Web content engine library. This package contains
104the documentation for %{name}, including various LICENSE, README, and
105AUTHORS files.
106
107
108%prep
109%setup -q -n webkit-%{version}
110
111# upstream
112## %patch100 -p0
113
114%build
115%configure \
116--with-gtk=3.0 \
117--enable-icon-database \
118--enable-geolocation \
119--enable-introspection=yes \
120%{?with_coverage:       --enable-coverage               }       \
121%{?with_pango:          --with-font-backend=pango       }       \
122%{?with_wml:            --enable-wml                    }
123make %{?_smp_mflags}
124
125# workaround for bug 488112
126# Compile libJavaScriptCore.a with -fno-strict-aliasing
127##touch JavaScriptCore/AllInOneFile.cpp
128##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
129
130
131%install
132rm -rf %{buildroot}
133
134make install DESTDIR=%{buildroot}
135install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
136install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
137
138# Finally, copy over and rename the various files for %%doc inclusion.
139%add_to_doc_files Source/WebKit/LICENSE
140%add_to_doc_files Source/WebKit/gtk/po/README
141%add_to_doc_files Source/WebKit/gtk/NEWS
142%add_to_doc_files Source/WebCore/icu/LICENSE
143%add_to_doc_files Source/WebCore/LICENSE-APPLE
144%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
145%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
146%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
147%add_to_doc_files Source/JavaScriptCore/THANKS
148%add_to_doc_files Source/JavaScriptCore/AUTHORS
149%add_to_doc_files Source/JavaScriptCore/icu/README
150%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
151
152%find_lang webkit-3.0
153
154%clean
155rm -rf %{buildroot}
156
157
158%post   gtk -p /sbin/ldconfig
159
160%posttrans gtk
161glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
162
163%postun gtk
164/sbin/ldconfig
165if [ $1 -eq 0 ] ; then
166    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167fi
168
169
170# %files -f webkit.lang gtk
171%files gtk -f webkit-3.0.lang
172%defattr(-,root,root,-)
173%doc
174%{_libdir}/*.so.*
175%{_libexecdir}/WebKit3/
176%{_bindir}/jsc-3
177%{_libdir}/girepository-1.0/*.typelib
178%{_datadir}/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
179%{_datadir}/webkitgtk-3.0/*
180
181%files  gtk-devel
182%defattr(-,root,root,-)
183%exclude %{_libdir}/*.la
184%{_includedir}/webkit-3.0
185%{_libdir}/*.so
186%{_libdir}/pkgconfig/*.pc
187%{_datadir}/gir-1.0/*.gir
188
189%files  doc -f docfiles.list
190%defattr(-,root,root,-)
191%{_docdir}/%{name}-%{version}/
192
193
194%changelog
195* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
196- new upstream release
197
198* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
199- new upstream release
200
201* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
202- new upstream release
203
204* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
205- initial build for Vine Linux
206
Note: See TracBrowser for help on using the repository browser.