source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 10459

Revision 10459, 8.5 KB checked in by tomop, 8 years ago (diff)

WebKit3-2.4.11-2

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        2.4.11
19Release:        2%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk3-devel
40BuildRequires:  at-spi2-core-devel
41BuildRequires:  gtk2-devel
42BuildRequires:  harfbuzz-icu-devel
43BuildRequires:  libjpeg-turbo-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gcr-devel
51BuildRequires:  gstreamer1-devel
52BuildRequires:  gstreamer1-plugins-base-devel
53BuildRequires:  enchant-devel
54BuildRequires:  libwebp-devel
55BuildRequires:  libsecret-devel
56BuildRequires:  gobject-introspection-devel
57BuildRequires:  gsettings-desktop-schemas
58BuildRequires:  gtk-doc
59
60%if %{with pango}
61BuildRequires:  pango-devel
62%else
63BuildRequires:  cairo-devel
64BuildRequires:  fontconfig-devel
65BuildRequires:  freetype2-devel
66%endif
67
68BuildRequires:  libsoup-devel >= 2.28.2
69
70
71%description
72WebKit is an open source web browser engine.
73
74%package        gtk
75Summary:        GTK+ port of WebKit
76Summary(ja):    WebKit の GTK+ ポート
77Group:          Development/Libraries
78Provides:       webkitgtk3 = %{version}-%{release}
79
80%description    gtk
81%{name} is an open-source Web content engine library. This package contains
82the shared libraries for the WebKit GTK+ port as well as the sample
83GtkLauncher tool.
84
85
86%package        gtk-devel
87Summary:        Development package for %{name}
88Summary(ja):    %{name} の開発パッケージ
89Group:          Development/Libraries
90Provides:       webkitgtk3-devel = %{version}-%{release}
91Requires:       %{name}-gtk = %{version}-%{release}
92Requires:       pkgconfig
93Requires:       gtk3-devel
94Requires:       libsoup-devel >= 2.28.2
95
96%description    gtk-devel
97The %{name}-gtk-devel package contains libraries, build data, and header
98files for developing applications that use %{name}-gtk.
99Please note that the WebKit/GTK+ API is not yet stable. This should
100only be used as a "preview" rather than a stable platform library.
101
102
103%package        docs
104Summary:        Documentation for %{name}
105Summary(ja):    %{name} のドキュメント
106Group:          Documentation
107BuildArch:      noarch
108Provides:       webkitgtk3-docs = %{version}-%{release}
109Provides:       %{name}-doc = %{version}-%{release}
110
111%description    docs
112%{name} is an open-source Web content engine library. This package contains
113the documentation for %{name}, including various LICENSE, README, and
114AUTHORS files.
115
116
117%prep
118%setup -q -n webkitgtk-%{version}
119
120%build
121%configure \
122--with-gtk=3.0 \
123--with-gstreamer=1.0 \
124--enable-icon-database \
125--enable-geolocation \
126--enable-introspection=yes \
127--enable-dependency-tracking \
128%{?with_coverage:       --enable-coverage               }       \
129%{?with_pango:          --with-font-backend=pango       }       \
130%{?with_wml:            --enable-wml                    }
131
132make %{?_smp_mflags}
133#make V=1
134
135# workaround for bug 488112
136# Compile libJavaScriptCore.a with -fno-strict-aliasing
137##touch JavaScriptCore/AllInOneFile.cpp
138##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
139
140
141%install
142rm -rf %{buildroot}
143
144make install DESTDIR=%{buildroot}
145install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
146install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
147
148find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
149
150# conflict with WebKit-doc
151rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
152
153# Finally, copy over and rename the various files for %%doc inclusion.
154%add_to_doc_files Source/WebKit/LICENSE
155%add_to_doc_files Source/WebKit/gtk/NEWS
156%add_to_doc_files Source/WebCore/icu/LICENSE
157%add_to_doc_files Source/WebCore/LICENSE-APPLE
158%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
159%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
160%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
161%add_to_doc_files Source/JavaScriptCore/THANKS
162%add_to_doc_files Source/JavaScriptCore/AUTHORS
163%add_to_doc_files Source/JavaScriptCore/icu/README
164
165%find_lang WebKitGTK-3.0
166
167%clean
168rm -rf %{buildroot}
169
170
171%post   gtk -p /sbin/ldconfig
172
173%posttrans gtk
174glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
175
176%postun gtk
177/sbin/ldconfig
178if [ $1 -eq 0 ] ; then
179    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
180fi
181
182
183# %files -f webkit.lang gtk
184%files gtk -f WebKitGTK-3.0.lang
185%defattr(-,root,root,-)
186%{_bindir}/jsc-3
187%{_libdir}/*.so.*
188%{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
189%{_libdir}/girepository-1.0/*.typelib
190%{_libexecdir}/WebKit3/
191%{_libexecdir}/WebKitNetworkProcess
192%{_libexecdir}/WebKitPluginProcess
193%{_libexecdir}/WebKitWebProcess
194%{_datadir}/webkitgtk-3.0/*
195
196%files  gtk-devel
197%defattr(-,root,root,-)
198%exclude %{_libdir}/*.la
199%{_includedir}/webkitgtk-3.0
200%{_libdir}/*.so
201%{_libdir}/pkgconfig/*.pc
202%{_datadir}/gir-1.0/*.gir
203
204%files  docs -f docfiles.list
205%defattr(-,root,root,-)
206
207
208%changelog
209* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-2
210- rebuilt with new toolchain.
211
212* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
213- new upstream release
214
215* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
216- rebuild with icu-56.1
217
218* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
219- new upstream release
220
221* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
222- new upstream release
223
224* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
225- new upstream release
226
227* Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
228- new upstream release
229
230* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
231- new upstream release
232
233* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
234- new upstream release
235
236* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
237- new upstream release
238
239* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
240- new upstream release
241
242* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
243- new upstream release
244
245* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
246- new upstream release
247
248* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
249- rebuild with icu-52.1
250
251* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
252- new upstream release
253
254* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
255- new upstream release
256
257* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
258- new upstream release
259- add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
260- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
261
262* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
263- new upstream release
264
265* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
266- new upstream release
267
268* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
269- new upstream release
270- add BuildRequires: ruby, gtk2-devel
271- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
272- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
273
274* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
275- new upstream release
276
277* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
278- new upstream release
279
280* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
281- new upstream release
282- change BuildRequires: gcr-devel instead of gnome-keyring-devel
283- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
284
285* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
286- new upstream release
287
288* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
289- new upstream release
290
291* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
292- new upstream release
293
294* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
295- initial build for Vine Linux
296
Note: See TracBrowser for help on using the repository browser.