source: projects/specs/trunk/W/WebKit3/WebKit3-vl.spec @ 11373

Revision 11373, 8.7 KB checked in by tomop, 6 years ago (diff)

WebKit3-2.4.11-3

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit3
18Version:        2.4.11
19Release:        3%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk3-devel
40BuildRequires:  at-spi2-core-devel
41BuildRequires:  gtk2-devel
42BuildRequires:  harfbuzz-icu-devel
43BuildRequires:  libjpeg-turbo-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gcr-devel
51BuildRequires:  gstreamer1-devel
52BuildRequires:  gstreamer1-plugins-base-devel
53BuildRequires:  enchant-devel
54BuildRequires:  libwebp-devel
55BuildRequires:  libsecret-devel
56BuildRequires:  gobject-introspection-devel
57BuildRequires:  gsettings-desktop-schemas
58BuildRequires:  gtk-doc
59
60%if %{with pango}
61BuildRequires:  pango-devel
62%else
63BuildRequires:  cairo-devel
64BuildRequires:  fontconfig-devel
65BuildRequires:  freetype2-devel
66%endif
67
68BuildRequires:  libsoup-devel >= 2.28.2
69
70
71%description
72WebKit is an open source web browser engine.
73
74%package        gtk
75Summary:        GTK+ port of WebKit
76Summary(ja):    WebKit の GTK+ ポート
77Group:          Development/Libraries
78Provides:       webkitgtk3 = %{version}-%{release}
79
80%description    gtk
81%{name} is an open-source Web content engine library. This package contains
82the shared libraries for the WebKit GTK+ port as well as the sample
83GtkLauncher tool.
84
85
86%package        gtk-devel
87Summary:        Development package for %{name}
88Summary(ja):    %{name} の開発パッケージ
89Group:          Development/Libraries
90Provides:       webkitgtk3-devel = %{version}-%{release}
91Requires:       %{name}-gtk = %{version}-%{release}
92Requires:       pkgconfig
93Requires:       gtk3-devel
94Requires:       libsoup-devel >= 2.28.2
95
96%description    gtk-devel
97The %{name}-gtk-devel package contains libraries, build data, and header
98files for developing applications that use %{name}-gtk.
99Please note that the WebKit/GTK+ API is not yet stable. This should
100only be used as a "preview" rather than a stable platform library.
101
102
103%package        docs
104Summary:        Documentation for %{name}
105Summary(ja):    %{name} のドキュメント
106Group:          Documentation
107BuildArch:      noarch
108Provides:       webkitgtk3-docs = %{version}-%{release}
109Provides:       %{name}-doc = %{version}-%{release}
110
111%description    docs
112%{name} is an open-source Web content engine library. This package contains
113the documentation for %{name}, including various LICENSE, README, and
114AUTHORS files.
115
116
117%prep
118%setup -q -n webkitgtk-%{version}
119
120perl -pi -e 's/static_cast/reinterpret_cast/' ./Source/WebKit2/Shared/API/c/WKString.cpp
121
122%build
123autoreconf -ifv
124CXXFLAGS="%{optflags} -fpermissive --std=c++11" \
125%configure \
126--with-gtk=3.0 \
127--with-gstreamer=1.0 \
128--enable-icon-database \
129--enable-geolocation \
130--enable-introspection=yes \
131--enable-dependency-tracking \
132%{?with_coverage:       --enable-coverage               }       \
133%{?with_pango:          --with-font-backend=pango       }       \
134%{?with_wml:            --enable-wml                    }
135
136make %{?_smp_mflags}
137#make V=1
138
139# workaround for bug 488112
140# Compile libJavaScriptCore.a with -fno-strict-aliasing
141##touch JavaScriptCore/AllInOneFile.cpp
142##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
143
144
145%install
146rm -rf %{buildroot}
147
148make install DESTDIR=%{buildroot}
149install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
150install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
151
152find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
153
154# conflict with WebKit-doc
155rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc
156
157# Finally, copy over and rename the various files for %%doc inclusion.
158%add_to_doc_files Source/WebKit/LICENSE
159%add_to_doc_files Source/WebKit/gtk/NEWS
160%add_to_doc_files Source/WebCore/icu/LICENSE
161%add_to_doc_files Source/WebCore/LICENSE-APPLE
162%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
163%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
164%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
165%add_to_doc_files Source/JavaScriptCore/THANKS
166%add_to_doc_files Source/JavaScriptCore/AUTHORS
167%add_to_doc_files Source/JavaScriptCore/icu/README
168
169%find_lang WebKitGTK-3.0
170
171%clean
172rm -rf %{buildroot}
173
174
175%post   gtk -p /sbin/ldconfig
176
177%posttrans gtk
178glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
179
180%postun gtk
181/sbin/ldconfig
182if [ $1 -eq 0 ] ; then
183    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
184fi
185
186
187# %files -f webkit.lang gtk
188%files gtk -f WebKitGTK-3.0.lang
189%defattr(-,root,root,-)
190%{_bindir}/jsc-3
191%{_libdir}/*.so.*
192%{_libdir}/webkit2gtk-3.0/injected-bundle/libwebkit2gtkinjectedbundle.so
193%{_libdir}/girepository-1.0/*.typelib
194%{_libexecdir}/WebKit3/
195%{_libexecdir}/WebKitNetworkProcess
196%{_libexecdir}/WebKitPluginProcess
197%{_libexecdir}/WebKitWebProcess
198%{_datadir}/webkitgtk-3.0/*
199
200%files  gtk-devel
201%defattr(-,root,root,-)
202%exclude %{_libdir}/*.la
203%{_includedir}/webkitgtk-3.0
204%{_libdir}/*.so
205%{_libdir}/pkgconfig/*.pc
206%{_datadir}/gir-1.0/*.gir
207
208%files  docs -f docfiles.list
209%defattr(-,root,root,-)
210
211
212%changelog
213* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-3
214- rebuilt with libicu-60.2.
215
216* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.11-2
217- rebuilt with new toolchain.
218
219* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
220- new upstream release
221
222* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
223- rebuild with icu-56.1
224
225* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
226- new upstream release
227
228* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
229- new upstream release
230
231* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
232- new upstream release
233
234* Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
235- new upstream release
236
237* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
238- new upstream release
239
240* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
241- new upstream release
242
243* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
244- new upstream release
245
246* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
247- new upstream release
248
249* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
250- new upstream release
251
252* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
253- new upstream release
254
255* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
256- rebuild with icu-52.1
257
258* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
259- new upstream release
260
261* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
262- new upstream release
263
264* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
265- new upstream release
266- add BuildRequires: at-spi2-core-devel, libwebp-devel, libsecret-devel
267- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
268
269* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
270- new upstream release
271
272* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
273- new upstream release
274
275* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
276- new upstream release
277- add BuildRequires: ruby, gtk2-devel
278- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
279- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-pluings-base-devel
280
281* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
282- new upstream release
283
284* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
285- new upstream release
286
287* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
288- new upstream release
289- change BuildRequires: gcr-devel instead of gnome-keyring-devel
290- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
291
292* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
293- new upstream release
294
295* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
296- new upstream release
297
298* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
299- new upstream release
300
301* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
302- initial build for Vine Linux
303
Note: See TracBrowser for help on using the repository browser.