source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 825

Revision 825, 9.9 KB checked in by shaolin, 14 years ago (diff)
  • WebKit?, libboost: rebuilt again on ppc
Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with libsoup : use libsoup for HTTP backend instead of cURL (default: no)
15%bcond_with     libsoup
16# --with svg : experimental svg support (default: no)
17%bcond_with     svg
18# --with wml: Build support for WML
19%bcond_with     wml
20
21Name:           WebKit
22Version:        1.2.0
23Release:        2%{?_dist_release}
24Summary:        Web content engine library
25Summary(ja):    ウェブコンテンツエンジンライブラリ
26
27Group:          Development/Libraries
28License:        LGPLv2+ and BSD
29URL:            http://webkitgtk.org/
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: yasumichi
34
35Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
36
37# upstream patch
38Patch100:       WebKit-icu44-36381.patch
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
41
42BuildRequires:  bison
43BuildRequires:  flex
44BuildRequires:  gperf
45BuildRequires:  gtk2-devel
46BuildRequires:  libicu-devel
47BuildRequires:  libjpeg-devel
48BuildRequires:  libtool
49BuildRequires:  libxslt-devel
50BuildRequires:  libXt-devel
51BuildRequires:  pcre-devel
52BuildRequires:  sqlite3-devel
53BuildRequires:  geoclue-devel
54BuildRequires:  gnome-keyring-devel
55BuildRequires:  gstreamer-devel
56BuildRequires:  gstreamer-plugins-base-devel
57BuildRequires:  enchant-devel
58
59%if %{with pango}
60BuildRequires:  pango-devel
61%else
62BuildRequires:  cairo-devel
63BuildRequires:  fontconfig-devel
64BuildRequires:  freetype2-devel
65%endif
66
67%if %{with libsoup}
68BuildRequires:  libsoup-devel >= 2.23
69%else
70BuildRequires:  curl-devel
71%endif
72
73
74
75%description
76WebKit is an open source web browser engine.
77
78%package        gtk
79Summary:        GTK+ port of WebKit
80Summary(ja):    WebKit の GTK+ ポート
81Group:          Development/Libraries
82
83%description    gtk
84%{name} is an open-source Web content engine library. This package contains
85the shared libraries for the WebKit GTK+ port as well as the sample
86GtkLauncher tool.
87
88
89%package        gtk-devel
90Summary:        Development package for %{name}
91Summary(ja):    %{name} の開発パッケージ
92Group:          Development/Libraries
93Requires:       %{name}-gtk = %{version}-%{release}
94Requires:       pkgconfig
95Requires:       gtk2-devel
96
97%description    gtk-devel
98The %{name}-gtk-devel package contains libraries, build data, and header
99files for developing applications that use %{name}-gtk.
100Please note that the WebKit/GTK+ API is not yet stable. This should
101only be used as a "preview" rather than a stable platform library.
102
103
104%package        doc
105Summary:        Documentation for %{name}
106Summary(ja):    %{name} のドキュメント
107Group:          Documentation
108
109%description    doc
110%{name} is an open-source Web content engine library. This package contains
111the documentation for %{name}, including various LICENSE, README, and
112AUTHORS files.
113
114
115%prep
116%setup -q -n webkit-%{version}
117
118# upstream
119%patch100 -p0
120
121%build
122%configure \
123--enable-icon-database \
124--enable-gnome-keyring \
125--enable-geolocation \
126%{?with_coverage:       --enable-coverage               }       \
127%{?with_pango:          --with-font-backend=pango       }       \
128%{?with_libsoup:        --with-http-backend=soup        }       \
129%{?with_svg:            --enable-svg-filters            }       \
130%{?with_wml:            --enable-wml                    }
131make %{?_smp_mflags}
132
133# workaround for bug 488112
134# Compile libJavaScriptCore.a with -fno-strict-aliasing
135touch JavaScriptCore/AllInOneFile.cpp
136make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
137
138
139%install
140rm -rf %{buildroot}
141
142make install DESTDIR=%{buildroot}
143install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
144install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
145
146## Finally, copy over and rename the various files for %%doc inclusion.
147rm -f docfiles.list
148%add_to_doc_files JavaScriptCore/COPYING.LIB
149%add_to_doc_files JavaScriptCore/icu/LICENSE
150%add_to_doc_files WebKit/LICENSE
151%add_to_doc_files WebCore/LICENSE-APPLE
152%add_to_doc_files WebCore/LICENSE-LGPL-2
153%add_to_doc_files WebCore/LICENSE-LGPL-2.1
154%add_to_doc_files WebCore/icu/LICENSE
155
156%add_to_doc_files JavaScriptCore/AUTHORS
157%add_to_doc_files JavaScriptCore/pcre/AUTHORS   
158
159%add_to_doc_files JavaScriptCore/THANKS
160
161%find_lang webkit
162
163
164%clean
165rm -rf %{buildroot}
166
167
168%post   gtk -p /sbin/ldconfig
169
170%postun gtk -p /sbin/ldconfig
171
172
173%files -f webkit.lang gtk
174%defattr(-,root,root,-)
175%doc
176%{_libdir}/libwebkit-1.0.so.*
177%{_libexecdir}/WebKit/
178%{_bindir}/jsc
179
180%files  gtk-devel
181%defattr(-,root,root,-)
182%exclude %{_libdir}/*.la
183%{_includedir}/webkit-1.0
184%{_datadir}/webkit-1.0
185%{_libdir}/libwebkit-1.0.so
186%{_libdir}/pkgconfig/webkit-1.0.pc
187
188%files  doc -f docfiles.list
189%defattr(-,root,root,-)
190
191
192%changelog
193* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
194- rebuilt again on ppc
195
196* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
197- new upstream release
198- rebuilt with libicu-4.4
199- added Patch100 for compiling with libicu-4.4
200- s/sqlite-devel/sqlite3-devel/
201- s/freetype-devel/freetype2-devel/
202
203* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
204- updated to 1.1.18
205
206* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
207- change BR from libsoup to libsoup-devel
208
209* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
210- new upstream release.
211- add Vendor, Distribution and Packager.
212
213* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
214- update to webkit-1.1.10 release version
215- added BuildRequires:  enchant-devel
216
217* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
218- update to webkit-1.1.6 release version
219
220* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
221- update to new upstream snapshot (svn r41944)
222
223* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
224- update to new upstream snapshot (svn r40471)
225
226* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
227- update to new upstream snapshot (svn r37056)
228- disable html5video by default
229
230* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
231- update to new upstream snapshot (svn r36882)
232- build with gnome-2.24
233
234* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
235- build without pango by default.
236
237* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
238- update to new upstream snapshot (svn r36053)
239
240* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
241- update to new upstream snapshot (svn r34655)
242
243* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
244- initial build for Vine Linux
245
246* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
247- rebuild for new icu
248
249* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
250- Update to new upstream snapshot (SVN 34279) anyway
251- Add BR: libXt-devel
252
253* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
254- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
255  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
256  subdirectories either.)
257- Reference: bug 442200 (RFE: WebKit Migration)
258- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
259  tree).
260
261* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
262- Update to new upstream snapshot (SVN 32531).
263- Fix bug 443048 and hopefully fix bug 444445
264- Modify the process of building GTK+ port a bit
265- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
266
267* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
268- Update to new upstream snapshot (SVN 31787).
269- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
270  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
271- Switch to using autotools for building the GTK+ port.
272
273* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
274- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
275  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
276- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
277 
278* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
279- Fix include directory naming. Resolves: bug 435561 (Header file <> header
280  file location mismatch)
281- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
282  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
283
284* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
285- Update to new upstream snapshot (SVN 30667)
286- Add some build fixes for GCC 4.3:
287  + gcc43.patch
288
289* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
290- Autorebuild for GCC 4.3
291
292* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
293- Update to new upstream snapshot (SVN 29336).
294- Drop TCSpinLock pthread workaround (fixed upstream):
295  - TCSpinLock-use-pthread-stubs.patch
296
297* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
298- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
299- Add patch to forcibly build the TCSpinLock code using the pthread
300  implementation:
301  + TCSpinLock-use-pthread-stubs.patch
302
303* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
304- Package renamed from WebKitGtk.
305- Update to SVN 28482.
306- Build both the GTK and Qt ports, putting each into their own respective
307  subpackages.
308- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
309  the build-webkit script from upstream.
310- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
311
312* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
313- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.