source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 8771

Revision 8771, 13.3 KB checked in by Takemikaduchi, 10 years ago (diff)

poppler-0.26.2

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        2.4.4
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi, Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk2-devel
40BuildRequires:  harfbuzz-icu-devel
41BuildRequires:  libjpeg-turbo-devel
42BuildRequires:  libtool
43BuildRequires:  libxslt-devel
44BuildRequires:  libXt-devel
45BuildRequires:  pcre-devel
46BuildRequires:  sqlite3-devel
47BuildRequires:  geoclue-devel
48BuildRequires:  gcr-devel
49BuildRequires:  gstreamer1-devel
50BuildRequires:  gstreamer1-plugins-base-devel
51BuildRequires:  enchant-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libsecret-devel
54BuildRequires:  gobject-introspection-devel
55BuildRequires:  gsettings-desktop-schemas
56BuildRequires:  gtk-doc
57
58%if %{with pango}
59BuildRequires:  pango-devel
60%else
61BuildRequires:  cairo-devel
62BuildRequires:  fontconfig-devel
63BuildRequires:  freetype2-devel
64%endif
65
66BuildRequires:  libsoup-devel >= 2.28.2
67
68
69%description
70WebKit is an open source web browser engine.
71
72%package        gtk
73Summary:        GTK+ port of WebKit
74Summary(ja):    WebKit の GTK+ ポート
75Group:          Development/Libraries
76
77%description    gtk
78%{name} is an open-source Web content engine library. This package contains
79the shared libraries for the WebKit GTK+ port as well as the sample
80GtkLauncher tool.
81
82
83%package        gtk-devel
84Summary:        Development package for %{name}
85Summary(ja):    %{name} の開発パッケージ
86Group:          Development/Libraries
87Requires:       %{name}-gtk = %{version}-%{release}
88Requires:       pkgconfig
89Requires:       gtk2-devel
90Requires:       libsoup-devel >= 2.28.2
91
92%description    gtk-devel
93The %{name}-gtk-devel package contains libraries, build data, and header
94files for developing applications that use %{name}-gtk.
95Please note that the WebKit/GTK+ API is not yet stable. This should
96only be used as a "preview" rather than a stable platform library.
97
98
99%package        docs
100Summary:        Documentation for %{name}
101Summary(ja):    %{name} のドキュメント
102Group:          Documentation
103Provides:       %{name}-doc = %{version}-%{release}
104
105%description    docs
106%{name} is an open-source Web content engine library. This package contains
107the documentation for %{name}, including various LICENSE, README, and
108AUTHORS files.
109
110
111%prep
112%setup -q -n webkitgtk-%{version}
113
114%build
115%configure \
116--with-gtk=2.0 \
117--disable-webkit2 \
118--enable-icon-database \
119--enable-jit \
120--enable-geolocation \
121--enable-introspection=yes \
122--enable-webgl \
123--enable-dependency-tracking \
124%{?with_coverage:       --enable-coverage               }       \
125%{?with_pango:          --with-font-backend=pango       }       \
126%{?with_wml:            --enable-wml                    }
127
128make %{?_smp_mflags}
129
130# workaround for bug 488112
131# Compile libJavaScriptCore.a with -fno-strict-aliasing
132##touch JavaScriptCore/AllInOneFile.cpp
133##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
134
135
136%install
137rm -rf %{buildroot}
138
139make install DESTDIR=%{buildroot}
140install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
141install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
142
143# Finally, copy over and rename the various files for %%doc inclusion.
144%add_to_doc_files Source/WebKit/LICENSE
145%add_to_doc_files Source/WebKit/gtk/NEWS
146%add_to_doc_files Source/WebCore/icu/LICENSE
147%add_to_doc_files Source/WebCore/LICENSE-APPLE
148%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
149%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
150%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
151%add_to_doc_files Source/JavaScriptCore/THANKS
152%add_to_doc_files Source/JavaScriptCore/AUTHORS
153%add_to_doc_files Source/JavaScriptCore/icu/README
154
155%find_lang WebKitGTK-2.0
156
157%clean
158rm -rf %{buildroot}
159
160
161%post   gtk -p /sbin/ldconfig
162
163%posttrans gtk
164glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
165
166%postun gtk
167/sbin/ldconfig
168if [ $1 -eq 0 ] ; then
169    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170fi
171
172
173# %files -f webkit.lang gtk
174%files gtk -f WebKitGTK-2.0.lang
175%defattr(-,root,root,-)
176%doc
177%{_libdir}/*.so.*
178%{_libexecdir}/WebKit/
179%{_bindir}/jsc-1
180%{_libdir}/girepository-1.0/*.typelib
181#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
182%{_datadir}/webkitgtk-1.0/*
183
184%files  gtk-devel
185%defattr(-,root,root,-)
186%exclude %{_libdir}/*.la
187%{_includedir}/webkitgtk-1.0
188%{_libdir}/*.so
189%{_libdir}/pkgconfig/*.pc
190%{_datadir}/gir-1.0/*.gir
191
192%files  docs -f docfiles.list
193%defattr(-,root,root,-)
194%{_datadir}/gtk-doc/html/webkitgtk
195%{_datadir}/gtk-doc/html/webkitdomgtk
196
197
198%changelog
199* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
200- new upstream release
201
202* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
203- new upstream release
204
205* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
206- new upstream release
207
208* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
209- new upstream release
210
211* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
212- new upstream release
213
214* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
215- new upstream release
216
217* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
218- rebuild with icu-52.1
219
220* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
221- new upstream release
222
223* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
224- new upstream release
225
226* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
227- new upstream release
228- add BuildRequires:  libwebp-devel, libsecret-devel
229- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
230- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
231- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
232
233* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
234- new upstream release
235
236* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
237- new upstream release
238
239* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
240- new upstream release
241- add BuildRequires: ruby
242
243* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
244- new upstream release
245
246* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
247- new upstream release
248
249* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
250- new upstream release
251- change BuildRequires: gcr-devel instead of gnome-keyring-devel
252- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
253
254* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
255- new upstream release
256
257* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
258- new upstream release
259
260* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
261- new upstream release
262
263* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
264- new upstream release
265
266* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
267- new upstream release
268- delete Patch0
269- add BuildRequires: gtk-doc
270
271* Fri Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
272- new upstream release
273
274* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
275- new upstream release
276
277* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
278- new upstream release
279- add BuildRequires: gobject-introspection-devel
280- add configure option (--enable-introspection=yes)
281- add Patch0 (WebKit-1.2.5-gir.patch)
282
283* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
284- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
285- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
286
287* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
288- new upstream release
289- add Requires: libsoup-devel (devel package)
290- fix configure (remove unrecognized option)
291- drop Patch100
292
293* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
294- rebuilt again on ppc
295
296* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
297- new upstream release
298- rebuilt with libicu-4.4
299- added Patch100 for compiling with libicu-4.4
300- s/sqlite-devel/sqlite3-devel/
301- s/freetype-devel/freetype2-devel/
302
303* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
304- updated to 1.1.18
305
306* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
307- change BR from libsoup to libsoup-devel
308
309* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
310- new upstream release.
311- add Vendor, Distribution and Packager.
312
313* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
314- update to webkit-1.1.10 release version
315- added BuildRequires:  enchant-devel
316
317* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
318- update to webkit-1.1.6 release version
319
320* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
321- update to new upstream snapshot (svn r41944)
322
323* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
324- update to new upstream snapshot (svn r40471)
325
326* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
327- update to new upstream snapshot (svn r37056)
328- disable html5video by default
329
330* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
331- update to new upstream snapshot (svn r36882)
332- build with gnome-2.24
333
334* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
335- build without pango by default.
336
337* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
338- update to new upstream snapshot (svn r36053)
339
340* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
341- update to new upstream snapshot (svn r34655)
342
343* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
344- initial build for Vine Linux
345
346* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
347- rebuild for new icu
348
349* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
350- Update to new upstream snapshot (SVN 34279) anyway
351- Add BR: libXt-devel
352
353* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
354- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
355  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
356  subdirectories either.)
357- Reference: bug 442200 (RFE: WebKit Migration)
358- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
359  tree).
360
361* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
362- Update to new upstream snapshot (SVN 32531).
363- Fix bug 443048 and hopefully fix bug 444445
364- Modify the process of building GTK+ port a bit
365- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
366
367* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
368- Update to new upstream snapshot (SVN 31787).
369- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
370  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
371- Switch to using autotools for building the GTK+ port.
372
373* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
374- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
375  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
376- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
377 
378* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
379- Fix include directory naming. Resolves: bug 435561 (Header file <> header
380  file location mismatch)
381- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
382  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
383
384* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
385- Update to new upstream snapshot (SVN 30667)
386- Add some build fixes for GCC 4.3:
387  + gcc43.patch
388
389* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
390- Autorebuild for GCC 4.3
391
392* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
393- Update to new upstream snapshot (SVN 29336).
394- Drop TCSpinLock pthread workaround (fixed upstream):
395  - TCSpinLock-use-pthread-stubs.patch
396
397* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
398- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
399- Add patch to forcibly build the TCSpinLock code using the pthread
400  implementation:
401  + TCSpinLock-use-pthread-stubs.patch
402
403* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
404- Package renamed from WebKitGtk.
405- Update to SVN 28482.
406- Build both the GTK and Qt ports, putting each into their own respective
407  subpackages.
408- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
409  the build-webkit script from upstream.
410- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
411
412* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
413- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.