source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 8084

Revision 8084, 12.8 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        2.2.3
19Release:        2%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk2-devel
40BuildRequires:  harfbuzz-icu-devel
41BuildRequires:  libjpeg-turbo-devel
42BuildRequires:  libtool
43BuildRequires:  libxslt-devel
44BuildRequires:  libXt-devel
45BuildRequires:  pcre-devel
46BuildRequires:  sqlite3-devel
47BuildRequires:  geoclue-devel
48BuildRequires:  gcr-devel
49BuildRequires:  gstreamer1-devel
50BuildRequires:  gstreamer1-plugins-base-devel
51BuildRequires:  enchant-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libsecret-devel
54BuildRequires:  gobject-introspection-devel
55BuildRequires:  gsettings-desktop-schemas
56BuildRequires:  gtk-doc
57
58%if %{with pango}
59BuildRequires:  pango-devel
60%else
61BuildRequires:  cairo-devel
62BuildRequires:  fontconfig-devel
63BuildRequires:  freetype2-devel
64%endif
65
66BuildRequires:  libsoup-devel >= 2.28.2
67
68
69%description
70WebKit is an open source web browser engine.
71
72%package        gtk
73Summary:        GTK+ port of WebKit
74Summary(ja):    WebKit の GTK+ ポート
75Group:          Development/Libraries
76
77%description    gtk
78%{name} is an open-source Web content engine library. This package contains
79the shared libraries for the WebKit GTK+ port as well as the sample
80GtkLauncher tool.
81
82
83%package        gtk-devel
84Summary:        Development package for %{name}
85Summary(ja):    %{name} の開発パッケージ
86Group:          Development/Libraries
87Requires:       %{name}-gtk = %{version}-%{release}
88Requires:       pkgconfig
89Requires:       gtk2-devel
90Requires:       libsoup-devel >= 2.28.2
91
92%description    gtk-devel
93The %{name}-gtk-devel package contains libraries, build data, and header
94files for developing applications that use %{name}-gtk.
95Please note that the WebKit/GTK+ API is not yet stable. This should
96only be used as a "preview" rather than a stable platform library.
97
98
99%package        docs
100Summary:        Documentation for %{name}
101Summary(ja):    %{name} のドキュメント
102Group:          Documentation
103Provides:       %{name}-doc = %{version}-%{release}
104
105%description    docs
106%{name} is an open-source Web content engine library. This package contains
107the documentation for %{name}, including various LICENSE, README, and
108AUTHORS files.
109
110
111%prep
112%setup -q -n webkitgtk-%{version}
113
114%build
115%configure \
116--with-gtk=2.0 \
117--disable-webkit2 \
118--enable-icon-database \
119--enable-jit \
120--enable-geolocation \
121--enable-introspection=yes \
122--enable-webgl \
123--enable-dependency-tracking \
124%{?with_coverage:       --enable-coverage               }       \
125%{?with_pango:          --with-font-backend=pango       }       \
126%{?with_wml:            --enable-wml                    }
127
128make %{?_smp_mflags}
129
130# workaround for bug 488112
131# Compile libJavaScriptCore.a with -fno-strict-aliasing
132##touch JavaScriptCore/AllInOneFile.cpp
133##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
134
135
136%install
137rm -rf %{buildroot}
138
139make install DESTDIR=%{buildroot}
140install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
141install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
142
143# Finally, copy over and rename the various files for %%doc inclusion.
144%add_to_doc_files Source/WebKit/LICENSE
145%add_to_doc_files Source/WebKit/gtk/NEWS
146%add_to_doc_files Source/WebCore/icu/LICENSE
147%add_to_doc_files Source/WebCore/LICENSE-APPLE
148%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
149%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
150%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
151%add_to_doc_files Source/JavaScriptCore/THANKS
152%add_to_doc_files Source/JavaScriptCore/AUTHORS
153%add_to_doc_files Source/JavaScriptCore/icu/README
154
155%find_lang WebKitGTK-2.0
156
157%clean
158rm -rf %{buildroot}
159
160
161%post   gtk -p /sbin/ldconfig
162
163%posttrans gtk
164glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
165
166%postun gtk
167/sbin/ldconfig
168if [ $1 -eq 0 ] ; then
169    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
170fi
171
172
173# %files -f webkit.lang gtk
174%files gtk -f WebKitGTK-2.0.lang
175%defattr(-,root,root,-)
176%doc
177%{_libdir}/*.so.*
178%{_libexecdir}/WebKit/
179%{_bindir}/jsc-1
180%{_libdir}/girepository-1.0/*.typelib
181#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
182%{_datadir}/webkitgtk-1.0/*
183
184%files  gtk-devel
185%defattr(-,root,root,-)
186%exclude %{_libdir}/*.la
187%{_includedir}/webkitgtk-1.0
188%{_libdir}/*.so
189%{_libdir}/pkgconfig/*.pc
190%{_datadir}/gir-1.0/*.gir
191
192%files  docs -f docfiles.list
193%defattr(-,root,root,-)
194%{_datadir}/gtk-doc/html/webkitgtk
195
196
197%changelog
198* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
199- rebuild with icu-52.1
200
201* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
202- new upstream release
203
204* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
205- new upstream release
206
207* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
208- new upstream release
209- add BuildRequires:  libwebp-devel, libsecret-devel
210- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
211- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
212- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
213
214* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
215- new upstream release
216
217* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
218- new upstream release
219
220* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
221- new upstream release
222- add BuildRequires: ruby
223
224* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
225- new upstream release
226
227* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
228- new upstream release
229
230* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
231- new upstream release
232- change BuildRequires: gcr-devel instead of gnome-keyring-devel
233- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
234
235* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
236- new upstream release
237
238* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
239- new upstream release
240
241* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
242- new upstream release
243
244* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
245- new upstream release
246
247* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
248- new upstream release
249- delete Patch0
250- add BuildRequires: gtk-doc
251
252* Fri Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
253- new upstream release
254
255* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
256- new upstream release
257
258* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
259- new upstream release
260- add BuildRequires: gobject-introspection-devel
261- add configure option (--enable-introspection=yes)
262- add Patch0 (WebKit-1.2.5-gir.patch)
263
264* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
265- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
266- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
267
268* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
269- new upstream release
270- add Requires: libsoup-devel (devel package)
271- fix configure (remove unrecognized option)
272- drop Patch100
273
274* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
275- rebuilt again on ppc
276
277* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
278- new upstream release
279- rebuilt with libicu-4.4
280- added Patch100 for compiling with libicu-4.4
281- s/sqlite-devel/sqlite3-devel/
282- s/freetype-devel/freetype2-devel/
283
284* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
285- updated to 1.1.18
286
287* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
288- change BR from libsoup to libsoup-devel
289
290* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
291- new upstream release.
292- add Vendor, Distribution and Packager.
293
294* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
295- update to webkit-1.1.10 release version
296- added BuildRequires:  enchant-devel
297
298* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
299- update to webkit-1.1.6 release version
300
301* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
302- update to new upstream snapshot (svn r41944)
303
304* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
305- update to new upstream snapshot (svn r40471)
306
307* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
308- update to new upstream snapshot (svn r37056)
309- disable html5video by default
310
311* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
312- update to new upstream snapshot (svn r36882)
313- build with gnome-2.24
314
315* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
316- build without pango by default.
317
318* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
319- update to new upstream snapshot (svn r36053)
320
321* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
322- update to new upstream snapshot (svn r34655)
323
324* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
325- initial build for Vine Linux
326
327* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
328- rebuild for new icu
329
330* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
331- Update to new upstream snapshot (SVN 34279) anyway
332- Add BR: libXt-devel
333
334* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
335- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
336  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
337  subdirectories either.)
338- Reference: bug 442200 (RFE: WebKit Migration)
339- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
340  tree).
341
342* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
343- Update to new upstream snapshot (SVN 32531).
344- Fix bug 443048 and hopefully fix bug 444445
345- Modify the process of building GTK+ port a bit
346- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
347
348* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
349- Update to new upstream snapshot (SVN 31787).
350- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
351  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
352- Switch to using autotools for building the GTK+ port.
353
354* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
355- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
356  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
357- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
358 
359* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
360- Fix include directory naming. Resolves: bug 435561 (Header file <> header
361  file location mismatch)
362- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
363  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
364
365* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
366- Update to new upstream snapshot (SVN 30667)
367- Add some build fixes for GCC 4.3:
368  + gcc43.patch
369
370* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
371- Autorebuild for GCC 4.3
372
373* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
374- Update to new upstream snapshot (SVN 29336).
375- Drop TCSpinLock pthread workaround (fixed upstream):
376  - TCSpinLock-use-pthread-stubs.patch
377
378* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
379- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
380- Add patch to forcibly build the TCSpinLock code using the pthread
381  implementation:
382  + TCSpinLock-use-pthread-stubs.patch
383
384* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
385- Package renamed from WebKitGtk.
386- Update to SVN 28482.
387- Build both the GTK and Qt ports, putting each into their own respective
388  subpackages.
389- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
390  the build-webkit script from upstream.
391- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
392
393* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
394- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.