source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with libsoup : use libsoup for HTTP backend instead of cURL (default: no)
15%bcond_with     libsoup
16# --with svg : experimental svg support (default: no)
17%bcond_with     svg
18# --with wml: Build support for WML
19%bcond_with     wml
20
21Name:           WebKit
22Version:        1.1.18
23Release:        1%{?_dist_release}
24Summary:        Web content engine library
25Summary(ja):    ウェブコンテンツエンジンライブラリ
26
27Group:          Development/Libraries
28License:        LGPLv2+ and BSD
29URL:            http://webkitgtk.org/
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: yasumichi
34
35Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38
39BuildRequires:  bison
40BuildRequires:  flex
41BuildRequires:  gperf
42BuildRequires:  gtk2-devel
43BuildRequires:  libicu-devel
44BuildRequires:  libjpeg-devel
45BuildRequires:  libtool
46BuildRequires:  libxslt-devel
47BuildRequires:  libXt-devel
48BuildRequires:  pcre-devel
49BuildRequires:  sqlite-devel
50BuildRequires:  geoclue-devel
51BuildRequires:  gnome-keyring-devel
52BuildRequires:  gstreamer-devel
53BuildRequires:  gstreamer-plugins-base-devel
54BuildRequires:  enchant-devel
55
56%if %{with pango}
57BuildRequires:  pango-devel
58%else
59BuildRequires:  cairo-devel
60BuildRequires:  fontconfig-devel
61BuildRequires:  freetype-devel
62%endif
63
64%if %{with libsoup}
65BuildRequires:  libsoup-devel >= 2.23
66%else
67BuildRequires:  curl-devel
68%endif
69
70
71
72%description
73WebKit is an open source web browser engine.
74
75%package        gtk
76Summary:        GTK+ port of WebKit
77Summary(ja):    WebKit の GTK+ ポート
78Group:          Development/Libraries
79
80%description    gtk
81%{name} is an open-source Web content engine library. This package contains
82the shared libraries for the WebKit GTK+ port as well as the sample
83GtkLauncher tool.
84
85
86%package        gtk-devel
87Summary:        Development package for %{name}
88Summary(ja):    %{name} の開発パッケージ
89Group:          Development/Libraries
90Requires:       %{name}-gtk = %{version}-%{release}
91Requires:       pkgconfig
92Requires:       gtk2-devel
93
94%description    gtk-devel
95The %{name}-gtk-devel package contains libraries, build data, and header
96files for developing applications that use %{name}-gtk.
97Please note that the WebKit/GTK+ API is not yet stable. This should
98only be used as a "preview" rather than a stable platform library.
99
100
101%package        doc
102Summary:        Documentation for %{name}
103Summary(ja):    %{name} のドキュメント
104Group:          Documentation
105
106%description    doc
107%{name} is an open-source Web content engine library. This package contains
108the documentation for %{name}, including various LICENSE, README, and
109AUTHORS files.
110
111
112%prep
113%setup -q -n webkit-%{version}
114
115
116%build
117%configure \
118--enable-icon-database \
119--enable-gnome-keyring \
120--enable-geolocation \
121%{?with_coverage:       --enable-coverage               }       \
122%{?with_pango:          --with-font-backend=pango       }       \
123%{?with_libsoup:        --with-http-backend=soup        }       \
124%{?with_svg:            --enable-svg-filters            }       \
125%{?with_wml:            --enable-wml                    }
126make %{?_smp_mflags}
127
128# workaround for bug 488112
129# Compile libJavaScriptCore.a with -fno-strict-aliasing
130touch JavaScriptCore/AllInOneFile.cpp
131make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
132
133
134%install
135rm -rf %{buildroot}
136
137make install DESTDIR=%{buildroot}
138install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
139install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
140
141## Finally, copy over and rename the various files for %%doc inclusion.
142rm -f docfiles.list
143%add_to_doc_files JavaScriptCore/COPYING.LIB
144%add_to_doc_files JavaScriptCore/icu/LICENSE
145%add_to_doc_files WebKit/LICENSE
146%add_to_doc_files WebCore/LICENSE-APPLE
147%add_to_doc_files WebCore/LICENSE-LGPL-2
148%add_to_doc_files WebCore/LICENSE-LGPL-2.1
149%add_to_doc_files WebCore/icu/LICENSE
150
151%add_to_doc_files JavaScriptCore/AUTHORS
152%add_to_doc_files JavaScriptCore/pcre/AUTHORS   
153
154%add_to_doc_files JavaScriptCore/THANKS
155
156%find_lang webkit
157
158
159%clean
160rm -rf %{buildroot}
161
162
163%post   gtk -p /sbin/ldconfig
164
165%postun gtk -p /sbin/ldconfig
166
167
168%files -f webkit.lang gtk
169%defattr(-,root,root,-)
170%doc
171%{_libdir}/libwebkit-1.0.so.*
172%{_libexecdir}/WebKit/
173%{_bindir}/jsc
174
175%files  gtk-devel
176%defattr(-,root,root,-)
177%exclude %{_libdir}/*.la
178%{_includedir}/webkit-1.0
179%{_datadir}/webkit-1.0
180%{_libdir}/libwebkit-1.0.so
181%{_libdir}/pkgconfig/webkit-1.0.pc
182
183%files  doc -f docfiles.list
184%defattr(-,root,root,-)
185
186
187%changelog
188* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
189- updated to 1.1.18
190
191* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
192- change BR from libsoup to libsoup-devel
193
194* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
195- new upstream release.
196- add Vendor, Distribution and Packager.
197
198* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
199- update to webkit-1.1.10 release version
200- added BuildRequires:  enchant-devel
201
202* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
203- update to webkit-1.1.6 release version
204
205* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
206- update to new upstream snapshot (svn r41944)
207
208* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
209- update to new upstream snapshot (svn r40471)
210
211* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
212- update to new upstream snapshot (svn r37056)
213- disable html5video by default
214
215* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
216- update to new upstream snapshot (svn r36882)
217- build with gnome-2.24
218
219* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
220- build without pango by default.
221
222* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
223- update to new upstream snapshot (svn r36053)
224
225* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
226- update to new upstream snapshot (svn r34655)
227
228* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
229- initial build for Vine Linux
230
231* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
232- rebuild for new icu
233
234* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
235- Update to new upstream snapshot (SVN 34279) anyway
236- Add BR: libXt-devel
237
238* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
239- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
240  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
241  subdirectories either.)
242- Reference: bug 442200 (RFE: WebKit Migration)
243- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
244  tree).
245
246* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
247- Update to new upstream snapshot (SVN 32531).
248- Fix bug 443048 and hopefully fix bug 444445
249- Modify the process of building GTK+ port a bit
250- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
251
252* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
253- Update to new upstream snapshot (SVN 31787).
254- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
255  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
256- Switch to using autotools for building the GTK+ port.
257
258* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
259- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
260  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
261- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
262 
263* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
264- Fix include directory naming. Resolves: bug 435561 (Header file <> header
265  file location mismatch)
266- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
267  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
268
269* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
270- Update to new upstream snapshot (SVN 30667)
271- Add some build fixes for GCC 4.3:
272  + gcc43.patch
273
274* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
275- Autorebuild for GCC 4.3
276
277* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
278- Update to new upstream snapshot (SVN 29336).
279- Drop TCSpinLock pthread workaround (fixed upstream):
280  - TCSpinLock-use-pthread-stubs.patch
281
282* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
283- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
284- Add patch to forcibly build the TCSpinLock code using the pthread
285  implementation:
286  + TCSpinLock-use-pthread-stubs.patch
287
288* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
289- Package renamed from WebKitGtk.
290- Update to SVN 28482.
291- Build both the GTK and Qt ports, putting each into their own respective
292  subpackages.
293- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
294  the build-webkit script from upstream.
295- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
296
297* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
298- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.