source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 6951

Revision 6951, 12.0 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        1.10.1
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk2-devel
40BuildRequires:  libicu-devel
41BuildRequires:  libjpeg-turbo-devel
42BuildRequires:  libtool
43BuildRequires:  libxslt-devel
44BuildRequires:  libXt-devel
45BuildRequires:  pcre-devel
46BuildRequires:  sqlite3-devel
47BuildRequires:  geoclue-devel
48BuildRequires:  gcr-devel
49BuildRequires:  gstreamer-devel
50BuildRequires:  gstreamer-plugins-base-devel
51BuildRequires:  enchant-devel
52BuildRequires:  gobject-introspection-devel
53BuildRequires:  gsettings-desktop-schemas
54BuildRequires:  gtk-doc
55
56%if %{with pango}
57BuildRequires:  pango-devel
58%else
59BuildRequires:  cairo-devel
60BuildRequires:  fontconfig-devel
61BuildRequires:  freetype2-devel
62%endif
63
64BuildRequires:  libsoup-devel >= 2.28.2
65
66
67%description
68WebKit is an open source web browser engine.
69
70%package        gtk
71Summary:        GTK+ port of WebKit
72Summary(ja):    WebKit の GTK+ ポート
73Group:          Development/Libraries
74
75%description    gtk
76%{name} is an open-source Web content engine library. This package contains
77the shared libraries for the WebKit GTK+ port as well as the sample
78GtkLauncher tool.
79
80
81%package        gtk-devel
82Summary:        Development package for %{name}
83Summary(ja):    %{name} の開発パッケージ
84Group:          Development/Libraries
85Requires:       %{name}-gtk = %{version}-%{release}
86Requires:       pkgconfig
87Requires:       gtk2-devel
88Requires:       libsoup-devel >= 2.28.2
89
90%description    gtk-devel
91The %{name}-gtk-devel package contains libraries, build data, and header
92files for developing applications that use %{name}-gtk.
93Please note that the WebKit/GTK+ API is not yet stable. This should
94only be used as a "preview" rather than a stable platform library.
95
96
97%package        doc
98Summary:        Documentation for %{name}
99Summary(ja):    %{name} のドキュメント
100Group:          Documentation
101
102%description    doc
103%{name} is an open-source Web content engine library. This package contains
104the documentation for %{name}, including various LICENSE, README, and
105AUTHORS files.
106
107
108%prep
109%setup -q -n webkitgtk-%{version}
110
111%build
112%configure \
113--with-gtk=2.0 \
114--disable-webkit2 \
115--enable-icon-database \
116--enable-jit \
117--enable-geolocation \
118--enable-introspection=yes \
119--enable-webgl \
120--enable-dependency-tracking \
121%{?with_coverage:       --enable-coverage               }       \
122%{?with_pango:          --with-font-backend=pango       }       \
123%{?with_wml:            --enable-wml                    }
124
125make V=1 %{?_smp_mflags}
126
127# workaround for bug 488112
128# Compile libJavaScriptCore.a with -fno-strict-aliasing
129##touch JavaScriptCore/AllInOneFile.cpp
130##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
131
132
133%install
134rm -rf %{buildroot}
135
136make install DESTDIR=%{buildroot}
137install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
138install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
139
140# Finally, copy over and rename the various files for %%doc inclusion.
141%add_to_doc_files Source/WebKit/LICENSE
142%add_to_doc_files Source/WebKit/gtk/po/README
143%add_to_doc_files Source/WebKit/gtk/NEWS
144%add_to_doc_files Source/WebCore/icu/LICENSE
145%add_to_doc_files Source/WebCore/LICENSE-APPLE
146%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
147%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
148%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
149%add_to_doc_files Source/JavaScriptCore/THANKS
150%add_to_doc_files Source/JavaScriptCore/AUTHORS
151%add_to_doc_files Source/JavaScriptCore/icu/README
152%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
153
154%find_lang webkitgtk-2.0
155
156%clean
157rm -rf %{buildroot}
158
159
160%post   gtk -p /sbin/ldconfig
161
162%posttrans gtk
163glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
164
165%postun gtk
166/sbin/ldconfig
167if [ $1 -eq 0 ] ; then
168    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
169fi
170
171
172# %files -f webkit.lang gtk
173%files gtk -f webkitgtk-2.0.lang
174%defattr(-,root,root,-)
175%doc
176%{_libdir}/*.so.*
177%{_libexecdir}/WebKit/
178%{_bindir}/jsc-1
179%{_libdir}/girepository-1.0/*.typelib
180#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
181%{_datadir}/webkitgtk-1.0/*
182
183%files  gtk-devel
184%defattr(-,root,root,-)
185%exclude %{_libdir}/*.la
186%{_includedir}/webkitgtk-1.0
187%{_libdir}/*.so
188%{_libdir}/pkgconfig/*.pc
189%{_datadir}/gir-1.0/*.gir
190
191%files  doc -f docfiles.list
192%defattr(-,root,root,-)
193%{_datadir}/gtk-doc/html/webkitgtk
194
195
196%changelog
197* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
198- new upstream release
199
200* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
201- new upstream release
202- add BuildRequires: ruby
203
204* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
205- new upstream release
206
207* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
208- new upstream release
209
210* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
211- new upstream release
212- change BuildRequires: gcr-devel instead of gnome-keyring-devel
213- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
214
215* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
216- new upstream release
217
218* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
219- new upstream release
220
221* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
222- new upstream release
223
224* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
225- new upstream release
226
227* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
228- new upstream release
229- delete Patch0
230- add BuildRequires: gtk-doc
231
232* Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
233- new upstream release
234
235* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
236- new upstream release
237
238* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
239- new upstream release
240- add BuildRequires: gobject-introspection-devel
241- add configure option (--enable-introspection=yes)
242- add Patch0 (WebKit-1.2.5-gir.patch)
243
244* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
245- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
246- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
247
248* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
249- new upstream release
250- add Requires: libsoup-devel (devel package)
251- fix configure (remove unrecognized option)
252- drop Patch100
253
254* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
255- rebuilt again on ppc
256
257* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
258- new upstream release
259- rebuilt with libicu-4.4
260- added Patch100 for compiling with libicu-4.4
261- s/sqlite-devel/sqlite3-devel/
262- s/freetype-devel/freetype2-devel/
263
264* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
265- updated to 1.1.18
266
267* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
268- change BR from libsoup to libsoup-devel
269
270* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
271- new upstream release.
272- add Vendor, Distribution and Packager.
273
274* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
275- update to webkit-1.1.10 release version
276- added BuildRequires:  enchant-devel
277
278* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
279- update to webkit-1.1.6 release version
280
281* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
282- update to new upstream snapshot (svn r41944)
283
284* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
285- update to new upstream snapshot (svn r40471)
286
287* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
288- update to new upstream snapshot (svn r37056)
289- disable html5video by default
290
291* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
292- update to new upstream snapshot (svn r36882)
293- build with gnome-2.24
294
295* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
296- build without pango by default.
297
298* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
299- update to new upstream snapshot (svn r36053)
300
301* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
302- update to new upstream snapshot (svn r34655)
303
304* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
305- initial build for Vine Linux
306
307* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
308- rebuild for new icu
309
310* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
311- Update to new upstream snapshot (SVN 34279) anyway
312- Add BR: libXt-devel
313
314* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
315- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
316  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
317  subdirectories either.)
318- Reference: bug 442200 (RFE: WebKit Migration)
319- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
320  tree).
321
322* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
323- Update to new upstream snapshot (SVN 32531).
324- Fix bug 443048 and hopefully fix bug 444445
325- Modify the process of building GTK+ port a bit
326- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
327
328* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
329- Update to new upstream snapshot (SVN 31787).
330- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
331  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
332- Switch to using autotools for building the GTK+ port.
333
334* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
335- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
336  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
337- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
338 
339* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
340- Fix include directory naming. Resolves: bug 435561 (Header file <> header
341  file location mismatch)
342- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
343  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
344
345* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
346- Update to new upstream snapshot (SVN 30667)
347- Add some build fixes for GCC 4.3:
348  + gcc43.patch
349
350* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
351- Autorebuild for GCC 4.3
352
353* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
354- Update to new upstream snapshot (SVN 29336).
355- Drop TCSpinLock pthread workaround (fixed upstream):
356  - TCSpinLock-use-pthread-stubs.patch
357
358* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
359- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
360- Add patch to forcibly build the TCSpinLock code using the pthread
361  implementation:
362  + TCSpinLock-use-pthread-stubs.patch
363
364* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
365- Package renamed from WebKitGtk.
366- Update to SVN 28482.
367- Build both the GTK and Qt ports, putting each into their own respective
368  subpackages.
369- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
370  the build-webkit script from upstream.
371- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
372
373* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
374- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.