source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 6078

Revision 6078, 11.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        1.8.1
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  gtk2-devel
39BuildRequires:  libicu-devel
40BuildRequires:  libjpeg-turbo-devel
41BuildRequires:  libtool
42BuildRequires:  libxslt-devel
43BuildRequires:  libXt-devel
44BuildRequires:  pcre-devel
45BuildRequires:  sqlite3-devel
46BuildRequires:  geoclue-devel
47BuildRequires:  gcr-devel
48BuildRequires:  gstreamer-devel
49BuildRequires:  gstreamer-plugins-base-devel
50BuildRequires:  enchant-devel
51BuildRequires:  gobject-introspection-devel
52BuildRequires:  gsettings-desktop-schemas
53BuildRequires:  gtk-doc
54
55%if %{with pango}
56BuildRequires:  pango-devel
57%else
58BuildRequires:  cairo-devel
59BuildRequires:  fontconfig-devel
60BuildRequires:  freetype2-devel
61%endif
62
63BuildRequires:  libsoup-devel >= 2.28.2
64
65
66%description
67WebKit is an open source web browser engine.
68
69%package        gtk
70Summary:        GTK+ port of WebKit
71Summary(ja):    WebKit の GTK+ ポート
72Group:          Development/Libraries
73
74%description    gtk
75%{name} is an open-source Web content engine library. This package contains
76the shared libraries for the WebKit GTK+ port as well as the sample
77GtkLauncher tool.
78
79
80%package        gtk-devel
81Summary:        Development package for %{name}
82Summary(ja):    %{name} の開発パッケージ
83Group:          Development/Libraries
84Requires:       %{name}-gtk = %{version}-%{release}
85Requires:       pkgconfig
86Requires:       gtk2-devel
87Requires:       libsoup-devel >= 2.28.2
88
89%description    gtk-devel
90The %{name}-gtk-devel package contains libraries, build data, and header
91files for developing applications that use %{name}-gtk.
92Please note that the WebKit/GTK+ API is not yet stable. This should
93only be used as a "preview" rather than a stable platform library.
94
95
96%package        doc
97Summary:        Documentation for %{name}
98Summary(ja):    %{name} のドキュメント
99Group:          Documentation
100
101%description    doc
102%{name} is an open-source Web content engine library. This package contains
103the documentation for %{name}, including various LICENSE, README, and
104AUTHORS files.
105
106
107%prep
108%setup -q -n webkit-%{version}
109
110%build
111%configure \
112--with-gtk=2.0 \
113--enable-icon-database \
114--enable-jit \
115--enable-geolocation \
116--enable-introspection=yes \
117--enable-webgl \
118%{?with_coverage:       --enable-coverage               }       \
119%{?with_pango:          --with-font-backend=pango       }       \
120%{?with_wml:            --enable-wml                    }
121
122make V=1 %{?_smp_mflags}
123
124# workaround for bug 488112
125# Compile libJavaScriptCore.a with -fno-strict-aliasing
126##touch JavaScriptCore/AllInOneFile.cpp
127##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
128
129
130%install
131rm -rf %{buildroot}
132
133make install DESTDIR=%{buildroot}
134install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
135install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
136
137# Finally, copy over and rename the various files for %%doc inclusion.
138%add_to_doc_files Source/WebKit/LICENSE
139%add_to_doc_files Source/WebKit/gtk/po/README
140%add_to_doc_files Source/WebKit/gtk/NEWS
141%add_to_doc_files Source/WebCore/icu/LICENSE
142%add_to_doc_files Source/WebCore/LICENSE-APPLE
143%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
144%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
145%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
146%add_to_doc_files Source/JavaScriptCore/THANKS
147%add_to_doc_files Source/JavaScriptCore/AUTHORS
148%add_to_doc_files Source/JavaScriptCore/icu/README
149%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
150
151%find_lang webkit-2.0
152
153%clean
154rm -rf %{buildroot}
155
156
157%post   gtk -p /sbin/ldconfig
158
159%posttrans gtk
160glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
161
162%postun gtk
163/sbin/ldconfig
164if [ $1 -eq 0 ] ; then
165    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
166fi
167
168
169# %files -f webkit.lang gtk
170%files gtk -f webkit-2.0.lang
171%defattr(-,root,root,-)
172%doc
173%{_libdir}/*.so.*
174%{_libexecdir}/WebKit/
175%{_bindir}/jsc-1
176%{_libdir}/girepository-1.0/*.typelib
177#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
178%{_datadir}/webkitgtk-1.0/*
179
180%files  gtk-devel
181%defattr(-,root,root,-)
182%exclude %{_libdir}/*.la
183%{_includedir}/webkitgtk-1.0
184%{_libdir}/*.so
185%{_libdir}/pkgconfig/*.pc
186%{_datadir}/gir-1.0/*.gir
187
188%files  doc -f docfiles.list
189%defattr(-,root,root,-)
190%{_datadir}/gtk-doc/html/webkitgtk
191
192
193%changelog
194* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
195- new upstream release
196- change BuildRequires: gcr-devel instead of gnome-keyring-devel
197- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
198
199* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
200- new upstream release
201
202* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
203- new upstream release
204
205* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
206- new upstream release
207
208* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
209- new upstream release
210
211* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
212- new upstream release
213- delete Patch0
214- add BuildRequires: gtk-doc
215
216* Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
217- new upstream release
218
219* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
220- new upstream release
221
222* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
223- new upstream release
224- add BuildRequires: gobject-introspection-devel
225- add configure option (--enable-introspection=yes)
226- add Patch0 (WebKit-1.2.5-gir.patch)
227
228* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
229- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
230- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
231
232* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
233- new upstream release
234- add Requires: libsoup-devel (devel package)
235- fix configure (remove unrecognized option)
236- drop Patch100
237
238* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
239- rebuilt again on ppc
240
241* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
242- new upstream release
243- rebuilt with libicu-4.4
244- added Patch100 for compiling with libicu-4.4
245- s/sqlite-devel/sqlite3-devel/
246- s/freetype-devel/freetype2-devel/
247
248* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
249- updated to 1.1.18
250
251* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
252- change BR from libsoup to libsoup-devel
253
254* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
255- new upstream release.
256- add Vendor, Distribution and Packager.
257
258* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
259- update to webkit-1.1.10 release version
260- added BuildRequires:  enchant-devel
261
262* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
263- update to webkit-1.1.6 release version
264
265* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
266- update to new upstream snapshot (svn r41944)
267
268* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
269- update to new upstream snapshot (svn r40471)
270
271* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
272- update to new upstream snapshot (svn r37056)
273- disable html5video by default
274
275* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
276- update to new upstream snapshot (svn r36882)
277- build with gnome-2.24
278
279* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
280- build without pango by default.
281
282* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
283- update to new upstream snapshot (svn r36053)
284
285* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
286- update to new upstream snapshot (svn r34655)
287
288* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
289- initial build for Vine Linux
290
291* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
292- rebuild for new icu
293
294* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
295- Update to new upstream snapshot (SVN 34279) anyway
296- Add BR: libXt-devel
297
298* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
299- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
300  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
301  subdirectories either.)
302- Reference: bug 442200 (RFE: WebKit Migration)
303- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
304  tree).
305
306* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
307- Update to new upstream snapshot (SVN 32531).
308- Fix bug 443048 and hopefully fix bug 444445
309- Modify the process of building GTK+ port a bit
310- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
311
312* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
313- Update to new upstream snapshot (SVN 31787).
314- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
315  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
316- Switch to using autotools for building the GTK+ port.
317
318* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
319- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
320  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
321- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
322 
323* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
324- Fix include directory naming. Resolves: bug 435561 (Header file <> header
325  file location mismatch)
326- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
327  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
328
329* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
330- Update to new upstream snapshot (SVN 30667)
331- Add some build fixes for GCC 4.3:
332  + gcc43.patch
333
334* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
335- Autorebuild for GCC 4.3
336
337* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
338- Update to new upstream snapshot (SVN 29336).
339- Drop TCSpinLock pthread workaround (fixed upstream):
340  - TCSpinLock-use-pthread-stubs.patch
341
342* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
343- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
344- Add patch to forcibly build the TCSpinLock code using the pthread
345  implementation:
346  + TCSpinLock-use-pthread-stubs.patch
347
348* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
349- Package renamed from WebKitGtk.
350- Update to SVN 28482.
351- Build both the GTK and Qt ports, putting each into their own respective
352  subpackages.
353- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
354  the build-webkit script from upstream.
355- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
356
357* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
358- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.