source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 4616

Revision 4616, 11.1 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        1.5.1
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
32
33# upstream patch
34Patch100:       WebKit-icu44-36381.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37
38BuildRequires:  bison
39BuildRequires:  flex
40BuildRequires:  gperf
41BuildRequires:  gtk2-devel
42BuildRequires:  libicu-devel
43BuildRequires:  libjpeg-turbo-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gnome-keyring-devel
51BuildRequires:  gstreamer-devel
52BuildRequires:  gstreamer-plugins-base-devel
53BuildRequires:  enchant-devel
54BuildRequires:  gobject-introspection-devel
55
56%if %{with pango}
57BuildRequires:  pango-devel
58%else
59BuildRequires:  cairo-devel
60BuildRequires:  fontconfig-devel
61BuildRequires:  freetype2-devel
62%endif
63
64BuildRequires:  libsoup-devel >= 2.28.2
65
66
67%description
68WebKit is an open source web browser engine.
69
70%package        gtk
71Summary:        GTK+ port of WebKit
72Summary(ja):    WebKit の GTK+ ポート
73Group:          Development/Libraries
74
75%description    gtk
76%{name} is an open-source Web content engine library. This package contains
77the shared libraries for the WebKit GTK+ port as well as the sample
78GtkLauncher tool.
79
80
81%package        gtk-devel
82Summary:        Development package for %{name}
83Summary(ja):    %{name} の開発パッケージ
84Group:          Development/Libraries
85Requires:       %{name}-gtk = %{version}-%{release}
86Requires:       pkgconfig
87Requires:       gtk2-devel
88Requires:       libsoup-devel >= 2.28.2
89
90%description    gtk-devel
91The %{name}-gtk-devel package contains libraries, build data, and header
92files for developing applications that use %{name}-gtk.
93Please note that the WebKit/GTK+ API is not yet stable. This should
94only be used as a "preview" rather than a stable platform library.
95
96
97%package        doc
98Summary:        Documentation for %{name}
99Summary(ja):    %{name} のドキュメント
100Group:          Documentation
101
102%description    doc
103%{name} is an open-source Web content engine library. This package contains
104the documentation for %{name}, including various LICENSE, README, and
105AUTHORS files.
106
107
108%prep
109%setup -q -n webkit-%{version}
110
111# upstream
112## %patch100 -p0
113
114%build
115%configure \
116--with-gtk=2.0 \
117--enable-icon-database \
118--enable-geolocation \
119--enable-introspection=yes \
120%{?with_coverage:       --enable-coverage               }       \
121%{?with_pango:          --with-font-backend=pango       }       \
122%{?with_wml:            --enable-wml                    }
123make %{?_smp_mflags}
124
125# workaround for bug 488112
126# Compile libJavaScriptCore.a with -fno-strict-aliasing
127##touch JavaScriptCore/AllInOneFile.cpp
128##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
129
130
131%install
132rm -rf %{buildroot}
133
134make install DESTDIR=%{buildroot}
135install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
136install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
137
138# Finally, copy over and rename the various files for %%doc inclusion.
139%add_to_doc_files Source/WebKit/LICENSE
140%add_to_doc_files Source/WebKit/gtk/po/README
141%add_to_doc_files Source/WebKit/gtk/NEWS
142%add_to_doc_files Source/WebCore/icu/LICENSE
143%add_to_doc_files Source/WebCore/LICENSE-APPLE
144%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
145%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
146%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
147%add_to_doc_files Source/JavaScriptCore/THANKS
148%add_to_doc_files Source/JavaScriptCore/AUTHORS
149%add_to_doc_files Source/JavaScriptCore/icu/README
150%add_to_doc_files Source/JavaScriptCore/icu/LICENSE
151
152%find_lang webkit-2.0
153
154%clean
155rm -rf %{buildroot}
156
157
158%post   gtk -p /sbin/ldconfig
159
160%posttrans gtk
161glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
162
163%postun gtk
164/sbin/ldconfig
165if [ $1 -eq 0 ] ; then
166    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167fi
168
169
170# %files -f webkit.lang gtk
171%files gtk -f webkit-2.0.lang
172%defattr(-,root,root,-)
173%doc
174%{_libdir}/*.so.*
175%{_libexecdir}/WebKit/
176%{_bindir}/jsc-1
177%{_libdir}/girepository-1.0/*.typelib
178%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
179%{_datadir}/webkitgtk-1.0/*
180
181%files  gtk-devel
182%defattr(-,root,root,-)
183%exclude %{_libdir}/*.la
184%{_includedir}/webkit-1.0
185%{_libdir}/*.so
186%{_libdir}/pkgconfig/*.pc
187%{_datadir}/gir-1.0/*.gir
188
189%files  doc -f docfiles.list
190%defattr(-,root,root,-)
191%{_docdir}/%{name}-%{version}/
192
193
194%changelog
195* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
196- new upstream release
197
198* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
199- new upstream release
200- delete Patch0
201- add BuildRequires: gtk-doc
202
203* Sat Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
204- new upstream release
205
206* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
207- new upstream release
208
209* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
210- new upstream release
211- add BuildRequires: gobject-introspection-devel
212- add configure option (--enable-introspection=yes)
213- add Patch0 (WebKit-1.2.5-gir.patch)
214
215* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
216- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
217- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
218
219* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
220- new upstream release
221- add Requires: libsoup-devel (devel package)
222- fix configure (remove unrecognized option)
223- drop Patch100
224
225* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
226- rebuilt again on ppc
227
228* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
229- new upstream release
230- rebuilt with libicu-4.4
231- added Patch100 for compiling with libicu-4.4
232- s/sqlite-devel/sqlite3-devel/
233- s/freetype-devel/freetype2-devel/
234
235* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
236- updated to 1.1.18
237
238* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
239- change BR from libsoup to libsoup-devel
240
241* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
242- new upstream release.
243- add Vendor, Distribution and Packager.
244
245* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
246- update to webkit-1.1.10 release version
247- added BuildRequires:  enchant-devel
248
249* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
250- update to webkit-1.1.6 release version
251
252* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
253- update to new upstream snapshot (svn r41944)
254
255* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
256- update to new upstream snapshot (svn r40471)
257
258* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
259- update to new upstream snapshot (svn r37056)
260- disable html5video by default
261
262* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
263- update to new upstream snapshot (svn r36882)
264- build with gnome-2.24
265
266* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
267- build without pango by default.
268
269* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
270- update to new upstream snapshot (svn r36053)
271
272* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
273- update to new upstream snapshot (svn r34655)
274
275* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
276- initial build for Vine Linux
277
278* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
279- rebuild for new icu
280
281* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
282- Update to new upstream snapshot (SVN 34279) anyway
283- Add BR: libXt-devel
284
285* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
286- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
287  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
288  subdirectories either.)
289- Reference: bug 442200 (RFE: WebKit Migration)
290- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
291  tree).
292
293* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
294- Update to new upstream snapshot (SVN 32531).
295- Fix bug 443048 and hopefully fix bug 444445
296- Modify the process of building GTK+ port a bit
297- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
298
299* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
300- Update to new upstream snapshot (SVN 31787).
301- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
302  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
303- Switch to using autotools for building the GTK+ port.
304
305* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
306- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
307  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
308- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
309 
310* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
311- Fix include directory naming. Resolves: bug 435561 (Header file <> header
312  file location mismatch)
313- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
314  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
315
316* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
317- Update to new upstream snapshot (SVN 30667)
318- Add some build fixes for GCC 4.3:
319  + gcc43.patch
320
321* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
322- Autorebuild for GCC 4.3
323
324* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
325- Update to new upstream snapshot (SVN 29336).
326- Drop TCSpinLock pthread workaround (fixed upstream):
327  - TCSpinLock-use-pthread-stubs.patch
328
329* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
330- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
331- Add patch to forcibly build the TCSpinLock code using the pthread
332  implementation:
333  + TCSpinLock-use-pthread-stubs.patch
334
335* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
336- Package renamed from WebKitGtk.
337- Update to SVN 28482.
338- Build both the GTK and Qt ports, putting each into their own respective
339  subpackages.
340- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
341  the build-webkit script from upstream.
342- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
343
344* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
345- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.