source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 1489

Revision 1489, 9.7 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        1.2.3
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi
30
31Source0:        http://www.webkitgtk.org/webkit-%{version}.tar.gz
32
33# upstream patch
34Patch100:       WebKit-icu44-36381.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37
38BuildRequires:  bison
39BuildRequires:  flex
40BuildRequires:  gperf
41BuildRequires:  gtk2-devel
42BuildRequires:  libicu-devel
43BuildRequires:  libjpeg-devel
44BuildRequires:  libtool
45BuildRequires:  libxslt-devel
46BuildRequires:  libXt-devel
47BuildRequires:  pcre-devel
48BuildRequires:  sqlite3-devel
49BuildRequires:  geoclue-devel
50BuildRequires:  gnome-keyring-devel
51BuildRequires:  gstreamer-devel
52BuildRequires:  gstreamer-plugins-base-devel
53BuildRequires:  enchant-devel
54
55%if %{with pango}
56BuildRequires:  pango-devel
57%else
58BuildRequires:  cairo-devel
59BuildRequires:  fontconfig-devel
60BuildRequires:  freetype2-devel
61%endif
62
63BuildRequires:  libsoup-devel >= 2.28.2
64
65
66%description
67WebKit is an open source web browser engine.
68
69%package        gtk
70Summary:        GTK+ port of WebKit
71Summary(ja):    WebKit の GTK+ ポート
72Group:          Development/Libraries
73
74%description    gtk
75%{name} is an open-source Web content engine library. This package contains
76the shared libraries for the WebKit GTK+ port as well as the sample
77GtkLauncher tool.
78
79
80%package        gtk-devel
81Summary:        Development package for %{name}
82Summary(ja):    %{name} の開発パッケージ
83Group:          Development/Libraries
84Requires:       %{name}-gtk = %{version}-%{release}
85Requires:       pkgconfig
86Requires:       gtk2-devel
87Requires:       libsoup-devel >= 2.28.2
88
89%description    gtk-devel
90The %{name}-gtk-devel package contains libraries, build data, and header
91files for developing applications that use %{name}-gtk.
92Please note that the WebKit/GTK+ API is not yet stable. This should
93only be used as a "preview" rather than a stable platform library.
94
95
96%package        doc
97Summary:        Documentation for %{name}
98Summary(ja):    %{name} のドキュメント
99Group:          Documentation
100
101%description    doc
102%{name} is an open-source Web content engine library. This package contains
103the documentation for %{name}, including various LICENSE, README, and
104AUTHORS files.
105
106
107%prep
108%setup -q -n webkit-%{version}
109
110# upstream
111## %patch100 -p0
112
113%build
114%configure \
115--enable-icon-database \
116--enable-geolocation \
117%{?with_coverage:       --enable-coverage               }       \
118%{?with_pango:          --with-font-backend=pango       }       \
119%{?with_wml:            --enable-wml                    }
120make %{?_smp_mflags}
121
122# workaround for bug 488112
123# Compile libJavaScriptCore.a with -fno-strict-aliasing
124touch JavaScriptCore/AllInOneFile.cpp
125make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
126
127
128%install
129rm -rf %{buildroot}
130
131make install DESTDIR=%{buildroot}
132install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
133install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
134
135## Finally, copy over and rename the various files for %%doc inclusion.
136rm -f docfiles.list
137%add_to_doc_files JavaScriptCore/COPYING.LIB
138%add_to_doc_files JavaScriptCore/icu/LICENSE
139%add_to_doc_files WebKit/LICENSE
140%add_to_doc_files WebCore/LICENSE-APPLE
141%add_to_doc_files WebCore/LICENSE-LGPL-2
142%add_to_doc_files WebCore/LICENSE-LGPL-2.1
143%add_to_doc_files WebCore/icu/LICENSE
144
145%add_to_doc_files JavaScriptCore/AUTHORS
146%add_to_doc_files JavaScriptCore/pcre/AUTHORS   
147
148%add_to_doc_files JavaScriptCore/THANKS
149
150%find_lang webkit
151
152
153%clean
154rm -rf %{buildroot}
155
156
157%post   gtk -p /sbin/ldconfig
158
159%postun gtk -p /sbin/ldconfig
160
161
162%files -f webkit.lang gtk
163%defattr(-,root,root,-)
164%doc
165%{_libdir}/libwebkit-1.0.so.*
166%{_libexecdir}/WebKit/
167%{_bindir}/jsc
168
169%files  gtk-devel
170%defattr(-,root,root,-)
171%exclude %{_libdir}/*.la
172%{_includedir}/webkit-1.0
173%{_datadir}/webkit-1.0
174%{_libdir}/libwebkit-1.0.so
175%{_libdir}/pkgconfig/webkit-1.0.pc
176
177%files  doc -f docfiles.list
178%defattr(-,root,root,-)
179
180
181%changelog
182* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
183- new upstream release
184- add Requires: libsoup-devel (devel package)
185- fix configure (remove unrecognized option)
186- drop Patch100
187
188* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
189- rebuilt again on ppc
190
191* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
192- new upstream release
193- rebuilt with libicu-4.4
194- added Patch100 for compiling with libicu-4.4
195- s/sqlite-devel/sqlite3-devel/
196- s/freetype-devel/freetype2-devel/
197
198* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
199- updated to 1.1.18
200
201* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
202- change BR from libsoup to libsoup-devel
203
204* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
205- new upstream release.
206- add Vendor, Distribution and Packager.
207
208* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
209- update to webkit-1.1.10 release version
210- added BuildRequires:  enchant-devel
211
212* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
213- update to webkit-1.1.6 release version
214
215* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
216- update to new upstream snapshot (svn r41944)
217
218* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
219- update to new upstream snapshot (svn r40471)
220
221* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
222- update to new upstream snapshot (svn r37056)
223- disable html5video by default
224
225* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
226- update to new upstream snapshot (svn r36882)
227- build with gnome-2.24
228
229* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
230- build without pango by default.
231
232* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
233- update to new upstream snapshot (svn r36053)
234
235* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
236- update to new upstream snapshot (svn r34655)
237
238* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
239- initial build for Vine Linux
240
241* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
242- rebuild for new icu
243
244* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
245- Update to new upstream snapshot (SVN 34279) anyway
246- Add BR: libXt-devel
247
248* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
249- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
250  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
251  subdirectories either.)
252- Reference: bug 442200 (RFE: WebKit Migration)
253- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
254  tree).
255
256* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
257- Update to new upstream snapshot (SVN 32531).
258- Fix bug 443048 and hopefully fix bug 444445
259- Modify the process of building GTK+ port a bit
260- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
261
262* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
263- Update to new upstream snapshot (SVN 31787).
264- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
265  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
266- Switch to using autotools for building the GTK+ port.
267
268* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
269- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
270  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
271- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
272 
273* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
274- Fix include directory naming. Resolves: bug 435561 (Header file <> header
275  file location mismatch)
276- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
277  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
278
279* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
280- Update to new upstream snapshot (SVN 30667)
281- Add some build fixes for GCC 4.3:
282  + gcc43.patch
283
284* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
285- Autorebuild for GCC 4.3
286
287* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
288- Update to new upstream snapshot (SVN 29336).
289- Drop TCSpinLock pthread workaround (fixed upstream):
290  - TCSpinLock-use-pthread-stubs.patch
291
292* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
293- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
294- Add patch to forcibly build the TCSpinLock code using the pthread
295  implementation:
296  + TCSpinLock-use-pthread-stubs.patch
297
298* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
299- Package renamed from WebKitGtk.
300- Update to SVN 28482.
301- Build both the GTK and Qt ports, putting each into their own respective
302  subpackages.
303- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
304  the build-webkit script from upstream.
305- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
306
307* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
308- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.