source: projects/specs/trunk/W/WebKit/WebKit-vl.spec @ 10195

Revision 10195, 14.0 KB checked in by Takemikaduchi, 8 years ago (diff)

new upstream release

Line 
1%define         add_to_doc_files()      \
2        mkdir -p %{buildroot}%{_docdir}/%{name}-%{version}; \
3        cp -p %1  %{buildroot}%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') \
4        echo %%{_docdir}/%{name}-%{version}/$(echo '%1' | sed -e 's!/!.!g') >> docfiles.list
5
6#define         svn_revision    43436
7
8# --with coverage: Enables compile-time checking of code coverage. (default: no)
9%bcond_with     coverage
10# --with jit: Enable JIT ("just-in-time") JavaScript compiling support.
11#%bcond_with    jit
12# --with pango : use pango for font rendering instead of freetype2 (default: use freetype2)
13%bcond_with     pango
14# --with wml: Build support for WML
15%bcond_with     wml
16
17Name:           WebKit
18Version:        2.4.11
19Release:        1%{?_dist_release}
20Summary:        Web content engine library
21Summary(ja):    ウェブコンテンツエンジンライブラリ
22
23Group:          Development/Libraries
24License:        LGPLv2+ and BSD
25URL:            http://webkitgtk.org/
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: yasumichi, Takemikaduchi
30
31Source0:        http://www.webkitgtk.org/webkitgtk-%{version}.tar.xz
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34
35BuildRequires:  bison
36BuildRequires:  flex
37BuildRequires:  gperf
38BuildRequires:  ruby
39BuildRequires:  gtk2-devel
40BuildRequires:  harfbuzz-icu-devel
41BuildRequires:  libjpeg-turbo-devel
42BuildRequires:  libtool
43BuildRequires:  libxslt-devel
44BuildRequires:  libXt-devel
45BuildRequires:  pcre-devel
46BuildRequires:  sqlite3-devel
47BuildRequires:  geoclue-devel
48BuildRequires:  gcr-devel
49BuildRequires:  gstreamer1-devel
50BuildRequires:  gstreamer1-plugins-base-devel
51BuildRequires:  enchant-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libsecret-devel
54BuildRequires:  gobject-introspection-devel
55BuildRequires:  gsettings-desktop-schemas
56BuildRequires:  gtk-doc
57%if %{with pango}
58BuildRequires:  pango-devel
59%else
60BuildRequires:  cairo-devel
61BuildRequires:  fontconfig-devel
62BuildRequires:  freetype2-devel
63%endif
64BuildRequires:  libsoup-devel >= 2.28.2
65
66
67%description
68WebKit is an open source web browser engine.
69
70%package        gtk
71Summary:        GTK+ port of WebKit
72Summary(ja):    WebKit の GTK+ ポート
73Group:          Development/Libraries
74Provides:               webkitgtk = %{version}-%{release}
75
76%description    gtk
77%{name} is an open-source Web content engine library. This package contains
78the shared libraries for the WebKit GTK+ port as well as the sample
79GtkLauncher tool.
80
81
82%package        gtk-devel
83Summary:        Development package for %{name}
84Summary(ja):    %{name} の開発パッケージ
85Group:          Development/Libraries
86Provides:       webkitgtk-devel = %{version}-%{release}
87
88Requires:       %{name}-gtk = %{version}-%{release}
89Requires:       pkgconfig
90Requires:       gtk2-devel
91Requires:       libsoup-devel >= 2.28.2
92
93%description    gtk-devel
94The %{name}-gtk-devel package contains libraries, build data, and header
95files for developing applications that use %{name}-gtk.
96Please note that the WebKit/GTK+ API is not yet stable. This should
97only be used as a "preview" rather than a stable platform library.
98
99
100%package        docs
101Summary:        Documentation for %{name}
102Summary(ja):    %{name} のドキュメント
103Group:          Documentation
104Provides:       webkitgtk-docs = %{version}-%{release}
105Provides:       %{name}-doc = %{version}-%{release}
106
107%description    docs
108%{name} is an open-source Web content engine library. This package contains
109the documentation for %{name}, including various LICENSE, README, and
110AUTHORS files.
111
112
113%prep
114%setup -q -n webkitgtk-%{version}
115
116%build
117%configure \
118--with-gtk=2.0 \
119--disable-webkit2 \
120--enable-icon-database \
121--enable-jit \
122--enable-geolocation \
123--enable-introspection=yes \
124--enable-webgl \
125--enable-dependency-tracking \
126%{?with_coverage:       --enable-coverage               }       \
127%{?with_pango:          --with-font-backend=pango       }       \
128%{?with_wml:            --enable-wml                    }
129
130make %{?_smp_mflags}
131
132# workaround for bug 488112
133# Compile libJavaScriptCore.a with -fno-strict-aliasing
134##touch JavaScriptCore/AllInOneFile.cpp
135##make %{?_smp_mflags} CXXFLAGS="%{optflags} -fno-strict-aliasing"
136
137
138%install
139rm -rf %{buildroot}
140
141make install DESTDIR=%{buildroot}
142install -d -m 755 %{buildroot}%{_libexecdir}/%{name}
143install -m 755 Programs/GtkLauncher %{buildroot}%{_libexecdir}/%{name}
144
145# Finally, copy over and rename the various files for %%doc inclusion.
146%add_to_doc_files Source/WebKit/LICENSE
147%add_to_doc_files Source/WebKit/gtk/NEWS
148%add_to_doc_files Source/WebCore/icu/LICENSE
149%add_to_doc_files Source/WebCore/LICENSE-APPLE
150%add_to_doc_files Source/WebCore/LICENSE-LGPL-2
151%add_to_doc_files Source/WebCore/LICENSE-LGPL-2.1
152%add_to_doc_files Source/JavaScriptCore/COPYING.LIB
153%add_to_doc_files Source/JavaScriptCore/THANKS
154%add_to_doc_files Source/JavaScriptCore/AUTHORS
155%add_to_doc_files Source/JavaScriptCore/icu/README
156
157%find_lang WebKitGTK-2.0
158
159%clean
160rm -rf %{buildroot}
161
162
163%post   gtk -p /sbin/ldconfig
164
165%posttrans gtk
166glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
167
168%postun gtk
169/sbin/ldconfig
170if [ $1 -eq 0 ] ; then
171    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
172fi
173
174
175# %files -f webkit.lang gtk
176%files gtk -f WebKitGTK-2.0.lang
177%defattr(-,root,root,-)
178%doc
179%{_libdir}/*.so.*
180%{_libexecdir}/WebKit/
181%{_bindir}/jsc-1
182%{_libdir}/girepository-1.0/*.typelib
183#%{_datadir}/glib-2.0/schemas/org.webkitgtk-1.0.gschema.xml
184%{_datadir}/webkitgtk-1.0/*
185
186%files  gtk-devel
187%defattr(-,root,root,-)
188%exclude %{_libdir}/*.la
189%{_includedir}/webkitgtk-1.0
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_datadir}/gir-1.0/*.gir
193
194%files  docs -f docfiles.list
195%defattr(-,root,root,-)
196%{_datadir}/gtk-doc/html/webkitgtk
197%{_datadir}/gtk-doc/html/webkitdomgtk
198
199
200%changelog
201* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.11-1
202- new usptream release
203
204* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-2
205- rebuild with icu-56.1
206
207* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.9-1
208- new usptream release
209
210* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.8-1
211- new usptream release
212
213* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.7-1
214- new usptream release
215
216* Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.5-1
217- new upstream release
218
219* Wed Jul 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.4-1
220- new upstream release
221
222* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.3-1
223- new upstream release
224
225* Wed May 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.2-1
226- new upstream release
227
228* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.1-1
229- new upstream release
230
231* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.4.0-1
232- new upstream release
233
234* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.4-1
235- new upstream release
236
237* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-2
238- rebuild with icu-52.1
239
240* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.3-1
241- new upstream release
242
243* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.2-1
244- new upstream release
245
246* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.2.1-1
247- new upstream release
248- add BuildRequires:  libwebp-devel, libsecret-devel
249- change BuildRequires: harfbuzz-icu-devel instead of libicu-devel
250- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
251- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
252
253* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.2-1
254- new upstream release
255
256* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.1-1
257- new upstream release
258
259* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.10.0-1
260- new upstream release
261- add BuildRequires: ruby
262
263* Tue Aug 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.3-1
264- new upstream release
265
266* Thu Aug 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.2-1
267- new upstream release
268
269* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.1-1
270- new upstream release
271- change BuildRequires: gcr-devel instead of gnome-keyring-devel
272- add BuildRequires:  gsettings-desktop-schemas, gtk-doc
273
274* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.6.1-1
275- new upstream release
276
277* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.90-1
278- new upstream release
279
280* Sat Aug 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.2-1
281- new upstream release
282
283* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.5.1-1
284- new upstream release
285
286* Sun Jul 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.2-1
287- new upstream release
288- delete Patch0
289- add BuildRequires: gtk-doc
290
291* Fri Apr 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.7-1
292- new upstream release
293
294* Sat Jan 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.6-1
295- new upstream release
296
297* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.5-1
298- new upstream release
299- add BuildRequires: gobject-introspection-devel
300- add configure option (--enable-introspection=yes)
301- add Patch0 (WebKit-1.2.5-gir.patch)
302
303* Thu Sep 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.4-1
304- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
305- changed BuildRequires: libjpeg-devel to libjpeg-turbo-devel
306
307* Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.2.3-1
308- new upstream release
309- add Requires: libsoup-devel (devel package)
310- fix configure (remove unrecognized option)
311- drop Patch100
312
313* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaoliN@vinelinux.org> - 1.2.0-2
314- rebuilt again on ppc
315
316* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
317- new upstream release
318- rebuilt with libicu-4.4
319- added Patch100 for compiling with libicu-4.4
320- s/sqlite-devel/sqlite3-devel/
321- s/freetype-devel/freetype2-devel/
322
323* Mon Jan 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.18-1
324- updated to 1.1.18
325
326* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-2
327- change BR from libsoup to libsoup-devel
328
329* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.1.15.3-1
330- new upstream release.
331- add Vendor, Distribution and Packager.
332
333* Mon Jul 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.10-1
334- update to webkit-1.1.10 release version
335- added BuildRequires:  enchant-devel
336
337* Sun May 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
338- update to webkit-1.1.6 release version
339
340* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-8.svn41944
341- update to new upstream snapshot (svn r41944)
342
343* Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-7.svn40471
344- update to new upstream snapshot (svn r40471)
345
346* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-6.svn37056
347- update to new upstream snapshot (svn r37056)
348- disable html5video by default
349
350* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-5.svn36882
351- update to new upstream snapshot (svn r36882)
352- build with gnome-2.24
353
354* Thu Sep 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-4.svn36053
355- build without pango by default.
356
357* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-3.svn36053
358- update to new upstream snapshot (svn r36053)
359
360* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2.svn34655
361- update to new upstream snapshot (svn r34655)
362
363* Mon Jun 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1.svn34279
364- initial build for Vine Linux
365
366* Tue Jun  3 2008 Caol叩n McNamara <caolanm@redhat.com> - 1.0.0-0.12.svn34279
367- rebuild for new icu
368
369* Tue Jun  3 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.11.svn34279
370- Update to new upstream snapshot (SVN 34279) anyway
371- Add BR: libXt-devel
372
373* Tue Apr 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.10.svn32531
374- Remove the -Qt subpackage stuff. QtWebKit is now included in Qt proper, as
375  of qt-4.4.0-0.6.rc1. (We no longer need separate build-qt and build-gtk
376  subdirectories either.)
377- Reference: bug 442200 (RFE: WebKit Migration)
378- Add libjpeg dependency (was previously pulled in by the qt4-devel dependency
379  tree).
380
381* Mon Apr 28 2008 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 1.0.0-0.9.svn32531
382- Update to new upstream snapshot (SVN 32531).
383- Fix bug 443048 and hopefully fix bug 444445
384- Modify the process of building GTK+ port a bit
385- on qt port WebKit/qt/Plugins is not built for qt >= 4.4.0
386
387* Sat Apr 12 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.8.svn31787
388- Update to new upstream snapshot (SVN 31787).
389- Resolves: CVE-2008-1010 (bug 438532: Arbitrary code execution) and
390  CVE-2008-1011 (bug 438531: Cross-Site Scripting).
391- Switch to using autotools for building the GTK+ port.
392
393* Wed Mar 05 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.7.svn30667
394- Fix the WebKitGtk pkgconfig data (should depend on gtk+-2.0). Resolves
395  bug 436073 (Requires: gtk+-2.0 missing from WebKitGtk.pc).
396- Thanks to Mamoru Tasaka for helping find and squash these many bugs.
397 
398* Sat Mar 01 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.6.svn30667
399- Fix include directory naming. Resolves: bug 435561 (Header file <> header
400  file location mismatch)
401- Remove qt4-devel runtime dependency and .prl file from WebKit-gtk-devel.
402  Resolves: bug 433138 (WebKit-gtk-devel has a requirement on qt4-devel)
403
404* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.5.svn30667
405- Update to new upstream snapshot (SVN 30667)
406- Add some build fixes for GCC 4.3:
407  + gcc43.patch
408
409* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-0.5.svn29336
410- Autorebuild for GCC 4.3
411
412* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.4.svn29336
413- Update to new upstream snapshot (SVN 29336).
414- Drop TCSpinLock pthread workaround (fixed upstream):
415  - TCSpinLock-use-pthread-stubs.patch
416
417* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.3.svn28482
418- Add proper %%defattr line to qt, qt-devel, and doc subpackages.
419- Add patch to forcibly build the TCSpinLock code using the pthread
420  implementation:
421  + TCSpinLock-use-pthread-stubs.patch
422
423* Thu Dec 06 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.2.svn28482
424- Package renamed from WebKitGtk.
425- Update to SVN 28482.
426- Build both the GTK and Qt ports, putting each into their own respective
427  subpackages.
428- Invoke qmake-qt4 and make directly (with SMP build flags) instead of using
429  the build-webkit script from upstream.
430- Add various AUTHORS, README, and LICENSE files (via the doc subpackage).
431
432* Tue Dec 04 2007 Peter Gordon <peter@thecodergeek.com> 1.0.0-0.1.svn28383
433- Initial packaging for Fedora.
Note: See TracBrowser for help on using the repository browser.