source: projects/specs/trunk/V/VFlib/VFlib-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define version 2.25.6
3%define release 0vl2
4%define vfontcaps vine-vfontcaps-3.0
5%define fortest fortest-1.1
6
7Summary: Vector Font Library
8Summary(ja): ¥Ù¥¯¥È¥ë¥Õ¥©¥ó¥È¡¦¥é¥¤¥Ö¥é¥ê
9Name: VFlib
10Version: %{version}
11Release: %{release}
12Group: System Environment/Libraries
13License: GPL
14
15URL: http://typehack.aial.hiroshima-u.ac.jp/VFlib/
16Source0: ftp://TypeHack.aial.hiroshima-u.ac.jp/pub/TypeHack/VFlib2-2.25.6.tar.gz
17Source1: %{vfontcaps}.tar.bz2
18Source2: install-sh
19Source3: config.sub
20Source4: %{fortest}.tar.gz
21
22Patch9: VFlib2-2.25.6-gcc33.patch
23
24Patch20: VFlib2-2.25.6-config.sub-x86_64.patch
25Patch21: VFlib2-2.25.6-ltconfig-compat32.patch
26
27BuildPreReq: freetype-devel >= 1.2, XFree86-devel
28Requires: freetype >= 1.2, TrueTypeFonts_jp
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34A package of VFlib, a library to use vector fonts.  It is used by xdvi,
35GhostScript, etc...
36
37%description -l ja
38¥Ù¥¯¥¿¥Õ¥©¥ó¥È¤òÍøÍѤ¹¤ë¤¿¤á¤Î¥é¥¤¥Ö¥é¥êVFlib ¤ÎÆüËܸìÂбþÈǤǤ¹¡£
39xdvi, Ghostscript Åù¤ÇÍøÍѤµ¤ì¤Þ¤¹¡£
40
41%package utils
42Summary: Several utilities to manipulate and examine VFlib.
43Summary(ja): VFlib ¤òÁàºî¤·¤¿¤ê¼Â¹Ô¤·¤¿¤ê¤¹¤ë¥æ¡¼¥Æ¥£¥ê¥Æ¥£½¸
44Group: Applications/Publishing
45Requires: XFree86-libs
46
47%description utils
48This package contains several utilities which allow you to manupulate
49VFlib.  They are mainly useful for debugging and testing purposes,
50and are not required for using the VFlib.
51
52%description utils -l ja
53¤³¤Î¥Ñ¥Ã¥±¡¼¥¸¤Ë¤Ï¡¢VFlib ¤òÁàºî¤·¤¿¤ê¼Â¹Ô¤·¤¿¤ê¤¹¤ë¥æ¡¼¥Æ¥£¥ê¥Æ¥£¤¬
54¤¤¤¯¤Ä¤«´Þ¤Þ¤ì¤Æ¤¤¤Þ¤¹¡£¥Ç¥Ð¥Ã¥°¤ä¥Æ¥¹¥È¤ËÊØÍø¤Ç¤¹¤¬¡¢VFlib ¤Î»ÈÍѤË
55ɬÍפʤâ¤Î¤Ç¤Ï¤¢¤ê¤Þ¤»¤ó¡£
56
57%package devel
58Summary: Header files and library for development with VFlib.
59Summary(ja): VFlib ¤Î³«È¯¥­¥Ã¥È
60Group: Development/Libraries
61
62%description devel
63This package is only needed if you intend to develop or
64compile applications which rely on the VFlib.
65If you simply want to run existing applications, you won't
66need this package.
67
68%description -l devel
69¤³¤Î¥Ñ¥Ã¥±¡¼¥¸¤ÏVFlib¤òÍѤ¤¤¿¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¤ò³«È¯¤·¤¿¤ê¥³¥ó¥Ñ¥¤¥ë
70¤·¤¿¤ê¤¹¤ë¤È¤­¤Ë¤Î¤ßɬÍפˤʤê¤Þ¤¹¡£VFlib ¤òÍѤ¤¤¿¥¢¥×¥ê¥±¡¼¥·¥ç¥ó
71¤òñ¤Ë¼Â¹Ô¤¹¤ë»þ¤Ë¤ÏɬÍפ¢¤ê¤Þ¤»¤ó¡£
72
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: Vector Font Library
77Group: System Environment/Libraries
78Requires: freetype >= 1.2, TrueTypeFonts_jp
79%description -n compat32-%{name}
80A package of VFlib, a library to use vector fonts.  It is used by xdvi,
81GhostScript, etc...
82
83%package -n compat32-%{name}-devel
84Summary: Header files and library for development with VFlib.
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}
87%description -n compat32-%{name}-devel
88This package is only needed if you intend to develop or
89compile applications which rely on the VFlib.
90If you simply want to run existing applications, you won't
91need this package.
92
93
94%prep
95%setup -q -a 1 4 -n VFlib2-%{version}
96%patch9 -p1 -b .gcc33
97%patch20 -p1 -b .x86_64
98%if %{build_compat32}
99%patch21 -p1 -b .compat32
100%endif
101find . -type d -name CVS | xargs -r rm -frv
102
103#cp $RPM_SOURCE_DIR/{install-sh,config.sub} .
104#chmod 755 install-sh config.sub
105
106%build
107%if %{build_compat32}
108export CC='gcc -m32'
109%endif
110%ifarch alpha
111./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} \
112        --with-freetype --host=alpha-pc-linux
113%else
114##./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --with-freetype
115./configure \
116        --prefix=%{_prefix} \
117        --libdir=%{_libdir} \
118        --exec-prefix=%{_prefix} \
119        --enable-static \
120        --enable-shared \
121        --with-freetype \
122        --with-freetype-libdir=%{_libdir} \
123        --with-x \
124        --x-libraries=/usr/X11R6/%{_lib}
125%endif
126
127%if %{build_compat32}
128# to be changed imake result
129pushd src
130        make default_vfontcap=/etc/vfontcap
131popd
132pushd tools
133        imake -DUseInstalled -I/usr/X11R6/lib/X11/config
134        mv Makefile Makefile.x64_86
135        sed "s|lib64|lib|g" Makefile.x64_86 > Makefile
136        make default_vfontcap=/etc/vfontcap
137popd
138make default_vfontcap=/etc/vfontcap
139%else
140make default_vfontcap=/etc/vfontcap
141%endif
142
143%install
144rm -rf $RPM_BUILD_ROOT
145#make prefix=$RPM_BUILD_ROOT%{_prefix} exec_prefix=$RPM_BUILD_ROOT%{_prefix} install
146make \
147        prefix=$RPM_BUILD_ROOT%{_prefix} \
148        exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
149        libdir=$RPM_BUILD_ROOT%{_libdir} \
150        install
151
152# /usr/share/VFlib contains only documents
153rm -rf $RPM_BUILD_ROOT%{_datadir}/VFlib
154
155# install vfontcaps
156(cd %{vfontcaps}
157make DESTDIR=$RPM_BUILD_ROOT install
158)
159
160# prepare docs
161cp -p tools/README README.ktest
162rm -f doc/*~
163
164%post -p /sbin/ldconfig
165
166%postun -p /sbin/ldconfig
167
168%if %{build_compat32}
169%post -n compat32-%{name} -p /sbin/ldconfig
170%postun -n compat32-%{name} -p /sbin/ldconfig
171%endif
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%if !%{build_compat32}
177%files
178%defattr(-,root,root)
179%doc CHANGES COPYING{,.LIB} DISTRIB.txt INSTALL README.txt{,.JP_EUC}
180#%doc README.ktest dynafont doc fortest
181%doc README.ktest dynafont doc
182# vfontcap is included in truetype-fonts-ja
183%config /etc/vfontcap
184%{_datadir}/fonts/TrueType/vfontcap.ttf
185%{_datadir}/fonts/zeit/vfontcap.zeit
186%{_libdir}/libVFlib2.la
187%{_libdir}/libVFlib2.so.*
188
189%files utils
190%defattr(-,root,root)
191%{_bindir}/ttindex
192%{_bindir}/bdfindex
193%{_bindir}/fwindex
194%{_bindir}/ktest
195
196%files devel
197%defattr(-,root,root)
198%{_includedir}/VF.h
199%{_libdir}/libVFlib2.so
200%endif
201
202## to build compat32 for x86_64 architecture support
203%if %{build_compat32}
204%files -n compat32-%{name}
205%defattr(-,root,root)
206%{_libdir}/libVFlib2.la
207%{_libdir}/libVFlib2.so.*
208
209%files -n compat32-%{name}-devel
210%defattr(-,root,root)
211%{_libdir}/libVFlib2.so
212%endif
213
214%changelog
215* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.25.6-0vl2
216- dropt fortest in %doc (because which is not found)
217- added VFlib2-2.25.6-config.sub-x86_64.patch
218- added --with-freetype-libdir, --x-libraries to configure
219- added compat32-* packages for x86_64 architecture support
220- added VFlib2-2.25.6-ltconfig-compat32.patch
221- added current updating scripts of tools/Makefile for compat32
222
223* Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.25.6-0vl1
224- new upstream release
225- added entry for dynacomware fonts in vfontcap
226- use License tag instead of Copyright
227
228* Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 2.25.2-0vl2
229- added entry for ricoh fonts in vfontcap
230- update fortest
231
232* Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
233- 2.24.2-8
234
235* Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
236- minor spec fixes
237- dont pack CVS directory
238
239* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.24.2-7
240- build with gcc-2.95.3
241- partially used rpmmacros
242
243* Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
244- rel.6
245- modify vine-vfontcaps-1.0
246- merge vfontcaps for dyna and free
247- more Japanese Summary and description
248
249* Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
250- modified for Vine Linux.
251
252* Thu Nov 18 1999 Toru Hoshina <t@kondara.org>
253- add alphaev6 support.
254
255* Thu Nov 18 1999 Norihito Ohmori <nono@kondara.org>
256- add defattr(-,root,root) in utils & devel (jitter #108)
257
258* Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
259- be a NoSrc :-P
260
261* Sat Oct 30 1999 Norihito Ohmori <ohmori@flatout.org>
262- change dependency from TrueTypeFonts_jp to truetype-fonts-ja
263
264* Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
265- add defattr.
266
267* Fri Oct 15 1999 Norihito Ohmori <ohmori@flatout.org>
268- sprit VFlib, VFlib-devel and  VFlib-utils
269
270* Mon Oct 11 1999 Norihito Ohmori <ohmori@flatout.org>
271- rebuild for FreeType-1.3
272
273* Sat Sep 4 1999 Norihito Ohmori <ohmori@flatout.org>
274- Add BuildPreReq: Tag for FreeType
275
276* Mon Jul 26 1999 Jun Nishii <jun@flatout.org>
277- updated to 2.24.2
278- build for Vine-1.9
279
280* Fri Jul 9 1999 Norihito Ohmori <ohmori@flatout.org>
281- spec file fix (patch rejected).
282
283* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
284- if DynaFont was already installed, use it
285
286* Mon May 24 1999 Norihito Ohmori <ohmori@flatout.org>
287- Comment "GS-" entry in vfontcap
288 
289* Tue May 19 1999 Norihito Ohmori <ohmori@flatout.org>
290- add "GS-" entry for Ghostscript xfont extention
291
292* Fri Dec 11 1998 Hideya Hane <pje@linux.or.jp>
293- Requires TrueTypeFonts_jp(change from xtt_fonts)
294
295* Sun Nov 29 1998 Jun Nishii <jun@flatout.org>
296- dynamic link libttf to libVFlib
297
298* Wed Nov 25 1998 Jun Nishii <jun@flatout.org>
299- fix wrong symbolic link of /etc/vfontcap
300
301* Tue Nov 24 1998 Jun Nishii <jun@flatout.org>
302- use ttf as default fonts
303
304* Tue Nov 10 1998 Jun Nishii <jun@flatout.org>
305- for version 2.24 release 1
306
307* Tue Nov 10 1998 Jun Nishii <jun@flatout.org>
308- add descrption -l ja
309- tiny bug fix when building vflib
310
311* Fri Sep 25 1998 Jun Nishii <jun@flatout.org>
312- first release
313
Note: See TracBrowser for help on using the repository browser.