source: projects/specs/trunk/T/TrueType-vlgothic/TrueType-vlgothic-vl.spec @ 521

Revision 521, 15.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 2.29
2%define release 1%{?_dist_release}
3%define vlgothic_date 20100126
4%define ttfjp_version 6.0
5
6%define fontdir %{_datadir}/fonts/%{name}/
7%define texmf %{_datadir}/texmf
8%define mapdir %{texmf}/fonts/map/dvipdfmx
9
10Summary: VLGothic font family - Free Japanese True Type Font
11Summary(ja): VLゴシックフォントファミリ - フリーの日本語 True Type フォント
12Name: TrueType-vlgothic
13Version: %{version}
14Release: %{release}
15
16License: BSD style
17Group: User Interface/X
18Url: http://dicey.org/vlgothic/
19
20Source: %{name}.tar.bz2
21
22# VLGothic Font Family
23Source1: VLGothic-%{vlgothic_date}.tar.bz2
24
25Source10: 59-vlgothic.conf
26Source20: cidfmap.ja.vlgothic
27
28Distribution: Vine Linux
29Vendor: Project Vine
30
31BuildArch: noarch
32Buildroot: %{_tmppath}/%{name}-%{version}-root
33Requires(post): mktcapdir >= 0.5.4
34Requires(post): fontconfig, xorg-x11-font-utils
35Requires(post): vutils >= 2.0.2
36Provides: TrueTypeFonts_jp = %{ttfjp_version}
37Obsoletes: TrueTypeFonts_jp < 4.1
38Obsoletes: TrueType-kochi <= 4.4.1
39Obsoletes: TrueType-sazanami < 3.0
40BuildRequires: rpm >= 4.4.2.3-7
41
42%description
43VLGothic font family - Free Japanese True Type Font
44- VL PGothic
45- VL Gothic
46
47%description -l ja
48このパッケージには以下のフリーの日本語 True Type フォントが含まれています。
49- VL Pゴシック (M+ 1C Regular および さざなみゴシック をベースに
50  Project Vine が改良をおこなったフォント。)
51- VLゴシック (M+ 1M Regular および さざなみゴシック をベースに
52  Project Vine が改良をおこなったフォント。)
53
54%prep
55rm -rf ${RPM_BUILD_ROOT}
56
57%setup -n %{name} -a 1
58mv VLGothic/*.ttf .
59
60%install
61
62mkdir -p $RPM_BUILD_ROOT/%{fontdir}
63install -m664 *.ttfconf *.ttf $RPM_BUILD_ROOT/%{fontdir}
64mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
65install -m664 %{SOURCE10} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
66for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
67do
68  ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
69done
70
71# install ghostscript8 cidfmap
72mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
73install -m644 %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
74
75# add fontpath.d symlinks
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/fontpath.d
77ln -sf /usr/share/fonts/%{name} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fontpath.d/
78
79%post
80%__font_install_post %{fontdir}
81
82%postun
83%__font_install_postun %{fontdir}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(-,root,root)
90%doc VLGothic/*
91%{fontdir}/*
92%{_sysconfdir}/fonts/conf.avail/*.conf
93%{_sysconfdir}/X11/fontpath.d/%{name}
94%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/*.conf
95%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.vlgothic
96
97%changelog
98* Tue Jan 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.29-1
99- update to 20100126
100  - update VL kanji glyphs
101  - add new special sign charactors
102  - change glyph width of "MINUS SIGN"
103
104* Mon Dec 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28-1
105- update to 20091214
106  - update VL kanji glyphs
107
108* Fri Dec 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.27-1
109- update to 20091211
110  - update VL kanji glyphs
111
112* Tue Dec 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26-1
113- update to 20091208
114  - update M+ part
115  - update VL kanji glyphs
116
117* Wed Dec 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.25-1
118- update to 20091202
119  - update VL kanji glyphs
120
121* Fri Nov 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24-1
122- update to 20091127
123  - update VL kanji glyphs
124
125* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23-1
126- update to 20091118
127  - update M+ part
128
129* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22-1
130- add fontpath.d symlink
131
132* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21-1
133- update to 20090811
134  - update VL kanji glyphs
135
136* Mon Aug 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20-1
137- update to 20090810
138  - update VL kanji glyphs
139
140* Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19-1
141- update to 20090806
142  - update VL kanji glyphs
143  - update M+ part
144  - adjust CJK ambiguous width of VL Gothic
145
146* Fri Jul 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18-1
147- update to 20090710
148  - update VL kanji glyphs
149  - update M+ part
150
151* Fri Jul 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17-1
152- update to 20090703
153  - update VL kanji glyphs
154  - update M+ part
155
156* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16-1
157- update to 20090612
158  - update VL kanji glyphs
159  - update M+ part
160
161* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15-1
162- update VLGothic to 20090422
163  - fix GSUB vert table for vertical glyphs
164  - add VL kanji glyph
165
166* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-2
167- really update VLGothic to 20090421..
168
169* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14-1
170- update VLGotihc to 20090421
171  - update VL kanji glyphs
172  - update M+ part
173- use new rpm macros
174
175* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13-1
176- remove Require/Requires(post): TrueType-base
177
178* Wed Feb 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12-1
179- update VLGothic to 20090204
180  - update VL kanji glyphs
181  - update M+ part
182- use update-defaultfont (vutils>=2.0.2)
183
184* Thu Jan 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11-1
185- update VLGothic to 20090108
186  - update VL kanji glyphs
187  - update vine.map and exec updmap-sys on %%post/%%postun
188 
189* Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-1
190- update VLGothic to 20081203
191  - update VL kanji glyphs
192  - add some full width special sign charactors
193  - fix font metrics
194
195* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
196- update VLGothic to 20081124
197  - update VL kanji glyphs
198  - update M+ part (add more latin glyphs)
199  - change font metrics
200    - set negative value for ascend/descend to descrease line gap
201
202* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-1
203- update VLGothic to 20081029
204  - update VL kanji glyphs
205  - update M+ part (add more latin glyphs)
206  - fix embolden problem
207
208* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
209- add gs8 cidfmap for vlgothic
210
211* Mon Sep 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-1
212- update VLGothic to 20080908
213  - update VL kanji glyphs
214  - add M+ latin glyphs to VLPGothic
215
216* Tue Jun 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-1
217- update VLGothic to 20080610
218  - update VL kanji glyphs
219  - update M+ part
220
221* Tue Jun 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-1
222- update VLGothic to 20080610
223  - update VL kanji glyphs
224  - update M+ part
225
226* Tue Jun 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-1
227- update VLGothic to 20080603
228  - update VL kanji glyphs
229
230* Sun Jun 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-1
231- update VLGothic to 20080601
232  - update M+ part
233
234* Mon May 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-1
235- update VLGothic to 20080429
236- add 59-vlgothic.conf to set hinting configuration
237
238* Mon Apr 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
239- build for xorg-x11-7.3
240  - change font location to %%{_datadir}/fonts/%{name}
241  - require fontconfig and xorg-x11-font-utils
242
243* Sun Apr 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-1
244- update VLGothic to 20080420
245  - update M+ part
246  - add [aiueo]macron charactor
247
248* Thu Mar 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
249- update VLGothic to 20080327
250  - update M+ part
251
252* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
253- update VLGothic to 20071215
254  - update M+ part
255  - update VL kanji/latin extended/special sign charactor
256
257* Tue Oct 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
258- update VLGothic to new replaced archive.
259
260* Tue Oct 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
261- update VLGothic to 20071031
262  - update M+ part
263  - update VL kanji glyphs
264
265* Mon Oct 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
266- update VLGothic to 20071015
267  - update M+ part
268  - update VL kanji glyphs
269
270* Sat Oct 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
271- update VLGothic to 20071006
272  - update M+ part
273  - update VL kanji glyphs, hankaku-kana glyphs
274
275* Sat Sep 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
276- update VLGothic to 20070929
277  - update VL kanji glyphs
278
279* Mon Sep 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl2
280- Obsoletes: TrueType-sazanami < 3.0
281
282* Mon Sep 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
283- update VLGothic to 20070924
284  - update M+ part and some kanji glyphs
285
286* Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
287- update VLGothic to 20070915
288  - update M+ part and some kanji glyphs
289
290* Thu Sep 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
291- split VLGothic from TrueType-sazanami
292
293* Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
294- update VLGothic to 20070901
295  - update some kanji glyphs
296
297* Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
298- update VLGothic to 20070830
299  - update M+1C/M+1M to CVS head
300  - update some kanji glyphs
301
302* Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
303- update VLGothic to 20070731
304  - update M+1C/M+1M to CVS head
305  - add new glyphs to VL-PGothic/VL-Gothic
306    - add Roman Numeral Glyphs (some part of Number Forms)
307    - update some glyphs
308
309* Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
310- update VLGothic to 20070507
311  - add new glyphs to VL-Gothic
312    - add ISO8859-1 Glyphs (Latin-1 Supplement)
313    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
314
315* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
316- update VLGothic to 20070506
317  - add new glyphs to VL-PGothic
318    - add ISO8859-1 Glyphs (Latin-1 Supplement)
319    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
320
321* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
322- update VLGothic to 20070503
323  - update M+1C/1M to CVS head
324
325* Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
326- update VLGothic to 20070328
327  - update M+1C/1M to CVS head
328  - fix embolden problem on freetype-2.2
329
330* Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
331- update VLGothic to 20070317
332  - update M+1C/1M to CVS head
333    - include M+ Kanji glyphs
334  - update some glyphs
335  - add some special sign characters
336  - fix broken glyphs
337
338* Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
339- update VLGothic to 20070101
340  - fix embolden problem on freetype-2.2
341
342* Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
343- update VLGothic to 20061231
344  - update M+1C/M+1M to cvs head 20061231
345  - update kanji glyphs
346- update Sazanami to 20040629-vl-20061231
347  - fix broken glyphs of sazanami-mincho
348
349* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
350- bump up version to 2.0
351- update VLGothic to 20061026
352  - update greek letter glyphs
353  - split license information file from README.
354  - add english version of license.
355
356* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
357- update VLGothic to 20061021
358
359* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
360- update VLGothic to 20061020 (<BTS:221>)
361  - update M+1C/M+1M to TESTFILGHT012
362  - update some glyphs
363  - fix outline direction
364  - remove overlap path
365
366* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
367- update VLGothic to 20061005 (<BTS:221>)
368  - update some glyphs
369  - fix outline direction
370  - remove overlap path
371
372* Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
373- update VLGothic to 20060930 (<BTS:221>)
374  - fix outline direction
375  - remove overlap path
376
377* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
378- update VLGothic to 20060929
379  - update some glyphs
380  - fix outline direction
381  - remove overlap path
382
383* Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
384- update VLGothic to 20060925
385  - update some glyphs
386  - add minimum gsub table for vertical writing
387
388* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
389- update VLGothic to 20060921
390  - update few glyphs
391  - update M+1C/M+1M to cvs head 2006/09/21
392
393* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
394- update VLGothic to 20060913
395  - update some glyphs
396  - fix half width space
397
398* Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
399- update VLGothic to 20060911
400  - update M+1C/M+1M to cvs head 2006/09/11
401- use VL-PGothic for -alias-gothic-p- (legacy core font)
402
403* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
404- update VLGothic to 20060831
405  - add VL-Gothic-Regular.ttf for
406  - use M+1C for VLPGothic instead of M+1P
407
408* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
409- fix sazanami.ttfconf
410
411* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
412- change the fontname to VLPGothic
413- update VLPGothic
414- TODO:
415  - split VLGothic family to new package.
416  - add M+1M based VLGothic for monospace font.
417
418* Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
419- update M+1P+Sazanami.ttf
420  - refine more glyphs
421
422* Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
423- update M+1P+Sazanami.ttf
424  - refine more glyphs
425  - add some glyphs for windows compatibility
426- update sazanami.ttfconf
427  - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
428    for Flash Plugin. (<BTS:0100>)
429
430* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
431- update M+1P+Sazanami.ttf
432  - refine more glyphs
433  - add new full-width alphabets and numeric letters based on M+1P
434
435* Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
436- update M+1P+Sazanami.ttf
437  - refine more glyphs
438
439* Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
440- update M+1P+Sazanami.ttf
441  - refine more glyphs
442  - redesign greek letter based on M+ 1P fonts
443
444* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
445- update M+1P+Sazanami.ttf
446  - refine more glyphs
447
448* Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
449- update M+1P+Sazanami.ttf
450  - refine more glyphs
451
452* Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
453- update M+1P+Sazanami.ttf
454  - refine more glyphs
455  - fix encoding
456
457* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
458- update M+1P+Sazanami.ttf
459  - refine more glyphs
460  - fix outline direction (fix corruption on emboldening)
461
462* Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
463- update M+1P+Sazanami.ttf
464  - refine more glyphs
465  - fix broken glyph
466  - refine greek letters
467
468* Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
469- update M+1P+Sazanami.ttf
470  - refine more glyphs
471  - TODO: should rename the fontname?
472
473* Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
474- update M+1P+Sazanami.ttf
475  - fix outline direction (fix corruption of some glyphs)
476  - refine more glyphs
477
478* Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
479- update M+1P+Sazanami.ttf
480  - refine some glyphs.. (modified 200 or more)
481- update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
482
483* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
484- update M+1P+Sazanami.ttf
485  - refine some glyphs.. (modified 100 or more)
486
487* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
488- update M+1P-Sazanami.ttf
489  - fix corruption of some glyphs
490  - refine some glyphs to make it more usable..
491
492* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
493- add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
494
495* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
496- new upstream release
497
498* Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
499- initial build for Vine Linux based on TrueType-kochi-subst package
500- Provides TrueType-kochi, TrueTypeFonts_jp
501- include Kochi-{mincho,gothic}.ttf symlinks for compatibility
Note: See TracBrowser for help on using the repository browser.