source: projects/specs/trunk/T/TrueType-sazanami/TrueType-sazanami-vl.spec @ 8192

Revision 8192, 12.7 KB checked in by tanakanata, 10 years ago (diff)

rebuild with current env.

Line 
1# Command macros
2%define __mkfontdir     umask 133;/usr/bin/mkfontdir
3%define __mkfontscale   umask 133;/usr/bin/mkfontscale
4# Use this macro to call fc-cache throughout the specfile.
5%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache -f
6
7%define version 4.2
8%define release 3%{?_dist_release}
9%define sazanami_date 20040629-vl-20061231
10%define ttfjp_version 6.0
11
12%define xfontdir %{_datadir}/fonts/TrueType-sazanami
13%define fontpathdir %{_sysconfdir}/X11/fontpath.d
14
15Summary: Free Japanese True Type Font (Sazanami)
16Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
17Name: TrueType-sazanami
18Version: %{version}
19Release: %{release}
20BuildArch: noarch
21
22Obsoletes: TrueTypeFonts_jp < 4.1
23Obsoletes: TrueType-kochi <= 4.4.1
24Provides: TrueType-kochi = %{ttfjp_version}
25
26Requires: %{name}-mincho = %{version}-%{release}
27Requires: %{name}-gothic = %{version}-%{release}
28
29# This is not really required, but usefull to upgrade.
30Requires: TrueType-vlgothic
31
32Source: %{name}.tar.bz2
33Source10: 60-sazanami-mincho.conf
34Source11: 60-sazanami-gothic.conf
35
36Source20: cidfmap.ja.sazanami-mincho
37Source21: cidfmap.ja.sazanami-gothic
38
39# Sazanami Font Family
40Source4: sazanami-%{sazanami_date}.tar.bz2
41
42License: distributable
43Group: User Interface/X
44Buildroot: %{_tmppath}/%{name}-root
45
46Distribution: Vine Linux
47Vendor: Project Vine
48Packager: daisuke
49
50%description
51This is meta package for Free Japanese True Type Font 'Sazanami Font'
52- Sazanami-Mincho
53- Sazanami-Gothic
54
55%description -l ja
56このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
57の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
58パッケージで以下のフォントがインストールされます。
59- さざなみ明朝
60- さざなみゴシック
61
62%package mincho
63Summary: Sazanami Mincho TrueType Fonts
64Summary(ja): さざなみ明朝 True Type フォント
65Group: User Interface/X
66Requires(post,postun): mktcapdir >= 0.5.4
67Requires(post,postun): fontconfig, xorg-x11-font-utils
68
69%description mincho
70This package includes Sazanami Mincho TrueType fonts.
71
72%description -l ja mincho
73このパッケージにはさざなみ明朝フォントが含まれています。
74
75%package gothic
76Summary: Sazanami Gothic TrueType Fonts
77Summary(ja): さざなみゴシック 日本語 True Type フォント
78Group: User Interface/X
79Requires(post,postun): mktcapdir >= 0.5.4
80Requires(post,postun): fontconfig, xorg-x11-font-utils
81
82%description gothic
83This package includes Sazanami Gothic TrueType fonts.
84
85%description -l ja gothic
86このパッケージにはさざなみゴシックフォントがふくまれています。
87
88%prep
89rm -rf ${RPM_BUILD_ROOT}
90
91%setup -n %{name} -a 4
92mv sazanami-%{sazanami_date}/* .
93
94%install
95
96# mkdir fontdirs
97mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
98# install ttfconf
99install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
100install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
101# install fonts
102ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
103ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
104
105# install fontpath.d symlink
106mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
107ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
108ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
109
110# install fontconfig files
111mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
112install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
113for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
114do
115  ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
116done
117
118# install ghostscript8 cidfmap
119mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
120install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
121
122
123%post mincho
124%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
125( %__fccache %{xfontdir}-mincho ) ||:
126
127%post gothic
128%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
129( %__fccache %{xfontdir}-gothic ) ||:
130
131%postun mincho
132%{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
133( %__fccache %{xfontdir}-mincho ) ||:
134
135%postun gothic
136%{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
137( %__fccache %{xfontdir}-gothic ) ||:
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%files
143%defattr(-,root,root)
144%doc README doc/
145
146%files mincho
147%defattr(-,root,root)
148%{xfontdir}-mincho/*
149%{fontpathdir}/%{name}-mincho
150%{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
151%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
152%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
153
154%files gothic
155%defattr(-,root,root)
156%{xfontdir}-gothic/*
157%{fontpathdir}/%{name}-gothic
158%{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
159%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
160%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
161
162%changelog
163* Wed Jan 15 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp> 4.2-3
164- build with gcc-4.8
165
166* Sun Apr 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-2
167- remove R: TrueType-base
168- remove P: TrueTypeFonts_jp
169
170* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
171- add gs8 cidfmap for sazanami
172
173* Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
174- split mincho and gothic to its own fontdir
175- add fontpath.d symlink
176
177* Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
178- build for xorg-x11-7.3
179  - change font location to %{_datadir}/fonts/TrueType-sazanami
180  - require(post,postun) fontconfig and xorg-x11-font-utils
181- split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
182
183* Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
184- split out VLGothic to TrueType-vlgothic package.
185
186* Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
187- update VLGothic to 20070901
188  - update some kanji glyphs
189
190* Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
191- update VLGothic to 20070830
192  - update M+1C/M+1M to CVS head
193  - update some kanji glyphs
194
195* Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
196- update VLGothic to 20070731
197  - update M+1C/M+1M to CVS head
198  - add new glyphs to VL-PGothic/VL-Gothic
199    - add Roman Numeral Glyphs (some part of Number Forms)
200    - update some glyphs
201
202* Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
203- update VLGothic to 20070507
204  - add new glyphs to VL-Gothic
205    - add ISO8859-1 Glyphs (Latin-1 Supplement)
206    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
207
208* Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
209- update VLGothic to 20070506
210  - add new glyphs to VL-PGothic
211    - add ISO8859-1 Glyphs (Latin-1 Supplement)
212    - add ISO8859-15 Glyphs (some part of Latin Extended-A)
213
214* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
215- update VLGothic to 20070503
216  - update M+1C/1M to CVS head
217
218* Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
219- update VLGothic to 20070328
220  - update M+1C/1M to CVS head
221  - fix embolden problem on freetype-2.2
222
223* Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
224- update VLGothic to 20070317
225  - update M+1C/1M to CVS head
226    - include M+ Kanji glyphs
227  - update some glyphs
228  - add some special sign characters
229  - fix broken glyphs
230
231* Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
232- update VLGothic to 20070101
233  - fix embolden problem on freetype-2.2
234
235* Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
236- update VLGothic to 20061231
237  - update M+1C/M+1M to cvs head 20061231
238  - update kanji glyphs
239- update Sazanami to 20040629-vl-20061231
240  - fix broken glyphs of sazanami-mincho
241
242* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
243- bump up version to 2.0
244- update VLGothic to 20061026
245  - update greek letter glyphs
246  - split license information file from README.
247  - add english version of license.
248
249* Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
250- update VLGothic to 20061021
251
252* Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
253- update VLGothic to 20061020 (<BTS:221>)
254  - update M+1C/M+1M to TESTFILGHT012
255  - update some glyphs
256  - fix outline direction
257  - remove overlap path
258
259* Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
260- update VLGothic to 20061005 (<BTS:221>)
261  - update some glyphs
262  - fix outline direction
263  - remove overlap path
264
265* Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
266- update VLGothic to 20060930 (<BTS:221>)
267  - fix outline direction
268  - remove overlap path
269
270* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
271- update VLGothic to 20060929
272  - update some glyphs
273  - fix outline direction
274  - remove overlap path
275
276* Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
277- update VLGothic to 20060925
278  - update some glyphs
279  - add minimum gsub table for vertical writing
280
281* Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
282- update VLGothic to 20060921
283  - update few glyphs
284  - update M+1C/M+1M to cvs head 2006/09/21
285
286* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
287- update VLGothic to 20060913
288  - update some glyphs
289  - fix half width space
290
291* Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
292- update VLGothic to 20060911
293  - update M+1C/M+1M to cvs head 2006/09/11
294- use VL-PGothic for -alias-gothic-p- (legacy core font)
295
296* Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
297- update VLGothic to 20060831
298  - add VL-Gothic-Regular.ttf for
299  - use M+1C for VLPGothic instead of M+1P
300
301* Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
302- fix sazanami.ttfconf
303
304* Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
305- change the fontname to VLPGothic
306- update VLPGothic
307- TODO:
308  - split VLGothic family to new package.
309  - add M+1M based VLGothic for monospace font.
310
311* Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
312- update M+1P+Sazanami.ttf
313  - refine more glyphs
314
315* Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
316- update M+1P+Sazanami.ttf
317  - refine more glyphs
318  - add some glyphs for windows compatibility
319- update sazanami.ttfconf
320  - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
321    for Flash Plugin. (<BTS:0100>)
322
323* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
324- update M+1P+Sazanami.ttf
325  - refine more glyphs
326  - add new full-width alphabets and numeric letters based on M+1P
327
328* Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
329- update M+1P+Sazanami.ttf
330  - refine more glyphs
331
332* Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
333- update M+1P+Sazanami.ttf
334  - refine more glyphs
335  - redesign greek letter based on M+ 1P fonts
336
337* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
338- update M+1P+Sazanami.ttf
339  - refine more glyphs
340
341* Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
342- update M+1P+Sazanami.ttf
343  - refine more glyphs
344
345* Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
346- update M+1P+Sazanami.ttf
347  - refine more glyphs
348  - fix encoding
349
350* Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
351- update M+1P+Sazanami.ttf
352  - refine more glyphs
353  - fix outline direction (fix corruption on emboldening)
354
355* Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
356- update M+1P+Sazanami.ttf
357  - refine more glyphs
358  - fix broken glyph
359  - refine greek letters
360
361* Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
362- update M+1P+Sazanami.ttf
363  - refine more glyphs
364  - TODO: should rename the fontname?
365
366* Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
367- update M+1P+Sazanami.ttf
368  - fix outline direction (fix corruption of some glyphs)
369  - refine more glyphs
370
371* Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
372- update M+1P+Sazanami.ttf
373  - refine some glyphs.. (modified 200 or more)
374- update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
375
376* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
377- update M+1P+Sazanami.ttf
378  - refine some glyphs.. (modified 100 or more)
379
380* Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
381- update M+1P-Sazanami.ttf
382  - fix corruption of some glyphs
383  - refine some glyphs to make it more usable..
384
385* Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
386- add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
387
388* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
389- new upstream release
390
391* Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
392- initial build for Vine Linux based on TrueType-kochi-subst package
393- Provides TrueType-kochi, TrueTypeFonts_jp
394- include Kochi-{mincho,gothic}.ttf symlinks for compatibility
Note: See TracBrowser for help on using the repository browser.