source: projects/specs/trunk/T/TrueType-ricty/TrueType-ricty-vl.spec @ 9244

Revision 9244, 3.2 KB checked in by munepi, 9 years ago (diff)

new upstream release

Line 
1%define _fontdir %{_datadir}/fonts/%{name}
2%define migu_version 20121030
3%define inconsolata_version 001.010
4
5Summary: TrueType font designed for programing
6Summary(ja): プログラミング用 TrueType フォント
7Name: TrueType-ricty
8Version: 3.2.4
9Release: 1%{?_dist_release}
10License: public domain, SIL OFL v1.1, M+ FONT LICENSE, IPA Font License v1.0
11Group: User Interface/X
12URL: http://save.sys.t.u-tokyo.ac.jp/~yusa/fonts/ricty.html
13Source0: Ricty-%{version}.tar.gz
14Requires: OpenType-inconsolata >= %{inconsolata_version}
15Requires: TrueType-migu >= %{migu_version}
16
17BuildRequires: fontforge
18Requires(post): fontforge
19
20BuildArch: noarch
21BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
22
23%description
24Ricty is a free, TrueType font designed for programing.
25
26We remark that Ricty fonts is generated in the installation of this package.
27
28
29%description -l ja
30Ricty は Linux 環境での研究・開発に適したフリーのプログラミング用
31TrueType フォントです。
32
33Ricty フォントは、パッケージのインストール時に生成されます。
34
35%prep
36%setup -q -n Ricty-%{version}
37
38%__sed -i -e "s,#!/usr/local/bin/fontforge,#!/usr/bin/fontforge," ricty_discord_patch.pe || exit 1
39
40%build
41
42%install
43%__rm -rf $RPM_BUILD_ROOT
44
45%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/%{name}
46%__cp -a ricty_discord_patch.pe $RPM_BUILD_ROOT%{_datadir}/%{name}/
47%__cp -a ricty_generator.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/
48
49%__mkdir_p $RPM_BUILD_ROOT%{_fontdir}
50
51
52%clean
53%__rm -rf $RPM_BUILD_ROOT
54
55%post
56#set -x
57echo "Generating Ricty fonts ... "
58(cd %{_fontdir}
59    %__cp %{_datadir}/%{name}/ricty_discord_patch.pe . || exit 1
60    %__cp %{_datadir}/%{name}/ricty_generator.sh . || exit 1
61    sh ricty_generator.sh \
62        %{_datadir}/fonts/OpenType-inconsolata/Inconsolata.otf \
63        %{_datadir}/fonts/TrueType-migu/migu-1m-regular.ttf \
64        %{_datadir}/fonts/TrueType-migu/migu-1m-bold.ttf
65    %__rm -f ricty_discord_patch.pe ricty_generator.sh ||:
66    [ ! -f Ricty-Regular.ttf ] && echo "failed." && exit 1
67    [ ! -f Ricty-Bold.ttf ] && echo "failed." && exit 1
68)
69echo "done."
70%__font_install_post %{_fontdir}
71
72%preun
73if [ "$1" = 0 ]; then
74    %__rm -f %{_fontdir}/Ricty{,Discord}-{Regular,Bold}.ttf ||:
75fi
76
77%postun
78%__font_install_postun %{_fontdir}
79
80%files
81%defattr(-,root,root,-)
82%doc README.md
83%{_datadir}/%{name}/
84# %{_fontdir}/Ricty-Regular.ttf
85# %{_fontdir}/Ricty-Bold.ttf
86# %{_fontdir}/RictyDiscord-Regular.ttf
87# %{_fontdir}/RictyDiscord-Bold.ttf
88%{_fontdir}/
89
90%changelog
91* Sun Jan 11 2015 Munehiro Yamamoto <munepi@vinelinux.org> 3.2.4-1
92- new upstream release
93
94* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 3.2.2-1
95- new upstream release
96
97* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 3.2.1-1
98- new upstream release
99- supported the new naming rule for Migu fonts
100
101* Thu Jan 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.3-1
102- new upstream release
103
104* Sat Oct 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.2-1
105- new upstream release
106- set %%migu_version to 20111002
107
108* Wed Jun 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.0-2
109- added Requires(post): fontforge
110
111* Wed Jun 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.1.0-1
112- new upstream release
113
114* Sun Jun  5 2011 Munehiro Yamamoto <munepi@vinelinux.org> 3.0.2-1
115- Initial build.
Note: See TracBrowser for help on using the repository browser.