source: projects/specs/trunk/T/TrueType-kochi-subst/TrueType-kochi-subst-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Command macros
2%define __mkfontdir     umask 133;%{_x11bindir}/mkfontdir
3%define __mkfontscale   umask 133;%{_x11bindir}/mkfontscale
4# Use this macro to call fc-cache throughout the specfile.
5%define __fccache       umask 133;which fc-cache &> /dev/null && fc-cache
6
7%define version 4.6
8%define release 0vl3
9%define kochi_subst_date 20030809
10
11%define xfontdir /usr/X11R6/lib/X11/fonts/TrueType
12
13Summary: Free Japanese/English True Type Font (Kochi substitute, Luxi)
14Summary(ja): ¥Õ¥ê¡¼¤ÎÆüËܸì True Type ¥Õ¥©¥ó¥È(ÅìÉ÷ÂåÍÑÌÀÄ«/¥´¥·¥Ã¥¯)
15Name: TrueType-kochi-subst
16Version: %{version}
17Release: %{release}
18BuildArch: noarch
19
20PreReq: TrueType-base >= 4.4.1
21Requires: TrueType-base >= 4.4.1
22Provides: TrueTypeFonts_jp = %{version}
23
24Obsoletes: TrueTypeFonts_jp < 4.1
25Obsoletes: TrueType-kochi <= 4.4.1
26Provides: TrueType-kochi = %{version}-%{release}
27
28Source: %{name}-%{version}.tgz
29
30# Kochi substitute
31Source4: kochi-substitute-%{kochi_subst_date}.tar.bz2
32
33Copyright: distributable
34Group: User Interface/X
35Buildroot: %{_tmppath}/%{name}-root
36# Prereq: chkfontpath
37Prereq: mktcapdir >= 0.5.4
38
39Distribution: Vine Linux
40Vendor: Project Vine
41
42%description
43Free Japanese True Type Font (Kochi-Mincho-subst/Kochi-Gothic-subst)
44
45%description -l ja
46¥Õ¥ê¡¼¤ÎÆüËܸì True Type ¥Õ¥©¥ó¥È(ÂåÍÑÅìÉ÷ÌÀÄ«/¥´¥·¥Ã¥¯)
47
48%prep
49rm -rf ${RPM_BUILD_ROOT}
50
51%setup -a 4
52mv kochi-substitute-%{kochi_subst_date}/* .
53
54%install
55
56mkdir -p $RPM_BUILD_ROOT/%{xfontdir}
57mv *.ttfconf *.ttf \
58  $RPM_BUILD_ROOT/%{xfontdir}
59
60
61%post
62%{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
63if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
64  %{_bindir}/vine-update-gnome-font-install
65fi
66( %__fccache %{xfontdir} ) ||:
67
68%postun
69%{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
70if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
71  %{_bindir}/vine-update-gnome-font-install
72fi
73( %__fccache %{xfontdir} ) ||:
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(-,root,root)
80%doc README.ja COPYING Changelog docs/
81%{xfontdir}/*
82
83%changelog
84* Sat Jan 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6-0vl3
85- fix %post/%pre macros
86
87* Wed Dec 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.6-0vl2
88- use __fccache macro
89
90* Wed Oct 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6-0vl1
91- new upstream release
92- new upstream release
93- add "eo=m" to ttfconf to use Windows Unicode encoding
94
95* Fri Jun 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.5-0vl1
96- Kochi substitute fonts
97- spec file based on TrueType-kochi
98
99* Thu Feb 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.1-0vl1
100- update kochi-gothic to 0.20030118
101- modify kochi.ttfconf (use cell for monospace font)
102
103* Mon Nov 04 2002 Shoji Matsumoto <shom@vinelinux.org> 4.4-0vl2
104- add kochi-gothic-new
105
106* Sun Oct 06 2002 Shoji Matsumoto <shom@vinelinux.org> 4.4-0vl1
107- update to 0.2-20020727
108- modiry kochi.ttfconf
109- remove chkfontpath
110
111* Sun Mar 31 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3.1-0vl1
112- fix %post ( chkfontpath )
113- remove chkfontpath from %postun
114- update to 0.2-20020326
115
116* Sat Mar 16 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3.1-0vl0
117- add postun
118
119* Tue Mar 12 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3-0vl0
120- created
121- separated from TrueType_jp (to TrueType-base, TrueType-kochi)
122- *******************************************************************
123
124* Tue Mar 12 2002 Shoji Matsumoto <shom@vinelinux.org> 4.2-0vl0
125- update ricoh.ttfconf, kochi.ttfconf
126- add luxi*-2.ttf (bitmap embedded luxi*.ttf)
127
128* Mon Mar 11 2002 Shoji Matsumoto <shom@vinelinux.org> 4.1-0vl0
129- Package Name changed to TrueType-kochi (Provides TrueTypeFonts_jp)
130- update microsoft.ttfconf, ricoh.ttfconf
131
132* Sun Mar 10 2002 Shoji Matsumoto <shom@vinelinux.org> 4.0-0vl2
133- fix
134
135* Sun Mar 10 2002 Shoji Matsumoto <shom@vinelinux.org> 4.0-0vl1
136- upate kochi-*
137- update *.ttfconf
138- add xf42lux.ttfconf, symlinks to XF42 lux ttfs
139- add ricoh.ttfconf for CR
140
141* Mon Dec 03 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl6
142- update *.ttfconf
143- remove ricoh.ttfconf
144- update kochi-*
145
146* Mon Sep 10 2001 SHoji Matsumoto <shom@vinelinux.org> 3.0-0vl4
147- fixed bug in kochi.ttfconf
148
149* Mon Sep 10 2001 SHoji Matsumoto <shom@vinelinux.org> 3.0-0vl3
150- remove %post process for DynaFonts fonts
151  (/usr/share/fonts/TrueType/aliastt-* obsoletes)
152
153* Sat Sep 08 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl2
154- remove watanabe, wadalab
155- now using mktcapdir
156
157* Mon Jun 04 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl1
158- remove times/hevletica iso8859-1 aliases for kochi
159
160* Fri May 18 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl0
161- add kochi-mincho/kochi-gothic
162- add Type1 fonts from XFree86-4.0 (temp)
163- add -alias-{times,helvetica,monotype} to aliases
164
165* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2-7
166- remove Obsoletes DynaFonts tag.
167
168* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2-6
169- build with gcc-2.95.3
170- partially used rpmmacros
171 
172* Wed Mar  8 2000 Jun Nishii <jun@vinelinux.org>
173- 2-5
174- chkfontpath -remove TrueType in %post to get stability
175
176* Tue Feb  1 2000 Jun Nishii <jun@vinelinux.org>
177- 2-4
178- stop to add path for xfs to get stability
179
180* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
181- 2-3
182- oops...fix bugs for comment out in FONTS.ALIAS
183
184* Thu Jan 20 2000 Jun Nishii <jun@vinelinux.org>
185- 2-2
186- bug fix: added symlink for aliastt-...
187- added Obsoletes DynaFonts
188
189* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
190- TrueTypeFonts_jp-2-1
191- added %defattr
192- bzip2 source
193
194* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
195- change group
196
197* Fri Dec 10 1999 Jun Nishii <jun@vinelinux.org>
198- new fonts.alias
199
200* Mon Nov  8 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
201- 1-4
202- added Prereq: chkfontpath tag
203
204* Tue Sep 9 1999 Norihito Ohmori <ohmori@flatout.org>
205- change using chkfontpath
206
207* Wed Dec 23 1998 MATSUMOTO Shoji <vine@flatout.org>
208- 1-2
209- change fonts.dir and fonts.alias
210- some symbols defined
211
Note: See TracBrowser for help on using the repository browser.