source: projects/specs/trunk/T/TrueType-kiloji/TrueType-kiloji-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define fontname kiloji
2%define _fontdir %{_datadir}/fonts/TrueType-%{fontname}
3
4Name:             TrueType-%{fontname}
5Summary:          kiloji font - Handwriting-like general styles
6Summary(ja):      手書き風総合書体 きろ字フォント
7Version:          2.1.0
8Release:          1%{?_dist_release}
9License:          New BSD
10Group:            User Interface/X
11URL:              http://www.ez0.net/distribution/font/%{fontname}/
12
13Source0:          %{fontname}_%{version}.zip
14Source1:          %{fontname}_b%{version}.zip
15Source2:          %{fontname}_d%{version}.zip
16Source3:          %{fontname}_p%{version}.zip
17
18Requires:         %{name}-doc >= %{version}
19
20BuildRequires:    unzip
21BuildRoot:        %{_tmppath}/%{name}-%{version}-root
22BuildArch:        noarch
23
24%description
25kilo-ji, "kilo" is the author name of these fonts
26and "ji" means "characters" in Japanese.
27This fonts consists of four styles.
28
29- kiloji.ttf (kiloji Fixed)
30- kiloji_p.ttf (kiloji Proportional)
31- kiloji_b.ttf (kiloji Bold)
32- kiloji_d.ttf (kiloji Thin)
33
34%description -l ja
35きろ字の "kilo" とはこれらのフォントの作者の名前であり、
36"ji" は 日本語で "文字" を意味します。
37このフォントは4種の書体から成っています。
38
39- kiloji.ttf(等幅)
40- kiloji_p.ttf (プロポーショナル)
41- kiloji_b.ttf (太字)
42- kiloji_d.ttf (細字)
43
44このパッケージはきろ字フォントのメタパッケージです。
45上記4書体すべてをインストールします。
46
47%package fixed
48Summary: kiloji fonts (fixed)
49Summary(ja): きろ字フォント(等幅)
50Group: User Interface/X
51Requires: TrueType-kiloji-doc
52
53%description fixed
54This package includes kiloji TrueType fonts (fixed).
55
56%description -l ja fixed
57このパッケージにはきろ字フォント(等幅)が含まれています。
58
59%package proportional
60Summary: kiloji fonts (proportional)
61Summary(ja): きろ字フォント(プロポーショナル)
62Group: User Interface/X
63Requires: TrueType-kiloji-doc
64
65%description proportional
66This package includes kiloji TrueType fonts (proportional).
67
68%description -l ja proportional
69このパッケージにはきろ字フォント(プロポーショナル)が含まれています。
70
71%package bold
72Summary: kiloji fonts (bold)
73Summary(ja): きろ字フォント(太字)
74Group: User Interface/X
75Requires: TrueType-kiloji-doc
76
77%description bold
78This package includes kiloji TrueType fonts (bold).
79
80%description -l ja bold
81このパッケージにはきろ字フォント(太字)が含まれています。
82
83%package thin
84Summary: kiloji fonts (thin)
85Summary(ja): きろ字フォント(細字)
86Group: User Interface/X
87Requires: TrueType-kiloji-doc
88
89%description thin
90This package includes kiloji TrueType fonts (thin).
91
92%description -l ja thin
93このパッケージにはきろ字フォント(細字)が含まれています。
94
95%package doc
96Summary: kiloji fonts Documents
97Summary(ja): きろ字フォントドキュメント
98Group: User Interface/X
99
100%description doc
101This package includes important documents for kiloji fonts includes enduser
102license.
103
104%description -l ja doc
105このパッケージにはきろ字フォントのライセンスを含むドキュメント類が含まれています。
106
107
108%prep
109%setup -q -c -T
110
111%{_bindir}/unzip -oq %{SOURCE0}
112%{_bindir}/unzip -oq %{SOURCE1}
113%{_bindir}/unzip -oq %{SOURCE2}
114%{_bindir}/unzip -oq %{SOURCE3}
115
116%clean
117if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
118    rm -rf ${RPM_BUILD_ROOT}
119fi
120
121%build
122
123%install
124rm -rf %{buildroot}
125
126mkdir -p $RPM_BUILD_ROOT%{_fontdir}
127cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
128
129%post fixed
130%__font_install_post %{_fontdir}
131
132%post proportional
133%__font_install_post %{_fontdir}
134
135%post bold
136%__font_install_post %{_fontdir}
137
138%post thin
139%__font_install_post %{_fontdir}
140
141
142%postun fixed
143%__font_install_postun %{_fontdir}
144
145%postun proportional
146%__font_install_postun %{_fontdir}
147
148%postun bold
149%__font_install_postun %{_fontdir}
150
151%postun thin
152%__font_install_postun %{_fontdir}
153
154%files
155
156%files fixed
157%{_fontdir}/%{fontname}.ttf
158
159%files proportional
160%{_fontdir}/%{fontname}_p.ttf
161
162%files bold
163%{_fontdir}/%{fontname}_b.ttf
164
165%files thin
166%{_fontdir}/%{fontname}_d.ttf
167
168%files doc
169%doc Collecting.txt License.txt
170
171%changelog
172* Wed Sep 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.1.0-1
173- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.