source: projects/specs/trunk/T/TrueType-ipafont/TrueType-ipafont-vl.spec @ 12393

Revision 12393, 7.1 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

OpenType?-ipaexfont-4.01-1

OpenType?-ipamj-mincho-6.01-1

OpenType?-source-sans-pro-3.006-1

TrueType?-ipafont-3.03-4

TrueType?-vlgothic-2.120-2

ghostscript-9.52-1

Line 
1%define _fontdir %{_datadir}/fonts/TrueType-ipafont
2
3Name:    TrueType-ipafont
4Version: 3.03
5Release: 4%{?_dist_release}
6Summary: IPA TrueType Fonts
7Summary(ja): IPA の日本語 TrueType フォント
8Group: User Interface/X
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: IPA Font License Agreement v1.0
13URL: https://ipafont.ipa.go.jp/
14Source: https://ipafont.ipa.go.jp/IPAfont/IPAfont00303.zip
15Source10: ipafont-mincho.ttfconf
16Source11: ipafont-gothic.ttfconf
17Source20: cidfmap.ja.ipafont-mincho
18Source21: cidfmap.ja.ipafont-gothic
19Source30: 59-ipa-mincho.conf
20Source31: 60-ipa-gothic.conf
21
22BuildArch: noarch
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Obsoletes: TrueType-ipafont
25Requires: TrueType-ipafont-mincho = %{version}
26Requires: TrueType-ipafont-gothic = %{version}
27Requires: TrueType-ipafont-doc = %{version}
28
29%description
30This package is meta package to install both IPAMincho and IPAGothic
31fonts.
32
33%description -l ja
34このパッケージは独立行政法人情報処理推進機構のIPAフォントの明朝、ゴシック
35両書体をインストールするためのメタパッケージです。このパッケージで
36以下の4書体がインストールされます。
37(IPA明朝、IPAP明朝、IPAゴシック、IPAPゴシック)
38
39%package mincho
40Summary: IPAMincho TrueType Fonts
41Summary(ja): IPA明朝 True Type フォント
42Group: User Interface/X
43Requires: TrueType-ipafont-doc
44Requires: alternatives
45Requires(preun): alternatives
46
47%description mincho
48This package includes IPA Mincho TrueType fonts.
49
50%description -l ja mincho
51このパッケージには独立行政法人情報処理推進機構のIPA明朝フォントが含まれています。
52(IPA明朝、IPAP明朝)
53
54%package gothic
55Summary: IPA Gothic TrueType Fonts
56Summary(ja): IPA Gothic 日本語 True Type フォント
57Group: User Interface/X
58Requires: TrueType-ipafont-doc
59Requires: alternatives
60Requires(preun): alternatives
61
62%description gothic
63This package includes IPA Gothic TrueType fonts.
64This font is distributable without modification.
65(see /usr/share/doc/TrueType-ipafont/enduser_license.txt for details)
66
67%description -l ja gothic
68このパッケージには独立行政法人情報処理推進機構のIPAゴシックフォントが含まれて
69います。(IPAゴシック、IPAPゴシック)
70
71%package doc
72Summary: IPA Font Documents
73Summary(ja): IPA フォントドキュメント
74Group: User Interface/X
75
76%description doc
77This package includes important documents for IPA fonts includes enduser
78license.
79
80%description -l ja doc
81このパッケージには独立行政法人情報処理推進機構のIPAフォントのライセンス
82を含むドキュメント類が含まれています。
83
84%prep
85%setup -q -n IPAfont00303
86
87%build
88
89%install
90mkdir -p $RPM_BUILD_ROOT%{_fontdir}
91cp -a *.ttf $RPM_BUILD_ROOT%{_fontdir}
92cp -f %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT%{_fontdir}
93
94mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
95install -m664 %{SOURCE30} %{SOURCE31} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
96for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
97do
98  ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
99done
100
101# install ghostscript8 cidfmap
102#mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
103#install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
104
105# add fontpath.d symlinks
106mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/fontpath.d
107ln -sf /usr/share/fonts/%{name} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fontpath.d/
108
109%clean
110if test -n "${RPM_BUILD_ROOT}" && test "/" != "${RPM_BUILD_ROOT}"; then
111    rm -rf ${RPM_BUILD_ROOT}
112fi
113
114%post mincho
115%__font_install_post %{_fontdir}
116
117%post gothic
118%__font_install_post %{_fontdir}
119
120%posttrans mincho
121update-alternatives --install \
122        /usr/share/fonts/alias/TrueType/fonts-japanese-mincho.ttf \
123        fonts-japanese-mincho.ttf \
124        %{_fontdir}/ipam.ttf \
125        100
126if [ ! -f /usr/share/fonts/alias/TrueType/fonts-japanese-mincho.ttf ] ; then
127    /sbin/update-alternatives --auto fonts-japanese-mincho.ttf
128fi
129
130%posttrans gothic
131update-alternatives --install \
132        /usr/share/fonts/alias/TrueType/fonts-japanese-gothic.ttf \
133        fonts-japanese-gothic.ttf \
134        %{_fontdir}/ipag.ttf \
135        100
136if [ ! -f /usr/share/fonts/alias/TrueType/fonts-japanese-gothic.ttf ] ; then
137    /sbin/update-alternatives --auto fonts-japanese-gothic.ttf
138fi
139
140%preun mincho
141if [ $1 -eq 0 ]; then
142        update-alternatives --remove \
143                fonts-japanese-mincho.ttf \
144                %{_fontdir}/ipam.ttf
145    /sbin/update-alternatives --auto fonts-japanese-mincho.ttf ||:
146fi
147
148%preun gothic
149if [ $1 -eq 0 ]; then
150        update-alternatives --remove \
151                fonts-japanese-gothic.ttf \
152                %{_fontdir}/ipag.ttf
153    /sbin/update-alternatives --auto fonts-japanese-gothic.ttf ||:
154fi
155
156%postun mincho
157%__font_install_postun %{_fontdir}
158
159%postun gothic
160%__font_install_postun %{_fontdir}
161
162
163%files
164
165%files doc
166%doc *.txt
167
168%files mincho
169%license IPA_Font_License_Agreement_v1.0.txt
170%{_fontdir}/ipam*.ttf
171%{_fontdir}/ipafont-mincho.ttfconf
172#%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.ipafont-mincho
173%{_sysconfdir}/fonts/conf.avail/*-ipa-mincho.conf
174%{_sysconfdir}/X11/fontpath.d/%{name}
175%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/*-ipa-mincho.conf
176
177%files gothic
178%license IPA_Font_License_Agreement_v1.0.txt
179%{_fontdir}/ipag*.ttf
180%{_fontdir}/ipafont-gothic.ttfconf
181#%config %{_datadir}/ghostscript/conf.d/cidfmap.ja.ipafont-gothic
182%{_sysconfdir}/fonts/conf.avail/*-ipa-gothic.conf
183%config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/*-ipa-gothic.conf
184
185
186%changelog
187* Sun May 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.03-4
188- made to use alternatives for new ghostscript structure.
189
190* Wed Jul 13 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 3.03-3
191- fix fontconfig files (Source30, 31) for fontconfig 2.10
192 - sync Vine Linux Git repository
193
194* Mon Jan 13 2014 TANAKA hiroaki <mosaicist@jcom.home.ne.jp>
195- built with gcc-4.8
196
197* Sun Nov 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.03-1
198- update to IPAfont 00303
199
200* Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.02-1
201- update to IPAfont 00302
202- update ttfconf/cidfmap
203
204* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.01-3
205- add fontpath.d symlink
206
207* Wed Jun 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.01-2
208- use fixed width font for ghostscript.
209
210* Wed Apr 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.01-1
211- update to IPAfont 00301
212  - drop IPAUIGothic
213- update License tag
214  - OSI approved license 'IPA Font License Agreement v1.0'
215- add fontconfig file
216
217* Thu Jan 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-2
218- fix typo in cidfmap.ja.ipafont
219- update vine.map and exec updmap-sys on %%post/%%postun
220
221* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-1
222- add gs8 cidfmap
223- move font files to new location
224- new versioning policy, spec in utf-8
225
226* Fri Jan 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-0vl2
227- remove Provides: TrueTypeFonts_jp
228  - ipa*font is not free and should not be default font.
229
230* Mon Oct 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.01-0vl1
231- initial build with new ipafont license
232- sprit mincho and gothic as an independent package
233- sprit readme and license to doc package
234- drop M+IPA font which is not allowed by new enduser license.
Note: See TracBrowser for help on using the repository browser.