source: projects/specs/trunk/T/TrueType-base/TrueType-base-vl.spec @ 521

Revision 521, 5.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

RevLine 
[521]1%define version 4.4.1
2%define release 0vl1
3
4%define xfontdir /usr/X11R6/lib/X11/fonts/TrueType
5
6Summary: Vine TrueType font managing base
7Summary(ja): TrueType ¥Õ¥©¥ó¥È»ÈÍѤΥ١¼¥¹
8Name: TrueType-base
9Version: %{version}
10Release: %{release}
11BuildArch: noarch
12
13Source: TrueType-base-%{version}.tgz
14
15Copyright: distributable
16Group: User Interface/X
17Buildroot: %{_tmppath}/%{name}-root
18PreReq: mktcapdir >= 0.5.4
19# PreReq: chkfontpath
20Requires: mktcapdir >= 0.5.4
21
22Distribution: Vine Linux
23Vendor: Project Vine
24Packager: Shoji Matsumoto <shom@vinelinux.org>
25
26%description
27Vine TrueType font managing base.
28Include symlinks to basic TTF (luxi*.ttf in XFree86-4.2) and some .ttfconf
29
30%description -l ja
31Vine ¤Î TrueType ¥Õ¥©¥ó¥È¥Þ¥Í¥¸¥á¥ó¥È¤Î¥Ù¡¼¥¹¤Ç¤¹¡£
32XFree86-4.2 ¤Ë´Þ¤Þ¤ì¤ë´ðËÜŪ¤Ê TTF ¤Ç¤¢¤ë luxi*.ttf ¤Ø¤Î¥·¥ó¥Ü¥ê¥Ã¥¯¥ê¥ó¥¯¤È¡¢
33¤¤¤¯¤Ä¤«¤Î TTF ÍѤΠmktcapdir ÍÑÄêµÁ¥Õ¥¡¥¤¥ë¤¬´Þ¤Þ¤ì¤Æ¤¤¤Þ¤¹¡£
34
35%prep
36rm -rf ${RPM_BUILD_ROOT}
37
38%setup
39
40%install
41
42mkdir -p $RPM_BUILD_ROOT/%{xfontdir}
43rm *.spec
44mv * \
45  $RPM_BUILD_ROOT/%{xfontdir}
46
47# %post
48# %{_sbindir}/chkfontpath -q -a %{xfontdir}
49# %{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
50# if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
51#   %{_bindir}/vine-update-gnome-font-install
52# fi
53
54# %postun
55# %{_sbindir}/chkfontpath -q -r %{xfontdir}
56# %{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
57# if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
58#   %{_bindir}/vine-update-gnome-font-install
59# fi
60
61%post
62%{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
63if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
64  %{_bindir}/vine-update-gnome-font-install
65fi
66
67%postun
68%{_bindir}/mktcapdir %{xfontdir} %{xfontdir}/*.ttfconf
69if [ -x %{_bindir}/vine-update-gnome-font-install ]; then
70  %{_bindir}/vine-update-gnome-font-install
71fi
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(-,root,root)
78%dir %{xfontdir}
79%{xfontdir}/*
80
81%changelog
82* Thu Feb 20 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4.1-0vl1
83- update for 2.6errata
84- modify ttfconf
85
86* Wed Nov 20 2002 Shoji Matsumoto <shom@vinelinux.org> 4.4-0vl2
87- remove .spec in fontdir...
88- update for Seed
89
90* Sun Oct 06 2002 Shoji Matsumoto <shom@vinelinux.org> 4.4-0vl1
91- xtt bug (garbage glyph in -c-) workarownd with mktcapdir-0.5.4
92- chkfontpath removed
93
94* Sun Mar 31 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3-0vl3
95- chkfontpath fix in %post
96
97* Thu Mar 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-0vl2
98- add PreReq: chkfontpath, mktcapdir
99
100* Sun Mar 17 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3-0vl1
101- add Obsoletes TrueType_jp < 4.1
102
103* Tue Mar 12 2002 Shoji Matsumoto <shom@vinelinux.org> 4.3-0vl0
104- created
105- separated from TrueType_jp (to TrueType-base, TrueType-kochi)
106- *******************************************************************
107
108* Tue Mar 12 2002 Shoji Matsumoto <shom@vinelinux.org> 4.2-0vl0
109- update ricoh.ttfconf, kochi.ttfconf
110- add luxi*-2.ttf (bitmap embedded luxi*.ttf)
111
112* Mon Mar 11 2002 Shoji Matsumoto <shom@vinelinux.org> 4.1-0vl0
113- Package Name changed to TrueType-kochi (Provides TrueTypeFonts_jp)
114- update microsoft.ttfconf, ricoh.ttfconf
115
116* Sun Mar 10 2002 Shoji Matsumoto <shom@vinelinux.org> 4.0-0vl2
117- fix
118
119* Sun Mar 10 2002 Shoji Matsumoto <shom@vinelinux.org> 4.0-0vl1
120- upate kochi-*
121- update *.ttfconf
122- add xf42lux.ttfconf, symlinks to XF42 lux ttfs
123- add ricoh.ttfconf for CR
124
125* Mon Dec 03 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl6
126- update *.ttfconf
127- remove ricoh.ttfconf
128- update kochi-*
129
130* Mon Sep 10 2001 SHoji Matsumoto <shom@vinelinux.org> 3.0-0vl4
131- fixed bug in kochi.ttfconf
132
133* Mon Sep 10 2001 SHoji Matsumoto <shom@vinelinux.org> 3.0-0vl3
134- remove %post process for DynaFonts fonts
135  (/usr/share/fonts/TrueType/aliastt-* obsoletes)
136
137* Sat Sep 08 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl2
138- remove watanabe, wadalab
139- now using mktcapdir
140
141* Mon Jun 04 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl1
142- remove times/hevletica iso8859-1 aliases for kochi
143
144* Fri May 18 2001 Shoji Matsumoto <shom@vinelinux.org> 3.0-0vl0
145- add kochi-mincho/kochi-gothic
146- add Type1 fonts from XFree86-4.0 (temp)
147- add -alias-{times,helvetica,monotype} to aliases
148
149* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2-7
150- remove Obsoletes DynaFonts tag.
151
152* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2-6
153- build with gcc-2.95.3
154- partially used rpmmacros
155 
156* Wed Mar  8 2000 Jun Nishii <jun@vinelinux.org>
157- 2-5
158- chkfontpath -remove TrueType in %post to get stability
159
160* Tue Feb  1 2000 Jun Nishii <jun@vinelinux.org>
161- 2-4
162- stop to add path for xfs to get stability
163
164* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
165- 2-3
166- oops...fix bugs for comment out in FONTS.ALIAS
167
168* Thu Jan 20 2000 Jun Nishii <jun@vinelinux.org>
169- 2-2
170- bug fix: added symlink for aliastt-...
171- added Obsoletes DynaFonts
172
173* Sun Jan  9 2000 Jun Nishii <jun@vinelinux.org>
174- TrueTypeFonts_jp-2-1
175- added %defattr
176- bzip2 source
177
178* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
179- change group
180
181* Fri Dec 10 1999 Jun Nishii <jun@vinelinux.org>
182- new fonts.alias
183
184* Mon Nov  8 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
185- 1-4
186- added Prereq: chkfontpath tag
187
188* Tue Sep 9 1999 Norihito Ohmori <ohmori@flatout.org>
189- change using chkfontpath
190
191* Wed Dec 23 1998 MATSUMOTO Shoji <vine@flatout.org>
192- 1-2
193- change fonts.dir and fonts.alias
194- some symbols defined
195
Note: See TracBrowser for help on using the repository browser.