source: projects/specs/trunk/S/SysVinit/SysVinit-vl.spec @ 7165

Revision 7165, 12.2 KB checked in by daisuke, 11 years ago (diff)

SysVinit: remove sulogin and utmpdump which are part of util-linux >= 2.22

Line 
1Summary: Programs which control basic system processes.
2Summary(ja): 基本的なシステムプロセスを制御するプログラム
3Name: SysVinit
4Version: 2.88dsf
5Release: 3%{_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
9URL: http://savannah.nongnu.org/projects/sysvinit/
10Patch1: sysvinit-2.78-man.patch
11Patch2: sysvinit-2.86-autofsck.patch
12Patch3: sysvinit-2.86-loginshell.patch
13Patch4: sysvinit-2.86-inittab.patch
14Patch5: sysvinit-2.86-single.patch
15Patch6: sysvinit-2.88-quiet.patch
16Patch14: sysvinit-2.88-ipv6.patch
17Patch15: sysvinit-2.88-omit.patch
18Patch16: sysvinit-2.88-wall-maxlines.patch
19Patch17: sysvinit-2.88-wall-broadcast-message.patch
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Requires: pam >= 0.66-5
22Requires: %{name}-tools = %{version}-%{release}
23Requires: filesystem
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: daisuke
28
29
30%description
31The SysVinit package contains a group of processes that control
32the very basic functions of your system. SysVinit includes the init
33program, the first program started by the Linux kernel when the
34system boots. Init then controls the startup, running, and shutdown
35of all other programs.
36
37%description -l ja
38SysVinit パッケージには,システムの非常に基本的な機能を制御する
39プロセスが収められています.例えば,システム起動時に Linux カーネルに
40よって最初に起動されるプログラムである init 等です.init はその後
41システムの起動や,他のプログラムの起動/終了を制御します.
42
43%package tools
44Summary: Tools used for process management.
45Summary(ja): プロセス管理に使用するツール
46Group: System Environment/Base
47
48%description tools
49The sysvinit-tools package contains various tools used for process
50management.
51
52$description -l ja tools
53SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
54が含まれています。
55
56%prep
57%setup -q -n sysvinit-%{version}
58# We use a shell, not sulogin. Other random man fixes go here (such as #192804)
59%patch1 -p1 -b .manpatch
60# Unlink /.autofsck on shutdown -f
61%patch2 -p1 -b .autofsck
62# Invoke single-user shell as a login shell (#105653)
63%patch3 -p1 -b .loginshell
64# Adjust examples in inittab(5) to more accurately reflect RH/Fedora
65# usage (#173572)
66%patch4 -p1 -b .inittabdocs
67# Fix single user mode (#176348)
68%patch5 -p1 -b .single
69# Be less verbose when booted with 'quiet'
70%patch6 -p1 -b .quiet
71# Change accepted ipv6 addresses (#573346)
72%patch14 -p1 -b .ipv6
73# Add option to pidof to exclude similar processes to omitted processes (#632321)
74%patch15 -p1 -b .omit
75# Fix counting MAXLINES in wall
76%patch16 -p1 -b .maxlines
77# Raise limit for broadcast message
78%patch17 -p1 -b .broadcast
79
80%build
81make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
82
83%install
84rm -rf $RPM_BUILD_ROOT
85for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
86        mkdir -p $RPM_BUILD_ROOT/$I
87done
88make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
89        BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
90
91rm -f $RPM_BUILD_ROOT/bin/pidof
92ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
93rm -f $RPM_BUILD_ROOT/sbin/bootlogd
94rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
95chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
96
97# Remove these files, as we use upstart as /sbin/init.
98rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
99rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
100rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
101rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
102
103# /sbin/fstab-decode is part of initscripts
104rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
105rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
106
107# /bin/mountpoint is part of util-linux >= 2.20
108rm -f $RPM_BUILD_ROOT/bin/mountpoint
109rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/mountpoint.*
110
111# utmpdump and sulogin is part of util-linux >= 2.22
112rm -f $RPM_BUILD_ROOT%{_bindir}/utmpdump
113rm -f $RPM_BUILD_ROOT/sbin/sulogin
114rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/utmpdump.*
115rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/sulogin.*
116
117%post
118[ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
119exit 0
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%files tools
125%defattr(-,root,root)
126%doc doc/Changelog COPYRIGHT
127%{_bindir}/last
128%{_bindir}/lastb
129%{_bindir}/mesg
130%attr(2555,root,tty)  %{_bindir}/wall
131/sbin/pidof
132/sbin/killall5
133%{_mandir}/man1/*
134%{_mandir}/man8/killall5*
135%{_mandir}/man8/pidof*
136
137
138%changelog
139* Tue Nov 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-3
140- remove sulogin and utmpdump which are part of util-linux >= 2.22
141
142* Tue Feb 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-2
143- remove mountpoint which is part of util-linux >= 2.20
144
145* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
146- update to 2.88dsf
147- only build -tools subpackage
148
149* Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
150- new upstream release (2.87dsf)
151- remove upstreamed or obsoleted patches
152- split off a -tools subpackage to avoid upstart conflicts
153
154* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
155- new upstream release
156
157* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
158- add script to create $RPM_BUILD_ROOT/bin in %%install section
159
160* Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
161- install initreq.h
162
163* Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
164- new upstream release
165- merged with fedora package.
166  * Tue Jul 17 2001 <sagami@vinelinux.org>
167  - 2.78-10vl3: fix orphan symlink in %%doc
168  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
169  - 2.78-10vl1
170  - rebuilt under new %%{_mandir} definition
171  - added Japanese summary and description
172  * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
173  - build with gcc-2.95.3
174  - partially used rpmmacros
175
176* Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
177- add change_console, for changing console used by init
178
179* Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
180- block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
181
182* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
183- rebuilt
184
185* Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
186- clean up killall5 some
187
188* Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
189- update to 2.85, remove already applied patches
190
191* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
192- fix s390x build
193- fix silly warning (#83943)
194
195* Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
196- fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
197- fix segfault in spawn() function in shutdown
198
199* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
200- rebuilt
201
202* Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
203- Pass __cc macro to build, to facilitate cross-compiling
204- _smp_mflags
205
206* Mon Dec  2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
207- rebuild on all arches
208- change sulogin message to be slightly more correct (#65828)
209
210* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
211- don't strip binaries
212- have wall not write to non-ttys (#65412)
213- update usage for halt/reboot (#57753)
214- allow '-t' argument to last for checking state at certain times (#56863)
215- make 'pidof /foo/bar' not match /baz/bar (#53918)
216
217* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
218- automated rebuild
219
220* Thu May 23 2002 Tim Powers <timp@redhat.com>
221- automated rebuild
222
223* Thu Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
224- add patch to log messages on shutdown/reboot
225
226* Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
227- update to 2.84
228
229* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
230- automated rebuild
231
232* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
233- Fix pidof -o (#55954)
234- Handle RPM_OPT_FLAGS
235- s/Copyright/License/
236
237* Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
238- update to 2.79
239
240* Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
241- unlink /.autofsck on shutdown -f
242
243* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
244- Bump release + rebuild.
245
246* Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
247- update 'no logout' patch
248- fix setting of CREAD to work with 2.4.3+ kernels (#45284)
249
250* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
251- show users with no login pid but no logout record as gone (#42550,
252  <cwolf@starclass.com>)
253- fix sulogin to *always* work without a tty (#40934)
254
255* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
256- set umask 022 on startup
257- manpage tweaks (#21628, #27173)
258
259* Mon Apr  2 2001 Bill Nottingham <notting@redhat.com>
260- fix dangling symlink in %%doc (#34383)
261
262* Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
263- don't run telinit u if we don't appear to be on the root fs
264
265* Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
266- run telinit u on upgrade
267
268* Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
269- document '-n' option to wall, make it root-only (#18672)
270- don't open files in sulogin unless they're really ttys (#21862)
271
272* Tue Aug  8 2000 Bill Nottingham <notting@redhat.com>
273- set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
274
275* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
276- automatic rebuild
277
278* Thu Jun  8 2000 Bill Nottingham <notting@redhat.com>
279- fix the md5 code (#11534)
280- rebuild for FHS & the like
281
282* Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
283- ignore sigint in sulogin (#9803)
284- touch file in root directory if powering off (#7318)
285
286* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
287- rebuild for sparc baud rates > 38400.
288
289* Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
290- update to 2.78-final
291
292* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
293- handle compressed manpages
294
295* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
296- build to fix dependency problem
297
298* Tue Jan 10 2000 Bill Nottingham <notting@redhat.com>
299- update to 2.78
300
301* Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
302- on big endian machines use a kludge for broken pam md5 passwords
303
304* Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
305- update to 2.77
306
307* Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
308- move pam_console stuff to usermode package
309
310* Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
311- requires usermode to express the dependency on /usr/bin/consolehelper
312(#2813)
313
314* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
315- make man page references to single-user mode consistent with RH usage
316
317* Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
318- remove /etc/initlvl compatibility symlink from file list (#2236).
319
320* Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
321- pam.d files marked noreplace
322- added poweroff as a console application
323
324* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
325- marked config files as such in consolehelper part of filelist
326
327* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
328- auto rebuild in the new build environment (release 8)
329
330* Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
331- consolehelper support
332
333* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
334- glibc 2.1
335
336* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
337- poweroff symlink not included (problem #762)
338
339* Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
340- Fix a securelevel releated security hole. Go on, try and break append
341  only files + securelevel now ;-)
342
343* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
344- remove /etc/nologin at end of shutdown.
345- compile around missing SIGPWR on sparc
346
347* Thu May 07 1998 Prospector System <bugs@redhat.com>
348- translations modified for de, fr, tr
349
350* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
351- upgraded to 2.74
352- fixed the package source url... (yeah, it was wrong !)
353
354* Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
355- fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
356  22 bytes, not 24...). Fix in -md5.patch
357
358* Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
359- /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
360  just plain wrong..
361- /usr/bin/utmpdump was missing in the files section, although it was
362  explicitly patched into PROGS.
363- added attr's to the files section.
364- various small fixes.
365
366* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
367- updated to 2.71
368- built against glibc 2.0.4
369
370* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
371- Added sulogin.8 man page to file list.
Note: See TracBrowser for help on using the repository browser.